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1: Welcome to PAC Control

Introduction

Welcome to PAC Control ", Opto 22's visual control language for Opto 22 SNAP PAC control systems
and the input/output (I/0) units that work with them.

PAC Control makes it easy to write control applications with little or no programming experience. If
you know how to design a control application and can draw some flowcharts to describe it, you
already know the basics of PAC Control. At the same time, PAC Control provides a complete and
powerful set of commands, as well as the OptoScriptm programming language, to meet your most
demanding industrial control needs.

PAC Control comes in two forms: PAC Control Basic and PAC Control Professional .

«  PAC Control Basic is included in the purchase of an Opto 22 SNAP PAC controller and is also
available as a free download from our website, www.opto22.com. PAC Control Basic includes
both flowchart and OptoScript programming, subroutines, a graphical debugger, and about
400 commands.

«  PAC Control Professional is available for purchase either separately or as part of the
complete PAC Project  Professional software suite. The Professional version of PAC Control
adds:

- Support for controller redundancy and Ethernet link redundancy to controllers and /0 units

- Support for Legacy hardware, including serial mistic 1/0 units with a SNAP PAC S-series
controller

— A conversion utility to help you move older OptoControl” strategies to PAC Control
— Additional "Pro version only” PAC Control commands

For information on features supported by a specific controller, see the controller documentation.

For Developers: SNAP PAC REST API

If you're a developer who'd like to use PAC Control strategy tags in communications with other
devices, the Opto 22 SNAP PAC REST APl is a secure and powerful way to do just that. The APl is
available in SNAP PAC R-series and S-series controllers with PAC firmware R9.5a and higher. To
configure https access to your PAC's RESTful server and learn how to call the API, visit
developer.opto22.com.
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ABOUT THIS GUIDE

About this Guide

This user's guide not only teaches you how to use PAC Control, but also provides programming
instruction and tips. The separate PAC Control Command Reference describes in detail all PAC Control
programming commands and instructions.

This quide assumes that you are already familiar with Microsoft” Windows on your personal
computer, including how to use a mouse, standard commands, and menu items to open, save, and
close files. If you are not familiar with Windows or your PC, refer to the documentation from
Microsoft and your computer manufacturer.
This guide covers both PAC Control Basic and PAC Control Professional.

@ The Basic icon indicates features or functions that apply only to PAC Control Basic.

Bro The Pro icon indicates features or functions that apply only to PAC Control Professional.
Here's what is in this user’s guide:

1: Welcome to PAC Control—Information about the guide and how to reach Opto 22 Product
Support.

2: PAC Control Tutorial—A tutorial designed to help you use PAC Control as quickly as possible.
The chapter leads you through a sample strategy that you can manipulate, download, and run in
Debug mode.

3:What Is PAC Control?—An introduction to PAC Control, key terminology, and the main windows
and toolbars.

4: Designing Your Strategy—Programming in PAC Control: how to get from your real-world
control problem to a working strategy.

5: Working with Control Engines—How to configure and communicate with control engines.

6: Working with 1/0—How to configure and communicate with input/output (I/0) units, 1/0
points, and PID loops.

7: Working with Strategies—Detailed steps for creating, compiling, and running strategies.

8: Working with Flowcharts—Detailed steps for creating and working with the flowcharts that
make up your strategy.

9: Using Variables and Commands—Steps for configuring the seven types of variables you can
use in programming: communication handle, numeric, string, pointer, numeric table, string table,
and pointer table variables. Also shows how to use the commands that control the I/O and variables
you've configured.

10: Programming with Commands—Important tips on using PAC Control commands to
accomplish what you want in your strategy.

11: Using OptoScript—Details on the optional scripting language available in PAC Control for
complex loops, string handling, and mathematical expressions.

12: Using Subroutines—How to use subroutines to streamline your strategy development.

A: Troubleshooting—Tips for resolving communication problems and other difficulties you may
encounter.

B: Errors and Messages—Types of errors, where you'll see them, and the causes of common errors.

C: PAC Control Files—A list of all PAC Control files located in the PAC Control directory and in any
strategy directory.
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D: Sample Strategy—An illustration and description of the sample “Cookies” strategy used in
Chapter 1.

E: OptoScript Language Reference—Details about OptoScript code, including comparisons to
other languages, lexical reference, and notes to experienced programmers.

Index—Alphabetical list of key words and the pages where they are located.

Choosing Documentation

This user’s guide contains the latest information you need to use PAC Control with your SNAP PAC
system. However, if you are using Opto 22 “legacy” products designed to work with pre-SNAP PAC
systems, see Opto 22 form 1710, PAC Control User’s Guide, Legacy Edition. The legacy version includes
references to pre-SNAP PAC devices and commands, which are not included in this guide.

For information on what we mean by “legacy”and how to migrate from an older system to a SNAP
PAC system, see form 1688, the SNAP PAC System Migration Technical Note.

To enable legacy 1/0 units and commands in PAC Control, see “Legacy Options”on page 208.

Document Conventions

The following conventions are used in this document:

« ltalic typeface indicates emphasis and is used for book titles. (Example: “See the PAC Display
User’s Guide for details.”)

«  Names of menus, commands, dialog boxes, fields, and buttons are capitalized as they appear in
the product. (Example: “From the File menu, select Print.”)

«  File names appear either in all capital letters or in mixed case, depending on the file name itself.
(Example: “Open the file TEST1 txt.")

«  Key press combinations are indicated by plus signs between two or more key names. For
example, Shift+F1 is the result of holding down the Shift key, then pressing and releasing the
F1 key. Similarly, Ctrl+-Alt+Delete is the result of pressing and holding the Ctrl and Alt keys, then
pressing and releasing the Delete key.

«  “Click"means press and release the left mouse button on the referenced item. “Right-click”
means press and release the right mouse button on the item.

«  Menu commands are referred to with the Menu > Command convention. For example,
“File > Open Project”means to select the Open Project command from the File menu.

«  Numbered lists indicate procedures to be followed sequentially. Bulleted lists (such as this one)
provide general information.

Help, Documents, and Opto22.com Resources

To help you learn, understand, and use PAC Control systems, we offer a wide variety of options:

«  Helpis available in PAC Control and in all of the applications in the PAC Project™ Software Suite
from Opto 22.
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- To see screen and field-level help, click the Help button on any PAC Control screen. While
entering commands (instructions), click the Command Help button to see details about
the command.

- Inthe PAC Control menu bar, click Help to view the list of help topics.
- (lick Help > Manuals to open the PDF versions of the documents that are installed when
you install PAC Control, including:
- Opto 22 form 1700, the PAC Control User’s Guide—Shows how to install and use PAC
Control.
- Opto 22 form 1701, the PAC Control Command Reference—Contains detailed
information about each command available in PAC Control.
—  Opto 22 form 1703, the PAC Control Commands Quick Reference—Lists all PAC Control
commands plus their OptoScript code equivalents and arguments.
- Opto 22 form 1704, the PAC Manager User’s Guide, and other guides provided for
specific hardware—Help you install, configure, and use controllers and 1/0 units.
«  Ourwebsite at www.opto22.com offers has a broad range of resources—from helpful videos to

online blogs, forums, and news to free online self-training. We even offer free hands-on training
at our headquarters in Temecula, California.

Product Support

If you have any questions about PAC Control, you can call, fax, or email Opto 22 Product Support.

Phone: 800-TEK-OPTO (800-835-6786 NOTE: Email messages and phone
toll-free in the U.S. and Canada) calls to Opto 22 Product Support
951-695-3080 are grouped together and
Monday through Friday, answered in the order received.

7 a.m.to 5 p.m. Pacific Time

Fax: 951-695-3017
Email: support@opto22.com
Opto 22 website: WWw.0pto22.com

When calling for technical support, you can help us help you faster if you can provide the following
information to the Product Support engineer:

«  Software product and version (available by clicking Help > About in the application’s menu bar).
(When contacting us, please send a screen capture of the Help > About dialog box.)

+  Opto 22 hardware part numbers or models that you're working with.

«  Firmware version (available in PAC Manager by clicking Tools > Inspect).
«  Specific error messages you saw.

«  Version of your computer’s operating system.
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Installing PAC Control

PAC Control is a component of the PAC Project Software Suite, a comprehensive set of software tools
for industrial automation, remote monitoring, and data acquisition projects in any line of business.

Installation is easy and quick, and you can download PAC Project directly from the Opto 22 Support
> Downloads webpage.

The PAC Project installer includes both the Basic (free) version of the software suite, and the software
for PAC Project Professional. Click here for a comparison of PAC Project Basic and PAC Project
Professional features.

To install PAC Control:
1. Download PAC Project from the Opto 22 Support > Downloads webpage.

2. Navigate to the folder where you downloaded PAC Project, and then double-click the
installation file (PAC_Project_<release number>.exe) to begin installation.

NOTE: You must have an OptoPassword to install the Professional version of PAC Control. For details, see
the Opto 22 website, www.opto22.com, Support > Downloads tab, and click the link for OptoPassword
(located in the text above the Search field).

If you have trouble installing PAC Control, contact Opto 22 Product Support at 800-835-6786
(toll-free in the U.S. and Canada) or 951-695-3080.

System Requirements

Installation Requirements

Here’s what you need to install and run PAC Control. If you are using PAC Display, please note its
requirements in form 1702, the PAC Display User’s Guide.

«  Acomputer with a standard or mainstream core processor and (at least) the minimum memory
required for your version of Microsoft Windows. (Low-end CPUs are not recommended.)
Additional memory may be required for some configurations.

+  One of the following operating systems:
- Microsoft Windows 10 Professional (32-bit or 64-bit)
- Windows 8.1 Professional (32-bit or 64-bit)
- Windows 7 Professional (32-bit or 64-bit)
- Windows Vista® Business (32-bit only)

NOTE: PAC Project will not install on Windows XP or older Windows operating systems. Embedded
operating systems are not tested or supported.
«  Ethernet capability.

«  VGA or higher resolution monitor (Super VGA recommended). Minimum size: 800x600 with
small fonts.

«  Mouse or other pointing device.
+  (Optional) Installed Windows printer.
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INSTALLING PAC CONTROL

«  Foravailable hard disk requirements, please see the PAC Project Release Notes.

»  Compatible control engine and I/0 unit(s), as shown on page 6.

Important Note on Disk Drives

Opto 22 applications, including PAC Control, perform best when using files from a local hard disk.
Network drives may be used, but performance may suffer and depends upon the speed and

reliability of the network. While it may be possible to use other drive types, such as key chain USB
drives and memory cards, their use is not recommended. They are better suited for transferring files

rather than directly accessing them.

Compatible Controllers and I/0O Units

The following controller and I/0 unit combinations are compatible with PAC Control Basic and PAC

Control Professional as shown:

Using this controller

PAC Control Basic supports these I/O units

PAC Control Professional supports these I/O units

SNAP PAC S-series

SNAP-PAC-R1 SNAP-PAC-SB1
SNAP-PAC-R1-B SNAP-PAC-SB2
SNAP-PAC-R1-W*

SNAP-PAC-R2

SNAP-PAC-R2-W*
SNAP-PAC-EB1
SNAP-PAC-EB1-W*
SNAP-PAC-EB2
SNAP-PAC-EB2-W*

SNAP-PAC-R1
SNAP-PAC-R1-B
SNAP-PAC-R1-W*
SNAP-PAC-R2
SNAP-PAC-R2-W*
SNAP-PAC-EB1
SNAP-PAC-EB1-W
SNAP-PAC-EB2
SNAP-PAC-EB2-W*
SNAP-PAC-SB1
SNAP-PAC-SB2

SNAP PAC R-series

SNAP-PAC-R1
SNAP-PAC-R1-B
SNAP-PAC-R2
SNAP-PAC-EB1
SNAP-PAC-EB2

SNAP-PAC-R1
SNAP-PAC-R1-B
SNAP-PAC-R2
SNAP-PAC-EB1
SNAP-PAC-EB2

SoftPAC

SNAP-PAC-R1
SNAP-PAC-R1-B
SNAP-PAC-R1-W*
SNAP-PAC-R2
SNAP-PAC-R2-W*
SNAP-PAC-EB1
SNAP-PAC-EB1-W*
SNAP-PAC-EB2
SNAP-PAC-EB2-W*

SNAP-PAC-R1
SNAP-PAC-R1-B
SNAP-PAC-R1-W*
SNAP-PAC-R2
SNAP-PAC-R2-W*
SNAP-PAC-EB1
SNAP-PAC-EB1-W*
SNAP-PAC-EB2
SNAP-PAC-EB2-W*

* Wired+Wireless PACs and I/O can be used on a wired Ethernet network or on a wireless LAN.
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Introduction

In this chapter, we'll start with a sample strategy: a control application for a simple cookie factory.
You'll learn how to work with strategies, open and manipulate flowcharts, work with variables and
/0 points, configure a control engine, compile and download a strategy, run it in Debug mode,
make an online change, and more. The tutorial can be used with either PAC Control Basic or PAC
Control Professional. (The images in the tutorial show PAC Control Basic.)

The best way to use the tutorial is to sit down at your computer and follow it through. To start, all
you need is PAC Control, which allows you to do everything up to the point of downloading your
strategy. To do the complete tutorial you will need the controller and I/0 included in a SNAP PAC
Learning Center. For more information, go to the Opto 22 website, www.opto22.com, and search on
the part number SNAP-PACLC.

In this Chapter

OPENING thE SITATEGY w.vvovreverreeeseeresseensesessssssssssss s s sssss s
Saving the Strategy....
Examining the Strategy
Opening a Chart..
Opening a Block
FaYo Lo [Tat k= I @oTaaTa 2T g o FN OO
Configuring @ CONLrOl ENGING w.....ocooooeceeeeeceeeeeessseees e ssssseesssssseesssnssses oo
Compiling the Strategy
Running the Strategy.... . .
Compiling and Downloading the Change . . .
USING @ WAtCh WINAOW ...ocoveeosceeeeceseseecesssseeessssssesssssssesssssssesssssssseesssssseessssnsssessns
Closing the Strategy and EXItING .ooo.cvveoeceeecescceseeessssees e ssssseesssssseessssnsssessns
WNEE'S INEXE? .o s 43
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OPENING THE STRATEGY

Opening the Strategy

A strategy is a complete control program developed in PAC Control. Our sample strategy controls a
cookie factory. The sample strategy is described in detail on page 401, but for now, let's just open
and explore it.

1. Open PAC Control:

- InWindows 7 and Windows Vista, press the Windows Start key E and then click
Programs > Opto 22 > PAC Project 9.6 > PAC Control.

- InWindows 10 and Windows 8.1, press the Windows Start key E type PAC Control
9.6 and then press the Enter key.

The PAC Control main window opens.

1PAC Control Basic

File Edit Configure Chart Subroutine Tools  Wiew  Help Vlenu bar

EETE © 5 @ am X Ak Y mee el P

WF&C Contral: Ready | MU

2. On the PAC Control toolbar, click the Open Strategy button .

3. Inthe Open Strategy dialog box, browse to
CA\Users\Public\Documents\Opto 22\PAC Project 9.6\Control Basic Examples\ioCookies.

(If you're using PAC Control Pro, substitute “Control Pro Examples”for “Control Basic Examples”
in the folder location.)

4. C(lick Cookies.idb to select it, and then click Open to open the strategy in PAC Control.
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The Cookies strategy opens and the PAC Control window now shows the Cookies strategy in
the Strategy tree window. (Yours may look somewhat different.)

1 PAC Control Basic
File Edit Configure Chart Subroutine Compile Mode Tools View Window Help

EEETEEE @ © J C en X #AY kL ime e e E P

= Cookies

I Control Engines
1) Subroutines Included
I=5) Charts
= 1) Wariables
# IC5) Mumeric Yariables Strategy
I String Wariables
I5) Pointer Yariables
I5) Communication Handles
IE5) Mumeric Tables
IC5) Stiing Tables
I5) Pointer Tables
& I 140 Units

Strategy name

v| @ Mext ﬁ} Prey

—|1 Cookies

PAC Control; Ready Configure UM

Saving the Strategy

Now let’s save the strategy to a new name, so we can change it while leaving the original intact.
1. Inthe PAC Control menu bar, click File > Save Strategy As.

Save Strategy As

Save in: | |23 ioCookies |ﬂ| Q-
‘Cookies.idb

File: name: | | L Save J
Save as type: |F'AEI Contral Strategy Files [*.idb) v| [ Cancel ]

2. Since each PAC Control strategy must be located in its own directory, you cannot save the
strategy to a new name in its current location.
a. Inthe Save Strategy As dialog box, click the Up One Level button # to move up to the
Examples directory.
b. Click the Create New Folder button ©*
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The new folder appears in the list.

Save Strategy As

Save in: | |25 Contral Pro Examples Iv| ] ?‘ g .

[C)Error Handler Complesc
[CS)Error Handler Simple
[C5) InitYariables
(C)ioConkies
5 OptasScript Examples

1) (=g

File name: | | [ Save ]

Save as type: |F'AEI Contral Strategy Files [*.idb) v| [ Cancel ]

c. Type My Cookies toreplace New Folder.
d. Double-click the folder to open it.
e. Inthe File name field, type Cookies.

The dialog box now looks like this:

Save Strategy As

Save in: | I My Cookies IV| €] ?‘ ® -

File name: | Cookies | [ Save ]

Save as type: | PAL Control Strategy Files [*.idb) w | [ Cancel ]
f. Click Save.

Your new Cookies strategy is saved in the My Cookies directory.

Examining the Strategy

Briefly, our cookie factory consists of:

«  Atank of pre-mixed cookie dough

«  Atankof chocolate chips

+ Anoven

«  Avisual inspection station

«  Aconveyor belt

«  Compressed air to blow rejected cookies off the belt
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Conveyor EIORCOROD T H
belt ——~Push To Srar:}
FTic

Oven Inspection station

The process starts when a ball of dough drops on the belt. It moves along under the chip tank to
receive some chips, and then it moves into the oven to be baked. The next stop is an inspection,
where rejected cookies are blown off the belt and good cookies move along to shipping. Should
anything go wrong, we also have some built-in alarms to stop the process.

The best way to see all the components of the strategy is to look at the Strategy Tree.

The Strategy Tree Window

To configure and run a strategy, you must leave the strategy tree window open—if you close the
strategy tree window, the strategy closes, too.

To expand a folder in the strategy tree, click the plus sign; click the minus sign to collapse the folder.

To move the strategy tree window, click and drag title bar. To minimize, maximize, or dock it, click
the buttons in title bar. To resize the window, drag any edge.

Title bar — (BN =13

g The strategy tree
=2 = 3 . gy
. I5) Control Engines window
Click the 15 Subroutines Included
minus sign ) Charts
T Dy dlame

to collapse &, Dough. Chip_Contl |~ This strategy has

a folder l?o Dough_Vessel_Pressure_( five charts
l?o Oven_|nzpection_Control
l?o Powerup

= I£5) Wariables
I3 Mumeric Yariables

IC5) String Wariables
IC5) Pointer Yariables
I5) Communication Handles
I3 Mumeric Tables

. IC5) Stiing Tables
Click the IC5) Pointer Tables
plus sign & () 140 Units
to expand 5
afolder

<
-
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Expanding the folders in the strategy tree reveals that the strategy includes five flowcharts (in the
Charts folder), eight Numeric Variables, and one Mixed I/0 Unit (with both analog and digital
points). The Strategy Tree not only shows you all components of the strategy but it also provides
shortcuts to many common PAC Control activities, such as opening flowcharts.

Docking the Strategy Tree

Since the strategy tree is so useful, you'll probably want to keep it visible while you create and debug
your strategy. To keep the strategy tree window visible, you can dock it in a separate frame.

1. Click the docking button [ in the upper-right corner of the strategy tree window.

The strategy tree moves into its own frame at the left side of the main window.

1PAC Control Basic
File Edit Configure Chart Subroutine Compile Mode Tools  Wiew window Help

DEH ¥ af|a X | A '-B_‘,’B R 'g‘ S $ ® 5 & | ok vien 5 compikal

Docked
strategy tree

=) Cocke:
® =y Contral Engines
I Subroutines Included
= 5y Charts
= % Alarms
=] TQ Dough_Chip_Control
= T@ Dough_Yessel Pressure_Cor
] *@ Owen_Inspection_Contral
E % Powenp
= |5 Variables
2 I Mumeric Yarables
2] bStartFlag

izz

2 diCaokietotionT imer

TR
D oughPressursS etpaint
R ampt/ alue
[SetpointtinusD eadbanc
@ nChartStatus

2l nConkiehatinnPreset

=z
@ nLoopCounter

1= String Yariables

I Pointer Variables

I3 Communication Handles

I Mumeric Tables

I Shing Tables

I Pointer Tables

& =y 140 Units

& [IE | 3

B o

PAC Control: Ready Configure MM

2. Tochange the width of the strategy tree’s frame, move your mouse over the right side of the

frame. When the pointer changes to the Windows Splitter icon « , click and then drag the
side to make the frame wider or narrower.
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Using Quick Find

The quick find tool at the bottom of the strategy tree helps you to find items quickly in the tree.
Use the Next and Prev buttons (or F3 and Shift+F3) to find multiple matches. Any partial match will
work.

i Cookies (¢ |Z| |E| [gl

= £ Cookies
|53 Control Engines
(£ Subroutines Ineluded
(=) Charts
[ Wariables
() 140 Units

Quick find tool Use the Next and Previous buttons
tofind the next or previous instance
of your Quick Find search

Sner o

For example, if you enter the word, “setpoint,” when you click Next, the first match is found.

i Cookies <& |Z| |E| [X|

(£ Wariables ~
= () Mumeric Yariables

% bStartFlag
':]‘;21% dtCookiebationTimer
Ma‘[ch ER fDoughPres: tpoitt .
£ R ampvalue
@ {5 etpointtinusD eadband
II22| nChartStatus

2] nCookieMationPreset
[ s

< >
-

H
o
W

[

When you click Next again, the next match is found.

Opening a Chart

Every control process can be planned and mapped out using one or several PAC Control flowcharts,

or charts. Because flowcharts are easy to follow, PAC Control strategies are easy to understand.

For an example, let’s take a look at the Dough_Chip_Control chart.

1. With the Charts folder expanded, double-click the Dough_Chip_Control chart name on the
Strategy Tree. (You can also open a chart by clicking Chart > Open in the PAC Control menu
bar, and then double-clicking the chart name.)
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The chart appears somewhere in the large frame of the main window.

"1 PAC Control Basic

[ config ~1 ebuo oo IR

e

= 15 Cookies -
=) Control Engines
I Subroutines Included
= I5) Charts
H % Alarmz
EEO Dough_Chip_Contral
=] EEO Dough Vessel Pressure_
] % Oven_|nzpection_Control
H % Powerup
= ) Wariables
= 1) Numeric Yariables
@ bStartFlag
\'1'4?1% dtCookietotionTimer —
@ [DoughPressureSetpe
R amptfalue
@ [SetpointtinuzDeadb
@ hChartStatus
@ nCookiet otionPreset
12 nLoooCaunter b

& I -
v| @ Mext ﬁ} Presy

=

=

File Edit Configure Chart Subroutine Compile Mode Tools View Window Help

B R X

2

H | &

The Powerup chart starts
this chart.

This chart runs
continuously once the
program has been started.

#ay LM Eocoens dH @&

This chart drops the dough and chips on the conveyor belt.
The belt must be running between 50% and 65% of max rpm.

=

sart

[

Speed OK?

Start
Conveyar

z

v

>

(1) Shortcuts EX v

4] A2 T Ghart /

Dough_Chip_Contral |

PAC Control: Ready

Configure UM

White tab shows
this is a chart.

Gray tab shows

Maximize
button

2. (lick and drag the title bar of the chart window if necessary to see the Maximize button at the
upper right. Click the Maximize button to make the chart fully fit the frame.

Note the tabs at the bottom of the main window; the white tab tells you you're viewing a chart,
and the gray tab shows the chart’s name.

A PAC Control Basic - [Dough_Chip_Control]

ﬁFile Edit Configure Chart Subroutine Compile Mode Tools  Wiew Window Help

TS o~ J

= I5) Cookies
I5) Control Engines
15 Subroutines Included
= I3 Charts
EL'O Alarmz
EL'O [ough_Chip_Contral
EL'O Dough_esszel_Pressure_
EL'O Oven_|nzpection_Control
EL'O Powerup
= IC5) Wariables
= I£5) Mumeric Yariables
@ bStartFlag
\1'321% dtCookietotionTimer
@ [DoughPressureSetpc—
@ R amptalue
|3ij| 5etpointtinusDeadb
@ nChartStatus
12l nCookieMationPresst
@ nLoopCodm e
< | 3

chart name.

arl TL pewt Py
| | C

IPAC Control: Ready

ki ECo e 3|8
-
This chart drops the dough and chips on the conveyor belt. B
The belt must be running between 50% and 65% of max rpm.
The Powerup chart starts d Start
this chart.
1w
Start
Conweyar
7
This chart runs
continuously once the Speed OK?
program has been started.
T
e Drop the dough.
Drop Dough
L 7
< ¥
| (i)Shortcuts | 85% v
[T T hart/
—If:l [ough_Chip_Contral
Configure MM
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PAC Control Blocks and Connections

Let's take a closer look at what this chart does. Even without its descriptive comments, it's easy to
see that this program segment begins by starting a conveyor belt. If the belt isn't running at the
correct speed, the process goes into a loop until the speed is correct. When it is correct, dough is
dropped on the belt, and then chips are dropped on the dough. The process then loops back to
re-evaluate the conveyor speed, waiting if it's incorrect, and dropping more dough and chips if it's
correct.

The rectangular-shaped blocks are called action blocks. They do things.
The diamond-shaped blocks are condition blocks. They decide things.

Charts may also contain other blocks, including oval-shaped continue blocks, which route the
program logic back to another block in the same chart, and hexagon-shaped script blocks, which
contain instructions and logic written in PAC Control’s built-in OptoScript programming language.

Connections link the blocks together and show how the program logic flows. Action blocks exit
through just one connection, since they always go in one direction. Condition blocks exit through
two connections, one for a true evaluation and the other for a false evaluation.

Action Block tool

OptoScript Block tool
Find tool iondition Block tool
| # 2% ||L | ® 4] | £ Compile View £ Compile All
Y LT T
£ Pan tool ‘ | Texttool
elect tool Connect tool
ind and replace tool Continue Block tool

This chart drops the dough and chips on the conveyor belt.
The belt must be running between 50% and 65% of max rpm.

The Powerup chart starts ' start Action Block
this chart.
Connections OptoScript Block

7
Start
eyor
This chart runs

continuously once the
program has been started.

Text Drop the dough.
op Dough

§ Drop the chips.

Condition Block
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Opening a Block

Let's see what's in a block.
1. Double-click the Drop Dough block.

The Instructions dialog box appears.

A Instructions - Dough_Chip_Control - Drop Dough

5
nCookieMotionPreset
dtCookieMotionTimer
Open the dough valve,
ghDisp Val
Previous Block.

Keep the dough valve open for 2 seconds.
Delay (Sec)

2.0 =
Cloze the dough valve,
Turn Off

b
[ Cloze ] [ Help ] [ Command Help ]

This block contains four instructions: Move, Turn On, Delay (Sec), and Turn Off. Each one has a
description above it.

2. Double-click the Turn On instruction to see more about it. (You could also click it once and click
Modify).

The Edit Instruction dialog box for the Turn On command appears.

# Edit Instruction

X

Instruction:
v|[ Select... ]

Comment:

|Dpen the dough valve. |

Type Mame

Drigital Dutput v | | doDoughDispensel alve v |

[ QK. ] [ Cancel ] [ Help ] [ Command Help ]

Here we see the details of the command: It turns on doDoughDispenseValve (the digital output
point for the dough dispensing valve). In other words, it opens the valve.

3. Close the Edit Instruction dialog box by clicking OK or Cancel.
4. C(lose the Instructions dialog box by clicking Close or by pressing Esc (the Escape key).
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Add a New Block and a New Connection

Before we leave the Dough_Chip_Control chart, let's make a cosmetic change. We noted earlier that
we didn't have any continue blocks in this chart. Let's add one to replace the long connection that
loops from the Drop Chips block up to the Speed OK? block.

1.

Delete the existing long connection line by clicking it to select it, and then pressing the Delete
key.
Now click the Continue Block tool @ ' in the toolbar.

When you bring the mouse back into the chart area, an oval outline appears, representing the
new continue block.

Position the oval below the Drop Chips block, and then click the mouse.
A continue block appears with the default name Block (and the block number).

If you move the mouse pointer again, a new oval outline follows. Deactivate the Continue Block
tool by right-clicking the mouse, or by pressing Esc.

Your screen should now look something like this:

{J
The Powerup chart starts Start A
this chart.
1w
Start
Conveyar
g
This chart runs
continuously once the Speed OK?
program has been started.
T
d Drop the dough.
Drop Dough
i Drop the chips.
Drop Chips
18
v
< ¥
(i)Shortcuts | B4% w
[AT- TR chart £

5. Connect the Drop Chips block to the continue block:

a. (lickthe Connecttool t .
b. Click once in the Drop Chips block.

NOTE: When using connections, always click first in the block that the connection is coming from.

If you move your pointer around the screen, you see a connection following the pointer. Click
the top of the continue block to complete the connection. Deactivate the Connect tool by
right-clicking the mouse button or by pressing Esc.

Rename a Block

Let's rename the continue block.

1.

Click the continue block to select it.
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2. Right-click the continue block and select Name from its pop-up menu.
The Name Block dialog box appears.

#1 Name Block

Ok

Cancel

Help

il

3. Type Back to “Speed OK?~ over the selected text, and then click OK.
The chart now looks something like this:

{J
The Powerup chart starts Start A
this chart.
1w
Start
( Conveyar >
g
This chart runs
continuously once the Speed OK?
program has been started.
T -
d Drop the dough.
Drop Dough
i Drop the chips.
Drop Chips
I Bac::< to
'Speed OK?
L b
< | ¥
(i)Shortcuts | B4% w
[AT- TR chart £

Select a Continue Block’s Destination

Now let's give the continue block its instructions.
1. Double-click the continue block to see a list of all the blocks in the chart.

# Select Continue Block Destination E]

Block 1d: Mame Type
; Drop Chips
5 Drop Dough Action
2 Speed QK7 Condition
1] Start Action
17 Start Conveyor OptoScript

[ QK. ] [ Cancel ] [ Help ]

2. (lickthe Speed OK? block to select it, and then click OK.

When the program reaches the continue block, it returns to the Speed OK? block. We haven't
changed the way the program works; we've just done the same thing in a different way.
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Continue blocks are useful in a complex chart to avoid crossing connection lines.

Adding a Command

Now we're going to add a command (also called an “instruction”) to a block in the
Dough_Chip_Control chart. This command will keep track of the number of cookies we produce.

NOTE: To enable legacy commands in PAC Control for a specific strategy, see “Legacy Options”on
page 208.

1. Double-click the Drop Dough block.

A Instructions - Dough_Chip_Control - Drop Dough

>

nCookieMotionPreset Modify.

dtCookieMotionTimer

Open the dough valve,

Turn On Mext Block
doDoughDispenseValve
Previous Block.

Keep the dough valve open for 2 seconds.
Delay (Sec)
2.0 =

Cloze the dough valve,
Turn Off

£

[ Cloze ] [ Help ] [ Command Help ]

2, We'll add the new instruction (command) between the Turn On and Delay (Sec) commands.
a. Clickanywhere on Delay (Sec) to highlight this command.
This highlight indicates the position where the next command is added.
b. Click Add to open the Add Instruction dialog box.

9 Add Instruction rz|
Instruction:
g v| [ Select... ]
LComment:
|
Type Mame
ar |AII Walid Types v | |aiD0ughVesseIF'ressure v |
Fut Result in |AII Walid Types w | |aoE0nveyorSpeedEontrol w |
[ QK. ] [ Cancel ] [ Help ] [ Command Help ]

Finding Commandes in the Instructions Dialog Box. There are several ways to find
commands.

« If you know the exact name of the command you want, you can start typing it as soon as you
open the Instructions dialog box. (Don't worry about typing over the Absolute Value
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command—It appears in the Instruction field only because it's the first command in the
alphabetical list of commands).

As you type, the first command matching the letters you have typed is filled in automatically.
As you continue typing, PAC Control displays the next matching command. When you see the
command you want, press Enter or click the Add button to add it to the block.

For example, if you want to create a Move command:

As you type: This command appears:
m Make Integer 64
mo Modulo

mov Move

«  One way to add a command is to click the Instruction drop-down list, and then scroll through
the list of commands to find the one you want.

A third way to add a command is the one we'll use now.
3. Inthe Add Instruction dialog box, click Select.

4 Select Instruction *
Groups: Instructions:

Anialog Point ~ "
Chart Add

Communication Arccosine

Control Engine Arcsine

Deprecated Arctangent

Digital Point Clamp Float Table Element

Error Handling Clamp Float Variable

IO Unit Clamp Integer 32 Table Element

IO Unit - Event Message Clamp Integer 32 Variable

IO Unit - Memory Map Complement

IO Unit - Scratch Pad Cosine

Logical Decrement Variable

Divide

Miscellaneous Generate Random Mumber

PID - Ethernet Hyperbolic Cosine

Pointers - Hyperbolic Sine v
Sirnu datinn Hunarhnlic Tannent

Cancel Help Command Help

Command groups are listed on the left, and commands in the highlighted group are listed on
the right.

4. The command we want will increase a counter. Counting sounds like math, so let's try the
Mathematical group.
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Click Mathematical on the left to highlight it, then scroll through the list on the right until you
find the Increment Variable command. Clickit once.

# Select Instruction

Groups: Instructions:
Diigital Point # || | Clamp Integer 32 T able Element A
Error Handling ~ | | Clamp Integer 32 Y ariable b
Event/Reaction Complement
High Denzity Digital Module Cosine
1/0 Unit Decrement W ariable
140 Unit - Event Message Divide
140 Uit - Memary Map Generate Random Mumber
140 Unit - Scratch Pad Hyperbolic Cozine
Logical

Miscellaneous \
FID - Ethernet I awirnum

PID - Mistic Minirnum

Puairters Modulo

Simulation | | Multiply

Shing Matural Log

Time/D ate ¥ ||| Raize e to Power b

[ QK ] [ Cancel ] [ Help ] [ Command Help ]

NOTE: If you need information about a command, click the Command Help button.

Click OK, and this command is displayed in Instruction filed of the Add Instruction dialog box.
The cursor is automatically moved to the next field, which is Comment. Comments are optional
but very useful; they can help someone else understand the purpose of the instruction.

In the Comment field, type Increment a counter of cookies produced.

Next, click the Type down-down list (the field that currently reads “All Valid Types”).

This list shows what those valid types are: a float variable, an integer 32 variable, and an integer
64 variable.

Counters are integers, so select Integer 32 Variable.

Now we're going to create the integer 32 variable to increment, which will be called
nCookie_Counter.
a. C(lick the Name down-down list (the field that currently reads “bStartFlag”).

The drop-down list shows all variables currently configured as integer 32 variables:

1 Add Instruction g|

Instruction:

|IncrementVariabIe v| [ Select... ]

LComment:

|Increment a counter of cookies produced |

Type
Integer 32 Variable v
hChartStatus
nCookiet otionPreset
nLoopCounter
[ QK ] [ Cancel ] [ Help ] [ Command Help ]

nCookie_Counter is not in the list, because we haven't created it. We'll create it now using
what we call “on-the-fly configuration.”
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b. Click bStartFlag to selectit,and then type the new variable name right over it:
nCookie_Counter

¢. (lick OKto close the dialog box, and the following message appears.

PAC Control Professional

1 The object you have specified does not exist,
. Do you wish to add it now?

d. Click Yes to create the new nCookie_Counter variable.
Notice that the name and type have already been filled in.

Add Variable 53
Mame: | nCookie_Counter |
Description: | |

Initialization
O Initialize on strategy download
(%) Iritialize on strategy run
() Persistent/Redundant

Initial Value: |0

[ QK. H Cancel H Help ]

e. Add adescription, if you wish. Leave the initial value at zero, which is the default. Then click
OK to save your changes and close the dialog box.

9. Inthe Add Instruction dialog box, click OK to close it.
The new instruction appears in the Drop Dough Instructions dialog box.

A Instructions - Dough_Chip_Control - Drop Dough rz|
Far animation in ioDisplay A Add...
Move F —
From nCookieMotionPreset
To dtCookieMotionTimer
Open the dough valve,
ghDisp Val
Previous Block.

Increment & counter of cooki
Increment Variable

nCookie_Counter

Keep the dough valve open for 2 seconds.
Delay (Sec)

|

an

[ Cloze ] [ Help ] [ Command Help ]

But maybe it makes more sense to start the counter at the beginning of the process, rather than in
the middle, after some dough has already been dropped.
1. With the Increment Variable command highlighted, right-click to display the pop-up menu,

and then click Cut. (You can also use Ctrl+X to cut.) Cutting puts the instruction in the Windows
Clipboard.
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Now click Turn On to highlight it. Right-click to display the pop-up menu, and then click Paste.

You can also use Ctrl+V to paste. The Increment Variable command is pasted above the
highlighted instruction, like this:

# Instructions - Dough_Chip_Control - Drop Dough

>

|} |§ I
@ =9

@ - =o
b I == 5
T 3 g

d

nCookie_Counter

Open the dough valve,
Turn On

doDoughDispenseValve Mext Black

Keep the dough valve open for 2 zeconds. Previous Block.
Delay (Sec)
2.0
b
[ Cloze ] [ Help ] [ Command Help ]

Click Close to return to the chart.
To save the changes you've made, click the Save Strategy button [ on the toolbar, and then
click OK.
To see your new variable in the strategy tree:
a. Ifthe Variables folder is collapsed, click the plus sign to expand it.
b. If the Numeric Variables subfolder is collapsed, click the plus sign to expand it.
Your new nCookie_Counter variable should be in the list in alphabetical order.

Congratulations! You've just added a cookie counter variable. Now we're ready to download the
strategy to a control engine. But first we have to tell PAC Control that we have a control engine.

Configuring a Control Engine

Up to this point, we've been able to play around in PAC Control without hardware. Now it's time to
configure a control engine (a controller).

1.

If you have a PAC Control-compatible controller and I/0 unit you can use, make sure they are
on the same network as your PC, and make sure you have loaded the most recent firmware.

For a list of compatible controllers and /0 units, see page 6. For instructions to load firmware,
see form 1704, the PAC Manager User’s Guide.

Turn the 1/0 unit off and then back on again.

Double-click the Control Engines folder on the Strategy Tree, or select Configure > Control
Engines.
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CONFIGURING A CONTROL ENGINE

The Configure Control Engines dialog box appears.

rcﬁ!gﬁu\e:

|
Engines Associated with Strategy:
Lok || caml || bep |

Since we haven't configured a control engine yet, there are no control engines in the list.

4. (lick Add.
Configured Control Engines:
Add...
Modify...
Delete
Lo || concel |

5. (lick Add again to add a control engine.

The Control Engine Configuration dialog box appears.

Configure Ethemet Connection |

Configure cortrol engine name and paramsters:
Cortrol Engine Name: |

System Type
(®) Standard
() Redundant Networks (PRO only)
(2) Redundant Corttrollers (PRO only)

Settings
IP Address/Hostname: |0.0.0.0

Controlr ot (22001 |
Software Retries: |0 |
Software Timeout: 5000 msec

PAC Control User's Guide



CHAPTER 2: PAC CONTROL TUTORIAL

Enter Cookie Controller as the control engine name.

The name can contain letters, numbers, spaces, and most other characters except colons and
square brackets. Spaces cannot be used as first or last characters.

Under System Type, make sure Standard is selected.
Enter the control engine’s IP address.
On hardware such as a SNAP PAC R-series controller, he IP address is usually written on a sticker

on the side of the unit. If an IP address has not been assigned to the control engine, see form
1704, the PAC Manager User’s Guide, for configuration instructions.

On a SoftPAC controller, if PAC Control and SoftPAC are on the same PC, use the loopback IP
address, 127.0.0.1. However, if SoftPAC is on a different PC, use the address for that PC's network
interface card (NIC). In this case, the SoftPAC PC's NIC must be configured with a static IP
address.

NOTE: In PAC Control Professional, a second IP address field is available, so you can designate a
secondary communication path to the control engine should the primary one fail. For more
information, see “Using Ethernet Link Redundancy in PAC Control” on page 105.

Make sure that you have not changed the values in the Port, Retries, and Timeout fields, and
then click OK.

The newly configured control engine appears in the Select Control Engine dialog box.

Configured Control Engines:
Cookie Controller Add...
Modify.
Delete
0K Cancel

10. Click the new Cookie Controller control engine to select it, and then click OK.

The new control engine appears in the Configure Control Engines dialog box.

Active Engine:
| Cookie Controller

Engines Assodated with Strategy:
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COMPILING THE STRATEGY

Since you have only one configured control engine at this point, it is automatically set as the
active control engine. If there were more than one control engine, you would have to select it
and click Set Active to load it into the Active Engine field.

11. Click OK to close the Configure Control Engines dialog box.

On the Strategy Tree, the new control engine appears as the first entry in the Control Engines
folder.

Compiling the Strategy

The simplest way to compile a strategy is to enter Debug mode. The strategy is saved and compiled
before changing modes.

NOTE: The remainder of the tutorial is designed to work with the controller and I/0 on a SNAP PAC Learning
Center. For more information, go to the Opto 22 website, www.Opto22.com and search on the part
number, SNAP-PACLC.

1. Click the Debug mode button on the toolbar (or select Debug from the Mode menu).
2. Inthe Save Strategy dialog box, click Yes to save the strategy.
3. Ifyou see a Powerup Clear Expected message, click OK.

You may see a Download Warning message like this one:

X

Download Warning

'\ Strategy Mismatch
- —

The strategy to be downloaded does not match the strategy already in the control engine.
Strategy To Download

o Mame: Cookies
2 Checksum: 8ADI073CCSC4F42C0F 7B 7O0AFCF2FCED
Timestamp: 06/04/09 12:29.33

Strategy in the Controller

M ame: Cookies
Checksum: 577EF49E0D 78930 A3EFEEASIE3CF3031
Timestamp: 06/03/09 17.07.54
If you choose to continue, the strategy that is in the control engine will be replaced by this strategy.

Do you want ta continue the download?

[ Yes ] [ Mo ] [ Help ]

Or you may see a message that the control engine’s memory has been cleared.
4. C(lickYes to proceed.

Two additional dialog boxes appear. The first dialog displays the progress as the strategy is
compiled. The second dialog shows progress as the strategy is downloaded to the control
engine.

PAC Control User's Guide


http://www.opto22.com/site/pr_details.aspx?cid=1&item=SNAP-PACLC

CHAPTER 2: PAC CONTROL TUTORIAL

st rategy Download

E Downloading your strategy
=
v

Download strategy: [ |

Cancel

Assuming the strategy was compiled and downloaded successfully, you are now in Debug
mode.

In the PAC Control window, you'll notice that the Debug toolbar is now available. The mode is
shown at the bottom of the main window. The open chart window shows that the strategy is
stopped, as shown in the following figure:

Debug toolbar TER
buttons e
D)
A~
- This chart drops the dough and chips on the conveyor belt. 3
[ Cookies The belt must be running between 50% and 65% of max rpm.
= I£5) Control Engines
# Cociie Conuter The Powerup chart starts g
125 Subroutines Included this chart Start
= 15 Charts
l?o Alarms
l?o [ough_Chip_Contral
l?o Dough_esszel_Pressure_
l?o Intermupt -
l?o Owen_lnzpection_Contral
l?o Powerup - s
= I£5) Wariables This _chart runs '
= [ Numeric Variables continuously once the Speed OK?
[E] bChipDispenselialve program has been started.
2] bChipLevelSwitch
@ bDoughDizpenszetaly p
2] bDoughLevelSwitch Drop Dough Drop the dough.
@ bD oughPressureCornt
2] hest I v,
Strategy statu r bEStep e | .
iohP a5k ailS
< - o e
b Next 1 Prev —|f:", Dough_Chip_Contral f:ﬁ Dough_Yesszel Pressure_Contral | u Mode
IC:'l,Program Files\OptoZ2\PAC Project 8, 1\Display Pro ExamplesiioCookies\Control\Cookies Debug MM

Running the Strategy

In Debug mode, we're going to run our strategy and examine it. We'll see how the strategy run
affects variables, how the command blocks are executed, and so on. The first chart to run in any
strategy is the Powerup chart, so we'll ook at it first.

1. Double-click the Powerup chart on the Strategy Tree. When it opens, notice that it says
Stopped at the bottom left.

2. (lickthe Run Strategy button p- .
A dialog box asks if you are sure you want to run the strategy.
3. C(lick Start Strategy.
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4,

6.

A progress window appears, perhaps only briefly. And at the bottom of the chart window, the
word Stopped changes to Running. Let’s try pausing the program to see where we are.

Click the Pause Chart button ' .

#1 PAC Control Professional - [Powerup]

X

ﬂ’l File Edit Control Engine Debug Chart  Subroutine Mode Tools  Wiew Watch  Window Help - | &8 x
LR B %0
ookie 1 v
Cooki A .
& © Cookies : = This chart starts the program and all other charts.
= I£5) Control Engines
% Cookie Controller ]
125 Subroutines Included Start Program
= 15 Charts
L_E.]Q Alarmz
T Dough_Chip_Control Wait until start flag is set
L_r.’o Dough Yessel Pressure true (non-zero). =
l?o Intermipt
L_E.]Q Owen_lnzpection_Control
l?o Powerup
= | Variables [ Start the alarm monitoring,
= I£5) Mumeric Yariables Start Charts dough/chip control, pressure
2] bChipDispenseValve control, and oven/inspection
2] bChipLevelSwitch charts.
@ bDoughDizpenszetaly v
) ¢ | »
@ bDoughLevelSwitch
5 ! k4 [, Chart /
Ib Mext  qp Prev ﬂ’l Dough_Chip_Contral ﬁlDough_VesseI_F'ressure_E... |ﬁ| Pawerup
IPAC Control: Ready Debug MM

The hatch marks on the Start? block indicate that this command block was about to be
executed when we clicked Pause. Apparently the program isn’t getting past this block. Notice
that the False exit routes right back to the top of the Start? block, while the True exit moves on
to Start Charts. We can see that if the start flag had been true (non-zero), the program would
have gone right into the Start Charts block. Since we didn’t get that far, the start flag must be
zero.

And in fact it is. We planned it that way because we wanted someone (for example, a factory
operator) to start the process intentionally. We can simulate this ourselves in PAC Control by
manually setting the flag to a non-zero value.

Double-click the bStartFlag variable on the Strategy Tree.
A little box appears.

3 "bStartFlag" (scanning)

Value: [0 | E——Maximize button

In this dialog box you can view the variable value, but you cannot change it unless you
maximize the dialog box.

Click the Maximize button.

3 "bStartFlag" (scanning)

Mame: bStartFlag

Walue: | u} |

OMoeio 7

PAC Control User's Guide



CHAPTER 2: PAC CONTROL TUTORIAL

This dialog box displays current information on the variable bStartFlag. You can see that the
variable is initialized to zero on strategy download.

Highlight the value zero in the dialog box and type 1 to replace it.
The field turns purple, indicating a change has been made but not implemented.

Click Apply to implement the change. Click the Minimize button in the bStartFlag View Variable
dialog box and move it out of the way. Click the Powerup tab to make the Powerup chart the
active window.

Inspecting Messages

1.

Look for a light-blue [TMFS" box in the status bar at the bottom of the window.

The status bar in the main PAC Control window tells you when an information, warning, or error
message has been placed in the message queue. Messages can help in troubleshooting your
strategy. In this example an Information message is in the message queue.

Click the |IMF@ | box or select Control Engine > Messages to view the View Message Queue
dialog box.

+ View Message Queue for “Cookie Controller™ [’._|[’E|r‘5__<|
75 Refresh _é Copy Al ETPUD Top Message X Clear All Messages

#  Code Severty Description Chart Block. Line | Object Time Drate

o -4 Info Device has powered up. [Powerup clea..  <system: _|.. M4 Mia Miked.. 1313, 09/25

This message tells you that the I/O unit has powered up.

3. Close the dialog box to return to the Powerup chart.

Stepping Through the Chart

Now let's step through the chart to see what's happening.

1.

Click inside the Powerup chart, and then click the Step Over button TF .

The hatch marks move from Start? to Start Charts. We've just moved (stepped) to the next
block.

Click the button again.

PAC Control executes the Start Charts block and steps to the next command block. Since there
are no more blocks in this chart, we are actually exiting this chart and moving on to new
instructions in another chart. The Powerup chart has stopped, and you can see the word
Stopped at the bottom left of the chart.

In the View Variable dialog box, the bStartFlag value reverts to zero, because the Start Charts
block set the flag back to zero.
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Close the bStartFlag View Variable dialog box. In the Powerup chart window, click the Pause
Chart button to turn stepping off.

Then close the Powerup chart.
Double-click the Charts folder on the Strategy Tree.
The View Chart Status dialog box appears.

5, View Chart Status

Mame Statuz Mode Breakpoint Status FPaused At
Alarmz Fiunning Step Off Break Off
Dough_Chip_Control - Running Step Off Break Off
Dough_Yeszel_Pre... Running Step Off Break Off
Oven_|nzpection_...  Running Step Off Break Off
Powerup Stopped Step Off Break Off
< ¥

This dialog box shows us all the charts in our strategy. As you can see, four of the charts are
running, and one (Powerup) is stopped.

Powerup is stopped because it has already done its job. Let’s check the running charts.

Close the View Chart Status dialog box and click inside the Dough_Chip_Control chart again.

If your mouse has a wheel, hold down the Ctrl key and move the mouse wheel up or down to
change the zoom.

If your mouse doesn't have a wheel, there are several other ways to zoom out, too. You can
right-click on the chart and select Zoom from the pop-up menu. You can select Zoom Out
from the View menu. You can press the + or - keys on the keyboard. After zooming out, the
chart looks something like this:

Tl ohartdrop & 18 dough and ahilp & on s conveyor belt
The beltmu ctbe running betwesn 50% and 85% ofmax rpm.

The Fowerup ohart shrts
#ilcohart

Tisohartruns
oninuou ey onos s
program hac been shried.

b
>

<
% Chart /

—|ﬁ| Dough_Chip_Contral |

You can zoom back in if you wish by holding down the Ctrl key and moving the mouse wheel
down or one of the other methods.
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The chart’s status bar indicates that it is running, but we can't see much happening.
7. (lick the Pause Chart button 1 .

One of the command blocks appears with hatch marks.
8. Now click the Step Over button ¥ .

The next command block is hatched.

9. Continue clicking and watch how the program proceeds from Speed OK? to Drop Dough to
Drop Chips to Back to 'Speed OK?"and back up to Speed OK?

A pulsating green border appears around a block when the commands inside the block are
being executed. While you are stepping through, and anytime the Pause Chart button is
clicked, the chart status indicates Step On.

10. Click the Pause Chart button again to run the strategy at full speed.
Step Off now appears in the chart status bar.

Auto Stepping

The final stepping option is auto stepping. You can select this option whether or not the chart is
currently paused.

1. Clickthe Auto Step Chart button ¥ and watch the program move from block to block.

At one time or another, your chart looks like this:

this chart. STrt »

7
Start

Conveyor

This chart runs
continuously once the
program has been started.

Drop the dough.

rssasiess  Drop the chips.

13
Back to
"Speed OK?"
v

< ¥
[Furning 5tc0 Ao | Break 0 |_2.005 5ec._] Shoreus 100~
[ TR TR chart £

—|ﬁ’l Dough_Chip_Contral |

Notice that in the PAC Control toolbar, the Run and Auto Step Chart buttons are depressed. The
chart status bar shows us the chart is running and in Step Auto mode. The time indicator to the
right of Break Off shows the time it took for the most recent block to execute.

2. (lickthe Auto Step Chart button again to end auto stepping.
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Step Off appears, indicating the program is again running without interruption.
Now let's see how many cookies we've produced to this point.

3. Onthe Strategy Tree, double-click the numeric variable nCookie_Counter.

%< "nCookieCounter™ (scanning)

WValue: |42 =

The Value field should increase every time a cookie is produced, adding to the total number of
cookies produced since the strategy run began. The nCookie_Counter above shows this figure
as 42. (Yours may be different.)

But nCookie_Counter tells us the total number of cookies put on the conveyor belt, without
considering that some of them may be rejected by the inspection station. We need to subtract
the number of bad cookies so that nCookie_Counter keeps track of the number of cookies sent
out the door, not just sent to the oven.

4, C(lose the nCookie_Counter View Variable window and click the Configure mode button on the
toolbar.

5. Double-click the Oven_Inspection_Control chart on the Strategy Tree to open it.

The chart window looks something like this:

~
The Powerup chart starts
this chart. Start
v
2 . While conveyor speed
Speed F is out of spec, set oven
0K? OvenStandby | . 1 perature to 200
degrees.
>
7 Set oven temperature to
Oven On 450 degrees.
If inspection station sees
a bad cookie, open reject
valve for 0.5 second.
w
< >
(i) Shortcuts | 100% v
[T chart /

Near the bottom of the chart, the Reject Cookie? block determines whether a bad cookie has
been found. If one has, the strategy moves to the next block, Blow Off, which is where the bad
cookie gets blown off the conveyor. When that happens, we want to decrement the
nCookie_Counter variable.
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10.
11.

12.

13.

CHAPTER 2: PAC CONTROL TUTORIAL

Double-click the Blow Off block to open its instructions window:

A Instructions - Oven_Inspection_Control - Blow Off r>_<|

a
Clear O h
On Point dilnspectionPassFailSwitch Modify...
Turn on reject valve to blow away bad cookie.
Turn On
doRejectValve | Mest Block
Leave reject valve on for 2 seconds. Previous Block
Delay (Sec)
2.0
b
[ Cloze ] [ Help ] [ Command Help ]

This command block is executed only when a bad cookie has been found. This block first resets
the on-latch triggered by the bad cookie, so that the next cookie won't be marked bad, too. The
block then turns on the reject valve. The valve stays on for two seconds before being shut off.
Let's decrement the counter after the cookie is gone and the valve is shut.

Scroll down and click on the open spot, below the other instructions.
The highlighted line marks the position of the next command to be added.
Click Add.

A Add Instruction E]

Instruction:
; g v| [ Select... ]
|
Type Mame
ar |AII Walid Types v | |aiD0ughVesseIF'ressure v |
Put Result in |AII Walid Types - | |aoE0nveyorSpeedEontrol w |
[ QK. ] [ Cancel ] [ Help ] [ Command Help ]

You can use PAC Control without a mouse, and to demonstrate how, we'll use only the
keyboard to enter data in this dialog box.

Type dec in the Instruction field.

The Decrement Variable command appears, since it's the first command that starts with that
text pattern. This is the command we want to use.
Press Tab twice to move to the Comment field, and (if you want to) type a comment.

Press Tab again to move to the Type field. Press the down arrow on your keyboard twice to
select Integer 32 Variable.

Press Tab again to advance to the Name field, and then press the down arrow until you see
nCookie_Counter.

Press Tab again and notice that an outline appears on the OK button.
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14.

New
command

An outlined button means that pressing the space bar or Enter is equivalent to clicking the

button.
Now the dialog box looks like this:

A Add Instruction

Instruction:

X

| Decrement W ariable

v| [ Select... ]

LComment:

|Decreases cookie count by one to account for a rejected cookie

Type

Mame

Integer 32 Variable

v | | nCookie_Counter

[ QK. ] [ Cancel ] [ Help ] [ Command Help

Press Enter.

The dialog box closes and the new command appears in the Instructions window.

 Instructions - Oven_Inspection_Control - Blow Off

X

Leave reject valve on for 2 seconds.
Delay (Sec)
2.0

Turn off reject valve.
Turn Off

doRejectValve
[ :ourit by one to
Decrement Variable

nCookie_Counter

[ Cloze Help

J

] [ Command Help ]

>

Add...

Mext Block
Previous Block.

15. Click Close to return to the Oven_lInspection_Control chart.

Compiling and Downloading the Change

Now we'll compile and download the modified strategy.
Click the Debug mode button on the toolbar.
A message box appears, warning you that changes have been detected and asking if you want

1.

3.

to save them before downloading.

Click Yes to continue.

Another warning notes that the strategy name, check sum, or timestamp differs from that in
the control engine and asks if you want to continue.

Click Yes.
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4. On the toolbar, click the Run Strategy button - . In the Strategy Tree, double-click the
bStartFlag variable. Maximize the dialog box, change the value to 1, and click Apply. Close the

dialog box.

v

Auto Step Chart button.

Click inside the Oven_Inspection_Control chart to make it the active chart, and then click the

You see three blocks being processed: Speed OK?, Oven On, and Reject Cookie? The strategy
doesn’t move into the Blow Off block. That's because an inspector has to flag bad cookies, but
we don't have an inspector right now. So we'll simulate what would happen by tripping the

digital input that flags a bad cookie.

6. Inthe Oven_Inspection_Control chart, click the Auto Step Chart button again to stop auto

stepping.

Step Auto changes to Step Off in the status bar.

7. (lick the Pause Chart button.
Step Off changes to Step On.

8. (lickthe Breakpoint tool &% and click once on the Blow Off block.
A breakpoint hand appears on the block.

9.

in the chart status bar.

Click the right mouse button or press ESC to release the tool. Notice that Break On now appears

10. Click the Breakpoint tool and click once on the Blow Off block.

A red box appears around the Blow Off block, and Break On now appears in the chart status

bar.
The Powerup chart starts
this chart. Start
v
2 5
Speed F
OK?
=
T
Owven On

Break On |

\‘ — Blow Off

Owven Standby

Set oven temperature to

450 degrees.

If inspection station sees
a bad cookie, open reject
valve for 0.5 second.

While conveyor speed
is out of spec, set oven
temperature to 200
degrees.

v
>

<
[Fumning | Step 0 Jbroakon]

(i) Shortcuts | 1003 w

Oven_lnspection_Control\-‘LLLM

|ﬁ| Dough_Chip_CW Oven_lnzpection_Control |

11. Click the Dough_Chip_Control tab at the bottom of the PAC Control main window.

The chart appears.

12. Click the Pause Chart button to pause the chart.
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7
Start
Conveyor

This chart runs
continuously once the
program has been started.

Drop Dough

v

Drop Chips

T

h

3
ack to
"Speed OK?"

Drop the dough.

Drop the chips.

v

>

< |
[ unning J Step On JBreak 0t | 2003 Sec ]

(1) Shortcuts

“rrremwehae— 0

—|ﬁ| Dough_Chip_Contral ﬂ’l Oven_|nzpection_Control

Using a Watch Window

To see clearly what we're doing, we'll create a watch window to monitor cookie production.

1. Inthe Strategy Tree, double-click nCookie_Counter.

%+ " nCookieCounter” (scanning)

Walue: | 74 | =

The value is frozen at some number, such as the 74 shown above. Since the counter is no

longer increasing, we can see that cookie production has temporarily stopped.

2. (lick the Maximize icon [5] (in the lower right corner) to display the scanning options.

3w« “nCookie_Counter* (scanning)

Mame: nCookie_Counter

Walue: | 7q |

(i1 More Irfo 7

3. Click Watch.
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The Add Watch dialog box opens.

1 Add Watch Entry

Mame: | nCookie_Counter

Select Portions To ‘watch:

Walue Select Al

LClear

Select W atch Window

[ QK. H Cancel ][ Help ]

Since there is no watch window available to select, we'll create one.

Click New.
Create New Watch Window |
Lok in: | I3 My Cookies V| @ ?‘ ® -
File name: | | [ Open ]
Files of lpe: | PAL Control W atch 'Window Files [* wth] w | [ Cancel ]

Make sure the My Cookies directory appears in the Look in field. Type a name for the watch
window in the File name field. Then click Open.

The watch window name appears in the Add Watch dialog box, and the new watch window
appears behind it.

In the Add Watch Entry dialog box, click OK. Close the nCookie_Counter view variable dialog
box.
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7.

The new watch window looks something like this:

Watch window Docking

#1 PAC Control Professional - [nCookie_Counter]
¢ File Edit ControlEngine Debug Chart Subroutine Mode Tools Wiew ‘Wabtch Window Help

n (@]

Cookies = rame Type IVAL

= I5) Cookies ~ nCookie_ Counter Integer 32 Variable 74

I5) Control Engines
15 Subroutines Included
= I3 Charts
L_r.lo Alarms
L_[.'O [ough_Chip_Contral
L_[.'O Dough_Yeszel_Pressu

L_[.'O Intermupt
L_r.lo Oven_|nzpection_Conl
L_[.'O Powerup
= £ Wariables
= I£5) Mumeric Yariables
2] bStartFlag

Izz

a4 diCookietotionTir—

THR

] [DoughPressureSe

FLT

] R ampyalue

FLT

B 5 etpointtinusDe:

FLT

12l nChartStatus

=

n Jnter
@ nCookieCounter v
| > 3 | >

< >
-

IPAC Control: Ready Debug MM

ﬂ’l Dough_Chip_Contral ﬂ’l Oven_lnspection_Control | &® nCookie_Counter

Since we want to be able to see chart windows as well as the watch window, let's dock the
watch window at the bottom.

In the watch window, click the docking button [ in the upper-right corner.
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The watch window moves to the bottom of the main window.

A PAC Control Professional - [Dough_Chip_Control] |._||E|r>__<|
ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help - 8 x

# > mn ¥ (e

This chart runs : -
= ) Cookies A continuously once the
I5) Control Engines program has been started.
15 Subroutines Included
= I3 Charts T
&
Ty dlams . Bor o Drop the dough.
EL'O [ough_Chip_Contral =
EL'O Dough_Yesszel_Pressu *
ELIO Interrupt 7 Drop the chips.
EL'O Oven_|nzpection_Conl Drop Chips
EL'O Powerup
= £ Wariables *
= I£5) Mumeric Yariables ae
=] bStartFlag

< [ >
34 aicookieptotorri ¥ | ||| KRS NN CZEXNCTH I shorcus
< N T T
0 Next

ﬁ}Prev
Name Type IVAL VAL

—|ﬁ| Dough_Chip_Contral ﬂ’l Oven_|nzpection_Control |

Docked watch

window
nCookie_ Counter Integer 32 Warishle 74
PAC Control: Ready Debug MM

Now we'll trip the latch that signals a bad cookie.

8. On the Strategy Tree, under the I/0 Units folder at the bottom of the window, expand
Mixed_IO_Unit by clicking the plus sign at the left of the name.

You see a folder named Points.

9. Expand the Points folder to display the digital I/O points configured for this I/0 unit.

:« Cookies

IC5) Wariables ~
= £ 140 Units
= 28 Mived_I0_Unit
= ) Point Points folder

LU 4D oughLevelSwich
L diChipLevelSwitch
I“'%“_' dilrspectionPassFail3wi
L diEStop
B"’—_“,' doD oughPressureContro

B"’—_“,' doD oughDispensel alve
B"’—_“,' doChipDispenzetalve
B"’—_“,' doRejectyalve

OM_, aolvenT emperatureCol
OM_, aolonveyorSpeedContr
IM,_ aillvenT emperature
IM,_ aiDoughvesselPressure

= PiDs 3

< |
-
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10. Double-click dilnspectionPassFailSwitch.

%.& "dilnspectionPassFailSwit. .. rz|
= Maximize button

IVAL: AL

11. Inthe minimized dialog box, click the Maximize button.

3% "dilns pectionPassFailSwitch® |... rz|

Mame:  dilnzpectionPassF ailSwitch

Tupe:  Digital Input (i1 More Irfo

IVl Hual:
State: £
On-Lateh: s
Off Latch: E

Communication

Pairit:

140 Unit; _ =1 Open Parent
5

NOTE: Don't worry if the red error message “l/O unit not configured” or XVAL values appear in this
dialog box. This occurs because the strateqgy is configured for sample hardware that probably doesn't
correspond to your actual I/O units and modules. PAC Control can't locate this hardware. That's okay
for this example.

When an inspection finds a bad cookie, the on-latch attached to the I/O point
dilnspectionPasskailSwitch is supposed to go on. We're going to trip it manually.

12. Click one of the arrows in the On-Latch IVAL field to change it to On. Also make sure that the
Enable comm field says No.

The dialog box should look like this:

%.& "dilnspectionPassFailSwitch™ (... rz|

Mame:  dilnzpectionPassF ailSwitch
Tupe:  Digital Input (i1 More Irfo
HbL
On-latch On
Communication
140 Unit; _ =1 Open Parent
[ Apply ] [ Wwatch ] [ Flat > ] =

13. Click Apply.

The On-Latch IVAL field turns green after a second or two, indicating the latch is on.
14. Click Add Watch.

We'll add the variable to our watch window, so we can see what happens.

15. In the Add Watch dialog box, leave all portions checked. Click OK to add the variable to the
Cookie Watch window. Close the view point dialog box.
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16. In the Cookie Watch window, click the plus sign next to (02) dilnspectionPassFailSwitch.

Your screen may show only part of the words.

17. Move your cursor over the right side of the Name column until the cursor changes shape. Then
click and drag the column to make it wider, until you can see all the words.

== Watch Window

Type
Integer 32 Warisbhle

i nilIn:pPr‘r ionFassFail... |[Digit:

18. Clickin the Oven_Inspection_Control chart to make it active, and move the scroll bars until you
can see the Blow Off block at the bottom.

Your window now looks something like this:

A PAC Control Professional - [Oven_Inspection_Control]
ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help - | &8 x

i conig = oebug 03 or-Lo- [

Cookies

A/
=

15 Paints

El= Ems

,;J Ewent_01

S biwed |0_Unit

15 Paints
L1 4D oughLevelSwitch

IL‘" dlEhlpLeveISW|tch
jifal’

T+
I“'%“_' diEStop

B"’—_“,' doD oughPressureContraly's
B"’—_“,' doD oughDispensel alve
B"’—_“,' doChipDispenzetalve
B"’—_“,' doRejecty alve

OM_, aolvenT emperatureCaontrc

2 anCanveunrGinesdContnl

nCoockie Counter

< >
e

Yalchiindoisiisiiiiiiitiitihii bR %

Name

2} diInspectionP
Jtate

On-Latch
COff-Latch

X

—
\I'/ degrees. ~
Set oven temperature to
450 degrees.
If inspection station sees j
a bad cookie, open reject
valve for 0.5 second.
v
< | >
[ Running |[ Step On | Break 0if 435715 813 [EE=TS
% Chart /

. [Pigital Input

ﬂ’l Dough_Chip_Contral ﬂ’l Oven_|nzpection_Control |

Type IVAL XVAL
Integer 32 Warisbhle 472

C:\Program Files\Opko22\PAC Project 8, 1%Control Pro ExamplesiioCookies\Cookies.idb Debug (]

19. Click the Step Over button as many times as it takes to get the hatch marks to the Blow Off
block. Now watch the nCookie_Counter IVAL value in the watch window as you click the
button again.
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A bad cookie was found, so the counter was decreased by one. At the same time, the on-latch
was reset to Off, as you can also see in the watch window.

A PAC Control Professional - [Oven_Inspection_Control] |._||E|r5__<|
ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help - 8 x

CRMERCRGER

Oven Standby TS OUT OT Spet, et
- temperature to 20'
S Points e degrees
= [ E/Rs il
1
o fig Event 01 7 Set oven temperature to
- Muxed_!D_Umt Oven On 450 degrees.
= 5 Paints

L1 4D oughLevelSwitch

L diChipLevelSwitch

I“'%“_' dilnzpectionP azsF ailSwitch
L diEStop

B"’—_“,' doD oughPressureContraly's
B"’—_“,' doD oughDispensel alve

B"’—_“,' doChipDispenzetalve

B"’—_“,' doRejectyalve =

- e | _—
= aolvenTemperatureContre

= e =

2 anlnrweunisneedCantnl Y l:l Break D [#39719 813 Sec RIS
< "5 || e

@ Mext ﬁ} Prev ﬂ’l Oven_|nzpection_Control

If inspection station sees
a bad cookie, open reject
valve for 0.5 second.

<

ﬂ’l Dough_Chip_Contral

Name Type IVAL VAL
Integer 32 Warisbhle

nCoockie Counter
= {02} diInspectionPassFail... [ligital Input

------- on-Latch OFF ) OFF
------- Off-Latch OFF OFF 7
PAC Control: Ready Debug MM
On-latch reset to Off Counter decreased by one

20. Click the Auto Step Chart button to go back to auto stepping.

The counter does not decrease again, because the on-latch is no longer set. But the counter
won't increase until we start the Dough_Chip_Control chart again.

21. Click the Dough_Chip_Control chart tab. Click the Pause Chart button to unpause the chart.
Verify that Step On changes to Step Off in the chart status bar.

The watch window shows the nCookie_Counter value going up again.

Closing the Strategy and Exiting

Before we finish this tutorial, you may want to explore the sample strategy on your own. You can
double-click items in the Strategy Tree or open up other charts to see what they do. You can also
double-click command blocks to see what they contain.

1. When you're ready to stop, click the Stop Strategy button in the toolbar.
This action prevents the strategy from running continuously unattended on the control engine.
A dialog box asks if you are sure you want to stop the strategy.

2, (lick Stop Strategy.
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3. Toclose the strategy, select File > Close Strategy; or select File > Exit to quit PAC Control. If

What's Next?

dialog boxes ask whether you want to remove breakpoints and take charts out of stepping
mode, click Yes.

Your introduction to PAC Control is now complete. Using the sample Cookies strategy, you have
learned how to:

Open, save, and close a strategy

Work with the Strategy Tree

Work with charts and add commands in blocks

Configure a control engine

Compile, run, step through, and add breakpoints to a strategy
Make an online change

Use a watch window to monitor variables and /0 points.

The rest of this book expands on the knowledge you've just acquired. Now may be a good time to
look at the table of contents or thumb through the book and familiarize yourself with its contents.
Some sections you may want to read; others you'll probably just refer to as needed.
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3: What Is PAC Control?

Introduction

The tutorial in Chapter 2 introduced you to PAC Control without explaining much about it. In this
chapter we'll learn more about PAC Control and see its main windows and toolbars.

In this Chapter

ADOUL PAC CONEION oot ssssss s s
General Control Concepts...... . .
PAC CoNtrol TEMMINOIOGY ....ovooeeeeeresceerssicesssssecsssssssessssssssssssssssssssssssssssssss s
PAC Control Main WINAOW ..........oovvveeeeeeesssssssessssssenssssssenss

Windows and Dialog Boxes in PAC Control
CUSTOMIZATION FEATUIES .oveevrreeeversnneessssnesnesssses s

ONINE HEID oot es s sessssees s sssssssesessosssesses

About PAC Control

PAC Control is a programming language based on flowcharts. Whether you have PAC Control Basic
or PAC Control Professional, you use PAC Control to develop software that monitors and controls all
kinds of equipment and sensors, from a simple heating system to a complex factory. The software
you develop controls the Opto 22 hardware that runs your heating system or factory.

The diagram below shows how PAC Control on your PC can work with the hardware in your control
system. This example shows a small system; yours may be even smaller or considerably larger and
more complex. The diagram uses a SNAP-PAC-51 as the control engine. Input/output (I/O) points on
the subordinate SNAP PAC1/0O units monitor and control the analog, digital, and serial devices
connected to them. All these terms are defined in the following pages.
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Control System Example

PAC Display

Viewing, Trending, PAC Control
Alarming Programming,
Debugging

1 SNAP PAC S-series
g controller
;I | Runs strategy,
i controls all 1/0

Fuel Pump
(Analog output)

SNAP PAC
1/0 unit

rature :
ocouple) |
g input)

(Digital ot

Tank Level
SNAP PAC (Analog input)

1/0 unit

Photo Sensor
=+ (Digital input)

Barcode Reader

- AV

N

(Serial device)
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General Control Concepts

Automation

Automation is a way of adding intelligence to an industrial process. When you automate a process,
you are less dependent on human action to carry out the process. The process generally becomes
faster, more accurate, and more reliable. For example, take a look at the tank level and pump
combination in the diagram on the previous page. Instead of having a person watch the level in the
tank and turn the pump on or off when the level gets too low or too high, you can automate the
process by installing a processor and 1/0. The processor and /0 respond in milliseconds and are on
the job 24 hours a day.

Control Engines

In an Opto 22 PAC Control system, the control engine is the programmable component in Opto 22
controllers that provides the intelligence required for automation.

Using PAC Control, you create a software program (a strategy) that tells the control engine how
every aspect of a process should work. You download the strategy to an Opto 22 control engine
which runs it as a stand-alone application. On a SNAP PAC controller, the strategy is stored in the
controller's electronic memory; the development PC can be turned off or used for other operations
while the control engine runs the program. Whenever necessary you can modify the strategy and
download it again to the control engine.

In the diagram on the previous page, one SNAP PAC S-series controller runs the program that
controls the three areas of automation.

Digital and Analog Inputs and Outputs

An industrial process can include many different hardware components: switches, pumps, tanks,
valves, furnaces, conveyors, photo sensors, thermocouples, and so on. All the components
communicate with the control engine in the controller by way of input/output (1/0) points.

Input points are wired to hardware that brings information into the control engine from the
process. Examples of devices that can be wired to input points are thermocouples, switches, and
sensors. The control engine takes the information from the input points—such as whether a switch
is on or what temperature is registered on a sensor—processes it using the software instruction set,
and returns information to the process through output points.

Output points are wired to hardware that receives information from the control engine and uses
this information to control components of the process. For example, lights, motors, and valves are all
devices that can be wired to output points. Using an output point, the control engine might turn on
a light or open a valve.

There are two types of /0 points, digital and analog:

«  Digital points can be either on or off (True or False). Push buttons and LEDs are examples of
digital devices. An LED is either on or off; it has no other possible state.

In the Control System Example on page 46, the photo sensor is an example of a digital input
device. The photo sensor is either on or off. When it turns off as the sheet passes through its
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beam, the digital I/O module tells the control engine it is off, and the control engine responds
as programmed to stamp the sheet.

The pump is an example of a digital output device. Based on information from the tank level
input, the control engine turns the pump on or off as programmed.

Analog points have a range of possible values. Temperature and pressure are examples of
analog information. Temperature might be any number in a range, -2 or 31.65 or 70.1 or many
other possible numbers.

In the Control System Example on page 46, the tank level sensor is an analog input device. It
registers the changing level of water in the tank and reports the level to the control engine,
which responds by turning the pump on or off.

The fuel pump is an example of an analog output device. Based on information about the
temperature in the furnace, the control engine adjusts the pressure of fuel through the pump
as programmed.

SNAP Serial Communication Modules

In the PAC Control system, some I/O modules do not contain standard analog or digital
input/output points, but are used for communication over a serial network.

SNAP serial communication modules provide one or two channels for sending data to or receiving
data from a serial device (RS-232 or RS-485/422) or a protocol like PROFIBUS or Controller Area
Network (CAN) that can communicate over a serial network. In the Control System Example on
page 46, the barcode reader is an example of a serial device.

Key Features

See the following topics for some of PAC Control's key features:

“Copying /0 Configurations”on page 125

Using a configuration file, you can copy an /O configuration from one strategy to another. Or,
using PAC Manager, you can send the configuration to multiple I/O units at the same time.

"Using Network Segmenting in PAC Control”on page 103

You can leverage the two independent Ethernet network interfaces on a SNAP PAC controller
to segment the control network from the company network.

“Using Ethernet Link Redundancy in PAC Control”on page 105

(Pro only) If you are using SNAP PAC controllers and PAC Control Professional, you can use
Ethernet link redundancy to set up alternate network links.

“Persistent Data” on page 232

You can configure the data in most variables to be persistent. The variable’s value is saved in the
controller's memory; it does not change when the strategy is run, stopped, or started, and it
does not change if the strategy is changed and downloaded again.

“Pointer Commands”on page 322

For advanced programming, you can create pointers that store the memory address of a
variable or some other PAC Control item, such as a chart, an I/0 point, or a PID loop. You can
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perform any operation on the pointer that you could perform on the object the pointer points
to.

«  "Setting Initial Values in Variables and Tables During Strategy Download”on page 237

When you are adding table variables in PAC Control, you can set all table elements to one initial
value. Or you can set each individual table element to its own value by creating an initialization
file to download with your PAC Control strategy.

«  "Using Subroutines”on page 373"12: Using Subroutines”on page 365

You can use subroutines that are independent from strategies, but that can be called from any
chart or other subroutine in your strategy. Subroutines offer two ways to work with variables
and other logical elements: they can be passed in or they can be local to the subroutine.

«  "Configuring PID Loops”on page 146

A proportional integral derivative (PID) control loop (often referred to as a PID loop) monitors a
process variable, compares the variable’s current value to a desired value (a setpoint), and
calculates an output to correct error between the setpoint and the variable. Because the
calculation is complex, it is done by a mathematical formula, or algorithm, that you can then
adjust (tune) for each PID loop.

PAC Control Terminology

action block

Action blocks are rectangular blocks in a flowchart that contain one or more instructions (actions)
that do the work of the strategy, such as turning things on or off, setting variables, and so on. Several
instructions can be placed in one action block. Action blocks can have many entrances, but only one
exit.

analog point

Analog points have a range of possible values. Temperature and pressure are examples of analog
information. Temperature might be any number in a range, -2 or 31.65 or 70.1 or many other
possible numbers. Analog points can be either inputs (such as a tank level sensor) or outputs (such
as a fuel pump).
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blocks

A chartis made up of action blocks,
condition blocks, continue blocks, and
OptoScript blocks connected by arrows,
which show how the process flows. A
chart used with redundant controllers
also has sync blocks.

sync block

The sync block tool is visible only when
controller redundancy support is
enabled. A sync block is used to
synchronize redundant controllers at
strategic locations in a transactional

chart (a chart that contains sync blocks).

For more information, see form 1831,
the SNAP PAC Redundancy Option User’s
Guide.

condition block

Action block

Condition block

Process A

OptoScript block

4
Checkpoint

Sync block

Continue blocl

L . o
N v
< >

(iiShortcuts | 100% v
[ A1 TPI Chart /

Condition blocks are diamond-shaped blocks in a flowchart that contain questions (conditions) that
control the logical flow of a strategy. Condition blocks can have many entrances, but only two exits:
True and False. The block can contain more than one condition, and you can use AND or OR to

indicate whether all conditions must be true to exit True, or whether any one condition must be true

to exit True.

continue block

Continue blocks are oval-shaped blocks in a flowchart that route the flow of execution to an action,
condition, or OptoScript block. They do not contain any instructions, but store only the name of the
next block to execute. Continue blocks can have many entrances, but no exits, since the exit is

defined within the block. Continue blocks avoid awkward connections between two blocks that are

far apart.

digital point

Digital points can be either on or off (true or false). Push buttons and LEDs are examples of digital
devices: an LED is either on or off; it has no other possible state. Digital points can be either inputs
(such as a photo sensor) or outputs (such as a pump).

external value

The external value (XVAL) is the real-world value measured or set by an I/0 point. The PAC Control
strategy reads and writes only to internal values, and transfers internal values to external values if
communication to the associated I/0 unit is enabled.

flowcharts

Since most control applications are complex, the strategy typically consists of a series of process
flowcharts, or charts, that all work together. Each chart controls one aspect of the strategy—one
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piece of the automated process. Together, all the charts constitute the strategy. The total number of
charts in a strategy is limited only by the amount of memory available in the control engine.

A chart can be running, suspended, or stopped. A running chart is actively performing its assigned
task. A suspended chart is temporarily paused. A stopped chart is inactive. Every chart in a PAC
Control strategy can change the status of any other chart in the strategy, yet every chart is
independent of every other chart. Any combination of charts can be running simultaneously, up to
the maximum limit allowed on the control engine. (See also, multitasking.)

Every strategy automatically contains a Powerup chart. The Powerup chart is automatically started
when the strategy begins running, so it starts other charts. All other charts you create, based on the
needs of your process.

input point

Input points are wired to hardware that brings information into the brain from the process.
Examples of devices that can be wired to input points are thermocouples, switches, and sensors. The
control engine in the brain takes the information from the input points—such as whether a switch
is on or what temperature is registered—processes it using commands in the strategy, and returns
information to the process through output points.

instructions (commands)

PAC Control commands, or instructions, tell the control engine what to do at each step in the
flowchart to control the process. Each block in a chart contains one or more instructions, such as
Convert Number to String or Start Counter or Chart Running?

Commands are in two forms: Actions and Conditions.

«  Action commands do something in the process; for example, Convert Number to String and
Start Counterare both action commands. On the flowchart they appear as instructions in action
blocks, which are rectangular in shape. They may also appear in hexagonal OptoScript blocks.

«  Condition commands check a condition and are in the form of a question. Chart Running?
and Variable False? are examples of condition commands. They appear as instructions in
condition blocks, which are diamond-shaped, or in hexagonal OptoScript blocks. Condition
commands are questions that always have two possible answers, either yes or no (true or false).
The answer determines the flow of logic and what happens next in the chart.
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The instruction shown below is for the condition block, Button D3 On? This block contains only one
instruction. As you look at the chart, you can see that the answer to the question in the instruction
determines whether the process flows to Turn LED D7 On or to Turn LED D7 Off

“Button ™._]
D3 0n? o~ =

]

----- paron -

Instruction for the block—————
named Button D3 On? L [ bdod.. ]

Mext Block b
4y 0
Previous Block.

Operator
(&) AND
CI0R

Cloze ] [ Help ] [ Command Help

internal value

The internal value (IVAL) is the value read or written by the PAC Control strategy. Internal values are
transferred to external values only when communication to the I/0 unit is enabled.

multitasking

The control engine can run several charts seemingly at once, each performing a different task
through a time-slicing technique called multitasking (also called multicharting). Opto 22 SNAP PAC
R-series controllers can run up to 16 charts plus one host task simultaneously; SNAP-PAC S-series
controllers can run up to 32 charts plus one host task simultaneously; a SoftPAC controller can run up
to 64 charts plus one host task simultaneously. The host task is an invisible chart used to
communicate to a PC, which may be running PAC Control in Debug mode or PAC Display.

Each chartin a running or suspended state counts toward the total that can run simultaneously.
Charts that are stopped do not. When the Powerup chart is running, it also counts.

The actual order and timing for running tasks is not deterministic—that is, it is not always the same,
but depends on priorities at any given time. For example, communication may sometimes take a
higher priority than a running chart.

OptoScript block

OptoScript blocks are hexagonal blocks in a flowchart that contain OptoScript code. OptoScript is a
procedural language that can simplify tasks such as math computations, string handling, and
complex loops and conditions. OptoScript blocks can have more than one entrance but only one exit.
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output point

Output points are wired to hardware that receives information from the brain and uses this
information to control components of the process. For example, lights, motors, and valves are all
devices that can be wired to output points. Using an output point, the control engine in the brain
might turn on a light or open a valve.

pointer

A pointer does not store the value of a variable; instead, it stores the memory address of a variable or
some other PAC Control item, such as a chart, an I/0 point, or a PID loop. You can perform any
operation on the pointer that you could perform on the object the pointer points to. Pointers are an
advanced programming feature and are very powerful, but they also complicate programming and
debugging.

Because pointers can point to any data type, pointer tables can store an assortment of data types in
a single table.

Pointers allow one level of indirection within PAC Control; a pointer cannot point to another pointer.
After you add a pointer through the “Add Variable Dialog Box”on page 234, you can use it wherever
the object itself would be used.

strategy

The software program you create using PAC Control Basic or PAC Control Professional. The strategy
includes all the definitions and instructions (commands) necessary to control the process that one
Opto 22 controller handles. Since most control processes are complex, the strategy typically consists
of a series of process flowcharts that all work together, with each chart controlling one piece of the
automated process. You may have several PAC Control systems, each controlling a different process
and therefore running different strategies. Or you may have two or more PAC Control systems
controlling identical processes in different areas and running the same strategy.

variables

A variable is a holding place that represents a piece of information in a strategy, such as the
parameters for communication, temperature reported by a thermocouple, the name of a chart, or a
group of words and numbers to be sent to a display. The information a variable represents is called
the value of the variable. As a strategy runs, the variable’s name remains the same, but its value may
change. For example, the value of a variable named Oven_Temperature may change several times
while its strategy is running, but its name remains Oven_Temperature.

A variable stores one of six types of data: floating point, integer, timer, string, point, or
communication handle. When you create the variable, you designate the type of data it contains.

«  Afloating point (or float) is a numeric value that contains a decimal point, such as 3.14159,
1.0, 0r 1234.2. A good example of a float variable is one that stores readings from an analog
input, such as a thermocouple.

« Aninteger is a whole number with no fractional part. Examples of integer values are -1, 0, 1,
999, or -456. The state of a switch, for example, could be stored in an integer variable as 1 (on)
or 0 (off).

«  Atimer stores elapsed time in units of seconds with resolution in milliseconds. Up timers
count up from zero, and down timers start from a value you set and count down to zero. For
example, you could set a down timer to make sure a value is updated at precise intervals.
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»  Astring stores text and any combination of ASCII characters, including control codes and
extended characters. For instance, a string variable might be used to send information to a
display for an operator to see.

A string variable can contain numeric characters, but they no longer act as numbers. To use
them in calculations, you must convert them into floating point or integer numbers. And a
numeric value to be displayed on a screen must be converted into a string first.

«  Apointer does not store the value of a variable; instead, it stores the memory address of a
variable or some other PAC Control item, such as a chart or an 1/0 point.

«  Communication handles store parameters needed for communication with other devices.

You can use variables that are individual pieces of information, and you can also use table variables,
which are groups of related information in the form of a table.

PAC Control Main Window

With a strategy open, the main window in PAC Control Basic and PAC Control Pro look similar to this:

PAC Control title bar 441 PAC Control Basic - Cookies = 5 %
Menu bal’—-Flle Edit Configure Chart Subroutine Compile Mode Tools Wiew Window Help
Toolbar —— KL [N S H|% /@ X | #4% khGmeee @

Strategy Tree —— H ol i
() Subroutines Included
() Charts
= [ Variables
(Z5) Mumeric Variables
() String Variables
() Pointer Variables
(C3) Communication Handles
[C5) Numeric Tables
() String Tables
[L5) Pointer Tables
(=) 1/O units

] v Gom

|54 Cookies | | Mode

Status bar——eac controk Ready Configure NUM

Since PAC Control uses standard Microsoft Windows conventions, you'll recognize the title bar and
menu bar and already be familiar with some of the menus, such as File, Edit, View, Window, and
Help. This section discusses some things that may not be familiar.

Status Bar

The status bar at the bottom of the window shows you information about PAC Control. When you
move your mouse over the toolbar, a description of the button you're pointing to appears in the
status bar. The status bar indicates the mode PAC Control is in and indicates messages or errors
helpful in debugging.

To hide or show the status bar, choose View > Status Bar. A check mark next to the menu item
means the status bar will show; no check mark means it is hidden.
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Mode

You can run PAC Control in three modes: Configure, Debug, or Online. The current mode is shown in
the status bar, on the right. Toolbars and menus change depending on the mode.

Configure mode is used to create, modify, save, and compile strategies, flowcharts, and
subroutines; and to configure control engines, 1/0, and variables.

Debug mode is used to download, run, and debug strategies and to view control engine and
communication status and errors while the strategy is running.

Online mode is a scaled-down version of Configure mode, used to change a strategy while it
is running. You cannot add variables and I/0 in Online mode, but you can change ones that
already exist.

NOTE: When you change a chart in Online mode, a new copy of that chart is downloaded to the
control engine, but the old one is not deleted. After you have made a few online changes, the
additional chart copies begin to take up memory. To avoid memory problems, be sure you stop the
strategy after making several online changes and completely compile and download it to clear out
old chart copies.

To change modes, choose the mode you want from the Mode menu, or click its button in the
toolbar.

Toolbars

Toolbars give you shortcuts for doing many things that also appear on menus. Toolbars in PAC
Control include standard Windows buttons like New and Save as well as special buttons for PAC
Control functions. The tools that you can use depend on which mode you're in. Tools not currently
available are grayed out.

The following toolbars are standard in PAC Control.

“Mode Selection Toolbar”

“Configure Mode and Online Mode Toolbar”
“Debug Mode Toolbar”

Mode Selection Toolbar

The mode selection tools are always available.

£} pebug [1§ Online

Tool Description

B | Configuration Mode

Debug Mode

Online Mode

PAC Control User's Guide



PAC CONTROL MAIN WINDOW

Configure Mode and Online Mode Toolbar

The following toolbar appears in configure mode and online mode.

O EH # B X &« oo o @O Y A & compleview E5 Comple al

OEHE & 2@ X & [ d@mo et B &
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Tool Name Tool Name
i New Strategy 4 Pan Tool
= Open Strategy [ Action Block Tool
= Save Strategy [} OptoScript Block Tool
& Cut < Condition Block Tool
By Copy ] Continue Block Tool
Fe Paste ) Checkpoint Block Tool
x Delete ty Connect Tool
83 Find A Text Tool
B Find and Replace 2 Compile Active View
L Select Tool Compile All
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Debug Mode Toolbar

The following toolbar appears in debug mode.

P Run Strategy [l Stop Strategy ] Pause Chart  Pl1Inke [ ower [T out ':of fwutostep <l Breakpoint
In a smaller window, the debug toolbar looks like this.

B Il BiFIF & &

Tool | Name Tool | Name
" Run Strategy i Over
| Stop Strategy I* Out
11 Pause Chart % Auto Step
™ Into I Breakpoint
Strategy Tree

The Strategy Tree opens when you open a strategy, and closing it is equivalent to closing the
strategy. The Strategy Tree shows you all the elements of your strategy: control engines, flowcharts,
subroutines, variables, I/0 units and points, and PIDs.

Fooie 0 (ol jes
= [T Cookies
s
& R
|5 Subroutines Induded

Strategy tree @ charts
= I3 Variables

\ IC5) Mumeric Variables
@ T3 String Variables
|5 Painter Variables
I Communication Handles
[C5) Numeric Tables
[C3) String Tables
[C3) Pointer Tables
= 5 1o Units
= ‘o8 Mixed_I0_Unit
& T3 Points
=) PIDs

] trer o

The Strategy Tree works just like Windows Explorer: you can expand or collapse folders to view or
hide what is in them. You can easily see what is in your strategy, open elements to change them by
double-clicking them, or open a pop-up menu by right-clicking on an element.
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Each element in the strategy is represented by a button, shown just to the left of its name. The table
below shows the buttons and what they represent.

Button  Description Button Description

# Control Engine % Integer 32 Table

% Chart iEEI Integer 64 Table
IeY

_&_ Subroutine HH String Table
=TR

|E| Integer 32 Variable EEH Pointer Table

I=ZZ PTF.

=] Integer 64 Variable g Digital /O Unit

IeY 1]

34 Float Variable =l Mixed 1/O Unit

FLT RO

a Down Timer Variable | Analog Input Point

THE I+

@ Up Timer Variable Al Digital Input Point

THR I+

[AE]  String Variable =1 Analog Output Point

STR 9 o+ 9=up

|_EE| Communication Handle Digital Output Point

CH o—+

Float Table =3  PIDLoop

FLT PILC

|E| Pointer Variable

PTF.

Windows and Dialog Boxes in PAC Control

Windows and dialog boxes in PAC Control follow Microsoft Windows standards. You can minimize,
maximize, move, resize, and tile them as needed. See your Microsoft Windows documentation for
information on how to perform these functions.

The following topics describe other useful features in PAC Control:
“Using Tabs to View Open Windows”on page 59

“Docking Windows” on page 60

“Zooming in a Chart or Subroutine Window" on page 61
“Redrawing a Chart or Subroutine Window" on page 63
“Changing Column Width in a Dialog Box" on page 64

“Sorting Data in a Dialog Box" on page 65
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Using Tabs to View Open Windows

When multiple windows are open—especially if they are maximized—it can be difficult to know
where you are, and windows can become lost behind each other. However, you can click the tabs at
the bottom of the main PAC Control window to move among chart windows, subroutine windows,
watch windows, and blocks you may be stepping through for debugging.

oﬁ

ﬁ PAC Control Basic - Cockies * - [Dough_Chip_Control]
%File Edit Configure Chart Subroutine Compile Mode Tools View Window Help

Iuﬁﬂl

3

2O E o ¢ e s = |

- O X

- & *®

<

[ IC5) Cookies

[E5) Control Engines
IC5) Subroutines Induded
=5 Charts
= I£5) Variables
[C5) Mumeric Variables
|5 String Variables
[C5) Painter Variables
[C5) Communication Handles
[E5) Mumeric Tables
[C5) String Tables
[C5) Pointer Tables
[ 1/0 Urits

Powerup chart starts
chart.

chart runs
linuously once the

belt must be running between 50% and 65% of max pm. ~

Start

ram has been started.

Drop the dough.

Drop the chips.
v
>

(i)shortouts | 91% “

>

] &nee o

Ch\Users\Public\Documents\Opto 22\PAC Pro‘[,aé S\Control Basic Examples\}C gkies\Cpbkies.idb  Configure

e

[#  Dough_Vessel_Pressure_Control |

MNUM

White tabs show where you aré
when stepping through a chart
or subroutine.

Gray tabs show open windows. Click a
tab to bring its window into view.
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The upper layer of tabs appears when you are stepping through your strategy in Debug mode. It
acts as a kind of call stack to let you see how you got to the current block or command.

#1 PAC Control Professional - [Counter]

ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help

"

=1 |5 Sprinkler_Contral
=1 [C3 Contral Engines
& Sprinkler Controller
= subroutines Included
+ ) Charts
= | variables
+ T3 Mumeric Yariables
[C5) String Yariables
IC5) Painter Yariables
I3 Communication Handles
IC5) Mumeric Tables
[C5) String Tables
IC5) Painter Tables
= 5 O Units
= 28 Mixed_10_Unit
+ |5 Paints
=) PIDs

LA

CBX

Variahle
ncreased?.

) ? Confirmation
Beep

g SUpdate Holding
Variahle

T T A R

(1) Shortcuts

Sree

[T AW} Chart } Action Block - Teremert Courter” - I #7 Subroutine "Yariable_Increase_Motification”
—|ﬁ| Counter |ﬁ| Meszages |ﬁ| Mp |-=£ Wariable_lncrea... |6"\:r‘ Count Watch

PAC Control: Ready

Debug MM

Click the arrow @tons to
see tabs thatare notvisible
or are only partly visible.

Docking Windows

This white tab shows you are stepping inside the
Variable_Increase_ Notification subroutine, which was called by
the Increment Counter action block on the gray tab at left. The
gray Chart tab farther left shows the chart this action block is in.
Click any tab to see how you got to where you are.

You can place the strategy Tree and watch windows where you want them (dock them) in the PAC
Control main window. Docked windows do not have tabs but are contained in their own frames.
PAC Control remembers their position the next time you open that strategy.

«  Todock a window, click the docking button [ in the window’s title bar.
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The window moves to its own frame. (Compare the following figure with the one on page 54
to see the difference in the Strategy Tree window.)

1 PAC Control Professional

File Edit Configure Chart Subroutine Compile Mode Tools View Window Help

Dicoi e R

Sprinkler_Control < [x|

= | Sprinkler_Control
# ) Control Engines
|5 Subroutines Included
# ) Charts
=I5 variables
# I Mumeric Yariable
|5 String Yariables
IC5) Painter Yariables
15 Communication F
I Mumeric Tables
|5 String Tables
|5 Painter Tables
# I IO Units

@ Mext ﬁ} Prev

PAC Control: Ready Configure | MM

To change the docked position, click and drag the window’s title bar to any edge of the main
window.

To change the docked window’s width or height, click and drag the edge of its frame in the
direction you want.

To free the window from its docked position, click the docking button B in its title bar.

Zooming in a Chart or Subroutine Window

You can change the scale of any chart or subroutine window by using the zoom feature. There are
several ways to zoom:

Hold down the Ctrl key and move the mouse wheel up and down.
Press the + or - keys on the keyboard.

Right-click anywhere on a chart or subroutine window to display a pop-up menu. Select Zoom
and choose In, Out, or Reset (to return the zoom to 100 percent).

From the View menu, choose Zoom In, Zoom Out, or Zoom Reset.

To pick the zoom percentage you want, click the zoom field at the bottom right of the window
and choose one of the preset zoom levels. The “Zoom to fit"option resizes the chart to fit in the
window.

NOTE: Zooming always takes place with reference to the center point of the window.
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Here is a window at 50 percent zoom:

= Oven_Inspection_Control |Z| |E| rz|
-

Thic ohartmaintain g his oven #mperaiirs and rejeots
wookle & hatdo notpaces vimal Ingeodon.

The Fowerup ohart shrts
#ilcohart

Ifinspacdon shion we
a bad oookls, open rejeot
valve r 0.6 caoond.

(i) Shortcuts | B0 w

[4T> T2 Chart /

The same window at 200 percent zoom looks like this:

= Oven_Inspection_Control |Z| |E|P5__<

]
[ -

s ; ¢ - F P
pee
OK? Oven Standby
T .
7 Set oven temf.
Oven On 350 degrees.
< l 3 5
(1) Shortcuts ’m
[T [T chart /

Panning a Chart

The pan tool allows you to easily pan around a flowchart.

1. Using the pan tool €%, clickand hold to grab a portion of a chart.
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You can access the pan tool either from the toolbar or by holding down the space bar and
clicking the left mouse button.

: P WHITe Conveyor speed 3
Speed is out of spec, set oven
Oven Stand :
0!;?>_’ nStandby | o mperature to 200
Pan tool — degrees.

7 Set oven temperature to
Oven On 450 degrees.

If inspection station sees
a bad cookie, open reject
valve for 0.5 second.

2. Move the pan tool to a new position and release.

The chart moves to a new position.

This chart maintains the oven temperature and re
cookies that do not pass visual inspection.

The Powerup chart starts

this chart. Start

Redrawing a Chart or Subroutine Window
If you want to move quickly to a particular block, you can redraw a chart or subroutine window with
any block at its center.

1. With a chart or subroutine open in the active window, select View > Center On Block, or

right-click in the chart or subroutine window and choose Center On Block from the pop-up
menu.
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The Center On Block dialog box appears, listing all blocks in the chart.

M Center On Block

Block 1d: Mame Type
q Backto ".. Continue
7 Dirop Chips Action
5 Drop Dough Action
2 Speed DK7Y Condition
i} Skhart Action
17 Start Canv...  OptaScript
[ u] 4 l [ Cahcel ] ’ Help ]

2. Double-click the block you want, or click it once and click OK.

The chart or subroutine is redrawn with the selected block in the center of the window.

Changing Column Width in a Dialog Box

Many dialog boxes include several columns of information. To see all the data in some columns, you

may need to make columns wider.

«  Towiden or narrow a column, click the right edge of the column label and drag it horizontally.

A1 Configure 1/0 Units 53
Mame Type Port Address sate. Enabled RefC.. Descri.. Add...
| |... SMAP-.. Ethemn. 127.0.. Dizabled Enabled iz

[ Cloze ] [ Help ]

1/0 Paints...
FID Loops...

Event/Reactions...

|~ Click and drag

«  Toresize a column to the exact width of its longest entry, double-click the line that separates

the column from the one on its right.
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Sorting Data in a Dialog Box

In some dialog boxes with columns of data, you can sort the information in the way you want to see
it. The Center On Block dialog box provides an example. The blocks in this dialog box normally
appear in alphabetical order by the block name.

# Center On Block

Block 1d: Mame Type
Back to ... Caontinue
7 Drop Chips Action
5 Drop Dough  Action
2 Speed OK?  Condition
1] Start Action
17 Start Conv...  OptoScript
[ QK ] [ Cancel ] [ Help ]

«  Tosort by block number instead, click the Block Id column label.

# Center On Block

Bla... Mame Type
2 Speed OK?  Condition
5 Drop Dough  Action
7 Drop Chips Action
17 Start Conv...  OptoScript
13 Backto ... Continue
[ QK ] [ Cancel ] [ Help ]

«  Tosortin the opposite order (descending numbers instead of ascending numbers), click the
Block Id column label again.

Some dialog boxes don't allow custom sorting. If you click a column label in these dialog boxes,
nothing happens.

Customization Features

This section describes PAC Control special features for displaying numeric data, launching other

applications from PAC Control, and modifying strategies using PAC Control's Command-Line
Interface tool.

See also “Legacy Options”on page 208 and “Advanced Options”on page 211.

Setting Decimal, Binary, or Hex Display Mode

You can set up PAC Control to show the values of all integers and integer tables in decimal (the
default), binary, or hexadecimal (hex) format. Binary and hex formats help you use masks. Hex view
is available in all modes: Configure, Debug, and Online.
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The default view is in decimal notation, as shown in the following figure.

%< "nCookie_Counter™ (scanning)

Mame: hCookie_Counter
Value: [314 H Decimal view

OMoeio 7

To view integers and integer tables in binary view, choose View > Binary Integer Display, or click the

DEC button and choose Binary. The integers appear as shown below.

Al

=% "nCookie_Counter” (scanning)

Mame: nCookie_Counter

Binary view. All the bits
cannot be shown at once.

Walue: |DDDDDDDD Qo000000 00001110 00001000

OMoeio 7

To view integers and integer tables in hex view, click BIN in the dialog box, and then select
Hexadecimal. Here's how the integers appear in hex:

3. “nCookie_Counter* (scanning)

Mame: nCookie_Counter

Hex view. The 0x before the number
indicates that the number is in hex.

Yalue [0x00000EZ0

OMoeio 7

To return to decimal view, click HEX and then select Decimal.

Setting Hex String View

You can also set strings to appear in hex notation. Here is the View Variable window showing a

string in regular notation:

%, “String Variable™ (scanning)

Mame: Sting_ariable
wfidth: 10 max width 0 current width

Walue: |ITtem price =

Bytes: 0o: 73 116 101 109 Item
4: 32 112 114 105 price =
: 99 101 32 61
1z: 3z
Apply (i1 More Irfo =l

To change to hex notation, click the ASCII button on the dialog box.
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Here's how the string appears in hex:

%% String_Variable™ (scanning)

Mame: Sting_ariable
wfidth: 10 max width 0 current width

Walue:

Bytes:

49 74 g5 6D Z0 70 7E 69 63 65 Z0 3D

0: 73 11s 101 109 Item

4: 32 112 114 105 price =
§: 599 101 3z 61
iz: 32

OMoeio 7

Setting Up Applications to Launch from PAC Control

You may find it useful to launch other software applications directly from PAC Control. For example,
you may want to launch PAC Display, Notepad, or the Calculator from PAC Control. You can set up
PAC Control so that these applications appear in the Tools menu.

NOTE: If you launch an application from within PAC Control when that application is already running, a
second instance of the application may open. It depends on the application, some check to see whether
the application is already running, and some do not.

1.

With PAC Control open, choose Tools > Customize.
The Customize dialog box appears.

Menu Cantents o ]

Add

Click Add. In the Menu Text field, type the name of the application as you want it to appear in
the Tools menu.

In the Command field, type the path for the application’s executable file, or click the Browse
button [..] and navigate to the file.

(Optional) In the Arguments field, type any necessary command line parameters.

(Optional) In the Initial Directory field, type the directory the application should default to when
it runs. For example, this is the directory the application would show when you open or save files.

Repeat the steps to add other applications. To change an application’s position in the menu list,
highlight it and click the Move Up or Move Down keys.

When you have finished adding applications, click OK. The PAC Control main window is
displayed, and the applications you've added now appear in the Tools menu.
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Using PAC Control’s Command-Line Interface Tool

PAC Control's Command-Line Interface (CLI) tool was built for customers who want a fast and easy
way to modify existing strategies without using the PAC Control graphical user interface.

CLIis a command-line program that runs in Microsoft's Command Prompt window. It can:

+  Move a configured I/O module or I/O point to an empty position on the same or different I/0 unit
+ Add new variables

«  Create a control engine download (.cdf) file

You can perform operations one at a time, or you can run multiple commands in a batch.

Responses to commands (and error codes) are logged to a file. For details, see “Checking CLI
Command Qutput.”

CLI Commands and Syntax

CLI commands are not case-sensitive. You can run them from either a normal or an Admin
(“elevated privilege”) Command Prompt window.

The syntax for a CLI command is:
<CL1 executable program> <strategy filename> /<operation> <arguments>

where:

+  <CLI executable program> isyour PAC Control filename and extension:
- For PAC Control Basic, the programis ~ control .basic.exe
—  For PAC Control Professional, it is control .pro.exe

+ <strategy filename> isthe strategy to modify; for example: cookies.idb
Note that you can perform operations on only one strategy at a time.

/<operation> <arguments> isthe operation to perform and its required arguments (described
on page 69). Multiple arguments are separated by semicolons.

IMPORTANT: Paths, filenames, and arguments that contain a space must be enclosed in straight quotes (" ").

Depending on the folder you run CLI from, you may need to enter the path and filename for the CLI
executable program, the strategy, or both.

For example, if PAC Control Basic is installed on your C:\ drive, the path and filename for the CLI
executable program is:

"C:\Program Files (x86)\0pto22\PAC Project 9.6\control _basic.exe"
Because the path contains spaces, the path and filename have been enclosed in straight quotes.

B Command Prompt — [m] =

Example of a CLI command and response.
Paths, filenames, and arguments that include spaces must be enclosed in straight quotes.
Note that the response is a new prompt.
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When typing CLI commands:
«  Type aspace after:
— The ClLl executable program name.
- The strategy filename.
- The operator.
«  Type asemicolon (;) between arguments. Don't put spaces before or after the semicolons.

+  Ifyour path, filename, or arguments include spaces, you must enclose them with straight
quotes (" ).

The following table describes the CLI operations and arguments. Required characters are shown in
bold, red color to make them easier to see.

...use this

To do this: . ...with these arguments:
operation:
Move a configured 1/O /mm <source /O unit>;<source module position>;<target I/0 unit>;
module to an empty position <target module position>
where:

¢ <source I/O unit> is the name of the I/O unit that contains the
module? you want to move.

»  <source module position> is the current position number? of
the module to move.

e <target I/O unit> is the name of the I/O unit you want to move
the module to.

»  <target module position> is the position number® where you
want to move the module. Note that the position must be
empty (that is, not configured with another module).

Example: C:\>control .pro.exe cookies.idb /mm Mixed_10_Unit;8;Sprinkler_Control;4

Move a configured 1/O point /mp <source I/0 unit>;<source point name>;<target I/O unit>;
to an empty position <target module position>;<target point position>
where:

e <source I/O unit> is the name of the I/O unit that contains the
point you want to move.

e <source point name> is the name of the point to move.

e <target I/O unit> is the name of the I/O unit you want to move
the point to.

e <target module position> is the position number? of the
module where you want to move the point.

»  <target point position> is the point number on the module®
where you want to move the point. Note that the position
must be empty (that is, not configured with another point).

Example: C:\>control .pro.exe cookies.idb /mp Mixed_l10_Unit;doRejectValve;Valve_Unit;2;0
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NOTE: This operation does
not support pointer variables
or pointer table variables.

PAC Control User's Guide

To do this: use t.h's ...with these arguments: (Continued)
operation:
Add a variable /av <variable type>;<variable name>;<description>;<initialization

type>;<initial value>[;<string width>][;<table length>]

where:

<variable type> indicates the type of variable.
Enter one of the following values.

Type this: ...if the variable is a:
INT32_VAR 32-bit integer variable
INT64_VAR 64-bit integer variable
FLOAT_VAR Float variable
STR_VAR String variable

DNTMR_VAR Downtimer variable

UPTMR_VAR Uptimer variable

CMHDL_VAR Communication handle variable

INT32_TBL 32-bit table variable
INT64_TBL 64-bit table variable
FLOAT_TBL Float table variable

STR_TBL String table variable

<variable name> is the name of the variable. The name must
follow PAC Control conventions (for example, it cannot start with
or contain spaces, it cannot start with a number, and so forth).
Maximum length is 50 characters.

<description> is a brief description of the variable (in straight
quotes, if it contains spaces). To leave the description field
blank, enter a space in straight quotes (like this: " ).
Maximum length for the description is 127 characters.

<initialization type> indicates how to initialize the variable.
Enter one of the following values.

Type this: ..to:

ON_DOWNLOAD | Initialize the variable on strategy download.

ON_RUN Initialize the variable when the strategy runs.

PERSISTENT (Not applicable to timer variables.) This
argument makes the variable persistent.
For more information about

persistent variables, see “Persistent Data”
on page 232.

<initial value> is the variable’s initial value.

NOTE: Not applicable to timer variables. For timers, enter a
space for this argument.




CHAPTER 3: WHAT IS PAC CONTROL?

To do this: use t.h's ...with these arguments: (Continued)
operation:

e [;<string width>][;<table length>] Applicable only to strings
and table variables.

— Strings: The string width. Example: 15
The maximum width you can give a string is 1024
characters.

— String tables: The string width and table length.
Example: 15;99 Note the semicolon between the
numbers.

The maximum width you can give a string is 1024
characters. The maximum table length is 1,000,000
elements.

— Integer and float tables: The table length. Example: 99

Example: C:\>control .pro.exe cookies.idb /av INT32_VAR;nFlavor;"Cookie Flavor';ON_RUN;O

Perform a series of /f * <filename of a text file that contains CLI commands>
commands This feature lets you issue one command to perform all the
commands in a text file.

Each command must follow CLI command syntax:

<CLI executable program> <strategy filename> /<operation> <arguments>
Each command must be on a separate line. (Don’t use word
wrapping in the file.)

Each command is processed in order.

Responses (and, if applicable, errors) are logged to a file. For
details, see “Checking CLI Command Output.”

Example: C:\>control .pro.exe cookies.idb /f "C:\Documents\my batch commands.txt"

Compile a strategy into a /cdf This operation has no arguments.
.cdf file The output is saved in the folder where PAC Control is installed.

Example: C:\>control .pro.exe cookies.idb /cdf

@Remember that module numbers and point numbers are zero-based; the first position is number 0 (not 1).
The syntax to load a strategy in PAC Control's graphical user interface is:
<CLI executable program> <strategy filename>
Example: C:\>control.pro.exe cookies.idb

Checking CLI Command Output

For each CLI command you enter, the system logs a record in a Control.Output.csv file. (If the file
already exists, new messages are appended to the file.) You can view the Control.Output.csv file to
see whether or not a CLI command was successful. The file's .csv format lets you open the file in text
editors (like Notepad), as well as in spreadsheet programs (like Excel).

«  When a command is successful, CLI logs “Succeeded,” and the name of the operation you
performed.

+  When a command fails, the message shows “Failed,” followed by an error code (described on
page 72), the name of the operation, and the arguments entered with the operation.

Control.Output.csv files are located in the same folder as the strategy used in the CLI command.
For example, if the strategy in your command is located in the C:\MyStrategies folder, the
Control.Output.csv is saved in C:\MyStrategies.
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Example of a Control.Output.csv file opened in Microsoft Excel®.
In this example, Excel has parsed the data into columns.

[&] Control.Output.csv - Microsoft Excel - [m} X

Home Insert Page Layout Formulas Data Review  View Developer  Acrobat  Team @9 @ = e

A-d QL EOBEEY -
A5 - Jx | Succeeded
[ A B c

1 |Failed (Error4) Create Controller Download File No controller in strategy

2

3 |Failed (Error4) Create Controller Download File No controller in strategy
____§__1Succeeded _I Create Controller Download File

6

7 |Failed (Error 11) Add Variable INT32_VAR

8

9 |Failed (Error 12) Add Variable INT32_VAR;

10

11 |Succeeded Add Variable INT32_VAR;nRogersint32;"Test Variable";ON_RUN;0

Error Codes

This table explains the error codes you might see in the Control.Ouput.csv log file.

Operation Error code Meaning
all 1 No operation was entered. Please enter an operation.
/f (Command file) 2 The text file containing CLI commands could not be opened.
all 3 CLI could not open the strategy.
all 4 The strategy does not have a configured controller
5 CLI could not create the .cdf file.
6 CLI could not re-open the .cdf file.
{gcgéciitl)gpile to 7 CLI could not create the .crn file.
8 CLI could not open the intermediate file.
9 CLI could not append to the .crn file.
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Operation Error code Meaning (Continued)
10 The variable type argument is missing.
The variable name argument is missing, or too long (maximum length is 50
characters), or is formatted incorrectly, or already in use, or is a program-
1 C ” :
ming “reserved word.” (Reserved words cannot be used as variable
names.)
12 The description argument is missing or too long. The maximum size for a
description is 127 characters.
13 The initialization kind argument is missing.
/av (Add Variable) 14 The initial value argument is missing.
(Applicable only to string and string table variables.) The string width argu-
15 ment is missing or too long. The maximum size you can give a string is
1024 characters.
16 (Applicable only to table variables.) The table length argument is missing
or too long. (Maximum table length is 1,000,000 elements.)
17 Cannot create the variable.
18 Cannot get an ID for the new variable.
19 Cannot add the variable to the strategy.
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Operation Error code Meaning (Continued)

20 The source I/O unit is missing. Please enter the name of the source 1/0
unit.
The source module position is missing. Please enter a source module

21 position number. Remember that module positions are zero-based (count
up from 0 instead of from 1).

22 The target I/O unit is missing. Please enter the name of the target 1/O unit.
The target module position is missing. Please enter a target module

23 position number. Remember that module positions are zero-based (count
up from 0 instead of from 1).

24 The source /O unit is not in the strategy. Check the name and re-enter.
The source module position is out-of-range. Check the number and

25 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1).

26 The target I/0 unit is not in the strategy. Check the name and re-enter.
The target module position is out-of-range. Check the number and

27 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1).

/mm (Move Module) 28 A module alrgady exists at the target module position. Enter an empty

module position.

29 No module is defined at the source module position. Check the number
and re-enter.
One or more points on the source module are referenced by a PID loop,

30 and the target I/O unit is not the source 1/O unit. To move the module,
remove the PID loops, or make sure the source module and the target
module are the same.

31 The target module cannot be used because it's not compatible with the
source module.

32 The source I/O unit cannot be verified.

33 The target 1/O unit cannot be verified.
The source module position is out-of-range. Check the number and

34 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1)
The target module position is out-of-range. Check the number and

35 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1)

36 The points on the source module are not allowed on the target I/0 unit.
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Operation Error code Meaning (Continued)

40 The source I/O unit is missing. Please enter the name of the source 1/0
unit.

41 The source point name is missing. Please enter the name of the source
point.

42 The target I/0 unit is missing. Please enter the name of the target I/O unit.
The target module position is missing. Please enter a target module

43 position number. Remember that module positions are zero-based (count
up from 0 instead of from 1).
The target point position is missing. Please enter a target position number.

44 Remember that point positions are zero-based (count up from 0 instead of
from 1) and are the position on the module (not the absolute point
position).

45 The source /O unit is not in the strategy. Check the name and re-enter.

46 The source point name is not in the strategy. Check the name and re-enter.

47 The target I/0 unit is not in the strategy. Check the name and re-enter.
The target module position is out-of-range. Check the number and

48 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1).
The target point position is out-of-range. Check the number and re-enter.

49 Remember that point positions are zero-based (count up from 0 instead of
from 1) and are the position on the module (not the absolute point posi-
tion).

/mp (Move Point)

50 A point already exists at the target point position. Enter an empty point
position.
The point on the source module is referenced by a PID loop, and the target

51 I/O unit is not the source 1/0O unit. To move the point, remove the PID loop,
or make sure the source module and the target module are the same.

52 The target point cannot be used because it's not compatible with the
source point.

53 The source I/O unit cannot be verified.

54 The target 1/O unit cannot be verified.

55 The source point name cannot be verified.
The target module position is out-of-range. Check the number and

56 re-enter. Remember that module positions are zero-based (count up from
0 instead of from 1).
The target point position is out-of-range. Check the number and re-enter.

57 Remember that point positions are zero-based (count up from 0 instead of
from 1) and are the position on the module (not the absolute point
position).

58 The point on the source module is not allowed on the target 1/O unit.

59 Quadrature modules must be moved to an even numbered channel.

60 Quadrature modules require two adjacent channels. The second channel

is occupied by another point.
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Keyboard and Mouse Shortcuts

Use the following keyboard and mouse shortcuts to view and navigate a chart.

Action

Shortcut

Action

Shortcut

Center on Block 0

0 or Numeric Keypad 0

Move to Bottom Left

Numeric Keypad 1

Center on Block...

J

Move to Bottom

Numeric Keypad 2

Block Preview

Middle-click on a block

Move to Bottom Right

Numeric Keypad 3

Move to Top Left Numeric Keypad 7 Zoom In +
Move to Top Numeric Keypad 8 Zoom Out -
Move to Top Right | Numeric Keypad 9 Zoom to Fit and Center | F
Move to Left Numeric Keypad 4 Zoom to 100% 4

Move to Center

Numeric Keypad 5

Pan

Space + Left Mouse Button

Move to Right

Numeric Keypad 6

Online Help

To open Help within PAC Control, click Help > Help Topics in the PAC Control menu bar, or click the
Help button in any dialog box. Help buttons in dialog boxes are context-sensitive and provide help
specifically on that dialog box. Buttons labeled “Command Help” give specific information on the
command (instruction) you are currently using. (The command must be highlighted to open
Command Help.)

For brief explanations of buttons, move your mouse over the button and look in the status bar.

In Action and Condition Instructions dialog boxes, let your mouse rest for a second on a command,
and you'll see a list of the variable types used in that command. (To show or hide the variable types
list, in Configure mode, click PAC Control Options > Show/Hide Instruction Type Information.)

To open copies of PAC Control manuals and quick reference cards, click Help > Manuals. You will
need Adobe Acrobat Reader to open these files. You can also find information, documents, and
support on the Opto 22 website.
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4: Designing Your Strategy

Introduction

This chapter introduces you to PAC Control programming—how to design a PAC Control strategy to
control your automated process. For additional important information on using PAC Control
commands (instructions) to program your strategy effectively, see page 253 and the individual
command information in the PAC Control Command Reference.

NOTE: Because our focus in PAC Project is on the SNAP PAC System, PAC Control initially shows only SNAP
PAC /O units and the commands used with them. When you're using the SNAP PAC system only, hiding
legacy 1/0 units and commands makes it simpler and less confusing to build your strategy. However, the
legacy capabilities are still there and can be made visible in a specific strategy as needed. For information,
see “Legacy Options” on page 208.

In this Chapter

Steps to Design.... . . . . . . v 77
BASIC RUIES oo 84
INSTIUCTION EXAMIPDIES .oossosseeesecesssseee s ssssses s ssssssseessssnsssessss 87
(] oyalaa1v4Tale I 1 aTCo Ve aT LU SO0 97

Steps to Design

How do you get from your real-world control problem to a working PAC Control strategy that solves
it? Here’s an outline of the basic approach; we'll fill in the details on the following pages.

First, solve the problem.
+  Define the problem.
—  Whatam | trying to do?
- What inputs and data do | have to work with?
- What do the outputs have to be?
- How many times does the process have to be repeated?
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«  Design a logical sequence of steps to solve the problem.
— Break down the larger process task into sub-process tasks.
—  Break down the sub-process tasks into detailed steps.
+  Testthe steps.
Next, build the strategy.
«  Configure hardware.
- Control Engines
— 1/O units
- 1/0 points
«  Determine necessary variables and configure them.
«  Create charts, one for each sub-process, and add instructions.
«  Compile and debug each chart.
«  Compile and debug the whole strategy.
Finally, use and improve the strategy.
Now let’s take a look at each of these steps in order.

Solving the Problem

You can avoid a lot of extra time and rework if you define and solve your problem before you ever
start building a flowchart in PAC Control.

Defining the Problem

Suppose, for example, you want to automate a simple lawn sprinkler system. Start by asking yourself
(or others) questions about the control process you're trying to do.

What are you trying to do? Start with the big picture and work down to the smaller details.
«  Big picture: I'm trying to control this sprinkler system.
«  Smaller details:

— The sprinklers should turn on every Sunday and every Wednesday.

- They should not turn on if it’s raining.

— They should start at six o'clock in the morning.

— They need to run for 15 minutes.

What inputs and data do you have to work with? List all the inputs. Describe the data they
provide. Check for any inputs or data you need but don't have.

Input Data the input provides

Hygrometer Humidity (percentage from 0-100%)

Day Day of the week (Sunday through Saturday)
Time Hour of the day (24-hour clock)
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Input Data the input provides

Sprinkler status Whether sprinklers are currently running (on or off)

Input from timer Length of time sprinklers have been on (in minutes)

What do the outputs need to be? List all the outputs. Describe the results that are needed. Check
for any outputs you need but don't have.

Output What it does

Sprinkler switch Turns sprinklers on or off

Timer control Sets timer

How many times does the process have to be repeated? Our example is a simple sprinkler
system in which the process happens twice a week on certain days. In a more complex system,
however, you might have one section of the sprinklers turn on, followed by other sections, repeating
the process several times in different areas and then repeating the whole pattern on certain days.

Designing a Logical Sequence of Steps to Solve the Problem

Now that you've determined what you're trying to do and what your inputs, data, and outputs look
like, you're ready to outline the steps needed to solve the control problem. Think about how you
would do the job if you were doing it by hand. Again, work from the top down, starting with big
steps and then breaking those big steps into smaller steps.

Sprinkler Control System

Every day at 6:00 a.m.:
1. Check the day and the weather. 2. If it's raining, leave the 3.Ifit'stherightdayandit'sdry,
sprinklers off. turn them on.

| | |
1. Check the day and the 2.If it's raining, leave them 3. Ifit’s the right day and
weather. off. it's dry, turn them on.

Read the day of the week.
If it's Sunday or Wednesday, read
the hygrometer.

If the hygrometer says 100%,
check to make sure sprinklers
are off.

Ifit's Sunday or Wednesday and
if the hygrometer says 99% or
below, turn sprinklers on.

Start the timer.
When they've been on for 15
minutes, turn them off.

If they're on, turn them off.

If a human being were doing this job, this level of instruction would probably be just fine. With a
computer, however, the instructions need more detail. For example, the first instruction, “Every day
at 6:00 a.m.,"would have to be expanded more like this:

a. Read the hour.
b. If the hour equals six, go on to the next step.
c. If the hour does not equal six, go back to step a.
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Testing the Steps

Now that you have your steps in place, run through each sub-process in your mind to see if anything
is missing. Is there an answer for every “if"? Are all the possibilities taken into account?

It may help you to draw out your control process as a flowchart. Often it is easier to see decision
points and responses to decisions in a flowchart. You're still working at the human level at this point;
just be aware that the computer may require more details.

Here is a possible flowchart for the simple sprinkler control problem.

Simple Sprinkler System Process Flowchart

At 6:00 a.m., read
the day of the week

Is it Sunday or
Wednesday?

Wait 24 hours |«

| Read the hygrometer |

Yes

Is humidity less
than 100%?

Sprinklers off?

Turn sprinklers | Turn sprinklers off j=——t
onand settimer

for 15 minutes

Yes

|Turn sprinklers off :

Building the Strategy

Once you have the control problem solved in detail, you can begin building the strategy in PAC
Control. Now you'll add all the logical details the computer needs.

Configuring Hardware

The first step in building your strategy is to configure your control engine, 1/0 units, and I/O points.
(For more information and step-by-step procedures, see Chapter 5: Working with Control Engines
and Chapter 6: Working with 1/0) You can add more 1/0 units and points later if needed, but it saves
time to configure them now.
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When you solved this control problem, some of the inputs and outputs you defined were physical
/0, such as the hygrometer and the switch to turn on the sprinklers. You configure these physical
inputs and outputs as the I/0 points.

Here are the I/0 points you might configure for the simple sprinkler system:

Physical I/0 Type 1/0 Point Name
Hygrometer Analog Input Hygrometer

Sprinkler status Digital Input Sprinkler_Status
Sprinkler switch Digital Output Sprinkler_Switch

Determining and Configuring Variables

Some of the inputs and outputs you defined when you solved the problem were not physical I/0,
but information. For example, the day of the week is not a physical input; it's a piece of information
you can get using a command in PAC Control. These inputs and outputs become variables.

You also need variables to store the information that input points give you. And you may need
variables for manipulating information.

To determine the variables you need, think about the pieces of information your process requires.
Then look at the PAC Control commands in the PAC Control Command Reference. Find the commands
you need and check them to see what types of variables each command requires.

For example, you need to know what day of the week it is. Will the control engine give you this
information as a string (for example, “Wednesday”) or in some other format? When you check the
command Get Day of Week, you discover that the day is returned as a number

(Wednesday = 3), so you set up this variable as a numeric integer.

Here are some variables you may need. (See Chapter 9: Using Variables and Commands for more
information and step-by-step procedures to add variables.) You can change them or add other
variables later if necessary.

Variable Needed Type Name in PAC Control
Hour of the day Numeric (32-bit integer) Time_of_Day

Day of the week Numeric (32-bit integer) Day_of_the Week
Humidity Numeric (float) Humidity

Down timer Timer Timer

Creating PAC Control Charts and Adding Instructions

If you have already drawn the process in a flowchart, this step will go faster. PAC Control is based on
flowcharts because they are a natural way to show a control process. And the block names and
instructions you add to charts—just like the names of variables—are in normal, everyday language.
(For more information and step-by-step procedures, see Chapter 8: Working with Flowcharts and
Chapter 9: Using Variables and Commands).

The difference between the flowchart you drew before and the chart you create in PAC Control is
that the flowchart was designed for human beings, but the PAC Control chart must be more
detailed so the computer can follow it.
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Because the chart is more detailed—and because most control processes are far more complex
than our sprinkler system—you will usually create multiple charts for a PAC Control strategy. Break
the process down into logical chunks, or modules, and then create a chart for each module. A
modular design makes it easier to test and to update your strategy.

Even for a simple process like our sprinkler control, there is no single “correct” way to solve the

control problem and build the strategy. Instead, there are many possible ways. The following chart
shows one example:

This strategy turns on the 0

sprinklers at 6:00 a.m. Block 0

g
Wait 60 sec

Between
............. 687 am?

g

Wait 24 hrs

............. v Read
............. Hygrometer

. F¥- : :
1Jl'urn off sprinklers

Turn

v
S >

(i15horteuts | 100% v

[0 T chart /

One difference between this chart and the human-level chart on page 80 is that several delays have
been added to the chart. There is one before rechecking the hour of the day, one before rechecking
the day of the week, one before rechecking whether the timer has expired, and finally one before
starting the flowchart over again.

This sprinkler system is not time-critical. If the sprinklers turn on at a little past 6:00 a.m. or the grass
is watered an extra few seconds, it doesn't matter. Delays give the control engine time to do other
things. (For more information on delays and using control engine time effectively, see page 97.)
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Each block in the chart contains the PAC Control commands (instructions) that do the work in the
system. For example, here are the instructions for the block “Turn on sprinklers, set timer”:

# Instructions - Dough_Chip_Control - Start

Turn On Add...
Sprinkler_Switch

Set Down Timer Preset Value

Target Value 900.0

Down Timer Timer

Mewt Block

Start Timer

Timer Timer Previous Block

[ Cloze ] [ Help ]

As you create charts and enter instructions, keep referring to the PAC Control Command Reference.
The Command Reference describes the “arguments”for each command, which are pieces of
information you must enter in the instruction. You can also press F1 to open online help for
commands, which gives you the same information as in the printed Command Reference.

For example, one of the commands shown above, Set Down Timer Preset Value, has two arguments.
The Command Reference and online help tell you that the first argument—the target value, or the
value from which the timer counts down—can be a float variable or a float literal (entered in either
decimal or hexadecimal form), and that the second argument is the name of the down timer variable.
You need this information when you enter the instruction in the Add Instruction dialog box.

#1 Add Instruction rz|
Instruction:
|SetD0wnTimerPresetVaIue v| [ Select... ]
LComment:
Tupe Marme
Targst Value Float Literal v| [a000 v|

Arguments <

Down Timer

[ QK. ] [ Cancel ] [ Help ] [ Command Help ]

The sample flowchart we've shown uses standard PAC Control commands only. If you have a
programming background, you may wish to incorporate OptoScript blocks in your flowchart.
OptoScript is a procedural language that can simplify some programming tasks, including string
handling, math calculations, and complex loops and conditions. See Chapter 11: Using OptoScript
for more information.

Compiling and Debugging the Strategy

When all charts are completed and their instructions added, the next step is to compile and debug
the strategy. But first, check your hardware. Check cabling and connections, and make sure the
actual I/0 matches the configured I/O in the strategy.
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Now compile and debug the strategy. (See Chapter 7: Working with Strategies for more information
and step-by-step procedures. If you have problems, see Appendix A: Troubleshooting.Opto 22
form 1700, the PAC Control User's Guide.) If you have multiple charts, debug each one separately and
then debug the strategy as a whole. It is easier to find errors in one flowchart than in a group of
interrelated ones.

Make sure the connections between charts are accurate. For example, is a chart started at the
correct block in another chart?

Use the debugging tools discussed in Chapter 6 to find errors by stepping through a chart and
setting breakpoints to discover which block or line contains the problem. And if you've tried
everything and it still doesn't work, contact Opto 22 Product Support. (See page 4.)

Using and Improving the Strategy

Any strategy is one of several possible ways to solve a control problem. One way may be more
efficient under some circumstances; another way may be better for others. As you use the strategy
over time, as control needs change, and as you become more knowledgeable about PAC Control,
you'll find ways to make the strategy better.

Basic Rules
The sprinkler strategy we just created is a simple example. This section gives basic rules to keep in
mind when you're solving more complex control problems.

When you create a new PAC Control strategy, a Powerup chart is automatically included. You add all
the other charts you need, and the total number of charts in the strategy is limited only by the
control engine’s memory. Be aware, however, that the maximum number of charts that can be
running at any one time is based on the control engine you are using:

« 16 charts on a SNAP PAC R-series controller

«  32chartson a SNAP PAC S-series controller

« 64 charts on a SoftPAC controller

Program logic moves through a flowchart in one of two ways: flow-through or loop.

«  Achart with flow-through logic performs a set of specific commands and then stops. It has a
beginning and an end, and at the end is a condition or action block that has no exit.

Subroutines, the Powerup chart, and any other chart that does not need to run continuously
should always have flow-through logic. In complex strategies, be careful when using delays
and condition looping (waiting for something to occur) in charts with flow-through logic.

«  Achart with loop logic has no end. It loops through a set of actions and conditions
continuously. A loop-logic chart can have several paths through which the direction of the
logic may flow, depending on certain criteria. Use loop logic for a chart that needs to run
continuously. (The simple sprinkler chart has loop logic; it runs continuously.)
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Chart Guidelines

As you design your strategy, put each sub-process of your overall control problem into a separate
chart within the strategy. On a SNAP PAC R-series controller, a maximum of 16 charts (plus one host
task) can run at once. On a SNAP PAC S-series controller, 32 charts (plus one host task) can run at
once. On a SoftPAC controller, 64 charts (plus one host task) can run at once. (For more information,
see "Optimizing Throughput”on page 97.)

In general, follow these chart guidelines:

«  Use the Powerup chart just to set initial values for variables, perform setup commands, and
start the main charts. Use flow-through logic so the Powerup chart will stop as soon as the
other charts begin.

«  C(reate a few charts to monitor essential or time-critical pieces of your process, such as
emergency stops on dangerous equipment or I/O that must be monitored continuously. These
charts should use loop logic so they are constantly running.

« Ifasetof operationsis used multiple times in your strategy or is used in more than one
strategy, you can put that logic in a subroutine and call the subroutine when needed. Calling a
subroutine doesn't require as much time as calling a chart or starting a new chart. In addition, a
subroutine starts as soon as it is called in the context of the chart that is calling the subroutine.
A Start Chart command is simply placed in the task queue and started in turn. See Chapter 12:
Using Subroutines for more information.

«  Use the text tool to type a descriptive title in each chart and add any necessary explanations.
Keep blocks far enough apart to easily see the flow, and if possible, design the chart so its entire
flow can be seen within one window. If a chart becomes too complex, split it into smaller
charts.

«  When you use OptoScript code, remember that it is not self-documenting. Be sure to add
comments so that you or others can easily see what the code is doing. (Similar comments are
also useful in other PAC Control flowchart blocks.) Use OptoScript blocks within a flowchart for
operations they make easier, such as string handling and math calculations, but keep the logic
and purpose of the strategy clear in the flowchart.

«  Within a chart, leave Block 0 empty. This makes it easy to insert logic at the beginning of the
chart by adding a block between Block 0 and the next block. If a block contains more
instructions than can be easily traced and debugged, break it down into two or more
sequential blocks. Never place another block in the flowchart before Block 0. Charts always
start with Block 0, which cannot be deleted.

Naming Conventions

To save trouble in the long run, it's wise to establish naming conventions for charts, blocks, variables,
/0 units and points, control engines, subroutines, and so on. If you name these elements in a
consistent way from the beginning, it is easier to find them in lists, to see related elements, and to
know their functions without opening them.

Since PAC Control automatically alphabetizes these names, you can plan naming schemes to place
similar items together in the way you expect to use them.

Names have a maximum length of 50 characters. They can be all upper-case characters, or they can
be mixed case.
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In chart names, for example, you might include a few letters indicating whether the chart monitors
critical tasks, is a master chart calling others, or is periodically called:

«  Mntr_Tank_Leak (constantly running chart that monitors a critical situation)
+  Mstr_Conveyor_Process (master chart that calls others for a sub-process)
+  (Call_Message_Display (chart called by a master chart for a specific purpose)

Block names should tell what the block does, so you can understand a chart without needing
additional explanations. Block names should describe the purpose of the instructions within them.
Use a question for the name of a condition block, with a true exit reflecting the answer yes.

«  ReadThermometer (action block)

«  Temperature Too High? (condition block)

«  Turn OnPump 1 orPump 1 On (action block)
«  Pump On? (condition block)

Variable names can include Hungarian notation to indicate the type of variable, since the variable
type is not always apparent in its name. For example a variable named Month might be either a
string or an integer. However, using Hungarian notation, sMonth indicates a string, and nMonth
indicates an integer.

Another good practice is to identify variables used in a single chart differently than variables used by
more than one chart or process, especially if you have a large chart and want to separate these types
of variables. For variables used only in a table, you can include the table name in the variable name.
For example, you might use the name Fail_Count_in_Config_Values for a variable to be used in a
table named Config_Values.

The following table shows suggested notation for use in PAC Control:

Variable type Letter Variable type Letter
integer 32 variable n pointer variable p
integer 32 variable used as Boolean b pointer table pt
integer 32 table nt digital 1/0O unit dio
integer 64 variable nn mixed 1/O unit mio
integer 64 table nnt analog input point ai
float variable f analog output point ao
float table ft digital input point di
down timer dt digital output point do
up timer ut chart cht
string variable s communication handle cmh
string table st

In 1/0 point names, you may want to indicate the point’s function, the state of the device when the
point is active, its location, or a schematic reference. You can abbreviate names of familiar devices
and write out less familiar names. Include the information you need in the order in which it will be
most useful to you:

«  Heater_Switch (You have only one heater.)
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«  Htr6_Switch_SW23B (You have many heaters, and the schematic reference is needed.)
»  Cnvyr_Speed_Encoder_BIdgA (You want all conveyors to appear together.)
+  BldgA_Cnvyr_Speed_Encoder (You want all points in Building A to appear together.)

Instruction Examples

This section includes examples of common instructions you may want to use. See Chapter 10:
Programming with Commands. For additional information on programming with PAC Control. If you
need to use math calculations, strings, or complex loops and conditions in your strategy, also see
Chapter 11: Using OptoScript for examples of OptoScript. OptoScript is a procedural language
within PAC Control that can make programming easier, especially if you are an experienced
programmer.

Creating Messages to Display On Screen

You may need to create messages to display on screen, for example to give data to operators.
Typically these messages consist of some specific, literal words and symbols followed by a variable
value and maybe some additional literal words or symbols.

Current temperature=|86.3|F.

4
Literal words Variable Literal words
& symbols value & symbols

Average price=5/4.86
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You can create the message in a single block in your PAC Control chart, like this:

1. To enter the literal text, use the
command Move String.
Remember to include spaces __| | Move String
where you want them to appear, [~ From ‘Current temperature =

i To Current_Temp_Message
such as after the equal sign.

* Instructions - Message Display - Create Message

Convert Float to String

. Convert Current_Temp
2. Add thg var.|ab|e valge by Length : T
convertmg ttoa strmg and Decimals 1
appending it to the string you Put Result in Current_Temp_String Previous Block
JUSt created. ppend String to String
Append Current_Temp_5String
To Current_Temp_Message

Append String to String

3. If needed, append another Append .
i i To Current_Temp_Message
literal string.

[ Cloze ] [ Help ]

Alternatively, you can create the message by placing the following OptoScript code within a single

OptoScript block:

FloatToString(Current_Temp, 5, 1, Current_Temp_String);
Current_Temp_Message = "Current temperature = " + Current_Temp_String +
vELv-

OptoScript can be more efficient for string handling than standard PAC Control commands. See
Chapter 11: Using OptoScript for more information.
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.......................... umi‘[s as necessary.

S Yo 5......:::::::::
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Latch On2— Charts ] Handler |

U F /T

T

Action blocks take B
necessary action R T T T T T O RN TIE TR TR v
when event occurs. < —
(1) Shortcuts !'IDU°/° v!

Chart /
Error Handling

Every strategy should have a way to handle errors. It's important to check values and errors that are
returned from the commands in your strategy. Communication to an I/0 unit, for example, will be
automatically disabled if a command sends it variable values that are clearly wrong, such as a
memory map address in an incorrect format.

Counting

Most standard digital inputs can be used as counters to count the number of times the input
changes from off to on. The availability of counters depends on the brain’s capabilities, and the
speed of counters depends on the module.

For information on brain capabilities, see Opto 22 form 1689, the SNAP PAC Brains Data Sheet.

For more information on module counting speed, see the module’s specifications on the Opto 22
website, www.opto22.com. On the website, select Products > SNAP PAC System > Brains and /0 >
Digital I/0.

NOTE: You can use counters on high-density modules with SNAP-PAC-R1 and SNAP-PAC-R1-B controllers,
and SNAP-PAC-EBT and SNAP-PAC-SBT brains with firmware 8.1 or newer.
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Before using a counter, you must configure the point as a counter. (See “Adding a Digital I/0 Point”
on page 132, or use PAC Manager.) Counters on Ethernet and SNAP PAC1/0 units do not need to be
started, and they cannot be stopped. Therefore, do not use the Start Counter and Stop Counter
commands with SNAP PAC I/0 units. However, you can use Get Counter and Get & Clear Counter.

Counters on mistic 1/0 units must first be started using the Start Counter command. In addition to
Start Counter, you can use the following commands on mistic /O units: Stop Counter, Get Counter,
Get & Clear Counter, and Clear Counter.

Using a Count Variable for Repetitive Actions

A numeric variable for counting is useful when the same action needs to be repeated a specific
number of times. For example, suppose your process includes filling a packing box with a dozen
bags of cookies. You can use a count variable to track how many bags are dropped into the box.

Here's part of a chart showing how you would use a count variable in this way:

— Shipping_Area |'-_||'E|r2|
............. = = = :
- o B 1 Instructions - Shipping_Area - Set count to 1 r5__<|
Block 0
Mowve Add
. ' il From 1
7 S To Bag_Count
Move box #ito |- - |
posit”
Al ions - Shipping_Area - | by1 [X]
R S nstructions - Shipping_Area - Increase count by
2 g N
Set count to 1 Increment Variable Add..
Lo P Bag_Count
g - - .o
e dropper ]
1 . [ Mest Blact |
C —L """"" # Instructions - Shipping_Area - Count = 127 @
.
Increase count
SOl = Bag_Count Add..
................... Equal?
To 12
....... Yoo .E T C
LF ot - s T Atk to start o R
..... " N N prﬂ:e!: N 9
................... Mext Block.
.( .................. TR
(1) Sharteuts Operatar
[ATF T chare / @ 4ND
[ Cloze ] [ Help ] “ommand Help O0oR

If you are an experienced programmer, you'll notice that this example is a for loop. You can use the

following OptoScript code within a single OptoScript block to accomplish the same result:

for Bag_Count = 1 to 12 step 1 //Count 12 items dropped into box
Bag_Dropper = 1; //Turn on bag dropper

next

See Chapter 11: Using OptoScript for more information on using code to streamline control
structures in your strategy.
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Programming Case Statements

A frequent need in programming is to create case statements, also called “switch” statements,
“if/then/else” statements, or “nested if” statements. These statements create multiple decision
points: if the condition is A, then X will happen; if the condition is B, then Y will happen, and so on.
(This example uses regular PAC Control commands; seeChapter 11: Using OptoScript for another
option that takes up less space in your flowchart.)

For example, suppose you have a conveyor with three speeds: high (3), low (2), and stopped (1).
Sometimes it runs at high speed, sometimes at low speed; but before a box can be put on the
conveyor, the conveyor must be stopped. And it can be stopped only from low speed, not from high
speed. Here’s a portion of a chart showing the case statements that control this process:

Conveyor speed is
checked and moved
(copied) into a variable.

# Instructions - Conveyer_Operation - Get conveyor s... @

= Conveyer_Operation

’ ' 1 v
. Box ready? . g

Add...

From Conveyor_Speed_Sensor
Conveyor_Speed

Modify...

Delete

# Instructions - Conveyer_Operation - Speed high?

Each condition block

B Conveyor_Speed Add. checks for a particular
- P R Equal? .
............ S To 3 Madiy... speed. This one checks for
............ high Speed (3)4
................. A Instructions - Conveyer_Operation - Shift to low
..... L rry— e If speed is too high, it is
S : ' £fjam 2 : shifted down to the next
S P S To Conveyor_Speed Modify... K K
..... 2 § o level, until the conveyor is
............... [relet )
________________ | et finally stopped and the

box can be put on.

(i) Shortcuts | 1003 v

[ Cloze ] [ Help ] Command Help

[T [M Chart /

The example above shows three cases, because there are three possible speeds and each speed
demands a different action.

If you had only two possibilities
(for example, if the box could also

A Instructions - Conveyer_Operation - Conveyor stopped? [‘5_<|

be put on the conveyor at low . e Add.
speed), you could handle both To 1 Modity..
possibilities within one condition Is Conveyor_Speed Delete
block. For example, you could put | |“7 8
two Equal? commands in the
same condition block, and check p
the Or operator, as shown at right. © AND

[ oose [ Heb Command Help Oon

Or operator
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Using a Timer

Timers come in two forms:
»  Uptimers count up from zero and are generally used to measure how long something takes.

«  Down timers count down to zero from a number you set and are frequently used to determine
when events should begin.

Here's an example of a down timer. This process starts every 1.5 seconds.

The starting value for the
timer is set in Block 0.

“Instructions - Timer_Example_Chart - Block 0 rg|

— Timer_Examp/e_Chart Set Down Timer Preset Value Add...
- ——— Target Value 1.5
. , Down Timer Process_Timer Modify...
The condition block checks Block 0 T
. Start Timer Delete
whether the timer has Timer Process_Timer
reached zero. If it hasn't, the y
o O
chart loops until it has. ; f E L Previnus Black
P m::;fez;"e' Delay 1 msec -
o+ 5 - N I
T 1 Instructions - Timer_Example_Chart - Process Timer E... rg|
2
Start Process
. Ti Down Timer Process_Timer Add..
When the timer has // o Down Timer Expired?
expired, it is restarted and< A\ o
i ™~ 3 Delete
the process begins. "~ Start Proc <
Mext Block
“Instructions - Timer_Example_Chart - Start Process Ti... E]

4
When the process ends, EndBrEeess Start Timer Add..
the |OgiC |OOpS baCk to e / Timer Process_Timer

adify...
check whether the timer < - e
. . (i15h el
has expired again. &
b
ext Block
[ Cloge ] [ Help ] Command Help

For additional details, see “Using Timers”on page 333.

Using a Flag Lock

The Flag Lock and Flag Unlock commands allow you to give a task exclusive access to one or more
objects—such as tables, integers, or I/0 units—until the task is complete. For example, if you want
two different charts to change the values in the same table, it is important for one chart to complete
its task before allowing the second chart to access the table.

To demonstrate, the following charts show how to construct two charts in a strategy so that each
chart can access the same table without interference from the other chart.
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Chart 1 and Chart 2 are very similar. The main difference is that one block (D) in Chart 1 adds 2 to
each table element, while in Chart 2 it adds 3.

SR
AT Get Table
A— Lock
= =
B-_ - L Decrement
. “| Table Index
C—
D-— Add 2 to Table
: Element
"""" Chart 1

ﬁ.elease Table
Lock

" Get Table
Lock

.“.

¢ Decrement
Table Index

.‘.

Add 3 to Table
Element

Release Table —E
Lock

Here's what each block accomplishes:

A—Get Table Lock. Uses the following instructions to wait until Chart 2 unlocks the flag before
it locks the flag on the table. It also tracks the number of times Chart modifies the table, and it gets
the length of the table. The Timeout value of -1 makes the chart wait the other chart has
successfully unlocked the flag on the table. See also, “Flag Lock Timeout Values”on page 94.

Flag lock will wait until
Chart 2 unlocks the fla
on the table. See also,
“Flag Lock Timeout
Values”on page 94.

9 Instructions - Chart1 - Get Table Lock

X

Tracks the number of
times the table has been
modified by Chart1

Gets the length of
the table and puts it
in Int_Table_Index

-1 Timeout = "Wait until lock succeeds" s
Flag Lock

Flag Int_Table_Flag

Timeout -1

Put Result in Int_Table_Flag_Result
Increment Variable

Modified_by_Chart1

Get Length of Table

Tahle Int_Table

Put in Int_Table_Index

~

Cloze ] [ Help
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Using the numeric variables Modified_by_Chart1 and Modified_by_Chart2 (from Chart 2), a watch
window can track the number of times the table has been modified by each chart. For more
information, see “Using a Watch Window” on page 36.

Natne Type TIVAL

Modified by Chartl Integer 32 Variable 91
Modified by ChartZ Integer 32 Variable 49
Int_Table Index Integer 3Z Variahle 17

B—Decrement Table Index. The table has 100 elements, numbered from 0 to 99. This
instruction block starts at element 99 and on each loop decrements by 1 to go to the next element.
This continues until it reaches index 0.

C—Index >=0. If the index is greater or equal to zero, the chart proceeds to D. If the index equals
-1, the chart goes to E.

D—Add 2 (or 3) to Table Element. Adds two (or three) to the value of the current table index.

E—Release Table Lock. This block uses a Force unlock of zero, which means it will unlock only for
the chart that locked the flag. In this case, if Chart 1 locked the flag, only Chart 1 can unlock the flag.

Flag Lock Timeout Values

The following chart shows the effect of different Timeout values used with the Flag Lock command:

Timeout Effect

Wait until success.

The application will wait (block) as long
-1 as it takes to lock the flag. Since it never
gives up, the only value that can be
returned is 0.

Don’t wait at all. Succeeds only if the flag
is available to be locked immediately.
Makes this a non-blocking call. If the flag
is not already locked, a return of 0 (Suc-
cess) is returned. If the flag is locked, a
-17 (Already Locked) error is returned.

Wait maximum of value milliseconds to
lock the flag. If it succeeds within the
specified time, 0 is returned; otherwise, a
-37 (Timeout on Lock) error is returned.

Value greater than 0

Value less than 0 Produces a-8 (Invalid Data) error
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Pointers and Indexing

The following examples show three possible ways to control 16 fans based on setpoints.

Without Pointers

The first way, shown below, uses individual fan outputs and setpoint variables to determine whether
to turn off or on the appropriate fan. It's a simple way to solve the problem but takes a long time to
program and produces a large, repetitive section in the flowchart. It also consumes more control
engine memory, due to the large number of conditional and action blocks.

Is
Greater?
Than

Each fan output (Motor01-Motor16) uses
a separate temperature input (Temp01-
Temp16) and a separate setpoint variable
(SPO1-SP16). The flowchart cycles
through them all to control the fans.
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With Pointers and Indexing

The second way uses pointers and indexing to accomplish the same result in a smaller space, using
less control engine memory and fewer programming steps. The fan outputs and the temperature
inputs are referred to by pointers. The setpoints, instead of requiring individual variables, are simply

numbers in a table.

The flowchart sets initial values for the
pointers, and then cycles through the pointer
tables to control the fans. (Tables have already
been initialized in the Powerup chart.)

Turn Fan On
[

15
Increment

Index

m PAC Control User's Guide
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Setindex =1
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A Instructions - FanCtrl - Load Pointers

L

[ e | [ Commandiien |

Move from Pointer Table Element A Add...
Index FanCtriindex ¥ —
Of Table pthlotors
To Pointer pMotor

Mext Block
Previous Block

Move from Pointer Table Element
Index FanCtrlindex
Of Table ptTemps
To Pointer pTemp
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Using OptoScript

The third way also uses pointers and indexing, but places all the action in an OptoScript block. See
“11: Using OptoScript” for more information on using OptoScript.

9 ) & OptoScript - Alarms - Stop Conveyor |4
< ﬁp date Fan } : :
States a +O Ackions  + Conditions  +71 Variables &Test Compile #h A,
e 0 = & as OptoScript Code:
M//loop through elements 1-16 of the tables.
for FanCtrlIndex = 1 to 16 =tep 1

ssmove the AT and DO to the pointers
pHotor=ptMotors[FanCtrlIndex]:
pTenp=ptTenp=[FanCtrlIndex]:
ssocompare the walues and act.
if (*pTemp:ftSetpoints[FanCtrlIindex]ithen
*pHotor=1. ~~Turn on motor
else
*pHotor=0;: ~»Turn off motor
endif

next

Optimizing Throughput

For tips on how to design your PAC Project” system and program your PAC Control” strategy to
ensure optimum system performance see Opto 22 form 1776, Optimizing PAC Project System
Performance.

For additional information, see Opto 22 form 1702, the PAC Display User’s Guide.
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5: Working with Control
Engines

Introduction

This chapter shows you how to configure and work with control engines. See “Compatible
Controllers and I/0 Units” on page 6.

In this Chapter

Configuring CONLIOl ENGINES .....ovcooceeeeeecseeeeesscseeessssees e ssssseesssssssesssnsssesssns 99
Using Network Segmenting in PAC Control . . . . 2103
Using Ethernet Link Redundancy in PAC Control . . O 105

Using Redundant Controllers

Changing or Deleting a Control ENGINe ..o

Inspecting Control Engines and the Queue
Archiving Strategies on the Control Engine

Restoring Archived Strategies from the Control Engme ....................................... 118
Downloading Files Using PACTErMING .....coocevveeesceeveesscnseeesssssseesssnsseesssnssenssns 120

Configuring Control Engines

Before you can use a control engine to run a strategy, you must first define the control engine on
your PC and then associate the control engine with your PAC Control strategy.

See “Defining a Control Engine on Your PC”" below to identify the connection through which
the PC and the control engine communicate. Because this process writes to the Windows
Registry on your PC, you must define control engines for each computer that uses your
strategy. (If your computer can boot to two operating systems, you must configure control
engines for each operating system.) You can define control engines in PAC Control or in the
software utility, PAC Terminal.

See “Associating the Control Engine with Your Strategy” on page 103 to identify which defined
control engine is the active control engine. Although you can associate several control engines
with the same strategy if necessary, the strategy can be downloaded to only one at a time. The
control engine set to receive the download is called the active engine. You must use PAC
Control for associating the control engine with your strategy.
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Defining a Control Engine on Your PC

You can use either PAC Terminal or PAC Control to define a control engine on your PC. Follow these
steps to define a control engine using the PAC tool of your choice.

1. Starteither PACTerminal or PAC Control, and then open the Select Control Engine dialog box:
Using PAC Terminal:

- InWindows 7 and Windows Vista, press the Windows Start key E and then click
Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.

- InWindows 10 and Windows 8.1, press the Windows Start key E type PAC Terminal
9.6 and then press the Enter key.

From PAC Terminal’'s menu bar, click Configure > Control Engines. When the Select Control
Engine dialog box opens, go to step 2.

Using PAC Control:

— InWindows 7 and Windows Vista, press the Windows Start key H and then click
Programs > Opto 22 > PAC Project 9.6 > PAC Control.

— InWindows 10 and Windows 8.1, press the Windows Start key H type PAC Control
9.6 and then press the Enter key.

a. Open a strategy in either Configure mode or Online mode.

b. From PAC Control’s menu bar, click Configure > Control Engines. The Configure Control
Engines dialog box appears.

Active Engine:
| Cookie Controller
Engines Associated with Strategy:
[ SetActive
e
[ Modfy...
[ pelete |
| Download Options...

c. Click Add.
The Select Control Engine dialog box appears.

Configured Control Engines:
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The Select Control Engine dialog box lists all the control engines configured on your system,
whether or not they are associated with your strategy.

- If the control engine you want appears in the list, it has already been defined on this PC,
click to highlight the control engine’s name and then click OK. Then skip to “Associating the
Control Engine with Your Strategy”on page 103.

- If the control engine you want is not in the list, click Add.
The Control Engine Configuration dialog box appears.

Configure Ethemet Connection :

Configure control engine name and parameters:
Conttrol Engine Name: A

System Type
(®) Standard
() Redundant Networks (PRO only)
() Redundant Controllers (PRO only)

Settings

IP Address/Hostname: :D.D_O_ﬂ

Controller Pott: 22001
Software Retries: _I} ]
Software Timeout: | 5000 —

mMmmg N

Complete the fields as described in “Control Engine Configuration Dialog Box" below.
Click OK.
The Select Control Engines dialog box appears, displaying your new control engine in the list.

Modify...

Delete

In the Select Control Engine dialog box, highlight the control engine you want to associate
with the strategy, and then click OK. Continue with “Associating the Control Engine with Your
Strategy” on page 103.
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~ro

~ro

o)

~ro

Control Engine Configuration Dialog Box

A—Control Engine Name. Enter a descriptive name for the control engine. Valid characters
are letters, numbers, spaces, and most other characters except colons and square brackets. Spaces
cannot be used as first or last characters.

B—System Type. Select the system type:
«  Standard: A normal system not using redundant networks or redundant controllers.

+  Redundant Networks (PRO only): A system that has redundant networks, which is also referred
to as link redundancy. When selected, two IP address boxes are available under Settings for the
primary and secondary networks. See “Using Ethernet Link Redundancy in PAC Control”on
page 105 for more information.

«  Redundant Controllers (PRO only): Use with a system configured with the SNAP PAC
Redundancy Option. When selected, three IP address boxes are available under Settings for
Controller 1, Controller 2, and Arbiter. For more information on setting up the Redundancy
Option, see form 1831, the SNAP PAC Redundancy Option User’s Guide.

C—IP Address/Hostname. The IP Address/Hostname text boxes available depend on your
System Type. Each IP address is entered in decimal notation (for example, 192.9.200.24).

Hostnames are supported only in standard configurations, not redundant ones. In order to use a
hostname, your network must have a domain name server (DNS) and the hostname must already
have been entered in your DNS either by you or someone in your IT department.

«  For Standard: Enter the IP address or hostname of the control engine.

+  For Redundant Networks (PRO only): Enter the Primary and Secondary IP addresses. The
Primary address is ETHERNET 1 on a SNAP PAC controller, and the Secondary IP address is
ETHERNET 2. Both IP addresses use the same port number. See “Using Ethernet Link
Redundancy in PAC Control”on page 105 for more information.

+  For Redundant Controllers (PRO only): For the SNAP PAC Redundancy Option. Enter addresses
for Controller 1, Controller 2, and Arbiter. For more information on setting up the Redundancy
Option, see form 1831, the SNAP PAC Redundancy Option User’s Guide.

D—Port. Enter the control engine’s IP port number. The default of 22001 is the port of the host
task on the control engine; this default normally should not be changed.

E—Retries. Retries indicate the number of times PAC Control will reattempt communications
with the control engine. Since retries are automatically handled by the protocol (TCP/IP), enter zero
here.

F—Timeout. Enter the timeout value in milliseconds. Timeout value is the length of time PAC
Control tries to establish communication through the port. If it fails, it tries again as many times as
specified in D. Any positive integer is valid. For Ethernet, 3—5 seconds (3000-5000 milliseconds) is a
good starting point.
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Associating the Control Engine with Your Strategy

After you have defined the control engine on your PC (see page 100), it can be associated with your
strategy.

1. Ifyouarein PACTerminal, close PAC Terminal. Open the strategy in PAC Control (Configure
mode or Online mode) and from the menu bar, click Configure > Control Engines.

In the Configure Control Engines dialog box, the engine’s name appears in the list.

Configure Control Engines E3

Active Engine:
Active engine R1 Controller

Engines Assodated with Strategy:

List of control engines Set Active
Cookie Controller —

Delete

Download Options. ..

oK Cancel Help

2. Check to make sure the correct control engine appears in the Active Engine field. If not,
highlight the one you want and click Set Active.

Only one control engine can be active. If only one control engine is listed, it automatically
becomes the Active Engine.

Your control engine configuration is complete.

Using Network Segmenting in PAC Control

You can take advantage of the two independent Ethernet network interfaces on a SNAP PAC
controller to segment the control network from the company network. Because the two network
interfaces are completely independent and have separate IP addresses, they can be set up on two
separate networks. Host traffic can communicate on one, while the controller communicates with
the 1/0 units on the other.

To segment networks, start by assigning a secondary IP address to the controller in PAC Manager,
following instructions in Opto 22 form 1704, the PAC Manager User’s Guide. The secondary IP address
is used for communication through the controller's Ethernet 2 interface. Remember that this
interface must be on a completely separate network segment.

You don't need to do anything special in PAC Control. Configure only one control engine, using the
IP address of the Ethernet interface to be used for host communication. The control engine will
direct communication to /0 units through the other interface, based upon the I/O unit's IP address.
The IP addresses of the I/0 units must be compatible with the secondary IP address of the controller.
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USING NETWORK SEGMENTING IN PAC CONTROL

NOTE: PAC Display Basic and other hosts on the company network cannot communicate with I/0 units
when they are on a separate network. To solve this problem, you can purchase PAC Project Professional, or
PAC Display Professional and OptoOPCServer (version 7.0 and newer) separately; these applications
support network segmenting by communicating with 1/0 units through the controller. Also, you can add
a second network interface card (NIC) and assign it an IP address compatible with the I/0 unit network.
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Using Ethernet Link Redundancy in PAC Control

Ethernet link redundancy provides a backup network connection in case the primary connection
route becomes unavailable. If that happens, the controller uses a secondary communication route.

There are two types of link redundancy in PAC Project, which you can use individually or combined:

+  Controller to I/0: When link redundancy is configured from the controller to /0, if
communication to the primary I/0 unit IP address fails, communication switches automatically
to the secondary I/0 unit IP address, which usually is the second Ethernet network interface on
a SNAP PAC R-series controller. See “Commands for Ethernet Link Redundancy”on page 307 for
more information on primary and secondary 1/0 units.

SNAP PAC S-series

NOTE: If your system has redundant controllers, in
order to use link redundancy from the controller to
1 thel/O, you must connect ETHERNET 2 on the

controllers and on the /0 units to the same switch.
No other devices can be connected to that switch.

«  PACDisplay Pro to controller: When a PAC Display Professional project is installed on a PC
with two network interface cards (NICs), the project can be configured to use the primary and
secondary IP addresses to access data from the PAC Control strategy running on the control
engine. One address is always active. If the primary address is unavailable, then the secondary
address becomes the active address, and the PAC Display scanner automatically shifts to the
secondary address. If the secondary address fails, then the primary address becomes the active
address and automatically tries the primary address again. For details, see form 1702, the PAC

Display User’s Guide.
PC with two NICs =] = - | PC with two NICs
running PAC Display Pro [#8800 | | - running OptoOPCServer

— - -

@ = ”%mg i

SNAP PAC S-series

NOTE: If your system has redundant controllers, you cannot use link redundancy between PAC Display
Pro and the controller. For more information on using redundant controllers, see Opto 22 form 1831,
the SNAP PAC Redundancy Option User's Guide.

System Architecture for Ethernet Link Redundancy

As shown in the examples below, you can set up your system in several ways to take advantage of
the link redundancy capability in PAC Control. For additional information, see the SNAP PAC
controllers'user’s guides. For details on how PAC Display works with link redundancy, see form 1702,
the PAC Display User’s Guide.
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USING ETHERNET LINK REDUNDANCY IN PAC CONTROL

Using a SoftPAC Controller. In examples 1 and 2 below, the PAC S-series controller can be
replaced by a SoftPAC controller. The PC running SoftPAC must have two network interface cards
(NICs) configured with static primary and secondary IP addresses on different subnets.

Example 1: Ethernet Link Redundancy

In this example, the primary concern is that the Ethernet network may need maintenance or may
fail, leaving the computer running PAC Display Professional, the computer running the
OptoOPCServer (as the PAC Display scanner), the controller, and the I/0 units unable to
communicate.

The solution is to connect all these devices on two networks; if one network goes down, devices can
communicate on the other. Note that each computer has two network interface cards (NICs). 1/0
units are controlled by the controller. Each I/O unit is connected to its own group of sensors and
actuators, but all are connected to the same two networks.

If one network needs maintenance, for example to replace a switch, you can safely shut it down
using the Set Target Address commands in PAC Control and options in PAC Display Professional.

SNAP PAC R-series

“Sensors and ™ “Sensors and actuators, J
\._actuators, location #1_/ ; _!ocation #2 j

I ; PC with two NICs PC with two NICs Opto 22 Redundant Network :
: running PAC Display Pro running PAC Display Pro :
= |

: : u“% |
: PAC Display | . PAC Display :
I f e L) * B e = 4 * |
| | |
| = E = |
l 1 I |
|

: l
| |
| = |
I - == PC with two NICs [
: Ethernet switch, ~ running OptoOPCServer Ethernet switch, :
: network #1 — 7 * |(asPAC Display scanner) network #2 :
' I

| | |
: — |
| - |
| IE - |
| i1 I+ SNAP PAC S-series controller |
! "8 controls all I/O units |
: o |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
[

| |
| [
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Example 2: Ethernet Link, Computer, and Software Redundancy

The second example of link redundancy illustrates concern not only about the stability of the
Ethernet network, but also about the computers and the software run on them. Any of these
things—the network, a computer, or the OptoOPCServer or PAC Display Professional software
running on the computer—may need maintenance or may fail.

The solution here is to provide duplicate computers and software, and connect all devices on two
networks. FEach computer has two NICs. /0 units are all controlled by the controller. Each I/O unit is
connected to its own group of sensors and actuators, but both are connected to the same two
networks.

For more information on using Ethernet link redundancy with PAC Display, see form 1702, the PAC

Display User’s Guide.

B BT L R R Il i |
Two PCs, each with two NICs
running PAC Display Pro

e I- =

onne I oone
AL Binplay L PAL Displiny

Two PCs, each with two NICs running
OptoOPCServer (as PAC Display scanner)

N *

i | Wl 2

Ethernet switch, S : Ethernet switch,
éﬁ_l SNAP PAC S-series controller network #2

controls all 1/0 units

nsors and actuators,
location #1
SNAP PAC R-series [l -} Egaagggﬂ
ensors and actuators,
location #2

SNAP PAC R-series

|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| network #1
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
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USING ETHERNET LINK REDUNDANCY IN PAC CONTROL

@ Example 3: Ethernet Link Redundancy with Serial 1/0 Units

This third example of link redundancy shows a SNAP PAC S-series controller with serial I/0 units. The
redundancy is in the Ethernet networks between the controller and computers running PAC Display
Professional and OptoOPCServer. This example provides link redundancy for the Ethernet network.
Again, note that the computers all have two NICs.

Opto 22 Redundant Network

PC with two NICs running PCwith two NICs running
PAC Display Pro PAC Display Pro
= = =
PAC Display PAC Display

PCs, with two NICs running
OptoOPCServer (as PAC Display scanner)

Ethernet switch, P e — Ethernet switch,
network #1 mRESl network #2

éNAP PAC S—séries controller
controls all 1/0 units

,._._..____.______._-—__-.—______._.—___._._____._.__..,_.______

el e s e e g e i e e e i W S e e e e i i e e e e i i e e )

=

. I
ol S TS mEmna »
L Sensorsandactuators J L Sensorsandactuators J L Sensorsandactuators J

Iocatlon# 9 Iocatlon #2 \ Iocat|on #3
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Configuring Ethernet Link Redundancy

Ethernet link redundancy from PAC Display Pro to a control engine is easy to configure. First, make
sure the secondary IP address has been assigned to the controller in PAC Manager. Then in PAC
Control, just enter both the primary and secondary IP addresses when you configure the control
engine (see page 99). Once you have set up link redundancy for the control engine you are using in
your PAC Control strategy, it works automatically in PAC Display.

To configure link redundancy from the control engine to I/0 units, enter both the primary and
secondary IP addresses when you configure the 1/0 unit (see “Adding an I/0 Unit"on page 126).

Using Strategies with Link Redundancy

Although PAC Display and OptoOPCServer (as the PAC Display Pro scanner) automatically shift to the
secondary address when the primary address is not available, the PAC Control debugger does not. In
PAC Control, you control which address receives communication, so you know exactly how
communication is occurring during debugging. To change between primary and secondary control
engine addresses, follow the steps in “Changing the Control Engine that Receives the Downloaded
Strategy”on page 110.

Once you have changed the address, when you enter Debug mode, you are communicating
through the address you chose. Downloading the strategy to a SNAP PAC controller through one of
its Ethernet interfaces replaces any strategy that was downloaded earlier through its other interface.

Using Redundant Controllers

The SNAP PAC Redundancy Option allows you to configure two redundant SNAP-PAC-S controllers
that use the same PAC Control strategy. By utilizing sync blocks in the strategy and
persistent/redundant variables, critical data is synchronized in both controllers so that the inactive
controller can take over at any time and become the active controller. To learn more about the SNAP
PAC Redundancy Option and how to set up a strategy using sync blocks and persistent/redundant
variables, see Opto 22 form 1831, the SNAP PAC Redundancy Option User’s Guide.

NOTE: If your system has redundant controllers, you cannot use link redundancy between PAC Display Pro
and the controller.

Changing or Deleting a Control Engine

See the following topics to change or delete a control engine:

«  "Changing a Control Engine’s Definition” (below)

«  "Changing the Control Engine that Receives the Downloaded Strategy”on page 110
«  "Removing a Control Engine’s Association with a Strategy”on page 110

+  "Deleting a Control Engine from Your PC"on page 111
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Changing a Control Engine’s Definition

Whenever necessary, you can change a control engine’s definition on your PC—its name, the port
the PC uses to communicate with it, or the PC port setup (such as timeouts and retries). These
changes can be made either in PAC Control or in PAC Terminal.

1. Choose one of the following:

— In PAC Control: With the strategy open in Configure mode or Online mode, right-click the
control engine name on the Strategy Tree and choose Modify from the pop-up menu.

— In PAC Terminal: From the PAC Terminal menu bar, click Configure > Control Engine.
The Select Control Engine dialog box appears.

2. Inthe Select Control Engine dialog box, click the control engine you want to change and click
Modify.

3. Make the necessary changes, following the same steps you would for configuring the control
engine initially. (For help, see “Defining a Control Engine on Your PC"on page 100.)

Changing the Control Engine that Receives the Downloaded
Strategy

You can configure several control engines for a strategy, but only one at a time can receive the
downloaded strategy. The control engine that receives the strategy is called the active engine.

NOTE: In PAC Control Professional, you can also configure a control engine for Ethernet link redundancy
(see “Using Ethernet Link Redundancy in PAC Control” on page 105 for more information). In this case, you
can also choose whether the primary or secondary IP address will receive the strategy.

To change the control engine that receives the downloaded strategy, follow these steps:
1. Make sure the strategy is open and in Configure or Online mode.

2. On the Strategy Tree, right-click the name of the control engine you want to set as the active
engine.

If its name does not appear in the Strategy Tree, follow the steps in “Configuring Control
Engines”on page 99.

3. From the pop-up menu, choose Set Active.
The active engine moves to the top of the list in the Strategy Tree.

4. [fthe control engine is configured for Ethernet link redundancy, right-click the name of the
control engine on the Strategy Tree again. From the pop-up menu, choose Use Primary IP
Address or Use Secondary IP Address.

Removing a Control Engine’s Association with a Strategy

If you no longer want to use a control engine with a strategy, you can remove its association with
the strategy. This action does not delete the control engine’s definition on your PC.

CAUTION: Do not delete the control engine from within the Select Control Engine dialog box. Doing so
will delete it from the PC as well as the strategy.

1. Make sure the strategy is open in Configure mode or Online mode.

PAC Control User's Guide



CHAPTER 5: WORKING WITH CONTROL ENGINES

2. Onthe Strategy Tree, right-click the name of the control engine you want to remove. From the
pop-up menu, choose Delete.

The control engine is no longer associated with your strategy.

Deleting a Control Engine from Your PC

If you are sure that a control engine will no longer be used with your PC, you can delete it using
PAC Terminal. Deleting the control engine removes its definition only on the PC you are using.

1. Start PAC Terminal as follows:

- InWindows 7 and Windows Vista, press the Windows Start key :5/" and then click
Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.

—  InWindows 10 and Windows 8.1, press the Windows Start key O
9.6 and then press the Enter key.

2. Right-click the name of the control engine in the list.

,type PAC Terminal

CAUTION: Make sure you are highlighting the right one. You cannot undo a deletion.

3. From the pop-up menu, choose Delete.

The control engine is no longer defined on the PC.

Inspecting Control Engines and the Queue

You may want to inspect or change control engines while you are running the strategy in Debug
mode. See the following topics to view control engine information and the engine’s message
queue, either from PAC Control in Debug mode or from PAC Terminal:

«  “Inspecting Control Engines in Debug Mode” (below)
+  “Viewing the Message Queue”on page 114
+  "Inspecting Control Engines from PAC Terminal”on page 116

Inspecting Control Engines in Debug Mode

With the strategy running in Debug mode, choose Control Engine > Inspect.

You can also double-click the active engine (the first one under the Control Engines folder) on the
Strategy Tree, or right-click the control engine and choose Inspect from the pop-up menu.
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The Inspecting dialog box opens.

Inspecting: Cookie Controller

A— ﬁ Control Engine: SHAP-PAC-RZ at 10.192.54.115
B Firmware Yersion: RE3a [1223:25 September 18, 2008 )
C Volatile BAM: 4.33 MB free
Battery-backed BAM: 102396 KB free
File Storage RAM: 1.90 MB free
D Up Time: 12 days, 19 haourz, 27 minutes, 25 seconds
E Device Time: 12:2359 June 22, 2009 Sync time ta PC —F
G Message Queue: 0 mezzages
H Strategy information
Active: Cookies  [17:33:19 June 17,2009
5 chart(z) running Archive: Mo |
J |  Run | @ Stop B Store to Flash /K
L Alternate: Mot Enabled /
M
N Stored in Flagh: A strategy iz stored in flazh memon
(0] Autorun: () Enabled (%) Disabled
Communication
P Loop Time: 759 mzec
Q—F——Comm Emors: Mone

Here you see data relating to the control engine. If you are using Ethernet link redundancy in PAC
Control Professional, remember that the information shown is for the IP address you chose before
entering Debug mode. (See “Using Strategies with Link Redundancy” on page 109 for more
information.)

A—Control Engine. Type of device the control engine is running on and the device's IP address.

B—Firmware Version. \ersion number of the firmware (kernel) loaded on the device, and the
date the firmware was released.

C—Memory Available. Amount of memory (RAM) available on the control engine. For
example, a SNAP R-series controller has a total of 16 MB of RAM on the control side, 2 MB of which is
battery-backed. Volatile RAM shows the amount of total RAM available for use. Battery-backed RAM
shows the amount available in battery-backed RAM, where persistent variables, variables initialized
on download, the autorun flag, and the strategy archive are stored. File Storage RAM shows the
space available in the control engine’s file system See the PAC Manager User’s Guide for more
information about the file system. See also form 1646, the SNAP PAC Memory Usage Technical Note.

D—Up Time. Total time that the control engine has been running since powerup.
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E—Device Time. Current date and time recorded on the control engine.

F—Sync time to PC. Click to synchronize the control engine’s time and date to that of the PC
running PAC Control.

G—Message Queue. Number of messages (information, warning, and error messages)
encountered when attempting to run the strategy on the control engine (up to a maximum of 1000
messages). (See “Viewing the Message Queue”below.) Click to open the View Messages dialog bo,
listing the details of any information, warning, or error messages.

H—Active. Name of the strategy currently running on the control engine, the date and time it was
downloaded, and the number of charts currently running.

I—Archive. Information about the strategy currently archived on the control engine.
J—Run/Stop. Start or stop the active strategy.

K—Store to Flash. Click to store either the active or alternate strategy to flash memory. Only one
strategy at a time can be stored in flash memory. This button is enabled if there is a strategy stored in
RAM, even if the strategy is currently stored in flash. See Burned in flash (N) on this dialog box.
L—Alternate. Name of the alternate strategy, and the date and time it was downloaded.
M—Switch and Run/Switch. Click Switch and Run to make the alternate strategy the active
strategy and run it in the control engine. Click Switch to make the alternate strategy the active
strategy without running it.

N—Stored in flash. Shows whether a strategy is currently stored in flash memory.
O—Autorun. Click to indicate whether the strategy should automatically run when the control
engine is restarted. The strategy must be stored to flash to autorun. See Store to Flash (above) and

“Saving a Strategy to Flash”on page 176.

P—Loop Time. Time required to gather the inspection data from the control engine (the average
time taken for a single transaction).

Q—Comm Errors. Any communication errors.
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Viewing the Message Queue

The message queue holds error, information, and warning messages. All may be helpful in
troubleshooting. When a message is placed in the queue, a blue INFO, yellow WARNING, or red
ERROR box appears in the PAC Control status bar, as shown in the following diagram.

#1PAC Control Professional - [Counter] |Z||E|P5__<|

ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help - 8 x
o
I 4
ES
@ Prewvious_Counk o
@ Status Block 0
@ Takal_Count
+ |5 String Yariables
IC5) Painter Yariables
I3 Communication Handles
[C5) Mumeric Tables
[C5) String Tables ?
IC5) Painter Tables T I
= [ IO Units _ .
3
= GF RLA J “Production '
=1 | Paints : Details -
B po_switch : :
I“'%“_' Sprinkler _Switch
= plarm 2
E— - - - - o Counter
o= FID_Output L
24 Refrigeration < | ¥
= F'IE:I Input T =
IR iR ] Fiuino || Step Off fBreak 0rf || [EETET ST
< | = ' Chart /
| v| @ Mext ﬁ} Prev —|ﬁ| Counter ﬂ’l Meszages ﬂ’l Powerup |
IC:'l,Program Files\OptoZ2\PAC Project 8, 11Control Pro ExamplestioCookies\Cookies (INFO WARNING MM

Messages have been placed in the queue.

To see the message queue:
1. Clickthe INFO, WARNING, or ERROR box.

 Yiew Message Queue for “"Cookie Controller*

“ZyRefresh _-ﬁCnpy all ETPDD Top Message X Clear all Messages

# Code | Sewenty  Description Chart Block Line | Object | Time Date s
o -4 Infa Device haz powered up. [Powerup clear e <system: _INIT_... M/ M Miwed | 15:02:03  09/05/07

1 -35 Warning 1/0 paint mismatch: a configured point doe... <aystem: _IMIT_.. M/A M aolwen.. 15:02:03  09/05/07

2 -3 Warning 1/0 paint mismatch: a configured point doe... <aystem: _IMIT_... M/A M aoConw.. 15:02:03  09/05/07

3 35 Warning 1/0 paint mismatch: a configured point doe... <aystem: _IMIT_.. M/ M ailven.. 150203  09/05/07 _
4 700 Warning FID Loop O has been configured outside of .. <system: _INIT_... M/AA M Miwed | 15:02:03  09/05/07

5 13 Error Overflaw errar. Dough Chip_Co... 17 M [rull) 180221 09/058/07

E 13 Error Overflaw errar. Dough Chip_Co... 17 M [rull) 180221 09/058/07 v
Murmber of meszages: 12

2. Tosee all the information in the column, drag the edge of a column heading.
3. Toseeall of the information for one message, double-click the message.
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 View Message Queue for “Cookie Controller™

“sRefresh 25 Copy Al ETPop Top Message | ¢ Clear All Messages
# | Code | Sewenty  Description Chart Block, Line | Object | Time Date
0 4 |info |Device has powered up. [Poweng clear e. 1in; s [NsA Local .. ] 3/ 25/07
1 700 ‘wWaming PID Loop O hag been configured Stteidl ™. <suetem; INIT ... MAS WAL  Local |.. 16200268 08/25/07
2 B33 Info I/0 enor; pey” o i
3 539 Info 1/Demorpey 1) Message Details
4 BB Error Mo data recs
5 6534 Info Atternpt(z] to CODE: -4
E 53 Info 170 Unit not SEVERITY: Info
DESCRIPTION: Dewice has powered up. ('Powerup clear expected' message
received. )
Mumber of messages: 7 CHART: <«system: _INIT IO
BLOCK: M/4 L
LINE: N/4
OBJECT: Local IO I/0 Unic [127.0.0.1]
TIME: 16::20:26
DATE: 0%/25/07

o =

4, Torefresh the display with the latest messages, click Refresh.

5. Tocopy all messages in table format for transfer to another program such as Excel, click Copy
All.

6. Todelete the top (oldest) message on the list, click Pop Top Message.
7. Todelete all messages, click Clear Messages.
8. (lose the dialog box to return to the Inspect Control Engine dialog box.

Any changes you have made to the queue are reflected there.

Message Queue Information

Fach message in the View Messages dialog box includes the following information:

Code. The message or error code number (see “List of Common Messages” on page 391) or User if
the message was placed in the queue using the command Add Message to Queue.

Severity. Information, Warning, or Error.

Chart and Block. The chart and block being executed when the error occurred. If the error
occurred someplace outside the strategy, for example when trying to connect to an I/0 unit, Chart
shows <system>. If the error occurred in a subroutine, Chart shows the chart that called the
subroutine, and Block indicates the name of the subroutine plus the block number in the format
<sub name>.<block number>.Forexample, error #4 above (“Cannot divide by zero”) occurred in
block 1 of the subroutine Variable_Increase_Notification, which was called by the
Temperature_Control chart.

Line. If you are in Full Debug mode, the line being executed when the error occurred.
Object. The table, I/0 unit, or other object affected by the message. In errors #1 and #2 above, the
control engine was unable to communicate with /0 unit EIO_C. The unit’s IP address is shown for

easy reference.

Time and Date. \When the error occurred.
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Inspecting Control Engines from PAC Terminal

You can also inspect control engines from PAC Terminal.

1. [IfPA

CTerminal isn't running, start it as follows:

In Windows 7 and Windows Vista, press the Windows Start key '@—"’ and then click

Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.

In Windows 10 and Windows 8.1, press the Windows Start key @3' type PAC Terminal

9.6 and then press the Enter key.

The PAC Terminal window appears.
" PAC Terminal -oEd
File Tools Configure View Help
Control Engines:
Controller I:Jame System Type Address 1 Address 2 Status
¥ Cookie Controller  Standard JA2T.0:0.1 &
$¥R1 Controller Standard v10.195.55.111

Status Scan
%, Scan Al

“%, Scan Selected

2. Double-click the control engine you want to see (or right-click it and choose Status from the

pop
The

Archiving Strate

-up menu).
Inspect Control Engine dialog box appears. The dialog box is explained on page 111.

gieson the Control Engine

Archiving strategies on the control engine provides a backup in case original strategy files on the
computer are lost. When you archive a strategy to the control engine on an Opto 22 controller, a
Zipped file is saved in battery-backed RAM. On a SoftPAC controller, a zipped file is saved on the PC's
hard drive. In either case, if power to the control engine is lost, the archive is still there.

We recommend you archive both to the computer (during strategy development) and to the

control e

ngine (when the strategy is completed). Archiving to the control engine as well as the

computer makes sure that an older strategy can always be found and updated, even after personnel

changes

Archive files are date and time stamped, and zipped for compact storage. The archive file name on

occur and years pass. See also, “Archiving Strategies on the Computer”on page 177.

the control engine is in one of the following formats:

Path\File
Path\File
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The date stamp (D) is in the format mm/dd/yyyy. In the examples above, the date is February 28,
2000. The time stamp (T) is in the format hh/mm/ss. In the examples above, the time is 51 seconds
past 11:43 AM.

Make sure the control engine has sufficient memory available to store the archive file. Since only one
strategy at a time can be on the control engine, only the latest archive for that strategy is on the
control engine. Other archives are erased during strategy download.

In addition to the archived strategy, the archive file also stores persistent variables and variables that
are initialized on strategy download.

To archive a strategy to the control engine:
1. In PAC Control, choose File > Strategy Options.

Strategy Options

X

Archive | Download | Legacy | Serial |40 Ports

[ Auchive strateqy to disk when strategy is downloaded

[ ar H Canicel ][ Help ]

2. On the Archive tab in the Strategy Options dialog box, select “Archive strategy to disk when
strategy is downloaded” Also select “During download, save archive to the control engine and
save strategy to flash memory.”

Strategy Options fg

Archive |D0wnload Legacy | Serial 120 Ports

[ Auchive strateqy ta disk when strategy is clozed

Archive strategy to disk when strategy is downloaded

oK H Canicel ][ Help

3. (ickOK.

The strategy will be archived to the computer and to the control engine when it is
downloaded. Any archive already on the control engine will be replaced by the new archive. In
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addition, the strategy will be saved to flash memory, so it will still be available if power to the
controller is turned off.

Restoring Archived Strategies from the Control Engine

If original strategy files are lost or damaged, you can use PAC Terminal to restore the strategy archive
from the control engine to a computer.

1. If PACTerminal isn't already open, start it as follows:

- InWindows 7 and Windows Vista, press the Windows Start key @3' and then click

Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.
- InWindows 10 and Windows 8.1, press the Windows Start key ':5,3' type PAC Terminal
9.6 and then press the Enter key.

The PAC Terminal window appears.

O PAC Terminal -
File Tools Configure View Help
Control Engines:
Controller iclame System Type Address 1 Address 2 Status
#¥ Cookie Controller  Standard ¥127.0.0.1 =
$¥R1 Controller Standard v10.195.55.111 %
Status Scan
2, saanAl
“Z, Scan Selected
< >

2. Right-click the control engine and choose Upload > Strategy Archive from the pop-up menu.

3. Inthe Save PAC Control Strategy Archive As dialog box, navigate to the folder where you want
to save the archive file. Keep the file name as it is, so you can see the date and time it was
originally downloaded to the control engine. Click Save.

A dialog box shows progress as the archive file is uploaded to the computer.

4. Navigate to the zipped archive file. Assuming you are using WinZip, double-click the file name.
Highlight all files and click Extract. Extract them to the location you want.

5.  When allfiles are extracted, double-click the .idb file to open the strategy. If necessary, re-link
subroutines and files run before or after a strategy.

Re-linking may be necessary because the directory structure in the zip file may not match what
was originally on the computer. The zip file structure is as follows:

Root (.idb, chart files, .inf)
Subroutines
Control engine files
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Control_Engine_Name_1
Before run file
After run file
Control_Engine_Name_2
Etc.

Moving Control Engines from One PC to Another

Sometimes it's necessary to transfer a strategy to another computer, such as when the computer has
to be replaced, or when another PC will be used to run the control application. Instead of typing in
each control engine on the new computer, you can open the ControllerNames.ini text file and
merge the control engine names from a source PC with those on a target PC.

NOTE 1: Use this procedure only if you have PAC Control version R9.4a or newer. For versions prior to R9.4a,
see the OptoKnowledgeBase article KB80603 on the Opto 22 website, http.//opto22.com. However, the
best method is to install the newest software and use the method described here.

NOTE 2: When PAC Control version R9.4a or newer is first used, it automatically migrates the control engine
definitions from older versions. If you then use an older version of PAC Control to add another control
engine, the new control engine will not automatically be available in the R9.4 or newer version, because it
checks the older versions of control engine definitions only the first time it is run.

To move all the control engines from a source PC to a target PC:
1. Onthe source PC, locate the Controller.ini file. This file can be found in the following location:

C\ProgramData\Opto 22\PAC Project\ControllerNames.ini

2. Send the file by email or other means so that it can be opened on the target PC.

3. On the target PC, open the ControllerNames.ini files for the source and target PCs with a text
editor such Notepad.

Source
£ :
File Edit Format View Help

R2 Control Engine 9.0.0.0 10.195.55.112
R1 Control Engine 9.0.0.0 10.195.55.111
Cookie Controller 9.0.0.0 127.0.0.1

File Edit Format View Help

S2-M Control Engine 9.0.0.0 10.195.56.102
S1-M Control Engine 9.0.0.0 10.195.56.101

PAC Control User's Guide 119


http://www.opto22.com/site/knowledgebase/kb_view_article.aspx?aid=1419
http://opto22.com

DOWNLOADING FILES USING PAC TERMINAL

4. Copy the list of control engines from the source PC file and paste them to the end of the list of
control engines in the target PC file.

Target and Source merged on target PC

File Edit Format View Help
S2-M Control Engine 9.0.0.0 10.195.56
S1-M Control Engine 9.0.0.0 10.195.56
R2 Control Engine 9.0.0.0 10.195.55
9.0.
0.0.

2.0 10.195.55
2.0 127.0.0.1

R1 Control Engine
Cookie Controller

<

5. Save the target ControllerNames.ini file on the target PC before closing it.

All of the control engines in the merged file will now be available in PAC Control.

Downloading Files Using PAC Terminal

Using PAC Terminal, you can download PAC Control strategies or Forth files related to the strategy,
such as library or initialization files, directly to a control engine, without having to open each
program.

For information on using the brain’s file system to store data and manipulate it within your strategy,
see “Using the Control Engine’s File System” on page 276.

NOTE: If you are downloading a PAC Control strategy that requires other files, be sure to download the files
in the correct order (for example, library file, then strategy file, then initialization file). If you need to set
initial values for individual table elements on strategy download only, see “Setting Initial Values in
Variables and Tables During Strateqy Download” on page 237.

1. If PACTerminal isn't already open, start it as follows:

— InWindows 7 and Windows Vista, press the Windows Start key H and then click
Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.

— InWindows 10 and Windows 8.1, press the Windows Start key H type PAC Terminal
9.6 and then press the Enter key.
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The PAC Terminal window appears.

Eile Tools Configure View Help
Control Engines:

Controller Name System Type Address 1 Address 2 Status C re Control
$¥'Cookie Controler  Standard v127.0.0.1 % /Q Add... |
#R1 Controlier Standard 410.195.55.111 %

Right-click the control engine and choose Download > Forth File from the pop-up menu.

In the Download File dialog box, click Browse.

In the Open dialog box, locate the file you want to download. When the full path appears,
click OK.

If necessary to find the file, choose All Files from the Files of Type drop-down menu.

The download begins, and a dialog box shows its progress.
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Introduction

In addition to configuring a control engine to run your strategy, you also need to configure
input/output hardware to do the work: turning things on, setting temperatures, monitoring

controls, and so on.

This chapter shows you how to configure and work with I/0 units, 1/0 points, and PID loops.

In this Chapter

Choosing a Configuration TOO! ........ccceeereevveeesssreeessseeessssseeees

Adding an I/0 Unit........

AAAING 1/0 POINTS oo

Configuring a Serial Module...... . .

Changing I/0 Unit and Point Configuration.............cc...

Configuring PID Loops.

Inspecting 1/0 in Debug Mode ...

Inspecting and Tuning PID Loops.....

Using Watch Windows for MONitoring ...

Choosing a Configuration Tool

Configuring I/0 is one of your major planning steps in developing a PAC Control strategy. Generally
it's best to configure all /0 units, points, and PID loops at once, before you start building flowcharts.

There are two tools you can use for configuration: PAC Control and PAC Manager. These two tools
serve different purposes, but they overlap when it comes to configuring I/0. The image on the next

page compares their functions.
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PAC Manager Tasks |
‘ ‘ PAC Control Tasks

Assign and change——) Conflgure /0 —Configure —j Programand
IP ad('jress a 110 Unit control engine debug
Load firmware [} A UI0_Staton_ (So PC running PAC control logic
Configure communications ; Coil e
and events E!G Ponts communicate with

T the SNAP controller)

i
I/0 can be configured in PAC Control.

Ethernet-based 1/0 can also be configured in
PAC Manager and imported into PAC Control.

/0 units and points must be configured to match the PAC Control strategy you will run. You can
configure most I/0 units and point functions either in PAC Control or in PAC Manager.

For most I/0 units, if you are already in PAC Control, configuration is easier there and you can use the
loopback IP address forSNAP PAC R-series /0 units controlling themselves. However, some functions
for 1/0 units cannot be configured in PAC Control.

If you use PAC Manager, you can save your configuration to afile, load it to multiple I/0 units at
once, and use it for referencing points in OPC. However, you cannot use the loopback address in PAC
Manager.

Choose your configuration tool based on what you need to do:

Use PAC Control for I/O configuration if Use PAC Manager for I/0 configuration if

You have only one I/O unit or I/O unit * You have multiple 1/0 units whose
configurations are different. configurations are exactly the same or similar.

» The strategy will run on SNAP PAC R-seriesl/O | * You are using a modem connection (PPP) or
units that are controlling themselves using the SNMP.
loopback IP address, 127.0.0.1 » You are using event messages or email.

* You are using an Ethernet network for « You are configuring events and reactions on the
communications (or using a SNAP PAC I/0O unit in addition to strategy logic.
controller with an SB brain). + You are not using PAC Control.

» The strategy handles all logic; you are not also
configuring events and reactions on 1/O units.

Whichever tool you use for configuring I/0, be aware of the impact if you later change configuration.
For example, if you configure I/0 in PAC Manager, download the configuration file to I/O units, and
then later add a point in PAC Control, remember that your configuration file doesn’t contain that
point.

If you use PAC Manager, follow instructions in Opto 22 form 1704, the PAC Manager User’s Guide.
When you have finished configuration and saved the configuration file, you can import it into PAC
Control following the steps in “Importing 1/0 Configuration into PAC Control”below.

If you use PAC Control, follow the steps beginning with “Adding an I/0 Unit"on page 126.
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Importing I/0 Configuration into PAC Control

If you have configured all I/O units, points, and PID loops in PAC Manager, follow these steps to
import the configuration file into a PAC Control strategy.

1. Open the strategy in PAC Control. In the Strategy Tree, right-click the I/O units folder. From the
pop-up menu, choose Import.

2. Navigate to the configuration file you created and saved in PAC Manager. Double-click it to
open it.
The configuration information is imported. You can expand the I/0 units folder to see the
imported units and their points.

If you need to configure additional I/0 units from within PAC Control, see “Adding an I/0 Unit”
on page 126.To tune PID loops, see “Inspecting and Tuning PID Loops”on page 158.

Copying I/0 Configurations

If you have two strategies that use similar I/0 units and points, you can export an I/0 configuration
from one strategy into a file, and then import it into the other strategy.

If you need similar configurations for several I/0 units, you can use PAC Manager to send it to
multiple 1/0 units at once. (You cannot use PAC Manager for serial-based /0 units.) For more
information on using PAC Manager, see Opto 22 form 1704, the PAC Manager User’s Guide.

Creating the Configuration Export File

1. Open the strategy you are copying from in PAC Control. In the Strategy Tree, right-click the 1/O
Units folder and choose Export from the pop-up menu.

The Export I/0 Units to an Opto Tag Database dialog box appears.

2. Navigate to the location where you want to place the export file. Type the file name, and click
Save.

The export file is created. It is a comma-delimited ASClI file. If you wish, you can open it in
Notepad or Excel.

Importing the Configuration File

When you import the I/0 configuration file, it does not delete any I/O units or points that are already
there. If the import file contains I/O units with the same names as those already in the strategy, you
can choose whether to update them. Updating changes points that have the same name and adds
new points, but does not delete points.

1. Open the strategy into which you want to import the I/O configuration.
2. Inthe Strategy Tree, right-click I/0 Units and choose Import from the pop-up menu.
3. Navigate to the location of the export file you created. Highlight its name and click Open.

The I/0 units and points are updated from the configuration file. To see them, click the plus sign
next to the I/O Units folder on the Strategy Tree.
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Adding an I/0O Unit

In PAC Control, the term I/O unit usually refers to a mounting rack with an brain or brain board and

I/O modules attached.

NOTE: If you have already configured I/0 in PAC Manager, you can also add I/0 units or points if necessary
from within PAC Control, as you add commands to the blocks in your strategy.

To enable legacy I/0 units in PAC Control for a specific strategy, see “Legacy Options”on page 208.

1. Make sure the strategy is open and in Configure mode. On the Strategy Tree, double-click the
/0 Units folder. (You can also select Configure > 1/0 from the menu bar.)

The Configure I/0 Units dialog box opens, showing all configured 1/0 units.

You configure most of the data in these columns when you add or modify an 1/0 unit.

The Ref Count (Reference Count) is a field that you don't configure.
It represents the number of I/0 points configured on the I/0 unit
plus the number of times the I/0 unit is referenced in the strategy.

4 Configure /0 Units *
Mame Type Port Address Watchdog  Enabled RefCount Description Add...
R1 local IO  SNAP-PACRI1 Ethernet 2001 127.0.0.1 Disabled Enabled 14 Modify
Delete
1/O Points...
PID Loops...
Close Help Event/Reactions. ..

2. Toconfigure a new I/0 unit, click Add or double-click anywhere in the box below any listed

units.

126 PAC Control User's Guide




CHAPTER 6: WORKING WITH 1/0

The Add I/0 Unit dialog box appears.

& Add 1/0 Unit 4
Informatior
A — 1 Mame: | | |
B — | Description: | |
Type —
C—— Type |5NAP-PAC-R1 v|
Addressing
D——F— Frimary Address: B s0e 0 -0 [JLocal loopback)
E —— Secondary Address: [ e
F —— EthernetPort: 2001

Communication from control

G—— Enable communications from control engine

H ——— Timeout and disable communications after tries of III second(s) each.
Device Options — d

For temperature points, use degreet () Fahrenheit  (®) Celsius

J—m— [Jwatchdog timeout after | 0.5 second(s) of no communications

Gl | [

3. Complete the fields as described in “Add 1/0 Unit Dialog Box" below.

Add I/0 Unit Dialog Box

Use this dialog box to add a new I/0 unit to the strategy or edit an existing unit.

For information on saving the 1/0 Unit Configuration, see “Inspecting I/0 Units and Saving Settings
to Flash”on page 153.

A—Name. Enter a name for the I/0 unit. The name must start with a letter and may contain
letters, numbers, and underscores. (Spaces are converted to underscores.)

B—Description. (Optional) Enter a description of the unit.

C—Type. When adding an I/0 unit, select the type of I/O unit from the drop-down list. When
upgrading an older I/0 unit to a SNAP PAC brain, possible upgrades are available in the drop-down
list.

D—Primary Address. For Ethernet I/0 units, type the IP address of the brain attached to the I/0
unit. If the unit is local (the same SNAP PAC brain on which the strategy will run), select Local
(loopback). This sets the address to a loopback address, 127.0.0.1. This tells the brain to talk to
itself, so if you change the brain’s IP address, you don't have to change the address for the I/0 unit.

For serial units, type the unit’s address (valid range is 0-255).
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E—Secondary Address. (Optional, Pro only, Ethernet-based I/0 units only) To designate a
secondary I/0 unit for communication if this I/0 unit is unavailable, enter the secondary unit's IP
address. Note that both I/0 units use the same port number.

F—Port. For Ethernet-based I/0 units, communication with the control engine is Ethernet, and the
default port number is 2001. If you have changed this port for security purposes, also change it here.
(See the controller's user guide for details.)

For serial-based I/0 units, the communication port and parameters are shown for you. binary/CRC
settings on your hardware are required. For more information, see “Changing the Baud Rate for
Serial I/0 Units”

G—Enable Communications. Select whether you want communication to the I/0 unit
enabled or disabled on startup. Enabled is the default. Disabling communication to an I/O unit is the
same as disabling communication to all points on the unit.

H—Timeout. Enter the number of times the control engine should try to communicate with the
I/0 unit, and enter the length of time the control engine should wait for a response when
communicating with this I/0 unit. If after the first communication attempt there is no response
within the timeout period, the control engine retransmits. If there is no response within the timeout
period, it transmits again. This repeats according to the number of tries specified. If no response is
received within the final timeout period, communication to the I/O unit is disabled. The default
number of tries is 3. The default timeout period is 1 second.

In most cases, it is a good idea to start with the default values and only make changes if your system
has problems using the defaults.

CAUTION: If the timeout is long and the I/0 unit is turned off or unreachable, the control engine could
take quite a while to execute a command that talks to I/0. See also, “Tuning the I/O Unit Timeout Value for
Ethernet I/0 Units” on page 130.

I—Fahrenheit/Celsius. (Analog and Mixed units only) Choose whether temperatures will be
handled in Fahrenheit or Celsius.

J—Watchdog. Select whether you want a Watchdog on the unit (not available on remote simple
I/0 units). The default is No (disabled). If you select Yes, a new field appears; enter the Watchdog
timeout value (in seconds). The default timeout is 0.5 seconds.

With a Watchdog, the 1/0 unit monitors activity on the port. If no communication is received for the
specified interval, the unit assumes a Watchdog state. All selected outputs will then immediately go
to a specified value, as configured in the Watchdog field of the Add Analog Point or Add Digital
Point dialog boxes. (See “Adding 1/0 Points”on page 132.)

K—Maximum Analog and High-Density Digital Scantime. (Ethernet-based I/0 units
only) You can decrease the analog and high-density digital scan time to make sure the scanner isn't
slowed or stopped by heavy communication on the network. The Default is 1000 msec. This feature
is also available in PAC Manager where you can fine tune the scan time on the fly.

NOTE: Digital Scantime applies only to non-PAC I/0 units. PAC I/O units use Digital feature Resolution
Value instead.
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For more information on optimizing scanner performance, see “Optimizing Throughput”on
page 97 in this guide.

Changing the Baud Rate for Serial I/0 Units

NOTE: This section is for PAC Control Basic users. If you have the Pro version, see “Changing the Baud Rate
and Mode for Serial I/O Units” on page 129.

If the default baud rate shown in the Add I/0 Unit dialog box is not correct, you can change it. This
baud rate is for communication through the RS-485 port to serial /0 units. It does not affect other
serial ports on the controller or communication handles using these ports.

NOTE: Once you have configured a serial port for use with an I/O unit, do not configure a communication
handle on the same port.

1. Make sure the strategy is open and in Configure mode.
2, Choose File > Strategy Options, then click the Serial I/O Ports tab.

Strategy Options *
Archive Download ~Serial I/O Ports  Legacy
The SMAP-PAC-51 and SNAP-PAC-52 controllers may use serial /0 units such as the SNAP-PAC-SB1.

The port type must first be set to R5-485, either by using default ports or by PAC Manager.

You must also corfigure which ports will be used for /0 within this strategy:

[ Port Ofor 140 with 115,200 baud (SNAP-PAC-52 only)
[ Port 1 for 140 with 115,200 baud (SNAP-PAC-52 only)
[ Port 2 for 140 with 115,200 baud (SNAP-PAC-52 or -51)
[ Port 3for 140 with 115,200 baud (SNAP-PAC-52 only)

Serial ports may also be used for communicating with other devices by using PAC Control
communication handles.

Cancel Help

3. Select the correct port for the controller, and then choose the correct baud rate from the
drop-down list and click OK.

NOTE: If you are configuring a SNAP-PAC-S1 controller you must use port 2. If you are using a
SNAP-PAC-S2, see Opto 22 form 1704, the PAC Manager User's Guide, for the default serial port
assignments or to change a serial port assignment.

Changing the Baud Rate and Mode for Serial /0 Units

This section is for PAC Control Professional users. If you have the Basic version, see “Changing the
Baud Rate for Serial I/0 Units”on page 129.

NOTE: Once you have configured a serial port for use with an I/0 unit, do not configure a communication
handle on the same port.
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If the default baud rate shown in the Add I/0 Unit dialog box is not correct, you can change it. This
baud rate is for communication through the RS-485 port to serial I/0 units. It does not affect other
serial ports on the controller or communication handles using these ports.

In addition you can also choose Binary or ASCI mode. The controller will talk to all 1/0 units on that
port in the same mode.

NOTE: There is no ASCll version of OptoMMP protocol (which is used on SNAP PAC SB brains), so if a port is
set to ASCII, you won't be able to mix mistic and SNAP PAC SB brains as you can in Binary mode.

1. Make sure the strategy is open and in Configure mode.
2, Choose File > Strategy Options, then click the Serial 1/0 Ports tab.

| Strategy Options *
| Archive Download Serial 10 Ports  Redundancy Legacy

The SMAP-PAC-51 and SNAP-PAC-52 controllers may use serial /0 units such as the B3000
or SNAP-PAC-5B1.

The port type must first be set to R5-485, either by using default ports or by PAC Manager.

You must also corfigure which ports will be used for /0 within this strategy:

[ Port Dfor 140 with 230,400 baud and  Binary mode (SMAP-PAC-52 only)
[ Port 1 for 140 with 230,400 baud and | Binary mode (SMAP-PAC-52 only)
[ Port 2for 140 with 230,400 baud and  Binary mode (SMAP-PAC-52 or-51)
[ Port 3for 140 with 230,400 baud and  Binary mode (SMAP-PAC-52 only)

Serial ports may also be used for communicating with other devices by using PAC Control
communication handles.

Cancel Help

3. Select the correct ports for the controller, and then choose the correct baud rate and mode
from the drop-down lists and click OK.

If you are configuring a SNAP-PAC-S1 controller, you must use port 2 for serial 1/0 units. If you
are using a SNAP-PAC-S2, see Opto 22 form 1704, the PAC Manager User’s Guide, for the default
serial port assignments or to change a serial port assignment.

In addition, make sure to jumper the non-SNAP PAC brain for the correct setting, either Binary
CRC (cyclic redundancy check) or ASCII CRC. Although at the brain level you can choose
Binary/ASCIl and CRC/Checksum independently, the Opto 22 drivers support only binary CRC
or ASCII CRC.

ASCII CRC is only for mistic brains. If a port is set for ASCIl but has a SNAP-PAC-SB1/2 on it, the
compiler will generate a warning.

Tuning the I/0 Unit Timeout Value for Ethernet I/0O Units

The default I/0 Unit timeout value is 1 second. However, for best overall performance you can tune
the value for your system.

A SNAP PAC controller automatically retries 2 times before disabling communication to an 1/0 unit
that is unresponsive, and it uses the same timeout value for the first attempt and the 2 retries. So,
with a 1 second timeout value and 2 retries, it takes 3 seconds before an unresponsive unit is taken
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offline. This means the chart or command that is trying to read or write to that I/O unit will be
delayed by 3 seconds.

When using SNAP PAC Ethernet brains (SNAP-PAC-R1, SNAP-PAC-R1-B, SNAP-PAC-R2,
SNAP-PAC-EBT, or SNAP-PAC-EB2) on a wired LAN (local area network), a timeout value of 0.1
seconds may be fine. When using a WAN (wide area network), a wireless network, the Internet, or
you are not sure what the networking technology is, it may be best to use the default value of 1
second. However, if the controller's message queue shows loss of communication with Ethernet /0O
units, it may be necessary to increase the timeout value.

For Advanced Users:
If you are an advanced user with a lot of Ethernet experience, you may want to determine normal
response times from a brain using an Ethernet capture utility such as Wireshark®

(www.wireshark.org). Look for the fastest response time, the normal or typical response time, and
the longest response time.

Adjust the timeout value to be larger than the maximum observed response time. It is best not to
use a timeout value that is too short because this will cause unnecessary communication retries and
timeouts. We recommend making the timeout be at least 50% to 100% longer than the maximum
observed response time. In addition, we recommend not using a timeout value that is less than 0.1
seconds. For example, if the value is 0.1 seconds, then communication to an unresponsive I/0 unit
will be disabled within 0.3 seconds. If the network connectivity is very slow, you may need to use a
significantly longer timeout value such as 3 to 5 seconds or longer.

Changing Configured 1/0 Units

1. Tochange a configured I/O unit, make sure the strategy is open and in Configure mode.

2. Find the I/O unit's name on the Strategy Tree. Double-click it to open the Edit /0 Unit dialog
box. See “Add I/0 Unit Dialog Box"on page 127.

3. Make the necessary changes and click OK.

You can also change an 1/0 unit from the Configure I/0 Units dialog box by double-clicking the
unit's name or highlighting it and clicking Modify.

Deleting Configured I/0 Units

You cannot delete an I/0 unit if it has I/O points configured or if the I/O unit is referenced in a PAC
Control command.

CAUTION: Be careful when deleting I/0 units. You cannot undo a deletion.

1. To delete a configured I/0 unit, make sure the strategy is open and in Configure mode.

2. Find thel/O unit's name on the Strategy Tree. Right-click it and choose Delete from the pop-up
menu.

The I/0 unit is deleted from the strategy.

You can also delete an 1/0 unit from the Configure I/0 Units dialog box by highlighting the unit’s
name and clicking Delete.
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Adding I/O Points

Before you add an individual I/0 point, such as a sensor or a switch, you must add the I/0 unit the
pointis on. See “Adding an I/0 Unit"on page 126.

Adding a Digital I/0 Point

1. With the strategy open and in Configure mode, double-click the I/0 Units folder (not the
individual unit’s icon) on the Strategy Tree.

The Configure I/0 Units dialog box appears.

# Configure 1/O Units >
Mame Type Port Address  Watch... Enabled RefC... Desciption I Add... |
Ethern... 127.0.... Disabled Enabled [ 1
R1 SMAP-.., Ethern... 10.19... Disabled Enabled 0
: PID Loops... !
Event/Reactions. ..
£ >
| close || Heb

2. Highlight the I/0 unit the points are on, and click I/O Points.
The Configure I/0 Points dialog box appears.

3. Ifyouare using G1 or G4 single-point modules (for example with a G4EB2 or E1 brain),
double-click the point you want to use. Skip to step 11.

4. If you are using SNAP /0 modules, notice the module icons in the dialog box.

& Configure 170 Points — O X
1/0 Unit: |R1 | Type: | snaP-PACRI |
Modules and Points Type Features / Subty... | ~ Add...
Module icons ; :
) [01] ot Used Haiibrs
02] Net Used Delate
[03] Not Used
[04] Mot Used Mowe To...
[05] Not Used
[06] Not Used CopyTo »
[07] Not Used
[08] Not Used Expand All 3
09] Not Used | Collapse All |
[10] Not Used .
1111 Mot Used o
< >
=
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NOTE: This example shows a SNAP PAC I/O unit, so both digital and analog modules can be
configured on the same rack.

Highlight the number that represents the module’s position on the rack, then click Add.
Alist of available modules appears.

& Add Module x
Type: @) Digital Input (O Digital Output (O Analog Input - () Analog Output
Module:

Part Channels  Type(s) o

ESNAP—IDCE—FAST 4 2.5-16VvDC

ESNAP—IDC SFAST-A 4 18 -32vDC

ESNAP-IDCSD 4 2,5-28VDC

|jSNAP-IDC SMA 4 10 - 32 VDCVAC ManfAuto Switch

|jSNAP—IDC 5-5wW 4 Dry Contact Switch

|j SMAP-IDC5Q 2 4 -24VDC

|j5NAP—IDC 5G 4 35 - 75 VAC/NDC

ﬂSNAP—IDCS—Fﬂ' 4 15-32VDC

EESNAP-IDC S-SWHNC 4 Dry Contact Switch

|jSNAF‘-IDC SFM 4 10 -32vDC

|jSNAP—IDC5DFM 4 2.5-23VvDC

|jSNAP—IDC—32 32 10 - 32vDC

ﬂSNAP—IDC—SZ‘DN 32 -2.5--12VDC

|jSNAP—IDC—32D 32 2.5-12vDC

ﬂSNAP—IDC—SZN 32 -10-32vDC

ﬂSNAP-IDC-IG 15 10 -32vDC

|jSNAP-IDC-H'I'-16 15 15 - 28 WDC/VAC

ﬂSNAP—IACE 4 90 - 140 VDC/WAC

ﬂSNAP—IAC 54 4 180 - 280 VDCVAC W

< >
[] automatically create points within the new module

Mame Format: | %1_%2_ %3%4 q; Format information

Cancel | Help

Choose the module type and then the exact module from the lists.
To add points automatically, select “Automatically create points within the new module.”

Use the “Name format”text field to create a format for the point names. Enter any combination
of text and the following format codes:

%1 = point type (for example, ai or do)

%2 =1/0 unit name

9%3 = module position

%4 = channel position

%5 = a unique identifier that is generated automatically

Example: %1_%2_%3%4 would expand to something like di_MyloUnit_0801.

Example: %1ABC_%5 would expand to something like aoABC_473

Click OK.
In the Configure I/0 Points dialog box, click the plus sign next to the new module to expand it.
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Notice that the module icon is color-coded to reflect the type of module being configured:
white for digital DC input, red for digital DC output, yellow for digital AC input, and black for

i Configure /O Points O p
. IjO Unit: | Sprinkler_Control Type: | SNAP-PAC-R1
Module icon~___ | | |
Modules and Points Features # Subty... Add...
. [00] SNAP-IDCS: 10 - 32 VDCAVAC Digital Input _
Expand or collapse points ™9 0 Not Used
on the module by clicking L 1 Net Used Delete |
the + or - sign in the box. £ 2 Not Used B—
_Ilﬂ 3 Mot Used Maove To... |
POiﬂtS [01] Not Used
[02] Not Used LinEE L
[03] Not Used 1
[04] Not Used | Expand Al |
[05] Not Used [ Callapse All |
[D6] Not Used I
1071 Not Used
>
I Close i | Help i

digital AC output.

10. Highlight the point you want to configure and click Add.
11. Complete the fields as described in “Add Digital Point Dialog Box” below.
12. When you have completed the fields, click OK.

The new point appears in the list.

Here is an example of how it might look on a SNAP 1/O unit:

i Configure |/0 Points

— O =
1/0 Unit: | Sprinkler_Control | Type: | snappPacr1 |
Modules and Paoints I Type I Features / Subty... I -~ Add...
El [ [00] SNAP-IDC5: 10 - 32 VDCAAC Digital Input :
90 Sutcn 00 ErTa—
I 1 Not Used W|
T 2 Not Used -
}"%‘ 3 Mot Used Move To...
[01] Mot Used —
[02] Not Used | CopyTo b
[03] Mot Used -
[04] Mot Used @
[D5] Not Used [ Collapse All |
[D6] Mot Used S
1071 Mot Used v
£
I Close i | Help i

NOTE: If you need to add several similar points, see “Copying a Configured I/0 Point” on page 143.
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Add Digital Point Dialog Box

| Add Digital Point X
A ———— MName: | | |
B —————— Description: | |
C Type: Input

: Module: SNAP-IDCS: 10 - 32 VDC/MAC

D ——+— Features: Mone ~
E ———Default  ®No  (OYes
F ————— watchdog: @ No Yes
G [ Enable communication

Goncal | [l

A—Name. Enter a name for the point. The name must start with a letter and may contain letters,
numbers, and underscores. (Spaces are converted to underscores.)

B—Description. (Optional) Enter a description of the point.

C—Type/Module. For non-SNAP I/0 units, choose the module type and the exact module from
the drop-down lists. For a G4EB2, all 32 digital points are addressed as a single I/O unit; if you are
using the G4EB2 with Quad Pak modules, make sure you configure each group of four points as
either all inputs or all outputs.

For SNAP 1/0 units: Type and module are already filled in for you, as shown in the example above.

D—Features. To use a feature of the module, choose it from the drop-down list. You can
configure some input modules with a counter, totalizer, or other feature. (Inputs automatically have
both on-latches and off-latches.)

E—Default. To set a default state for the point when the strategy is run, click Yes and choose the
state (Off or On). To leave the point in the state it was before, click No.

F—Watchdog. (Output modules only) To set a Watchdog, click Yes and choose On or Off from
the drop-down list.

G—Enable Communication. Select whether you want communication to this I/0 point
enabled or disabled on startup. Enabled is the default.

Adding an Analog I/O Point

1. With the strategy open and in Configure mode, double-click the I/0O Units folder (not the
individual unit's icon) on the Strategy Tree.

2. Inthe Configure I/0 Units dialog box, highlight the I/0 unit the points are on, and click I/0 Points.
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The Configure I/0 Points dialog box appears.
3. (Proonly) If you are using a non-SNAP 1/0 unit (not including the B3000 or B3000-B),
double-click the channel you want to use. Skip to step 8.

4. If you are using a SNAP I/0 unit (including the B3000 or B3000-B), notice the module
icons in the Configure I/0 Points dialog box.

& Configure I/0 Points — O >
1/0 Unit: | Sprinkler_Contral | Type: | sNAPPACRL |
Modules and Poirts Type Features / Subty... | Add...
i) (001 SNAP-DCS: 10 - 32 VDC/VAC Digital Input _
[01] Mot Used
[02] Mot Used Delete
[03] Mot Used
[04] Mot Used [ Move To... |
[05] Mot Used ; 3
[06] Net Us=d CopyTo b
[07] Mot Used : :
[08] Net Used | Expand Al |
[0] Not Used | collapse Al |
[10] Mot Used - B
1111 Mot Used v
£ >
| Close | Help

NOTE: In this example, a digital module has already been added in position zero. This example shows
a SNAP PACI/0 unit, so both digital and analog modules can be configured on the same rack.

5. Highlight the number of the analog module’s position on the rack, then click Add.
6. (Choose the module type (Analog Input or Analog Output).

& Add Module X

Type: () Digital Input () Digital Output () Analog Input  (®) Analog Output

Module:
Part Channels  Type(s)
[lsMAP-AOA-3-16 1 4-20mA
[ SMNAP-AQV-5 1 0-10VDC
[ sMaP-a0V-7 1 -10 - +10VDC
[l sMAP-80A-23 2 4-20mA
[AlSMAP-AOA-234H 2 4-20mA
[l SMNAP-AQA-2345RC 2 4-20mA
[ SMAP-AQV-25 2 0-10vDC
[ SMAP-AOV-27 2 -10 - +10VDC
[l SNAP-AOA-23 ] 0-20mA
[ SNAP-ACD-29 2 5 - 80 VDC TPO
[alSMNAP-AGD-29-HFi 2 2.5 - 24VDC TPO
[l SNAP-ACVA-B 8 0-5VDC, 0 - 10VDC, 5 - +5VDC, -10 - +1
£ >

[] automatically create points within the new module
Mame format: | %1_%2_%3%4 9 Format information

7. Toadd points automatically, select “Automatically create points within the new module.”
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Use the “Name format”text field to create a format for the point names. Enter any combination
of text and the following format codes:

%1 = point type (for example, ai or do)

%2 =1/0 unit name

9%3 = module position

%4 = channel position

%5 = a unique identifier that is generated automatically

Example: %1_%2_%3%4 would expand to something like di_MyloUnit_0801.
Example: %1ABC_%5 would expand to something like aoABC_473

8. Inthe Configure I/0 Points dialog box, click the plus sign next to the new module to expand it.
Notice that the module icon is color-coded to reflect the type of module being configured:
blue for analog input, green for analog output.
4 Configure 170 Points — O *
4 1/0 Urit: | Sprinkler_Control | Type: | sNAP-PACRL |
Module icon Modules and Poirts | Type | Features / Subty... | ~ Add...
[j [00] SNAP-IDCE: 10 - 32 VDCAVAC Digital Input -
Expand or collapse points——-="yal IS e Z A T

on the module by clicking
the + or - sign in the box.

7
. [03] Net Used
Points / Copy Tir'\* b

o.

7= 0 Not Used | Delete |
== 1 Not Usad ) '
/:2; Not Used Mave To...

[04] Net Used
[05] Not Used
[D6] Not Used
[07] Not Used | Collapse a1l |
[08] Not Used '
1091 Not Used 2

Expand All

Close Help

Highlight the point you want to configure and click Add.

10. Complete the fields as described in “Add Analog Point Dialog Box” below.
11. When you have completed the fields, click OK.

The new point is added.

NOTE: If you need to add several similar points, see “Copying a Configured /O Point” on page 143.
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Add Analog Point Dialog Box

| Edit Analog Point ot

A Mame: | |
B Description: | TT-102 Temperature Transmitter |
C i Type: Input
Module: SNAP-AICTD: ICTD Temp. Probe w~
| ~
D ————————FullRange F
Clear Default
/
G [ ]5end Value
0
H []send values
0 1 Default
| Default: @ No  (Oives
J Watchdog: (®)No Yes
K Enable communication

Cancel Help

A—Name. Enter a name for the point. The name must start with a letter and may contain letters,
numbers, and underscores. (Spaces are converted to underscores.)

B—Description. (Optional) Enter a description of the point.

C—Type/Module. For non-SNAP I/0 units, choose the module type and the exact module from
the drop-down lists.

For SNAP 1/0 units: Type and module are already filled in for you. You may be able to choose a
different range from the drop-down list.

D—Full Range. Full range and units for this module.

E—Clamping. (Outputs only—optional) Enter upper and lower clamp if necessary to limit
output to the device attached to the point, no clamp is applied. To empty the fields, click Clear.

F—Scaling. Use to assign custom units and values to the module. For example, you could scale
the readings of a-10 to +10 VDC input point to measure its input as zero liters per second when the
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real-world reading is zero VDC, and 1000 liters per second when the real-world reading is 5 VDC. This
example would look like this:

Add Analog Point >
Mame: | |
o In this example, units are changed
Description: | | .
to liters/second and lower and
uppervaluesare changed. Although
Type: QOutput

the module has an output of -10 to
Module: SNAP-AOV-27: -10 - +10 VDC ~ +10volts, the device attached to the
point outputs only 0-5 volts. Scaling

Tt _ 2EE h reflects the device's range.
Full Range Clamping Actual; Scaled: . .

) . In this case Clamping protects the

Units: | vDC | |[voc | [woc | |Litersjsed | : )
device by ensuring that
Lower: | -10 | |lo | [0 |[o | out-of-range voltage will never be
Upper: | 10 NIE | s | | 1000 | sentto it.
Clear Default
R ey v-—-““—l‘ﬂ-'\-—{-—

Custom scaled values are floating point values.

« Analoginput points: Analog inputs typically have under-range and over-range capability,
which means you can specify a lower or upper value beyond the standard value. Also note that
with firmware R8.0a and higher, you can use regular or inverted scaling. Inverted scaling means
the lower value is greater than the upper value; inverted scaling can accommodate a sensor, for
example, that is wired to the SNAP module in a way that produces a negative current or
voltage.

»  Analog output points: Analog outputs do not have under-range or over-range capability.
Also, you cannot use inverted scaling. The upper value must be greater than the lower value.

Thermocouple values are not linear and cannot be scaled.

To return the units and upper/lower values to the defaults for the module, click Default.

G—Send Value (Filter Weight). (Inputs only—optional) To set the average filter weight for an
analog output point, check this box and enter the value. A filter weight smooths analog input
signals that are erratic or change suddenly. The formula used for filtering is Y = (X - Y )/W + Y, where
Y is the filtered value, X is the new unfiltered value, and W is the filter weight. The larger the filter
weight you enter, the smoother the analog signal. Filtering is applied to values in engineering units,
including minimum and maximum values. It does not apply to values in counts.

H—Send Values (Offset and Gain). (Inputs only—optional) To set offset and gain for the
analog output point, check this box and enter values. If you don't know what values to enter, you
can use PAC Manager to calibrate offset and gain for the point. See the PAC Manager User’s Guide for
steps.

I—Default. To set the initial state of the controller's interval value (IVAL) for this I/O point when
the strategy is run, click Yes and define the value. To leave the IVAL at its last state, click No.

If communication to the point is disabled, only the internal values (IVALs) are accessed or updated
by the control engine. The real-world external values (XVALs) for inputs don't change because they
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are controlled by external devices. The IVALs for inputs are set and will be overwritten by the XVALs
unless communication to the I/O unit or point is disabled.

The default (value) is available for both inputs and outputs. It sets the IVAL for the point in the
strategy in the controller when the strategy is run. This can be useful when the I/0 unit is not
accessible or communication to the I/0 unit is intentionally disabled when the strategy first starts.
When communication to an I/0 unit is disabled, any 1/0-related commands in the strategy will act
only on the I/O point IVALs because the controller is not able to access the XVALSs at the I/O unit
when communication to that I/O unit is disabled.

Once communication to the I/O unit is enabled and the 1/0 unit is accessible, then the first
command to access that point will update the IVAL. For example, if you use the Move command to
write a different value to an output, both the IVAL and XVAL are updated with the new value. If you
use a Move command to read an input, the XVAL is moved to the IVAL as part of reading the input
point.

J—Watchdog. (Outputs only) To set a Watchdog on this point, click Yes, and define the value to
be assigned to the output if the Watchdog is triggered. A Watchdog is triggered if no
communication activity is detected on the bus for the amount of time specified in the Watchdog
field of this point’s I/0 unit. For no Watchdog, click No.

K—Enable. Select whether you want communication to this I/0 point enabled or disabled on
startup. Enabled is the default.

Configuring a Serial Module

Use PAC Manager to configure SNAP serial communication modules, including the PROFIBUS-DP
and CAN modules. For more information, see Opto 22 form 1704, the PAC Manager User’s Guide.

Changing I/0 Unit and Point Configuration

140

You can change configured 1/0 units and points as follows:

+  Ifyoureplace a SNAP brain or rack-mounted controller, you can often change the entire I/0
unit at once. This feature does not apply to serial B3000 or B3000-B brains. See the list of
allowed replacements in “Replace a SNAP Brain or Rack-mounted Controller”on page 141.

+  You can move an I/0 point or an entire /0 module to a different position on the same or a
different 1/O unit. See “Moving a Configured I/0 Module or Point” on page 142.

«  Youcanfillin empty points on a module or an I/O unit, or copy a point to another position. See
“Copying a Configured I/0 Point”on page 143.

«  Youcan also change a point you've configured (page 146) or delete it (page 146).
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Replace a SNAP Brain or Rack-mounted Controller

In most cases you can change the entire I/0 unit type when you replace any of the following brains
or rack-mounted controllers as shown in the table below, and you won't need to reconfigure
existing /0 points.

However, if you're replacing an R1 or EBT with an R2 or EB2, and any points on the I/0 unit have the
digital features Counter, On Pulse, Off Pulse, Frequency, or Period, you'll need to change those I/0

points. You'll see a warning about this when you try to change the I/0 unit type.

Old /O unit type

New I/O unit type

Old /O unit type

New I/O unit type

SNAP-PAC-R1

SNAP-PAC-R2
SNAP-PAC-EB1
SNAP-PAC-EB2

SNAP-UP1-D64

SNAP-PAC-R1*
SNAP-PAC-R2*
SNAP-PAC-EB1*
SNAP-PAC-EB2*

SNAP-PAC-R1-B

SNAP-PAC-R1*

SNAP-B3000-ENET

SNAP-PAC-R1-B
SNAP-PAC-R1*
SNAP-PAC-EB1*

SNAP-PAC-R2

SNAP-PAC-R1
SNAP-PAC-EB1
SNAP-PAC-EB2

SNAP-ENET-RTC

SNAP-PAC-R1-B
SNAP-PAC-R1*
SNAP-PAC-EB1*

SNAP-PAC-EB1

SNAP-PAC-R1
SNAP-PAC-R2
SNAP-PAC-EB2

SNAP-UP1-ADS

SNAP-PAC-R1-B
SNAP-PAC-R1*
SNAP-PAC-EB1*

SNAP-PAC-EB2

SNAP-PAC-R1
SNAP-PAC-R2
SNAP-PAC-EB1

SNAP-ENET-S64

SNAP-PAC-R1
SNAP-PAC-R2
SNAP-PAC-EB1
SNAP-PAC-EB2

SNAP-PAC-SB1

SNAP-PAC-R1
SNAP-PAC-EB1

SNAP-UP1-M64

SNAP-PAC-R1
SNAP-PAC-R2
SNAP-PAC-EB1
SNAP-PAC-EB2

SNAP-PAC-EB2
SNAP-PAC-SB1

gm‘ﬁﬁﬁgﬁ; SNAP-PAC-R1
GENERIC OPTOMMP | SNAP-PAC-R2
SNAP-PAC-SB2 SNAP-PAC-EB1 DEVICE SNAP-PAG-EB1

SNAP-PAC-EB2

SNAP-ENET-D64

SNAP-PAC-R1*
SNAP-PAC-R2*
SNAP-PAC-EB1*
SNAP-PAC-EB2*

* This change requires a mounting rack change.

To change an I/0 unit type:
1. With the strategy open in Configure mode, double-click the I/O Units folder in the Strategy

Tree.

2. Select the I/0 unit you want to change and click Modify.
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3. (lick the Type dropdown list to see the possible types you can change it to.

Ethernet Port:

Communication from control

Enable communications from control engine

Timeout and disable communications after tries of second(s) each.

Device Options

For temperature points, use degree: (_) Fahrenheit (@) Celsius

[watchdog tmeout after | 0.5 second(s) of no communications

| OK | | cancel | Help

& Edit1/0 Unit X
Information
Mame: | Sprinkler_Control |
Description: | |
Type
Type: SMAP-PACR1 |1§l
Current Type b
Addressing SHNAP-PACR1 Ethernet, SNAP Analog and Digital points
/Other Possible Types
IP Address: /|snAp-PAC-RZ Ethernet, SNAP Analog and Simple Digital
SMAP-PAC-EB1 Ethernet, SNAP Analog and Digital points
\SMAP-PAC-EE2 Ethernet, SNAP Analog and Simple Digi

Other I/0 unit types you can
change this one to

4. Choose the new type, make any other necessary changes, and click OK.

Moving a Configured I/0 Module or Point

You can move a configured I/0 module or I/O point to an empty position on the same I/0 unit or a
different I/0 unit.

With the strategy open in Configure mode, double-click the I/O Units folder on the Strategy

1.

2.

Tree.

In the Configure I/0 Unit dialog box, highlight the unit the module or point is on and click I/0O

Points.

The Configure I/0 Points dialog box opens. For a SNAP I/0 unit, it looks something like this:

027 Net Used
[03] Net Used
[04] Not Used
[05] Not Used
[06] Mot Used
[07] Not Used

Close | | Help

& Configure 1/O Points — O x
I1/0 Unit: | Sprinkler_Contrl | Type: | SNAP-PACRL |
Modules and Points I Type I Features / Subty... A Add...
[} [00) SNAP-IDC5: 10- 32 VDCAVAC Digital Input

Fle e rdog Oupst |

Delete

Mowe To... '
CopyTo

W

| Bxpand Al

Cc-d.l_apse #:ll ;

PAC Control User's Guide



CHAPTER 6: WORKING WITH 1/0

— To move a module, select it and click Move To.

i Mowve Module - SNAP-IDC5: 10 - 32 VDC/VAC *
Select a target IjO Unit: Select an available module position:
b3000enet Maodule [02] Mot Used A
Eﬂéias%nﬁer: Module [03] Not Used
ixe ni
B e

Maodule [05] Mot Used
Maodule [06] Mot Used
Maodule [07] Mot Used
Maodule [08] Mot Used
Maodule [09] Mot Used
Maodule [10] Mot Used
Maodule [11] Mot Used v

Cancel Help

~ To move a point, expand an individual module by clicking its plus sign [+], or expand all
modules by clicking Expand All. Select the point you want to move and click Move To.

i Move Point - Sensor_3 (Digital Input) et
Select a target IjO Unit: Select an available point position:
b3000enet Module [00] SMAP-IDCS: 10 - 32 VDC/VWAC Y
Back_Sprinklers Point 3 : Not Used
—=idesli g Module [01] SNAP-ODC5-: 5 - 60 VDC Tsolated

Module [02] SMAP-IDCSD: 2.5 - 28 VDC
Point 2 : Mot Used
Point 3 : Mot Used
Module [03] SMAP-QACS: 12 - 250 VAC
Module [04] SMAP-ATARMS
Module [05] SMAP-ADA-23
Madule [06] v

Cancel Help

3. Intheleft column, select the I/O unit you want to move the module or point to. (The 1/0 unit
it's on now is selected by default.) In the right column, select the position you are moving the
module or point to. Then click OK.

You return to the Configure /0 Points dialog box, and the point has been moved.

Copying a Configured I/0 Point

If you have several points on a SNAP I/0 module that are the same, you can copy a configured point:
«  Tofillempty points on the same module.
«  Tofill all empty points on the I/0 unit.

«  Toanother point on the same or a different I/O unit.

1. With the strategy open in Configure mode, double-click the I/O Units folder on the Strategy
Tree to open the Configure I/0 Points dialog box.
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2. (lick Expand All so you can see the points.

i Configure I/0 Points

IO Unit: | Sprinkler_Control

| Type: | sNAP-PACRL |

Modules and Points

| Type

| Features / Subty... &

= ﬂ [DO] SNAP-IDCS: 10 - 32 VDC/VAC
=1 0 Switch_DO

1 Mot Used

2 Mot Used

3 Mot Used

TR

=

Ei[u

1 Mot Used

i

Close Help
| |

Digital Input

Courter

MAP-ODCBSRC: 5 - 60 VDC Source  Digital Output

3
—m

>

Mo\re To.. |

I Copy To LI

Expand Al
Eﬂlapﬂe A_lljl

3.
choose one of the following:

Highlight the point you want to copy and click the Copy To button. From the pop-up menu,

To copy the point to fill empty points on the module, choose Fill In Module.

The point is copied to the other empty points on the same module.

ﬁ Configure |/Q Points

1O Unit: | Sprinkler_Control

| Type: | SNAP-PACRL |

Modules and Points | Type | Features / Subty... A
B [i [00] SNAP-IDCE: 10 - 32 VDC/VAC Digital Input
Original point e i Counter
L Switch_DO_0001 Courter
Copied points Ul 3 Switch_DO_| Courter
L 3 Switch_DO_ Courtter
= . [01] SNAP-ODCESRC: 5- 60 VDC Source  Digital Output
,;,i_':,'l 0 Alarm_1 Mone
L0 {1 Not Used
< >

Close Help

Add...
I Modify... ]
| Deete |

Move Ta... |
Expand Al |

i_?)llﬁ!:_:se A_ll- —i
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4 Configure /0 Points - O *
/O Unit: | Sprinkler_Contral | Type: | snap-PACR1 |
This moqme W_as a_' reaqy conﬂgured. Modules and Poirts | Type | Features / Subty... I - Add...
The copied point filled in all empty # [ [03] SNAP-IDC5D: 2.5 - 28 VDC Digital Input _
points, even though the module is a LW § Switch_DO_0300 Courter
different part number. T8 1 Swich_D0_0301 Courter Delete
TH 2 Switch_D0_0302 Courter
L 3 Switch_DO_0303 Counter Move To...
No module existed in this slot. # [T [04] SNAP-IDC5: 10 - 32 VOC/VAC Digital Input E——
. 3 Lopy (o
Both the points and the module ﬁ 0 Switch_D0_0400 Courter
. . 1 Switch_D0_0401 Courter
were copied from the original. T e
P 9 13 2 Swich_D0_0402 Counter v e
< > Collapse All
Close Help

CHAPTER 6: WORKING WITH 1/0

To copy the point to fill all empty points on the I/0 unit, choose Fill In 1/0 Unit.

The point is copied to all empty points on similar modules (for example, to all empty points on
digital input modules, whether they are the same or a different part number), and the module
and point are copied to all compatible slots without configured modules.

To copy the point to one other point (either on the same or a different I/O unit), choose
To Specific.

The Copy To dialog box opens.

#: Move Point - Alarm_1 (Digital Output) X
Select a target IjO Unit: Select an available point position:
b3000enet Module [00] SMAP-IDCS: 10 - 32 VDC/VAC s
Back_Sprinklers Module [01] SNAP-ODCSSRC: 5 - 60 VDC Source
Mixed 10 Unit

Paint 1 : Mot Used
Point 2 : Not Used
Paint 3 : Mot Used
Module [02] SMNAP-AQV-27
Module [03] SMAP-IDCSD: 2.5 - 28 VDC
Module [04] SMAP-IDCS: 10 - 32 VDC/VAC
Module [05] SMAP-IDCS: 10 - 32 VDC/VAC i
< >

Sprinkler Control

Cancel Help

In the left column, choose the same or another I/0 unit. In the right column, choose the
location of the point to copy to.

Available points are shown in black. Already configured points, points on a different type of
module (digital output instead of digital input, for example), and point numbers not on the
rack (such as point 40 on an 8-module rack) are grayed out.

If the point is copied to an empty module slot, the module part number from the copied point
is added, too.

After you copy a point, change the new point as needed by double-clicking its point name. In
the Edit Digital Point dialog box, type the new name and make any other changes.
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Changing a Configured 1/0 Point

1. With the strategy open in Configure mode, expand the 1/0 Units folder on the Strategy Tree
until you can see the 1/0 point you want to change. Double-click the I/0 point name.

2. Inthe Edit Analog Point or Edit Digital Point dialog box, make the necessary changes. Click OK
to save.

Deleting a Configured I/0O Point
You cannot delete an I/O point that is referred to in the strategy.

CAUTION: Be careful when deleting I/O points. You cannot undo a deletion.

1. With the strategy open in Configure mode, expand the 1/0 Units folder on the Strategy Tree
until you can see the I/0 point you want to delete.

2. Right-click the I/0 point’s name and choose Delete from the pop-up menu.

You can also delete an I/0 point from the Configure I/O Points dialog box by highlighting its name
and clicking Delete.

Configuring PID Loops

146

PID loops (or simply PIDs) are used to drive an input (a process variable) toward a particular value
(the setpoint) and keep the input very close to that value by controlling an output. For example,
consider temperature control, where the input is a measurement of ambient temperature, the
setpoint is the desired temperature, and the output is a heater. The PID for this system will use a
mathematical formula that controls the output to maintain a desired temperature, efficiently adjust
to changes in setpoint, and compensate for changes in load, such as the influx of cold air. In this
example, a temperature sensor (analog input), a thermostat (analog input), and a heater control
(analog output) are components of one system, controlled by a PID loop.

This guide assumes that you are already familiar with using PIDs. PID calculations are complex and
the physical qualities of systems suitable for PID control differ greatly. This guide includes only basic
information for configuring PIDs.

SNAP PAC I/0 units support 96 PID loops.
PIDs can control isolated systems or be part of cascaded systems where one loop controls the

setpoints or input variables of others. For maximum flexibility, any PID input, setpoint, or output can
be determined by PAC Control commands.

PIDs and Strategies

The PID operates at the 1/0 unit, independently of the controller. However, the controller supports
logic commands to read and write various PID parameters and modes. Once configured and
initialized, a PID operates until the I/0 Unit loses power.

When you change PID configuration in PAC Control, remember that changes are not written to the
/0 unit until the strategy is downloaded and run. For a SNAP PAC I/O unit, be sure to save PID
configuration to flash memory following instructions for the I/0 unit.

PAC Control User's Guide



CHAPTER 6: WORKING WITH 1/0

If you subsequently download a different strategy to the control engine, you'll receive an error
message (-700) reminding you that a PID loop is still running and that it may conflict with the new
strategy. To turn off a PID loop, open PAC Manager and use Inspect mode to change the PID’s
algorithm to None.

Each PID loop must be individually configured and tuned.

Configuration steps start in “Adding a PID Loop”on page 147, and tuning steps are described in
“Inspecting and Tuning PID Loops”on page 158. For additional information, see “PID—Ethernet
Commands”on page 318, form 1641, Optolutorial: SNAP PAC PID, and form 2171, Tuning a PID Control
Loop Technical Note.

Adding a PID Loop

1. PAG Ethernet I/0, and Ultimate With the strategy open and in Configure mode, double-click the
I/0 Units folder (not the individual unit's icon) on the Strategy Tree.

The Configure I/0 Units dialog box opens.

& Configure /0 Units >

Name Type Port Address  Watch... Enabled RefC.. Add...

b3000enet SMAP-B3000-E... Ethern... 10.19... Disabled Enabled ©

Mixed_IO_Unit  SMAP-UP1-ADS  Ethern... 127.0.... Disabled Enabled

12
T SNAPPACR1  Ethern... % 6 [ Delete
Sprinkler_Control  SMAP-PACR1 Ethern... 10.19... Disabled Enabled 3

1/O Points. ..
PID Loops...
Event/Reactions...
< >
Close - | Help
2. Select the I/0 unit the PID will be on, and click PID Loops.
& Configure PID Loops — O X
o RS g
# Name Input  Set.. Out.. Mode Enable Ref... Descri ® Add...
Ot Modify...
01 Mot ...
02 Not ... - Delete
a3 Not ... =
04 Mot ...
e e »
< >
Close . | Help

3. Double-click the lowest unused number.
The Add PID Loop Dialog appears.
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4. C(Complete the fields as described in “Add PID Loop Dialog Box” below.

5. C(lick OK.

The new PID appears in the Configure PID Loops dialog box.

6. When you have finished configuring PIDs, click Close.

PIDs appear in the Strategy Tree under the I/0 unit.

) [5) Cookies

[C3) Subrouti
[C5) Charts

RO

[£5) Control Engines

[C5) Variables
=
Al b a000enst
A0 pived 10 Unit
=] “—’}JSI Sprinkler_B
= Points
2 I PIDs

“—”}";l Sprinkler_Contral

nes Induded

,,:'T'[;‘ Sprinkers

PID loops

Add PID Loop Dialog Box
Add PID Loop X
A ——— Name: | | |
B — 1 Description: | |
C —— Input: OPoint | w | [Jsquare Roast —— D
F ———sepont:  1jopoint v | v|
G ——— output: jopPont v | v|
H——tmwrcam[o | tpec o |
| ———— Min Change: D Max Change: I:I (0 dizables min/max change)
Output options for when the input is out of range
wi manual mode when input goes out of range
J - [ switch to | mode when input t of
[JForce output when input is out of range {auto mode only)
Okpuat input is under-range: o and over-range: | g
Feed Forward N
— Algorithm: | Velodi ype ain:

K Algorithm: | Velocity (Type C) Gan: |1 |

e Initial: ICI i o
L ——— Mode: Auto w | Tune I: ICI

- O
M st [ s oo o] P

148

Enable communication

[oc 1
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A—Name. Type a unique, descriptive name for the PID. The name must start with a letter and may
contain letters, numbers, and underscores (spaces are converted to underscores).

B—Description. (Optional) Enter a description of the PID.

C—Input. Select the type of input: I/0 Point, Host, or PID Output.

+  Ifthe PID’s process variable comes from an I/0 point on the same unit, select I/0 Point. Choose
the point from the drop-down list or type a point name to configure a new point.

« Ifthe PID's process variable comes from the PAC Control strategy, select Host. Enter an initial
value for the input.

« Ifthe PID's process variable is the output of another PID on this brain (a cascading control loop),
select PID Output. Choose the PID from the drop-down list.

D—Square Root. (Optional) If you chose I/0 Point or PID for step C, check this box if the error
should be calculated based on the square root of the process variable (applies to flow control
systems where volumetric flow is proportional to the square root of a signal from a flow transducer).

E—Low/High Range. Set the valid range of the process variable by entering the low range and
the high range. (See Output Options for optional responses to out-of-range input.)

F—Setpoint. Choose the source for the setpoint: /0 Point, Host, or PID Output.

«  To control the setpoint using a device (on the same brain) such as a potentiometer, select I/O
Point; choose an I/0 point from the drop-down list or type a new point name.

«  Tocontrol setpoint using PAC Control or PAC Display, select Host. For Initial Value, enter the most
common operating value.

« Ifanother PID loop will control the setpoint, select PID Output and choose the PID from the
drop-down list.

G—Output. Choose the destination for the PID output: I/0 Point or Host. (To use the output for
controlling the setpoint or input of another PID, choose Host.)

H—Lower Clamp/Upper Clamp. Enter upper and lower clamp values to prevent the output
from exceeding a desirable range. These values should equal the range of the output point, if used.
Or choose values to make sure that the output device doesn't shut off (for example, keeping a
circulation pump running regardless of the PID output) or that the output never reaches a
destructively high setting (for example, keeping a motor below maximum).

I—Min Change/Max Change. (Optional) Enter minimum and maximum change values. The
output won't respond until the minimum change is reached (for example, you may not want a
heater to turn on to correct a 1 degree error). Maximum change prevents too drastic a change in
output (for example, you could limit the increase in a pump’s output to prevent pipe breakage). The
default for both minimum and maximum is zero, which disables the feature.

J—Output Options. Choose how the PID should respond if the input goes out of range. To have

PAC Control logic or an operator respond, check Switch to manual mode. To force the output to a
specific value, check that option and type the output values.

PAC Control User's Guide 149



CONFIGURING PID LOOPS

150

NOTE: If both boxes are checked (forced output and manual mode), the output will be forced and the PID
putinto manual mode; but if the PID is already in manual mode, the output will not be forced. (You can
use the command Get PID Status Flags to determine current settings.)

If neither box is checked and the PID input goes out of range (as defined by E- Low/High Range) then the
output will freeze, but only while the input is out of range.

K—Algorithm. Choose algorithm: Velocity, ISA, Parallel, or Interacting. For details on algorithms,
see "Algorithm Choices”on page 320.

L—Mode. Choose the Mode you want the PID to be initialized to. The main difference between
Automatic and Manual mode is that in Manual mode the PID loop stops its mathematical
calculation. In both modes the PID's output value is still copied to the analog output.

«  Auto mode: The PID makes calculations based on the difference between the input and the
setpoint resulting in changes to the output, which causes the input to move toward the
setpoint.

«  Manual mode: The PID stops making changes to the output, but continues to write the PID
output to the analog point (or configured destination for the PID output). Manual mode allows
PAC Control logic or an operator to control the PID output, which in turn is written by the PID
loop to the analog point (or configured destination of the PID output).

NOTE: If the value of the analog point or configured destination is changed, it will be overwritten by
the PID output.

PID

Setpoint

Analog
Input Output \\* Output

M—Scan Rate. Enter a scan rate to determine how often the input is scanned and the controller
output is calculated. Minimum value is 0.001 (1 ms). Scan time should be greater than system lag
(the time it takes for the controller output to have a measurable effect on the system). Also consider
other PIDs and tasks on the brain competing for processing power.

N—Gain. Type a positive or negative value for Gain. Heating systems usually require a negative
value and cooling systems a positive value. NOTE: Gain is usually refined during the tuning process.

O—Fd Fwd Initial/Fd Fwd Gain. (Optional) Enter Feed forward Initial and Feed forward gain
values if you need to offset the controller output in your application. These values are constants that
are multiplied and added to the controller output; often they are not used in PIDs.

P—Tune I/Tune D. (Optional) Type Integral and Derivative settings if you know the desirable
settings. However, Integral and Derivative are not essential to basic configuration and are better
determined in the tuning process.
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Changing a PID Loop

You can change the PID loop’s configuration and its position in the I/0O unit.

1.

Make sure the strategy is open and in Configure mode. On the Strategy Tree, expand the /0O
Units folder until you see the PIDs folder for the I/0 unit you want. Double-click the PIDs folder.

The Configure PID Loops dialog box opens, listing all configured PID loops. Remember that the
number of PID loops available depends on the I/0 unit.

& Configure PID Loops - O bt

IO Unit: | b3000b w Type: | B3000 Analog

#  Name Input set... Qutput Mode  Enable 1% Add...

Temperature_... Owven_Te... Modify. .
01 Mot Used
02 Mot Used Delete
03 MotUsed
04  MotUsed
05 Mot Used

Close Help

I
Up- and down-arrows

PID loops are scanned by the I/0 unit in the order that they appear in this list.

To move the PID loop to a different position on the 1/0 unit, use the up- and down-arrows in
the dialog box.

To change the PID loop’s configuration, double-click its name to open the Edit PID Loop dialog
box. Change the fields as necessary.

For help in completing the fields, see “Adding a PID Loop” on page 147.

Deleting a PID Loop

Only PID loops that have a reference count of zero can be deleted. Be careful when deleting PID
loops; you cannot undo a deletion.

1.

Make sure the strategy is open and in Configure mode. On the Strategy Tree, expand the I/O
units folder until you see the PID loop you want to delete.

Right-click the name of the PID loop and choose Delete from the pop-up menu.
The PID loop is deleted.

You can also delete a PID loop in the Configure PID Loops dialog box by highlighting it and
clicking Delete.
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Add Event/Reaction E|

A —— Hame: | |

B—— Description: | |

C ——scanonPun ®iYes (O No

Interrupt on Event: (J'Yes (3 Mo

This figure shows the fields in the

D ——EventTupe: Watchdag Timeout v dialog box when you first openit.
Depending on the type of event
or reaction you select, other fields
may appear.

E—— Beaction Type: Mone “

F —— Enable communication

I ak l [ Cancel ] [ Help ]

Inspecting I/0 in Debug Mode

You may want to inspect or change I/0 while you are running your strategy in Debug mode. This
section shows how to view information about I/0 and make changes while the strategy is running.

To monitor several /0 elements at once in a window you can save with your strategy, see “Using
Watch Windows for Monitoring”on page 168.
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Inspecting I/0 Units and Saving Settings to Flash

1. With the strategy running in Debug mode, double-click an I/O unit in the Strategy Tree.

The Inspect I/0 Unit dialog box appears, showing information about the unit and its points. The
title bar shows the name of the I/0 unit and whether scanning is occurring.

%< "Mixed_l0_ Unit" (scanning)

Mame:  Mimed_[0_nit
Ermor: |None Enable Comm.: fres
Faints [Detailed] | Points [Compact] || PID Loops || Information
M aodule Chi Marme Type WAL AL ~
[ﬂ [00] SMAPADCED 0 Emerge.. [ Input
1 FOs [ Input
2 Freezer_... [ Input
3 FPhata_5... [ Input
‘ [01] SMAP-ODCESRC O Alarm D Output
1 Freezer_... D Output
2 Inzide_L.. [ Output
3 Outzide.. D Output
[ﬁ [02] SMAP-AOV-27 D Fuel Dis... AQutput 00000 e
T MotUsed e ooood e
‘ [03] SMAP-AICTD 0 Store_T...  Alnput 0.0000 783616 o
[ Addwatch | [ Miew. |[  Help |

NOTE: Scanning stops whenever you click a changeable field. It resumes once you click Apply, another
button, or an unchangeable field. If scanning resumes before you click Apply, any changes you made
are lost.

2. Tosave the current configuration of the I/O unit to its EEPROM (flash memory), click the
Information tab and then click the Set button under Stored Configuration (Flash EEPROM).

The following parameters are saved:

Analog Digital
¢ |/O module configuration ¢ 1/0O module configuration
¢ Initial output settings ¢ Comm link watchdog time

e Comm link watchdog time
e Temperature conversion type
¢ Input offset and gain settings

NOTE: Use this option to protect the I/O unit configuration information from being lost when the
power is turned off. You should save the configuration settings to flash when they are final.

Saving to flash memory this way is the same as saving to flash by other methods, such as using
PAC Manager (see Opto 22 form 1704, the PAC Manager User’s Guide), and is preferable to using
the command Write I/0 Unit Configuration to EEPROM.

3. Toreset saved parameters to their powerup default values, click the Clear button.

4. Tochange the I/O unit's current status, click an arrow in the Enable Comm field. Then click
Apply.
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Yes on a green background means enabled; No on a red background means disabled. If you
change it, the background turns magenta until you click Apply.

To view an individual I/0 point, highlight its name in the list.
— Toaddan /O element to a watch window, click Add Watch. See page 168.

- Toopen an inspection window to change an I/0 point, click View. Then see “Inspecting
Digital I/0 Points” below for the 1/0 point you are changing (analog or digital).

When you have finished inspecting the I/0 unit, click Close.

Inspecting Digital I/0 Points

You can inspect a digital point’s data, change its status, or set its internal values or external values in
Debug mode. To monitor the point in a watch window, see page 168.To change the point, follow
these steps.

1.

With the strategy running in Debug mode, double-click the I/O point on the Strategy Tree. Or
double-click an I/0 unit in the Strategy Tree, click the Points (Compact) tab of the Inspect 1/0
Unit Dialog box, and then double-click the 1/0 point.

The small dialog box that appears shows the VAL and XVAL.

- The XVAL, or external value, is the “real” or hardware value as seen by the I/0O unit. This value
is external to the control engine.

— The VAL, orinternal value, is a logical or software copy of the XVAL that is in the control
engine. The IVAL may or may not be current, since it is updated to match the XVAL only
when a strategy in the control engine reads or writes to an 1/0 point.

3. "Sprinkler_Switch” h* (sc... [

AL el (R =

If the digital point is configured with a counter, the counter values appear instead of the point’s
status.

3t “DO_Switch™ (scanning) E|

IvaL: o | WL | S——— Maximize button

2. To change the value or to view more information, click the Maximize button.
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The title bar shows the name of the digital point and whether scanning is occurring.

P “diDoughLevelSwitch™ (scanning) E|

MHame:  diDoughlevelSwitch
Tepe:  Digital Input (i More Info

AL wisk—— 3+ B
A—Fstae DN 2 ON |2
o [ ot :
oo [ :
D ——f-Counter: |EI | |4 |
E ——- Communication
Pain:

Enabed  C
1200 Uit _ =1 Open Parent
=

Scanning stops whenever you click a changeable field. It resumes once you click Apply, another
button, or an unchangeable field. If scanning resumes before you click Apply, any changes you
made are lost. Use the Clear button to immediately clear the field.

Asterisks in a field indicate an out-of-range value. Dashes in an XVAL field indicate a
communication error.

3. (Change the fields as necessary:
A—State. The point’s current internal value. Switch between On and Off; then click Apply.
B—XVAL. The point’s current external value. Switch between On and Off; then click Apply.
C—On-Latch/Off Latch. The state of the point’s on and off latches.

D—~Counter. Internal and external feature values if the point has been configured with any
special features, such as a counter.

E—~£nable comm. Current point status: Yes on a green background means enabled, No on a
red background means disabled. To change the status, click one of the arrows; then click Apply.

4. Toadd the point to a watch window, click Watch and see page 168.
5. To view configuration information for the variable, click More Info.
6. Toinspection I/0 unit's configuration, click Open Parent.
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(Pro only) To add a plot control, click Plot.

2.2 "diDoughl evelSwitch™ (scanning)

F | I I
Off-Latch j|

Mame:  diDoughLevelSwitch
Type:  Digital Input (51 More Info
VAL: HVAL:

State: = | |ON £
OnLatch: < |[on 3
Off-Latch: % ||on Z
Cammunication

Paint:  [Enabled E

1/0 Unit: |Enabled = Open Parent o

]
Pt << | = [ Das

b | [Timeduds » | [include AL

The Data button allows you to save, copy, or print the current plot. Use the Time Axis button to
adjust the resolution. Click Include IVAL to see a concurrent plot of the IVAL.

Inspecting Analog I/O Points

You can review an analog point’s data, modify its status, or set its internal values or external values in
Debug mode. To monitor the point in a watch window, see page 168.To change the point, follow

these steps.
1.

With the strategy running in Debug mode, double-

click the I/0 point on the Strategy Tree. Or

double-click an I/0 unit in the Strategy Tree, click the Points (Compact) tab of the Inspect 1/0
Unit dialog box, and then double-click the I/0 point.

The small dialog box that appears shows the VAL and XVAL, as well as the units.

is external to the control engine.

The XVAL, or external value, is the “real” or hardware value as seen by the I/O unit. This value

The IVAL, or internal value, is a logical or software copy of the XVAL that is in the control

engine. The IVAL may or may not be current, since it is updated to match the XVAL only
when a strategy in the control engine reads or writes to an 1/0 point.

3. "PID_Input” (scanning)

MAL: |0 AL |B1.44073 G

—— Maximize button

2. Tochange the value or to view more information, click the Maximize button.
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The title bar shows the name of the analog point and whether scanning is occurring.

%« "PID_Input” (scanning)

Mame:  PFID_Input
Type:  Analog Input
A— Chdal: 0 =val: [B0.57779 +——B
C ——F Communication
Paint:  'Enabled s
10 Unit: 'Enabled =1 Open Parent
=

Scanning stops whenever you click a changeable field. It resumes once you click Apply, another
button, or an unchangeable field. If scanning resumes before you click Apply, any changes you
made are lost.

Asterisks in a field indicate an out-of-range value. Dashes in an XVAL field indicate a
communication error.

Change the fields as necessary:

A—IVAL. The point’s current internal value. You can change it to any value within the valid
range of the analog point. For an input, the valid range may exceed the apparent range; that is,
you may be able to enter a value lower than the zero-scale value or higher than the full-scale
value. For an output however, you cannot enter a value outside of the range defined by the
zero-scale and full-scale values. After you change it, click Apply.

B—XVAL. The point’s current external value. You can change it to any value within the valid
range of the analog point; then click Apply.

C—£nable comm. Current point status: Yes on a green background means enabled, No on a
red background means disabled. To change the status, click one of the arrows; then click Apply.

To add the point to a watch window, click Watch and see page 168.
To view configuration information for the variable, click More Info.
To inspect the I/0 unit’s configuration, click Open Parent.

(Pro only) To add a plot control, click Plot.

%, "ail6,_Pot” (scanning)
ail6_Pot

Type:  Analog [nput {1 More Info

Marne:

IVal:  439.0768 sl 42001997

Communication

Paint:  Enabled =
|40 Unit: Enabled =1 Dpen Parent
14:04:40 14:04:50
Apply | [ wateh Flat << 5= || Data » | [Valuedsis v | [ Timessis » | [ Show VAL

The Data button allows you to save, copy, or print the current plot. Use the Time Axis and Value
Axis buttons to adjust the resolution. Click Include IVAL to see a concurrent plot of the IVAL.
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Inspecting and Tuning PID Loops

Click a tab to see or

In Debug mode, you can view PID loops and tune them. This section gives you basic steps for
inspecting PIDs, determining system lag, and tuning PIDs. For additional information, see form 2171,
Tuning a PID Control Loop Technical Note, and form 1641, Optolutorial: SNAP PAC PID. Both forms are

available for download from our website at www.opto22.com.

Inspecting a PID

1. With the strategy running in Debug mode, double-click the PID on the Strategy Tree.

3. "pid0” - View PID Loop (scanning)

Name: | pidd Emar: |Mone
Input: 79.2753 Gain: 15 ScanRate: |3 ZEC. Mode: Auto
Setpoint: |79 Tunel: (005 Scan Counts: [112783 Enable comm: [Yes
COutput: | 2252621 Tune O | 0.02

Mizc. Details | MAL || Yelocity Algorithm [Type B

change additional data.

Setpointand Input plot. |

Adjust resolution using
the Input Axis button
below the plot. Click and
drag on the scale to
move the line.

Output plot.

Adjust resolution using
the Output Axis button.
Click and drag on the
scale to move the line.

Time axis. Adjust
resolution using the
Time Axis button. Click
and drag left or right to
see other times.

158

Plat 1/0 Details

AT

09:44:000  0344:300

[ Data

Cloze

b | [Input Axis » | [Output Asis b | [ Time Asis » |

[ Addwatch l [Save Tuning] [ Help ]

LR

2. Vieworchange PID parameters as necessary. Click the other tabs to see additional data. To tune

the PID, see page 163.
3. Toadd the PID to a watch window, click Add Watch and see page 168.

menu.
5. To save changes to any of the PID configuration parameters, click Save Tuning.
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Determining System Lag

You can directly control the PID output to determine system lag, which is essential to setting the PID

scan rate. Also see form 2171, Tuning a PID Control Loop Technical Note, available for download from

our website at www.opto22.com.

1. Determine two significantly different output settings that are within the capabilities of your
system.

2. With the strategy running in Debug mode, double-click the PID on the Strategy Tree.

% "pid0” - View PID Loop (scanning)

Mame: | pidl Ermar: |Maone

Input; 79,2753 Gain: 15 Scan Rate: |3 IEC., Mode: Auta |
Setpoint: |79 Tunel: |0.05 Scan Counts: | 112783 Enable comm: [es &
Output; | 2.252521 Tune D: |0.02

Plat 1/0 Details | Misc. Details | AL | Yelocity Algorithm [Type B]

[ Data ][Input.f-\:-cis » ][Dutput.ﬂ\xisb ][Time Az b ]

[ Addwatch ] [Save Tuning] [ Help ]

3. Setthe Mode to Manual (if not set already) and click Apply.
4. Inthe Output field, type one of your two output settings and click Apply.

Use an output value typical of your system but low enough to allow you to change output by
20%.

5. Reset your time axis, if necessary, by clicking the Time Axis and choosing from the pop-up
menu. Then choose Reset Scale Tracking from the same menu.

The span setting varies according to your system; a 3-minute span is often suitable. Until you
are familiar with the PID plot, it is recommended that you avoid using the shortest settings
(10-seconds or 1-second). After you've observed a change in the input, you can zoom in on the
graph, which is described later.

6. Wait for your system to stabilize.
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The system is stable when the Input value does not vary significantly (some drift can be
expected). Stabilization may take several minutes, depending on the system.

b1

% TemperatureControl” - View PID Loop [scanning)

MName:  |pid0 Eraor: |Mone
A stable system exhibits little
‘y | Inpuk— | 7732614 Gain: -5 ScanRate: |1 FEC, Mode: arual =
change in the Input value, —
L . Setpoint: {90 Tunel: |0 Scan Counts: | 249642 Enable comm: [Yes £
which is shown numerically
Output; {20 TureD: |0

and graphically.
Plaot 170 Details | Mizc. Details | AL | Welocity Algorithm (Tyepe B)

Reset Scale Tracking

View S00% Span
View 200% Span
View 100% Span
View 50% Span
View 22% Span
View 10% Span
View 5% Span
View 1% Span

Center on Input -
Center on Setpoink

[ Data  » ][Input.’-‘mis » ][Dutput iz p ][Time.-’-\xis 3 ]

Adjust resolution of the
Input Axis by clicking the

Input Axis button. | Addwaich | [SaveTuning| [ Help |

7. Increase the resolution of the Input Axis by clicking the Input Axis menu and choosing a span
setting of 1 or 5 percent.

8. (Centerthe Input Axis, if necessary, by clicking the red line at its left end and dragging it up or
down until the plot is visible.

9. Under the Time Axis menu, choose Reset Scale Tracking.

This is a precautionary step, as changing settings on the plot can fix the plot at a certain point
in time. Resetting the time axis ensures that you are viewing the real-time values.

In the Output field, type the other of your two output settings and click Apply.

A 20% percent increase is a moderate, detectable change for most systems. Your system may
require a larger or a smaller change to stay within safety constraints.

10
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11. Wait for a discernible change in the Input axis.

Flat 140 Detailz | Misc. Details | MAL | Velocity Algorithm (Type B)

The Input axis (indicated by
the upper white arrow
added to this picture)
begins to respond to the
change in output (lower
white arrow).

[ Data  » | [InputAsiz » | [Output dsis b | [ Time Asis » |

12. Increase the resolution of the Time Axis by clicking the Time Axis button and choosing a lower
percentage, such as View 1 Minute Span.

13. Scroll the Time Axis to locate the point at which you changed the Output.
Both the time and input axes should display the point at which the Output changed, the lag,
and the point the input changed. If not, adjust the Input axis and Time axis, until this
information is displayed.

Plot |/0 Details | Mizc, Details | MAL | Velocity Algarithm [Type B)

[ Data  p ][Input Bz p ][Dutput.-’-\xisb ][TimeAxis »

14. From the Data menu, select Cursor.
The data cursor, a line with a value bar attached to it, appears on the plot.
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15. Right-click the data cursor and choose Delta X from the Style submenu, as shown below.

Plat 140 Details | Migc, Details | MAL || Welocity Algorithm (Type B)

Channel

v value x-v

Flip alignment Delta ¥

[ Data  » ][Input Bz B ][Dutput.-’-‘n.:-cisb ][TimeA:-:iS » ]

16. To measure the system lag (the time between the change in output and the change in input),
click and drag the first vertical red bar to just after the output change. Drag the second bar to
just before the change in input.

Plat 1/0 Detailz || Mizc. Details | WAL || Welocity Algarithm (Type B)

The Delta X cursor displays
the time difference s !;'.-'p"";_,i,_lr
between the two vertical Output
bars.

= [utput

Drag the first bar into
position after the Output
change.

Drag the second barto a
position just before the [ Data  » | [Inputieis » | [Qutput sk | [ Time Asis » |
change in Input.

If you are unable to get the precision you want, you can view the plot at a lower time span,
such as 10 seconds. You will need to reposition your plot and the measurement bars of the
Delta X cursor.

The example above shows a system lag of 1.88 seconds. Generally, a suitable scan rate can be
anywhere from one-third the system lag to two times the system lag.
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Considerations in setting scan rate are:

«  Slower scan intervals may be easier to tune. The PID controller has time to see the effect of the
previous output before calculating a new output.

«  Faster scan rates may be necessary to achieve the desired response. When scan intervals are
shorter than the system lag, tuning must compensate for any over-correction from the
controller output.

Tuning a PID Loop

Tuning a PID involves manipulating the P, I, and D constants in real time. The following steps should
be viewed as general suggestions to show you features that are available for tuning. We highly
recommend form 1641, OptoTutorial: SNAP PAC PID, and form 2171, Tuning a PID Control Loop
Technical Note, for more detailed information. These forms are available for download from our
website at www.opto22.com.

CAUTION: Before following these procedures, make sure you know the limits of the equipment being
controlled and monitored by your PID loop. Also, make sure that these points are configured properly. Any
values suggested in these steps are for example only and must be modified according to the capabilities
and constraints of your system.

1. Make sure the following PID features have already been configured:
- Scan Rate
- Input
— Input low range and high range
—  Output
- Output lower and upper clamp.
- Algorithm

- Setpoint. If your setpoint changes during normal operation, tune your PID with the
setpoint configured to host, so you can simulate setpoints from an input point or from
another PID.

- Gain. Afinal gain constant will be determined by tuning, but before you can tune your PID,
your gain constant must be either a positive or negative number according to the type of
system you have. For example, a heating system reports a negative error when heat needs
to be applied; a negative gain constant turns this error into a positive output for the heater.
Alternatively, a cooling system reports a positive error when the input exceeds the
setpoint; a positive gain constant maintains the positive output to the chiller.

- Optional, depending on your system: Minimum and maximum changes to Output and
Output forcing when the Input is out of range.

2. Download and run your strategy.

The current PID configuration is written to the I/O unit. You can stop your strategy at this point
if you wish, as the PID will continue operating.
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3. InDebug mode, double-click the PID on the Strategy Tree.

% "pid0” - View PID Loop (scanning)

MName:  |pid0 Erar: |Maone

Input: 79.2753 Gain: -15 ScanRate: |3 ZEC. b ode: Auto -
Setpaint: |79 Tunel: (005 Scan Counts: [172783 Enable comm: |Yes F
Output | 2252521 Tune D: (0.02

Plat 140 Details || Mizc. Details | WAL || Welocity Algorithm [Twpe B)

[ Data ][Input.&xis » ][Dutput.&xis} ][Time Bz p ]

[ Addw atch ] [Save Tuning] [ Help l

4. Setthe PID Mode to Auto (if not set already) and click Apply.
5. Change the Setpoint, if desired, by typing a new setpoint and clicking Apply. (Setpoint must be
configured as Host.)

Depending on the type of system, your PID may maintain a setpoint or respond to changes in
setpoint. Experiment with setpoint changes again after tuning the P, 1, and D constants.

6. Adjust the span of the input, output, and time axes according to how much change you expect
from your system. To set a span, click the axis button and choose from the pop-up menu.

7. [If desired, type a new Scan Rate and click Apply.
For most systems, you should use an appropriate scan rate based on the system lag (see

"Determining System Lag”on page 159). However, you can experiment with Scan Rates before
tuning the P.1, and D constants or adjust scan rate after tuning.
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Here is an example for Scan Rate:

<. “TemperatureControl” - View PID Loop (scanning)

MName: | TemperatureContral Emor: | Mone

Input: 80.24991 Gain: A ScanRate: |3 ZEC. tode: Auto &
Setpaint: |20 Tunel: 10 Scan Counts: (112783 Enable comm: [Yes T
Output; |0 Tune D: |0

Plat 140 Details | Migc, Details | MAL | Welocity Algorithm (Type B)
The lag for this system was

determined to be about 2
seconds. The left half of the
plot reflects a 0.5-second
scan rate, while the right
half shows a 3-second scan
rate. Notice both scan rates
have the same effect on the
input; however, the
3-second scan rate is using
less of the processor’s
resources.

[ Data  » ][Input Bz B ][Dutput.-’-‘n.:-cisb ][TimeA:-:iS » ]

[ Add Watch l [Save Tuning] [ Help ]

8. Experiment with gain settings by typing a new value in the Gain field and clicking Apply.

The easiest way to tune most PIDs is to experiment with the gain constant first. Try various
gains to see how well the system stays at setpoint and responds to setpoint changes.
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In the example below, the white arrows (added for the example) show where gain constants of
-2,-5,-10, and -20 were applied:

&

2« "TemperatureControl” - View PID Loop, (scanning)

Mame: | TemperatureContral Erar: |Maone

Input: a7.5289 Gain: -20 ScanRate: (1.4 e, Made: At T
Setpoint: |90 Tunel: |0 Scan Counts: | 112783 Enable comm; es e
Output  |B1.7775 TureD: |0

Plat 170 Details | Mizc. Details | WAL | Yelocity Algorithm [Type B)

[ Data  » ][Input.&xis » ][Dutput.&xis} ][Time Bz P ]

[ Addw atch ] [Save Tuningl [ Help l

In this example, a gain setting of -30 revealed an offset error:

Plat 140 Details || Mizc. Details | WaL || Welocity Algarithm [Type B)

With only a gain constant 80.00

applied, the input often ""F"""___'
stabilizes at an incorrect 0 = ;:,,_”_p':'r_' '
value. In this heating
example, a gain setting of
-30 drove the input close
to the setpoint, but
subsequent increases 100
failed to eliminate the
offset. It is time to try
integral constants to
eliminate the offset error.

[ Data  » ] [Inputteis » | [Outputdeizp | [ Time Asis » |
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9. Experiment with the integral constant: in the Tune | field, type a number between 0 and 1 and
click Apply. (Your PID may require larger numbers.)

In this example, an integral constant of 0.1 corrected the offset error.

Flat |/0 Details | Misc. Detals | AL | Yelocity Algorithm [Type B)

The far left side of the plot
shows the offset before an
integral constant of 0.1 was
applied. This setting eliminated
the offset. Inmany applications,
a minor fluctuation around the
setpoint is acceptable, and
these applications use gain and
integral only. In some
applications, however, the
fluctuations at the setpoint
indicate that the gain is too
high (too much gain makes a
system unstable) or that a
derivative constant is required.

[ Data  » ][Inputﬁ-\:-:is 3 ][Dutput.ﬂ\xisb ][Time Az b ]

10. If derivative correction is needed, experiment with the derivative constant: in the Tune D field,
type 1 and click Apply. (Your PID loop may require a larger number.) In this example, a
derivative of 10 makes a noticeable difference in keeping the input near the setpoint.

% “TemperatureControl” - View PID Loop {scanning)

Many PID systems are effectively

controlled with gam and mtegra| MName: | TemperatureControl Eror: |Mone

constants Oﬂ|y and no derivative Input: 90.02628 Gain: -30 Scan Rate: |[1.4 ZEC. Maode: Auto E
Fonstant. In .thIS examplle, the.gam and Setpoint: |30 Tunel: |01 Scan Counts: |B1281 Enable comm: [fes $
mtegra\ settings are malntalnmg the Output |66.71089 TureD: 110

temperature at 0.06 from setpoint. To

demonstrate the effect of the derivative Plat 1/0 Details | Misc. Details | WAL || Velocity Algarithm (Type B)

constant, the resolution of the input axis 90.50
was increased to show a 1 percent span.
At this resolution, the plot reveals
changes of 0.01 degrees F.

it

W —— === Output

The left side of the plot shows the effect
of gain at -30, integral at 0.1, and no
derivative constant. The arrow shows
when a derivative constant of 10 was — A AT
applied. The right side of the plot shows
how the derivative constant is keeping
the input closer to setpoint.

[ Data  p ][InputAHis » ][Dutpumxisb ][TimeAxis » ]

[ Add watch ] [Save Tuning] [ Help
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11. Click Save Tuning to save your tuning parameters to the strategy database.

Changes are lost unless you save them. You may wish to save your tuning parameters when
you see any improvement in performance, even if they are not final.

PAC Control Professional X

'E The Following values will be saved to the strategy database:
L

Gain: -5.000000
Tune I 10000000
Tune 200,000000
Scan rate: 3.000000
Feed forward: 0.000000
Feed forward gain: 0.000000
Qutput min change: 0.000000
Output masx change: 0.000000
Oukput when input is under-range: 0.000000
Cukput when input is over-range: 0.000000

Saving these values ko the strategy will require the strategy
to be compiled and downloaded before entering debug mode again,

Do vou want ko conkinue?

12. Click Yes.

Values are saved to the PAC Control strategy. Remember to save PID parameters to the I/0 unit's
flash memory, too (see “Inspecting I/0 Units and Saving Settings to Flash”on page 153).

Using Watch Windows for Monitoring

168

While the strategy is running, you can monitor several strategy elements at once in a watch window:
/0 units, digital and analog points, PID loops, variables, even charts. You cannot monitor subroutine
parameters or variables that are local to a subroutine in a watch window.

Unlike inspection windows, watch windows can be created the way you want, docked in a position
most convenient for you, and are saved with your strategy. You cannot change strategy elements in
a watch window, but you can open the inspect dialog box from the watch window and change the
element there.

Creating a Watch Window

1. With the strategy open and in Debug mode, choose Watch > New.

2. Inthe Create New Watch Window dialog box, navigate to the location where you want the
watch window file to be kept (usually in the same folder as the strategy). Enter the watch
window file name and click Open.
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The empty watch window appears.

«+ Watch 2 o FEX
[ wawe = | Type | TwAL | IVAL
b X

Add elements you want to watch in this window by clicking them on the Strategy Tree and
dragging them into place in the watch window, or by right-clicking them and choosing Watch
from the pop-up menu.

You can add I/0 units, digital and analog points, PID loops, variables, and charts. You cannot
add subroutine parameters or variables that are local to a subroutine.

Depending on which element you add and how you add it, it may appear immediately in the
window, as shown here,

ceWaich2 S EEK

|l
%

PAC Control User's Guide 169



USING WATCH WINDOWS FOR MONITORING

For some elements, the Add Watch Entry dialog box appears, so you can specify what to watch.

#1 Add Watch Entry

Mame: IDigitaI_Control |

Select Partions Tawatch:

ltems in this area vary a‘aéus Select &
. ode
depending on the element B

you are watching. This [¥] Block Paused &t
example shows a chart.

Select Watch ‘Window

I K H Cancel l[ Help ]

4, [fan Add Watch Entry dialog box appears, click to place or remove the check mark next to any
item. When all the items you want to watch are checked, click OK.

The element is added to the watch window.

The watch window is automatically saved.

Opening an Existing Watch Window

If a watch window was open when you exited Debug mode, it will automatically open again when
you re-enter Debug mode. To open other watch windows, follow these steps.

1. Make sure the strategy is open and in Debug mode.
2. Choose Watch > Open.
3. Navigate to the watch window you want to open and double-click its name.

The window opens in the position you left it.

Working in Watch Windows

Watch windows are flexible. You can dock the window where you want it in the PAC Control main
window. You can also move, delete, and inspect elements in the window.

«  Todock the watch window, click the docking button [ in its title bar.
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Expand or collapse the
item by clicking the +
or - sign in the box.

‘ ‘ Sprinkler Control

CHAPTER 6: WORKING WITH 1/0

The window moves to its own frame.

A PAC Control Professional - [Oven_Inspection_Control]

(31 contio = pebug 1o JECNERRL I ¥ O

ﬁFile Edit Control Engine Debug Chart  Subroutine Mode Tools Wiew ‘Watch  Window Help - 8 x

CBX

= I5) Cookies
I5) Control Engines
15 Subroutines Included

[#
[#
= £ Wariables
I3 Mumeric Yariables
IC5) String Wariables
IC5) Pointer Yariables
I5) Communication Hanc
5 Mumeric Tables
IC5) Stiing Tables
IC5) Pointer Tables
= £ 140 Units
= 28 Mixed_10_Unit
+ | Paints
=) PIDs

| =

Drop Dough -

< |
T T ]
% Chart /

(1) Shortcuts

ad £
@ Mext ﬁ} Prev

ﬂ’l Dough_Chip_Contral

ﬂ’l Oven_|nzpection_Control |

Name Type
Integer 32 Warisbhle 713

Digital Input

nCookieCounter
B {02} diInspectionPassFail...

State 0OH OFF

COn-Latch OFF OFF

CQff-Latch OFF OFF v
Debug UM

See “Docking Windows” on page 60 for more information.

To expand or collapse watch window you have added to an I/0O unit, PID loop, chart, or

table, click its plus or minus sign.

= Watch 2

Type
Analog Input - Deg... O

‘ {12} Tewperature...
SMAP Mixed Ultcimat...

00}p Zwitch DO Counter
{05} Sprinkl... Digital Output OFF
- {12} Tewpera... Analog Input - Deg... O

Digital Control Chart

|l

o EEX
VAL
—-272.8985

OFF
—-272.9154

To rearrange elements in the watch window list, click the item you want to move and drag it
to a new location, or right-click it and choose Move Up or Move Down from the pop-up menu.

You can also sort elements in the window by clicking on the column label. For example, to sort
by Type, click the label Type in the column heading. Click again to change the order from

ascending (A-7) to descending (Z-A).
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+  To move an element from one watch window to another, open both windows and drag the
element where you want it. To copy an element to another watch window (so it will appear in
both windows), hold down the Ctrl key while you drag it.

+ Todelete an element, right-click it and choose Delete from the pop-up menu.
+ Toinspect an element, double-click it.

The inspect dialog box opens. For information on using it, see “Inspecting Control Engines and
the Queue”on page 111.
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7: Working with Strategies

Introduction

A strategy is the software program you create in PAC Control. A strategy is similar to a file in any
Microsoft Windows program. You use standard Windows menu items to create a new strategy, to
open an existing strategy, or to save a strategy. The strategy includes all the definitions and
instructions necessary to control your process. This chapter is a step-by-step reference for working
with strategies in all three strategy modes: Configure, Debug, and Online.

In this Chapter

Creating a New Strategy........c.eeeeeressssss
Opening a Strategy...............
Saving and CloSING wocvvvveeeccenee
Saving a Strategy to Flash
Archiving Strategies on the Computer.......... 177

Compiling and Downloading ........cccccceeeeeeee, 178
Running a Strategy Manually ... 186
(D23 oTUToTo 10T OO 187
Viewing and Printing ......eceveeeooeeersscseeesne 195
Searching and Replacing .......cveeereccceeeseee 204
Legacy Options

Advanced OPLIONS .......vvveeeeeeeeereeeenssssssissseeeees 21

Creating a New Strategy

Each PAC Control strategy must be located in its own directory. When you create a new strategy, you
must create a new directory or use an empty one. Each strategy in its own directory keeps all its files
in one place and makes it easy to copy a strategy to another location for modification or backup.

1. Tocreate a new strategy, select File > New Strategy, or press Ctrl+N, or click the New Strategy
icon ' on the toolbar.

2. Inthe New Strategy dialog box, navigate to the directory where you want the strategy to be
placed. Create a new folder if necessary.

3. Type the strategy name.
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As you can see in the Files of type field, PAC Control files have an extension of .idb.
4, (lick Open.

The new strategy is created. Its Strategy Tree and Powerup charts appear in the PAC Control
main window. For information on the main window, see “PAC Control Main Window” on
page 54. For programming information, see “4: Designing Your Strategy.” For steps to create
charts, see “8: Working with Flowcharts”

Opening a Strategy

Only one strategy at a time can be open in PAC Control. If you currently have a strategy open, it must
be closed before another is opened. You are prompted to save changes before it closes.

Opening an Existing Strategy

1. Toopen an existing strategy, select File > Open Strategy, or press Ctrl+0O, or click the Open
Strategy icon = on the toolbar.
2. Inthe Open Strategy dialog box, navigate to the strategy you want to open and click Open.

The strategy opens in Configure mode, with the windows in the same position they were when
the strategy was closed.

Opening an ioControl Strategy

If you have been using ioControl Basic or Professional with a SNAP PAC controller, migration to PAC
Project Basic or Professional is simple. Because the individual programs within the suite are
essentially the same (although they have new features and hardware support), you can simply open
a strategy in PAC Control and then save it. For safety, we recommend you back up all ioProject files
before opening them in PAC Project. See also, “Opening Strategies in PAC Control” below. For more
information on migrating your system to SNAP PAC, see form 1680, the SNAP PAC System Migration
Technical Note.

Opening a Recently Used Strategy

To open a strategy you have recently used, choose its name from the list at the bottom of the File
menu. The ten most recently opened strategies are listed.

Loading a Strategy or Mode at Startup

To have PAC Control automatically start up with the strategy that was open when you exited, choose
Configure > Options and click to put a check mark next to Load Last Strategy at Startup.

To have PAC Control open strategies in the same mode as when you exited PAC Control, choose
Configure > Options and click to put a check mark next to Load Last Mode at Startup.
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CHAPTER 7: WORKING WITH STRATEGIES

Opening Strategies in PAC Control

A strategy saved in ioControl version 6.1 or less can be opened in either PAC Control Basic or
Professional. A PAC Control Basic strategy can also be opened in PAC Control Professional. However,
PAC Control Professional strategies cannot be opened in Basic or in any earlier version of

PAC Control.

CAUTION: Once a strategy is opened in PAC Control Professional, it can no longer be opened in
PAC Control Basic.

Opening an OptoControl Strategy

If you are moving a strategy from OptoControl to PAC Control Professional, PAC Control will open it
and help you convert it. Although many things will convert without difficulty, planning ahead is
essential to make the job easier. Before opening an OptoControl strategy in PAC Control, read
form 1692, the FactoryFloor to PAC Project Migration Technical Note.

Pro

Saving and Closing

CAUTION: Once a strategy is opened in PAC Control Professional, it can no longer be opened in
PAC Control Basic.

Saving the Strategy and All Charts

To save all your work quickly, choose File > Save All. The strategy and all modified charts and
subroutines are saved.

Saving the Strategy and Some Charts

NOTE: You cannot save changes to a subroutine this way. To save a subroutine, use File > Save All, or use
Subroutine > Save or Subroutine > Save All.

1. Tosave changes to some charts but not others, click the Save Strategy icon & on the toolbar
(or choose File > Save Strategy, or press Ctrl+5).
The Save Strategy dialog box appears, highlighting all charts modified since the last save.

1 5ave Strategy &|

Save strategqy and zelected charts:

Digital_Control Select Al
Clear &l

Flag_Example Chart

)8 l[ Cancel ][W]
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SAVING A STRATEGY TO FLASH

2. To save some charts and not others, press Ctrl and then click any charts you don't want to save.
You can also click Select All to select all of the charts, or click Clear All to select none of them.
3.  When only the charts you want to save are highlighted, click OK.
The strategy and the highlighted charts are saved.

Saving the Strategy to a New Name

1. Tosave the strategy and all its charts under a new name, choose File > Save Strategy As.

2. Inthe Save Strategy As dialog box, navigate to where you want the new strategy to be. Create a
new folder if necessary.

Remember that each strategy must be in its own directory.
3. Inthe Strategy Name field, enter the new strategy name. Click Save.

The strategy and all its charts are saved under the new name in the new directory.

Saving Before Debugging

When you change to Debug mode, you are prompted to save a strategy you have modified. If you
don’t want to be prompted to save before entering Debug mode, choose Configure > Options and
click to remove the check box for Prompt To Save Strategy Before Running Debugger.

Closing a Strategy
To close a strategy, click the close box in the Strategy Tree or choose File > Close Strategy.

NOTE: Since only one strategy at a time can be open in PAC Control, creating a new strategy or opening an
existing strategy automatically closes any current strategy first. If you've made changes to the current
strateqgy, you are prompted to save them.

Saving a Strategy to Flash

176

When you finish working on your strategy and have downloaded it, you should save it to the control
engine’s flash memory. By default, a strategy is downloaded to the control engine’s RAM. Saving it to
flash protects the strategy in case of a power loss. You can save it to flash just once, when needed, or
save every time the strategy is downloaded.

Saving to Flash Once

You can save the strategy to flash at any time when you are in Debug mode. To do so, choose
Control Engine > Save Strategy to Flash.
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Saving to Flash on Every Download

CAUTION: It is possible to wear out flash memory if you save to it many, many times. Use the following
steps only when your strategy is finished.

1.  When you have finished the strategy and are in Configure mode, choose File > Strategy
Options.

2. Inthe Strategy Options dialog box, click the Download tab. Check Save strategy to flash
memory after download.

Strategy Options X
Archive Download  Seral I/ Pots  Legacy

Flash Memory

[liSave strateqy to flash memory fter download:
[ 5et autorun flag after download

Background Downloading

[] Use background downloading and fast strategy updating

The controller must be corfigured for this feature using PAC Manager.

Download Compression
None Full

Start Strategy
[ Start strateqy after download completes

Cancel Help

If a control engine loses power and then restarts, the autorun flag tells the control engine to
automatically start running the strategy that is in flash memory. If the autorun flag is not set,
the strategy must be started manually after power is restored to the control engine.

3. To have the strategy run automatically after a control engine restarts, check Set autorun flag
after download.

4. C(lick OK.

Archiving Strategies on the Computer

Archiving strategies to the computer helps you track changes during development and provides a
backup in case of a failure on the control engine. Archive files are date and time stamped, and
Zipped for compact storage that you can copy to another computer or disk for backup. Archives are
always placed in the same folder as your strategy. Since a new archive file is created each time you
archive a strategy, remember to manually delete any old archive files you do not want to keep.

We recommend you archive both to the computer (during strategy development) and to the
control engine (when the strategy is completed). Archiving to the control engine as well as the
computer makes sure that an older strategy can always be found and updated, even after personnel
changes occur and years pass. See also, “Archiving Strategies on the Control Engine”on page 116.
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PAC Control offers three ways to archive strategies to the computer:

»  Tomake an archive at any time, choose File > Archive Strategy. A dialog box shows you the
name and location of the archive file.

+  To have an archive automatically created whenever the strategy is closed, choose File >
Strategy Options. In the Strategy Options dialog box, click Archive strategy to disk when
strategy is closed.

+  Tohave an archive automatically created whenever the strategy is downloaded, choose File >
Strategy Options. In the Strategy Options dialog box, click Archive strategy to disk when
strategy is downloaded.

The archive file name will be in one of the following formats:

Archive method File name format

Manual archive or archive when strategy is closed Path\Filename.Archive.D02282007.T114351.zip

Archive on download Path\Filename.Download.D02282007.T114351.zip

Archive when downloading from online mode Path\Filename.Online.D02282007.T114351.zip

The date stamp (D) is in the format mm/dd/yyyy. In the examples above, the date is February 28,
2007.The time stamp (T) is in the format hh/mm/ss. In the examples above, the time is 51 seconds
past 11:43 AM.

Compiling and Downloading

178

TIP: To configure a strategy to start running at completion of the strategy download, select the "Start
strategy after download completes" check box on the File > Strategy Options > Download tab.

Before your strategy can be tested or run, it must be compiled and then downloaded to a control
engine. When a strategy is compiled, all the commands, OptoScript code, charts, and variable and
/0 definitions it contains are verified and converted into a format that the control engine can
understand. Then the strategy can be sent (downloaded) to a control engine. Only compiled
strategies can be downloaded.

NOTE: Before you can download your strategy, make sure you have downloaded the latest firmware to
your control engine. For instructions, see the controller's user’s guide.

Compiling and Downloading in One Step

NOTE: If you are using Ethernet link redundancy in PAC Control Professional, make sure you are
downloading through the IP address you want to use, either the primary or secondary address. See “Using
Ethernet Link Redundancy in PAC Control” on page 105 for more information.

1. With the strategy open in PAC Control, click the Debug mode icon on the toolbar, or
choose Mode > Debug.

Changing to Debug mode automatically saves and compiles the strategy, including all code in
OptoScript blocks.

2. Ifyou see a Powerup Clear Expected message, click OK.
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A download warning message may appear.

Download Warning,

r\ Strategy Mismatch
- -

X

The strateaqy to be downloaded does not match the strategy already in the contral engine.
Strategy To Download

 MName: Sprinkler_Control
2 Checksum: A4DCBOCSCOECE13D7E9F123FE148EB 11
Timestamp:  07/02/03 10:56:05

Strategy in the Controller

Mame: Sprinkler_Control
Checksum:  B2FF33307FFRC2B4EATDDAACIOGAE024
Timestamp: 06430709 1253:24

If pou chooge to continue, the strategy that is in the control engine will be replaced by this strategy.

Do you want bo continue the download?

Cvee J[He J[ tee ]

This message tells you that the strategy to be downloaded doesn't match the strategy already
loaded on the control engine, either because it is a different strategy or because it has been

changed since the last download.

3. To continue the download, click Yes.

As the strategy is compiled, the Compile Progress dialog box appears. This dialog may appear
only briefly. However, if there are errors or warnings, the dialog box will stay open. You can copy
the errors and warnings by clicking the right mouse button and selecting Copy All as Text.

Compile Progress

llj,l

Compiling tags...
WARMING - Senal port 2 iz being uszed by [/0 Unit tixed 0" but has not been configured for [/0,

Compiling charts...
Condition_[elay
Corvveyer_peration
Powerup
Shipping_Area
Timer_Example_Chart

Compiling subroutines...

Building run file...

Dare.

0 error(z). 1 warningls)

< |

Frogress: (HNNNNNNNNRENRNRRNNN RN NN NN AN ANAN| Eros D

Close

ﬂ Warnings: 1

If there are errors, the strategy will not compile. Click Close to continue in Configure mode.

If there are only warnings, click Close to continue in Debug mode.
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If no errors or warnings occur, the Strategy Download dialog box appears.

A Strategy Download El
E Downloading your strateqy
Download strategy: [Illllllllllllllllllllllq

=P Store to flash memaony: [III l

The Strategy Download dialog box will vary somewhat depending on your settings.

NOTE: If you are using background downloading (see “Background Downloading” on page 182), while the
strategy is downloaded, there may be a very slight degradation in performance. This is due to the overhead
on the controller to process the strategy download.

4. (Optional) If there is already an active strategy which is set up to have an alternate strategy, and
you want to switch strategies, click Switch & Run to stop the active strategy and run the
strategy you just downloaded. Or, you can click Switch to stop the active strategy and make the
new strategy the active one (but not yet running).

Cancel aborts the new download. The controller is left as it was before the download occurs.

When the download is complete, you are in Debug mode. (If you receive errors, see “A:
Troubleshooting.”)

After switching strategies, you can switch back to the original strategy by clicking Control Engine >
Inspect in Debug mode and use the Switch and Run or Switch button in the Inspect Control Engine
dialog box, or you can use PACTerminal. When the strategy is switched back, the persistent variables
are created and compared.

Switching the Strategy

If there is already an active strategy which is set up to have an alternate strategy (as described in

“Background Downloading”on page 182), and you want to switch strategies, do the following:

1. In Debug mode, choose Control Engine > Inspect to open the Inspect Control Engine dialog
box.

2. Choose either the Switch and Run or the Switch button.

The Switch & Run button stops the active strategy and runs the strategy you just downloaded.
The Switch button stops the active strategy and makes the new strategy the active one (but
not yet running).

When the strategy is switched (as described in the previous steps), the following operations occur:

«  Persistent variables are compared. If the type and size of the persistent variable are consistent,
the contents are copied. If the type and size do not match, a new persistent variable is created.
New persistent variables are initialized to zero and new persistent strings are initialized to NULL
(empty) strings.
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+ /0 unit configurations are compared. If the I/O unit configurations match, I/0 will not be
initialized.

«  The Powerup chartis called.

See also, “Background Downloading” on page 182.

Compiling without Downloading

Sometimes you may want to compile without downloading, just to see if a chart, subroutine, or
strategy compiles correctly. You can compile the active chart or subroutine only, just the changes
you have made to the strategy, or the entire strategy.

Compiling the Active Chart or Subroutine

Whenever a chart or subroutine window is open and active, you can compile just that chart or
subroutine. To do so, in Configure mode, click the Compile Active View icon & on the toolbar, or
choose Compile > Compile the Active Chart. The menu option shows the name of the chart or
subroutine you are compiling.

As soon as you choose the menu option, the chart or subroutine is saved and compiled. You are
alerted only if errors are found.

Compiling Changes Only

To compile just the changes since the strategy was last compiled, choose Compile > Compile
Changes. The menu option shows the name of the strategy you are compiling.

As soon as you choose the menu option, the strategy and all modified charts and subroutines are
saved and compiled. You are alerted only if errors are found.

Compiling the Entire Strategy

To compile the entire strategy including all charts and subroutines, in Configure mode, click the
Compile Allicon & on the toolbar, or choose Compile > Compile All. The menu option shows the
name of the strategy you are compiling.

As soon as you choose the menu option, the entire strategy is saved and compiled. The Compile
Progress dialog box appears. You are alerted if errors are found.

Downloading Only

If your strategy has been compiled, you can download it again quickly. Downloading again is useful
if you want to run your strategy from a clean slate by reinitializing any variables that are set only on a
strategy download.

To download a strategy that has already been compiled, you must be in Debug mode. Choose
Control Engine > Download Strategy.

The Download to dialog box appears and your strategy is downloaded.

TIP: To configure a strategy to start running at completion of the strategy download, select the "Start
strateqgy after download completes” check box on the File > Strategy Options > Download tab.
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Background Downloading

The Background Downloading feature allows you to download an alternate strategy to a controller
while the active strategy currently on the controller continues to run. With two different strategies

downloaded to the controller you can switch rapidly from one strategy to the other.

This allows you to:

«  Download a new or updated strategy to the controller and then optionally run it with minimal
downtime. For larger strategies, downtime is dramatically reduced.

«  Download and test a new or updated strategy but still keep the original strategy available. You
can bring back the original very quickly, either by manually switching from one strategy to the
other, or—if the original is still burned to flash—Dby cycling power.

You can use background downloading as an alternative to Online mode, which also allows you to
make changes while a strategy is running. The following table describes the differences between
Online Mode and Background Downloading:

and edit existing charts?

Online Mode Background Downloading
Can you add variables, 1/O,
and charts? No Yes
Can you add and change
blocks, change instructions, | Yes Yes

What is downloaded in
Debug mode?

Only the edited charts are
downloaded. All other charts
keep running.

The entire alternate strategy is down-
loaded while the entire active strategy
continues to run.

Where does the strategy
restart after download?

The affected charts restart at
block 0.

If you switch to the alternate strategy after
download, the strategy restarts with the
Powerup chart.

How is the controller mem-
ory affected?

When a chart is downloaded,
the old one is not deleted, so
this consumes additional mem-
ory. To clear memory, the strat-
egy should be stopped and then
compiled and downloaded.

Controller memory is cut in half when
background download is set it in PAC
Manager. Also, one chart is used for the
alternate download port, so there is one
less chart that can run.

To enable Background Downloading:

NOTE: Controller memory is cut in half when background downloading is set in PAC Manager. Also, one
chart is used for the alternate download port, so there is one fewer chart that can run.

1. Open PAC Manager and do the following steps:

a. (lick the Inspect icon to open the Inspect window.

b. Inthe Inspect Window's IP Address field, type the IP address for the SNAP PAC controller.

c. Click Status Write, then scroll down to Strategy Download Method.

d. Click on the Value field for Strategy Download Method, select Background from the
drop-down menu, and then click Apply.

e. Under Operation Commands, highlight “Store configuration to flash,”and click Send

Command.

The configuration is stored to flash memory and a Success message appears.

For more information, see Opto 22 form 1704, the PAC Manager User’s Guide.
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2. Turn off the power to the control engine, and then turn it back on again.
In Configure mode in PAC Control, choose File > Strategy Options.

4. Inthe Download tab under Background Downloading, select “Use background downloading
and fast strategy updating.”

5. (Optional) Under Flash Memory, select “Save strategy to flash memory after download.”

6. (Optional) To have the strategy run automatically after a control engine restarts, select “Set
autorun flag after download.”

w

Strategy Options X
Archive Download  Serial 140 Ports ~ Legacy

Flash Memory

[JiSave strateqy to flash memory after download
[] 5&t autorun flag after download

Background Downloading
[] Use background downloading and fast strateqy updating
The cortraller must be corfigured for this featurs using PAC Manager.

Download Compression
Naone Full

Start Strategy
[[] Start strategy after download completes

Cancel Helo

7. C(lick OK.

PAC Control is now set to download the strategy in the background when you click the Debug
mode icon ETEM. Next, see “Compiling and Downloading” on page 178. See also, “Switching the
Strategy”on page 180.

Downloading Without Using PAC Control

If you are creating strategies for users who do not have PAC Control on their systems (for example, if
you are an integrator or OEM), you can make a control engine download file that can be
downloaded to a SNAP PAC controller by using either the graphical interface in PAC Terminal or the
command line interface with a batch file. This one download file is built for a specific control engine
but can also be downloaded to other similar control engines. It contains everything PAC Control
would download, including .per, .inc, and .crn files, control engine-specific files, and initialization
information.

In most cases you will want the downloaded strategy to be saved to flash memory and to start
automatically (autorun) when power is cycled to the control engine. Before you create the
download file, follow the steps in “Saving to Flash on Every Download”on page 177. Check the
boxes to have the strategy saved to flash memory after download and to set the autorun flag after
download. This information will become part of the download file.
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Creating the Control Engine Download (.cdf) File

With the strategy open in PAC Control in Configure mode, right-click the name of the control engine
in the Strategy Tree and choose Compile Control Engine Download File from the pop-up menu. (You
can also choose Compile > Compile Control Engine Download File.)

The file is created in the same folder as the strategy, with a .cdf extension and a file name consisting
of the strategy’s name and the control engine’s name (for example, MyStrategy.MyEngine.cdf).

Once the control engine download file is created, it can be downloaded using either the graphical
interface in PAC Terminal or the command line interface with a batch file you create.

Downloading the .cdf File using PAC Terminal

1. Start PACTerminal as follows:

— InWindows 7 and Windows Vista, press the Windows Start key H and then click
Programs > Opto 22 > PAC Project 9.6 > Tools > PAC Terminal.

— InWindows 10 and Windows 8.1, press the Windows Start key H type PAC Terminal
9.6 and then press the Enter key.

The PAC Terminal window appears.

Eile Tools Configure View Help

Control Engines:
Controller Iiame System Type Address 1 Address 2 Status cm!n Control Engines
#'Cookie Controller  Standard ¥127.0.0.1 * i %
#R1 Controller Standard v10.195.55.111 #§
Status Scan

Z scan Al

“% Scap Selected
< >

2. Right-click the name of the control engine you want to download the file to.
3. Inthe pop-up menu, choose Download > Control Engine Download File.
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4, Enter the path and file name of the .cdf file, or click the Browse button and navigate to it. When
the file name appears in the File to Download field, click OK.

The file is downloaded to the control engine.

Using Command Lines or a DOS Batch File to Perform PAC Terminal Tasks

If you do not want your end user to have to use PAC Terminal, you can use DOS-level commands or
create a DOS batch file to download a .cdf file. In addition to downloading a .cdf file, the DOS
commands can also run or stop a strategy, or define the control engine on the PC that will download
the file. PAC Terminal must be installed on the PC where the batch file is used.

The following table lists actions you may want to take within PAC Terminal:

To do this

Use this

Show help information for termcl

-h control_engine_name

Download the specified file to the specified controller.
Compression can be between 0 (none) and 10 (max).

—-d control_engine_name filename [-z compression]

Run the strategy in the specified control engine

—-I control_engine_name

Stop the strategy in the specified control engine

—S control_engine_name

Send a Forth command to the control engine

—C control_engine_name Forth_command

Add a control engine definition to the system. Does not modify an
existing definition.
Example: -a MyCE tcp 10.20.30.40 22001 0 2000

—a control_engine_name tcp ip-addr port retries timeout_ms

Download the encrypted SSD file to the controller

—-dp control_engine_name ssd_filename

Prevent response messages from printing to the DOS screen

Append the DOS switch —q

This example shows lines included in a batch file that will define the control engine, download the

cdf file to it, and then run the strategy:

termcl -a MyCE tcp 10.20.30.40 22001 0 2000
termcl -d MyCE "c:\My_Project\MyStrategy.MyCE.CDF"

termcl -r MyCE

Changing Download Compression

If you have a very large strategy, short timeouts, and slow connections on your network, you may
need to decrease the compression level to download the strategy successfully. When you decrease
compression, the strategy takes longer to download because it is sent in smaller chunks. If you are
having difficulty downloading your strategy, follow these steps to decrease compression:

1. With the strategy open in Configure mode, choose File > Strategy Options.
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2. Inthe Strategy Options dialog box, click the Download tab.

Strategy Options X
Archive Download  Seral /O Ports  Legacy

Flash Memony
[[] 5ave strategy to flash memory after download
[] Set autorun flag after download

Background Downloading

[] Use background downloading and fast strategy updating

The controller must be configured for this feature using PAC Manager.

Download Compression
Mone Full

. Slider

Start Strategy
[] Start strateqy after download completes

Concal | [P

3. Move the slider to the left to reduce compression, and then click OK.
You may need to experiment with the setting until the strategy downloads successfully.

Running a Strategy Manually

1. With the strategy open, choose Mode > Debug.
2, (lickthe Run Strategy icon p  (or press F5, or select Debug > Run).

You can also run a strategy from the Inspecting dialog box. See “Inspecting Control Engines in
Debug Mode”on page 111.

Running a Strategy Automatically (Autorun)

You can set the strategy to run automatically (autorun) if the control engine loses power and then
restarts. In traditional Opto 22 controllers, the OptoControl autorun function was controlled by a
jumper. For PAC Control, it's controlled by the autorun flag. If the autorun flag is not set, the strategy
must be started manually after power is restored to the control engine. The strategy must be saved
in flash memory for autorun to work.

You can set the autorun flag in two ways:

»  In Configure mode, save the strategy to flash memory and set the autorun flag every time the
strategy is downloaded. (Be careful you do not save to flash too often, as flash memory
eventually wears out.) See “Saving to Flash on Every Download”on page 177.
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+  In Debug mode, save the strategy to flash memory by choosing Control Engine > Save
Strategy to Flash. Then right-click the control engine in the Strategy Tree and choose Inspect
from the pop-up menu. In the Inspect dialog box, enable Autorun. (See “Inspecting Control
Engines and the Queue”on page 111 for more on the Inspect dialog box.)

Protecting a Running Strategy

If you want a strategy to run automatically without interruption, you can protect the strategy by
disabling all host communications to the control engine.

To protect the strategy, first make sure the strategy is saved to flash and that the autorun flag is set.
To disable host communication, open PAC Manager and set the Control Engine port to 0, and then
save that change to flash. For more information on setting this port, see Opto 22 form 1704, the PAC
Manager User's Guide.

NOTE: This action also disables communication between PAC Display and the control engine.

Stopping a Strategy

To stop the strategy, click the Stop Strategy icon m (or press F3, or select Debug > Stop). You can
also stop a strategy from the Inspecting dialog box; see “Inspecting Control Engines in Debug
Mode”"on page 111.

Debugging

Once the strategy is running, if it doesn't appear to be working correctly, you can use several tools in
Debug mode to figure out what the problem is. You can pause a chart or subroutine; step into, over,
or out of each block; watch it slowly step through the blocks; or add a breakpoint to a block to stop
the strategy just before it executes that block.

The chart’s or subroutine’s status is shown in the lower left-hand corner of its window. This corner
shows whether the chart or subroutine is running, stopped, or suspended, and whether the
debugging tools, such as stepping and breakpoints, are in effect. The chart or subroutine must be
running in order to use these tools.

Choosing Debug Level

You can choose one of two levels of debugging:

«  Minimal Debug lets you step from block to block, but does not allow you to step into blocks.
Less information is downloaded to the control engine for minimal debugging, so downloading
the strategy takes less time and less control engine memory. The strategy also runs slightly
faster.

«  Full Debug lets you step into blocks, so you can step through each instruction in an Action or
condition block and through each line of OptoScript code in an OptoScript block. If you are
using OptoScript, you will probably want to spend the additional time to download your
strategy at the full debug level.
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To change debug level, make sure you are in Configure mode. From the Configure menu, choose
Minimal Debug or Full Debug. The next time you enter Debug mode, the strategy will be compiled
and downloaded with the new level.

Changing Debugger Speed

Before you enter Debug mode, you may want to consider changing debugger speed. Depending on
the number of charts and windows open in PAC Control, and depending on other processing your
computer is doing at the same time, you may find that running the debugger affects the computer’s
or the control engine’s performance of other tasks. If necessary, you can slow down the debugger by
increasing the time delay between debugging calls to the control engine, therefore leaving more
processing time for other tasks.

In addition, a slower setting may be useful when checking communication using PAC Message Viewer
(see page 384)).

To change debugger speed, follow these steps:

1. With the strategy in Configure mode, choose Configure > Options. Alternatively, in Debug
mode, choose Debug > Options.

2. Inthe PAC Control Options dialog box, click the Debugger tab.

| PAC Control Options X

Workspace Debugger Advanced

Debugger Peformance
Hi Low

When stepping, make sure the active block is visible

Prompt before starting or stopping a strategy

Cancel Help

3. (lickand drag the slider to the speed you want.

The default speed is shown in the figure above. Since performance varies depending on your
hardware and software, you may need to experiment to find the most efficient speed.

If you don't want the debugger to follow auto stepping, deselect “When stepping, make sure the
active block is visible.”

Pausing a Chart or Subroutine

You can temporarily stop any running chart or subroutine by pausing it. When you pause a chart or
subroutine, it finishes the instruction it was executing, then stops at the next block (in Minimal
Debug) or the next line (in Full Debug).

To pause the chart or subroutine in the active window, click the Pause Chart or Pause Subroutine
icon ', or press F7, or select Debug > Pause Chart or Debug > Pause Subroutine.
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Here's an example of a paused chart:

= Powerup

This chart starts the program and all other charts.

0
Start Program

Wait until start flag is set
F | true (non-zero).

[ Start the alarm monitoring,
Start Charts dough/chip control, pressure

control, and oven/inspection
charts.

v

< >
[ oneee T o on Jovor o Jroso 7o s
% Chart /

Status bar—Step On —]

Hatch marks and a red outline appear on the Start block, indicating that this block is to be executed
next. The status bar shows Step On, which means you can step through the chart or subroutine if
you wish.

Stepping Through a Chart or Subroutine

When you step through a chart or subroutine, you control the timing and execution of its
commands in a running strategy. You can see what commands are being executed when, and you
can monitor the status of variables and I/0 that are affected by the commands.

There are two types of stepping: single-stepping and automatic stepping. Use single stepping to go
through flowchart blocks at your own pace. Use auto stepping to watch the flowchart step
automatically.

CAUTION: Since stepping through a running chart or subroutine—even auto stepping—slows down
execution, be cautious if your strategy is running on real equipment. For example, stepping through a
strategy might leave a valve open much longer than it should be.

Single Stepping

When you are debugging a strategy, start by using the Step Over icon to go through a chart one
block at a time. The Step Over icon may be all you need to find any problems. If necessary, go back
to Configure mode and change to full debug (see “Choosing Debug Level”on page 187) so you can
step into blocks and execute one line at a time.

1. Pause the chart or subroutine to be stepped through by pressing the Pause Chart or Pause

Subroutine icon I .

2. Tostep to the next command block, click the Step Overicon I (or press F10, or select Debug
> Step Over).

The commands in the highlighted block are executed, the hatch marks move to the next
command block, and the chart pauses again. Compare the chart below to the one on
page 188.
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The hatch mark has moved to the next block.

= Dough_Chip_Control

runs
sly once the
as been started.

H Speed OK?

Drop the dough. =
rop Dough:
7 Drop the chips.
Drop Chips
T s
£ | >

(LA T Ghart /

If you need to step inside flowchart blocks and move through them one command at a time (or
in OptoScript blocks, one line of code at a time), make sure you have downloaded your strategy
at the full debug level. See “Choosing Debug Level” on page 187 for help.

If the chart or subroutine is not already paused, press the Pause Chart or Pause Subroutine icon
m.

To step inside the block you are on (the one with the hatch marks), click the Step Into icon ™
(or press F11, or select Debug > Step Into).

The Step Into button takes you inside the current block,
s0 you can step one command at a time.

The red arrow indicates the command

— 10_Enabler_Chart .
that will be executed next.

- Initialization :

_ 10_Enabler_Chart (=13

A

// Check pointer table slement to =es
if (ptIQ UThits[nI0 Enablerlndex] == nu.

7 Ho I-0 unit iz loaded in the ptI0
ntI0 UnitCommEnableStatus[nl0 Enable:

elze - IO Unit pointer i= walid at th:
HumberToString{nl0 EnablerIndex, =I0_

s et pointer to IO Unit
pld TnitEnetPAC = ptI0 Units[nlI0 Enat

## Check to se= if the usser wants tl
1f (ntI0_UnitUserDisable[nI0_Enabler:

A F A TaTallma + T AmmFnahlad f#n T TTes # B

>

L[]

| i Cormand Help L 8, Col1

hatt /4 OptoScript Block - "10 EnablerfiEnet & PAC™ - Id #2 /_

The small gray tabs at the left The white tab shows you where
of the white tab show how you are:inside a chart, a block, ora
you got to where you are. subroutine called by a chart.
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6. Tomove from line to line, click either the Step Into or the Step Over icon.
If a command within the block calls a subroutine, Step Into takes you into the subroutine. Step
Over skips over the subroutine.

7. Tostep from a command inside a block and go to the next block, click Step Out I .

Clicking Step Out when you are on a block, rather than inside it, causes the chart to resume. In
a subroutine, clicking Step Out takes you out of the subroutine.

Auto Stepping

Auto stepping lets you watch a chart’s or a subroutine’s logic in slow motion, one block at a time. A
chart or subroutine does not have to be paused before auto stepping can begin. To begin auto
stepping, click the Auto Step icon ¥, press F8, or select Debug > Auto Step Chart.

Step Auto appears in the status bar. The hatch marks move from block to block as each block’s
commands are executed. When you reach a block whose code is currently being executed, the
highlight around the block becomes changing shades of green instead of solid red (unless the block
is executed very quickly).

A chart that contains flow-through logic stops when it has been stepped through. In a chart that
contains loop logic, the auto stepping continues until you stop it by pressing the Auto Step icon
again.

Setting and Removing Breakpoints

Sometimes you want to see the action at one or two blocks without having to step through an
entire chart or subroutine. You can use a breakpoint to stop a running chart or subroutine just
before a block is executed.

You can set a breakpoint at any block in any chart or subroutine, whether it is running or stopped,
paused or auto stepped. The strategy does not need to be running. You can set up to 16 breakpoints
in one chart or subroutine.

You can also set a breakpoint inside an OptoScript block, but not inside other types of blocks.
To set a breakpoint, follow these steps:
1. With the chart or subroutine open and in Debug mode, click the Breakpoint tool % .

The pointer turns into a hand.
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192

2. To seta breakpoint on a block, click the target block to mark it with the breakpoint hand.

E-21UF
-
T
W
£l
Stop Charts
Stop all control charts and
* set all devices to a known
7 state.
Breakpoint hand B SetElMices =
Stop
Conveyor

When all alarms are clear,
restart system by starting
Powerup chart.

< >
T I I T -
[ 412 1>\ Chart /

F Powerup F Dough_Chi...
— -

f:':IDough_Ves...ﬁOven_lnsp... % Alamms I
INFO Debug

A red square appears around the block and Break On appears in the status bar.

Break On in status bar —|

T Ty P

Stop all control charts and
set all devices to a known
B state.

Red square Set Devices

When all alarms are clear,
restart system by starting
Powerup chart.

L

£ >
[ s [ stcoor Jocnkon |_oamosec [0
(L4 2] Chart /

F  Powerup F Dough_Chi...
— =

%Dough_‘u’es... %O\ren_lnsp... % Alarms

INFO Debug

To set a breakpoint within an OptoScript block:
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With the Select tool, double-click the block to open it.

In the PAC Control toolbar, select the Breakpoint tool, place the palm of the breakpoint
hand over the line of code where you want the chart to stop, and then click the left
mouse button.
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A red dot marks the breakpoint. The chart will stop running before executing the marked
line of code.

Note that in an OptoScript block, you can set breakpoints only on lines of code—you can't
set a breakpoint on a comment or within a comment block.

f OptoScript - Alarms - Stop Conveyor - Block 36 *

OptoScript Code:

< Ramp s=peed of conveyor to 0%, This is done by changing ac
s =mall increments over a 20 =s=econd period.

s Calculate the =mall increment= of change to acConwveyorSpe
fRampValue = (0.0 - aocConveyorSpesedControl) »~ 20.0;

Breakpoint set at this ;
s Loop twenty times

line of code —|® M for nloopCounter = 1 to 20 step 1
s Adjust aoConveyorSpesdControl
aoConveyorSpeedControl = aoConveyorSpeedControl + fRampVal

s Delay for one =s=econd
DelaySec(1.0):
next

<7 Wake sure aoConveyorSpesdControl is at exactly 0.0
aoConveyorSpeedControl = 0.0;

< >

Close Help Command Help Ln g, Col 2

3. (lick other blocks or OptoScript lines to set additional breakpoints, or click blocks or lines
currently marked with a hand to remove the breakpoint. (Make sure that the palm of the
breakpoint hand is directly over the line you want to select.)

4. When you have finished marking or removing breakpoints, click the Breakpoint icon again or
click the right mouse button within the window.

When the chart or subroutine runs, it pauses just before executing the breakpoint block or line.
You can inspect variables or I/0 points, disable strategy elements, change values, and so on to
see the effect the block has.

5. Tosingle step past the breakpoint, click the Step Block or Step Line button. Or to run the chart
or subroutine at full speed after the breakpoint, click the Pause Chart icon.

Managing Multiple Breakpoints

You can see all the breakpoints you have set, and you can remove breakpoints one at a time or all at
once. See also, “Setting and Removing Breakpoints”on page 191 to use the breakpoint tool.

1. Press Ctrl+B or click Debug > Breakpoints.
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The Breakpoints dialog box appears, showing all the breakpoints set in the strategy.

& Breakpoints X
Chart/Sub Name  Block ID Blodk Name Block Type Remove
Alarms 36 Stop Conveyor OptoScript Remove Al
Alarms 2 Set Devices Action

Concel | |t

2. Todelete a breakpoint, highlight it and click Remove. To delete all breakpoints in the strategy at
once, click Remove All.

3.  When you have finished making changes, click OK.

Interpreting Elapsed Times

As you debug your strategy, you may notice elapsed time readings appearing in a chart's or
subroutine’s status bar, as shown below.

= Sprinklers fg

- =
urns on the [0 ,
00 am. Block0 -
day and
dersstay 3
. Wait 60 sec

10 .
Wait 24 hrs |4 -
Read
Hygrometer
. . |Turn on sprinklers, 1Jl'urn off sprinklers i B Elapsed time
< B | >
[ Running |[ Step 0n ][ Break 0ff [[14180.050 5 [l e SN ETRN
% Chart /
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Elapsed time readings can help you determine how much time a chart, a subroutine, or a single
block takes to execute. The readings have slightly different meanings depending on what you did to
make them appear, as described in the table below:

Whenyou. .. Elapsed time represents . . .

Run a chart or subroutine and Time since the chart or subroutine started or was last paused

pause it
Single step (by line or block) Time to execute the previous block
Auto step Time to execute the most recently executed block

Time since the last pause, or if the chart or subroutine was not

Hit a breakpoint paused, elapsed time since it started running

Viewing and Printing
You can view and print several helpful things in a strategy as described in the following topics:
«  "Viewing Strategy Filename and Path” (below)
«  "Viewing an Individual Chart or Subroutine”on page 195
«  "Viewing All Charts in a Strategy” on page 196
«  "Printing Chart or Subroutine Graphics”on page 197
«  "Viewing and Printing Strategy or Subroutine Commands”on page 199
«  "Viewing and Printing Strategy or Subroutine Elements”on page 200
+  “Viewing and Printing a Cross Reference”on page 202
«  "Viewing and Printing a Bill of Materials” on page 202
«  "Viewing and Printing I/0 Point Mappings”on page 203

For information on viewing and changing I/0 units, see “Inspecting I/0 in Debug Mode”on
page 152. For variables, see “Viewing Variables in Debug Mode” on page 242.

Viewing Strategy Filename and Path

To see an open strategy’s file name and path, choose File > Strategy Information. A dialog box
appears showing the path and file name.

Viewing an Individual Chart or Subroutine

To view an individual chart or subroutine, double-click its name on the Strategy Tree, or choose
Chart > Open or Subroutine > Open. You can open as many of these windows as you need. The
names of open windows appear on tabs at the bottom of the PAC Control main window. Click a tab
to bring its window into view.
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Viewing All Charts in a Strategy

You can see the status of all charts at once and change a chart’s status without having to open it.

1. Make sure the strategy is open and in Debug mode. On the Strategy Tree, double-click the
Charts folder.

The View Chart Status dialog box appears, showing every chart in the strategy:

3% View Chart Status

M ame Status tode Breakpoint Status Paugzed At
Digital_Cotitral Rurning Step Off Break Off

Flag_Example_Chart  Stopped Step Off Break Off

Powerup Stopped Step Off Break Off

Sample Stopped Step Off Break Off

Simple_Ernar_Handli... Stopped Step OFf Break Off

Sprinklers Fiurning Step On Break Off Turn off zprinklers
Timer_Example_Chart Stopped Step Off Break Off

2. Tochange the status of a chart, double-click the chart name.

The View Chart dialog box appears, showing the chart name, chart status, run mode, and
breakpoint status. If the chart is paused (mode is Step On), the block at which it is paused is
shown in the Paused At field. In the figure below, the chart is not paused:

£ "Alarms” - View Chart (scanning) |:||z,&|

Chart: lag_Example Cl |
Status: Stopped £ Mode:|Step Off % | Breakpoints: |Break OfF 3
Pauzed At: | |

T e [

The title bar shows whether scanning is occurring. Scanning stops when you click one of the
changeable fields (Status, Mode, and Breakpoints) and resumes once you click Apply, another
button, or one of the other fields. If scanning resumes before you click Apply, any changes you
made are lost.

3. Tostop, run, or suspend a chart, click an arrow in the Status field to select the option. Click
Apply.

4., Toturn pausing on or off, click an arrow in the Mode field to select Step On or Step Off. Click
Apply.

5. Toobserve orignore any breakpoints set in the chart, click an arrow in the Breakpoints field to
select Break On or Break Off. Click Apply.
This action does not clear or set breakpoints, but just determines whether the chart stops at
breakpoints when it is running.

Chart changes occur as soon as you click Apply.
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6. Toadd the chart to a watch window so you can monitor it with other strategy elements, click
Add Watch. In the dialog box, choose what to watch. Select an existing watch window to add
this chart to, or create a new watch window.

See “Using Watch Windows for Monitoring”on page 168 for more information on watch
windows.

7. When you have finished making changes, click Close to return to the View Chart Status dialog
box.

Printing Chart or Subroutine Graphics

You can print a chart or subroutine just as it appears on screen. You can also print all charts within a
strategy. When printing a single chart or subroutine, you can preview the image to make sure it's
what you want before you print it.

NOTE: If you have trouble printing graphics, set your printer for PostScript emulation.

Setting Up the Page

Before printing graphics, you should verify your page setup, which determines how each graphic
appears on a page.

1. In Configure mode, select File > Page Setup.

The Page Setup dialog box appears.

1 Flowchart Graphics - Page Setup

Graphics Scaling

() fdiust ta % normnal size
() Fit to I:l

Fage
Frint Header

[ 0K ][ Cancel ] [ Help ]

2. Inthe Graphics Scaling area, choose whether you want each flowchart to print at a fixed
percentage of normal size or to span a specific number of pages.

— To print at a fixed percentage, click the Adjust To option and specify any scaling from one
percent to 1,000 percent.
You can type in a number or click the arrows to go up or down to the next increment of 25
percent. Typically, percentages between 50 percent and 200 percent work the best.

- To print to a specific number of pages, click the Fit To option and select the number of
pages wide and tall you would like each chart to print.

If you choose one for each dimension, each chart prints to a single page. For each
dimension, you can specify any integer between one and 255, but be careful. Selecting
values of five and five, for example, would cause each chart to print five pages wide and
five pages long, a total of 25 pages.

3. (Recommended) To print a header on each page, put a check mark in the Print Header box.
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The header lists the strategy name, chart or subroutine name, date and time of printing, page
number, and column and row of the page with respect to the full chart printout.

4. C(lick OK to save your settings.

Previewing a Flowchart Printout

1. To see how a chart or subroutine will print before actually printing it, open the chart or
subroutine window.

2. From the Chart or Subroutine menu, select Print Preview Graphics.

The preview window appears, showing the image as it will print. The cursor becomes a
magnifying glass.

APAC Control Professional - [Dough_Vessel Pressure_Control] = |[B][%
r S
Hext Page | | Prew Page | | Two Page Zoam Dut

S — o— Magnifying glass cursor

The Powsrup chart arts  [F
e enart.

Thischartruns
eontinuously oncs the
Caicutats i curment program hai been iisrted.
T 4iUre satpointminu 1
e deadband.

“When pra1aure |§ graater
han ar equal to setpaint,
closs e preaiure valve.

‘When prataure 1 lens than
he setpointminus the &
deadband, open the
previure valve.

Page 1 Corfigure

3. Tozoom in at 200 percent, click where you want to see more closely. Click again to zoom in at
400 percent. Click a third time to return to 100 percent view.

You can also use the Zoom In and Zoom Qut buttons at the top of the window to zoom in or
out with respect to the top left corner of the image.

4. [ftheimage spans more than one page, click the Next Page or Prev Page buttons to view the
next or previous page. To switch between a single-page view and a double-page view, click
the Two Page/One Page button.

5. Toprint, click the Printicon to open the standard Windows Print dialog box. To change settings
before printing, click Close and see “Setting Up the Page”on page 197.
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Printing One Chart or Subroutine

1. To print one chart or subroutine, open its window.
2. From the Chart or Subroutine menu, select Print Graphics.
3. Inthe standard Windows Print dialog box, do one of the following:

- To print to a printer, select the printer, page range, and number of copies. Click OK.

- To print to afile, select Print to file and click OK. In the dialog box, type the file name and
location.

Printing All Charts in a Strategy

CAUTION: You can print all charts included in a strategy, but be sure that's what you want to do before
you begin. You cannot cancel once printing has started.
1. To printall charts within a strategy, open the strategy and check the page setup.
For help, see “Setting Up the Page”on page 197.
2. Select File > Print All Graphics.

Printing begins immediately; no Print dialog box appears. Messages inform you of each chart’s
printing progress. To skip printing a particular chart, click Cancel when its message appears.

Viewing and Printing Strategy or Subroutine Commands

You must be in Configure mode to view and print commands.

1. Toview all commands (instructions) in a chart or subroutine, open its window and select
View/Print Instructions from the Chart or Subroutine menu. Choose whether to sort
instructions by block name or block ID number.

2. Toview allinstructions in an entire strategy, select File > View/Print > All Chart Instructions.

NOTE: Subroutine instructions are not included; you can print them separately.
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PAC Control processes the information and displays it in the Instructions window.

Save  Search

B Copkies - All Chart Instructions

HS #

|l.l‘ITLE: Elock Instructions for Every Chart e
STRATEGY: Cockies
DATE: 02705710 TIME: 10:359:55

CHART: Alarms
RCTIONS

Action Block: Powerup (Id: 25)
Exit to: Goto Start (Id: 28)

Restart Powerup chart. This will get system going again.
Start Chart

Chart Powerup

Iut Status In nChartStatus

Action Block: 3Zet Devices (Id: Z)
Exit to: Ztop Conveyor (Id: 36)

Lower oven tempereture while conveyor is siopped.
Hovre

From Z00.0

To aolvenTenperatureControl

Close all valves.
Turn O£f

AnMhinhi snancsalfalra
=

You may need to resize the window and use the scroll bar to see all the data. Blocks and their
instructions are listed in alphabetical or ID number order by type of block: action blocks first,
then OptoScript blocks, then condition blocks, and finally continue blocks.

3. To print the data, click the Print icon on the toolbar. To save it to a text file, click the Save icon. To
search the data, click the Search icon. When finished, close the window.

Viewing and Printing Strategy or Subroutine Elements

You must be in Configure mode.

1. Toview a summary of I/0 elements and variables configured in a strategy, select File >
View/Print > Database.

2. Toview the same summary for a subroutine, open the subroutine window and select
Subroutine > View/Print > Database.
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The View/Print Database dialog box appears.

View/Print Database

Include

Mumeric Yariables Mumeric Tables

Stiing Variables Stiing Tables

Fointer Y ariables Fointer Tables

1/0 Uniks & Paints Communication Handles

FID Loops Event/Reactions
[ Descriptions
I Ok ] [ Cancel ] [ Help ]

Make sure all element types you want to include are checked. Click to uncheck any elements
you do not want.

To include descriptive comments associated with the elements, click to put a check mark next
to Descriptions.

Click OK.

PAC Control processes the database and puts the data in the Database window.

Save Search

Print
B Sprinkler_Control - Database |.- ||I:I||
HES &
h‘ITLE: Strategy Database 5
STRATEGY: Sprinkler Control
DATE: 02/21/04 TIME: 1Z2:45:44
NUMERIC VARIAELES
NAME TYPE INIT. VALUVE EEE. COUNT
Day_of_the Week INT UN 0 4
Packer_ Busy INT RUN o 3
Status INT RUN o 3
Eum INT UN 0 o]
Timer DN TIMER RUN Z
COMMUNICATION HANDLES
NAME TYPE INIT. YALUE REF. COUNT
UI0_East RN 1l0z4 o
v

You may need to resize the window and use the scroll bar to see all the data. For each element
the name and reference count (that is, how many times the element is used in strategy
commands) are shown, plus other information depending on the element type. The figure
above shows numeric variables and communication handles.
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6. To print the data, click the Print icon on the toolbar. To save it to a text file, click the Save icon. To
search the data, click the Search icon. When finished, close the window.

Viewing and Printing a Cross Reference

You can view and print a report of every operand in your strategy or subroutine—charts, 1/0 units,
analog points, digital points, communication handles, numeric variables, string variables, pointer
variables, numeric tables, string tables, and pointer tables. The operands are cross-referenced to the
charts, blocks, and instructions in which they are used.

1. To produce a cross reference for a strategy, open it and select File > View/Print > Cross
Reference.

2. Toview asimilar report for a subroutine, open the subroutine window and select Subroutine >
View/Print > Cross Reference.

PAC Control processes the data and puts it in the Cross Reference window.

Save Search

B Spiinkler_Control - Cross Reference

HES #

TITLE: Strategy Cross References b
STRATEGY : Unit 3 Monitoring
DATE: 10/05/06 TIME: 14:47:Z0

CHARTS

Interrupt - Mot referenced.
Morning
Chart Referenced Elock Referenced Instruction
Powerup Start Charts Start Chart
Powerup - Not referenced.

ANALOG POINTS
Refrigeration

Chart Referenced Elock Referenced Instruction

Morning Check refrigeration Line #32
Morning Check refrigeration Line #11
Morning Check refrigeration Line #11

You may need to resize the window and use the scroll bar to see all the data. Notice that the
Instruction column (at right) shows the line number the operand appears in when it is in
OptoScript code.

3. To print the data, click the Print icon on the toolbar. To save it to a text file, click the Save icon. To
search the data, click the Search icon. When finished, close the window.

Viewing and Printing a Bill of Materials

You can view and print a bill of materials (BOM) that lists all the I/O units and /O modules (analog
and standard digital) required to run the strategy. (Special-purpose modules, such as serial and
high-density digital modules, are not included in the BOM.)
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1. To produce a BOM for a strategy, open it and select File > View/Print > Bill of Materials.

PAC Control processes the data and puts it in the Bill of Materials window.

Save . Search

B Coukies - Bill of Materials

TITLE: Eill of Materials
STRATEGY: Cookies
DATE: 0Z/1E5/05 TIME: 11:15:132

Brains
1 GENAP Mixed Ultimate I/0 (SNAP-UP1-ADE)

Digital Input Modules
1 SMNAP-IDCED: Z.5 - 28 VDC

Digital Output Modules
1 SMNAP-ODCESSRC: 5 - &0 VDC Source

hnalog Input Modules
1 ENAP-AICTD
1 ENAP-AIV

hnalog Output Modules
1 GENAP-AOV-Z7

Totals
Total Brains: 1
Total Modules: &

NOTE: Controllers, power supplies, and mounting racks are not specified.
Contact your local distributor or Opto ZZ for help or to purchase products.

You may need to resize the window and use the scroll bar to see all the data.

2. To print the data, click the Printicon on the toolbar. To save it to a text file, click the Save icon. To
search the data, click the Search icon. When finished, close the window.

Viewing and Printing /0 Point Mappings

You can view and print a report that shows the location and mappings of 1/0 points. You can use
this report as a look-up table for programming purposes. This can be useful with some commands
that use different point mappings such as Move 1/0 Unit to Numeric Table Ex, Move Numeric Table

to I/0 Unit Ex, and IVAL Move Numeric Table to I/O Unit Ex.

This report basically provides the same information provided in “Table Index Offset Examples,”
in form 1701, the PAC Control Command Reference, but for the actual points in the strategy.
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1. To produce an I/O point mappings report for a strategy, open the strategy and select File >
View/Print > 1/0 Point Mappings.

View/Print I/0 Point Mappings

This report shows where all the configured points are located on modules and
how they map out to various point mappings. Thiz can be useful with zome
commands that use different point mappings. like "Move 140 Unit to Numernc
Table Ex".

Report Style: (8 Formatted () Commarseparated

Options
todule Positions 4-channel mappings 1B-channel mappings
Channel Positions 8-channel mappings 32-channel mappings

| oK |[ Cancel ]

On the View/Print I/0 Point Mappings dialog box, select the report style, either Formatted or
Comma-separated, and select the position and mappings types, then click OK. A report
window appears.

B Cookies - Point Mappings

HES#n

TITLE: I/0 Point Mappings s
STEATEGY: Coockies
DATE: 04707702 TIME: 1Z:3&6:50

Point mappings for I/0 Unit "Mixzed I0 Unit":

I/0 POINTS MO CH 4 g 1e 3z
diDoughLietrel Strit el s e il S D i e D s a a a a a o
di Ehip el St R it s (X [ M A e e u} 1 1 1 1 1
diInspectionPassFaillwitch a Z Z Z Z Z
= i s i u} 2 2 2 2 2
doDoughPressureControlWal 1 a £ a 1& 3z
doDoughDispenseWalwe. .. .. . 1 1 13 2 17 a3
deChipPispenselaliye b i oo i gt B e 2 1 Z & 10 1s a4
doRejectVWalwe. ..o 1 3 7 11 13 <1
aolvenTenperatureControl. ... . ... ... ... . ... b a a 1& 3E a4
aoConveyorSpeedControl. oo ... . ... ... Z 1 2 17 a3 &5
Al0TenTemper AEUE B i i £ it i rh G e s 3 o 1z 24 43 26
aiboughWessel Pressure. . ... ...t i i £ o1& 3E 64 1E8

T e T

What the columns mean:

Column Description

MOD The module number on the rack

CH The channel number within the module
4 4-channel mapping

8 8-channel mapping

Searching and Replacing

You can search a chart, subroutine, or strategy for missing connections, empty condition blocks, or
any command or operand. An operand is anything that can be affected by a command, including
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charts, I/0 units, analog points, digital points, and all kinds of variables. Searching includes
OptoScript code within OptoScript blocks.

You can also replace instructions or operands with similar items.

Searching

You can search a strategy or one of its charts, or you can search a subroutine.
1. Open the strategy or subroutine and select Edit > Find.

The Find dialog box appears.

Search Scope

Find

7 Lacal

Search Far
(&) Operand () Instrustion () Missing Connections ) Empty Cond, Blocks

(o)

Tvpe: M arme: Help

I Crigital Quatput v_| | doR ejecty alve w |

Or, if the item you want to find is listed in the strategy tree, such as a variable, table, or point,
right-click the item and select either Find in the pop-up menu.

= 1) Paints
‘ HH diDoughLevelSwitch
Point name .

Madify...
Configure. ..
Delete

T dilmspectionPassh
T GiEStop
8 doDoughPressure

DL_"," doDoughDizpens
308 JoChipDispensey’ Replace, @

The item appears in the Find or dialog box automatically.

2. Under Search Scope, to search the entire strategy, click Global. To search one chart only, click
Local and choose the chart name from the drop-down list.

If you are searching a subroutine, the search is Local and the subroutine’s name is shown.
3. Under Search For, choose one of the following:

- Tosearch fora chart, an I/O unit or point, or a variable, click Operand. In the Type and Name
fields, choose the operand you want from the drop-down list.

- To search for an instruction, click Instruction. Click Action or Condition, and choose the
instruction you want from the drop-down list.

- To search for blocks that are not connected to other blocks, click Missing Connections.

— To search for condition blocks that have no instructions, click Empty Cond. Blocks.
4. C(lick Find.
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The dialog box expands and the search results appear at the bottom.

Search Scope
Find
i o
Ol:oc:al aital_Cantro Stop
Search For Erint
(O Operand (3 Instruction () Mizsing Connections () Empty Cond. Blocks
@ Action () Condition
Instruction: Help
!Delay [m5ec] v i [ Select... I
Chart Block Marne Block ID Command
Flag_E=ample_Chart Delay 1 mzec 5 Delay [mSec]
Simple_Emor_Handling_C... Delay 100 mzec 9 Delay [mSec] - Search
2 ocourrence(s] found.
results

For more information on any item in the search results, try double-clicking the item.

5. To save the search results to a file or to print them, click Print. In the window that opens, click
the Save icon to save or the Print icon to print your search results.

6. When you have finished your search, close the Find dialog box.

Replacing

You can also replace any operand, instruction, or tag with a similar item. As in searching, you can
replace items in a strategy or one of its charts, or you can replace items in a subroutine.

1. Open the strategy or subroutine, and select Edit > Replace.

The Find and Replace dialog box appears.

1 Find and Replace
Search Scope
@&
Beplace
o
Replace All
Search For
©
(O Instruction
1 Help
O
Tvpe: Mame:
Fird wihat: |»’-‘«II Valid Types w | |aiDough\-’esselF‘ressure w |
Replace with: |AII Walid Types “ | |aiDough\-’esselF‘ressure - |
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Or, if the item you want to find is listed in the strategy tree, such as a variable, table, or point,
right-click the item and select Replace in the pop-up menu.

= ) Paints
diDoughlLewelSwitch
diChipLe teh
dilnspectionPazsF
diEStop
doDoughPressure

Point name ——

doDoughDizpense
doChipDizpenset|

1 Find and Replace

Modify,
Configure...
Delete

Find...

Search Scope
(#) Global
Replace
Fits
Replace All
Search Far
© Operand
) Instruction
Help
e [ Hee |
Type: I anne:
Findwhat: | Digital Input + | |diChipLevelSwitch v|
Replace with: |A|| Valid Types v | |ai1 6 Fht v |
Point name

Under Search Scope, to search the entire strategy, click Global. To search one chart only, click
Local and choose the chart name from the drop-down list.

If you are searching a subroutine, the search is Local and the subroutine’s name is shown.

Under Search For, choose one of the following:

To search for a chart, an 1/0 unit or point, or a variable, click Operand. In the Find Type and
Name fields, choose the operand you want to replace from the drop-down list. In the
Replace With Type and Name fields, choose the operand you want to use instead.

To search for an instruction, click Instruction. Click Action or Condition, and choose the
instruction you want to replace from the Find drop-down list. In the Replace With
drop-down list, choose the instruction you want to use instead.

To search for a substring within tag names, click Tag. In the “Find what”text box under
Substrings, enter the substring you want to replace. In the “Replace with" text box, enter
the replacement text. For example, if you have several tag names that contain the
substring, “Generic,” such as nGenericCount, fGenericTemperature, and diGenericlnput, you
could replace “Generic”with “Station1,”and the tagnames would become nStation1Count,
fStation1Temperature, and diStation1input.

Click Find Next.
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When the first occurrence of the operand or instruction is found, the Instructions dialog box it
appears in is displayed.
5. Toreplace this occurrence, click Replace. To skip it and find the next one, click Find Next.

If you are replacing operands, you can replace all occurrences at once by clicking Replace All. If
you are replacing instructions, you must verify each one.

6. Ifthe Edit Instructions dialog box appears, make any necessary changes and click OK to save
them before moving on.

7.  When replacements are finished, close the Find and Replace dialog box.

Legacy Options

By default, PAC Control initially shows only SNAP PAC I/O units and the commands used with them.
When you're using the SNAP PAC system only, hiding legacy I/0 units and commands makes it
simpler and less confusing to build your strategy. However, the legacy capabilities can be made
visible as needed in a specific strategy.

NOTE: If you enable legacy I/O units and commands in PAC Contro, see the legacy versions of the PAC
control quides for information on how to use them:

Opto 22 form 1710, the PAC Control User's Guide, Legacy Edition

Opto 22 form 1711, the PAC Control Command Reference, Legacy Edition
Opto 22 form 1713, the PAC Control User's Guide, Legacy Edition

Existing Strategies

When you open an existing ioControl strategy in PAC Control, either Basic or Professional, PAC
Control will automatically show the I/O units and commands appropriate to that strategy.

For example, if you have been using SNAP Ultimate I/0, SNAP Ultimate I/0 units will be visible in the
strategy. In addition, commands used with SNAP Ultimate I/O but which are now deprecated
(obsolete) because they are not needed with SNAP PACs are also available.

Similarly, if you open an existing strategy that contains mistic serial I/0 units, all the mistic 1/0 unit
types and commands—such as event/reaction and mistic PID commands—are automatically shown.

New Strategies

When you create a new strategy in PAC Control, either Basic or Professional, the strategy will show
only the SNAP PAC System. This means:

«  When you use a command such as Get I/O Unit as Binary Value, the only I/0 units shown for
Argument T will be SNAP PAC I/0 units (SNAP-PAC-RT, SNAP-PAC-R1-B, SNAP-PAC-R2,
SNAP-PAC-EBT, SNAP-PAC-EB2, SNAP-PAC-SB1, and SNAP-PAC-SB2).

+  Commands that are used only with legacy hardware—such as Enable Communication to Mistic
PID Loop or Get All HDD Module Off-Latches—won't be listed.
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Since some Opto 22 customers work with multiple systems, legacy options can be set individually
for each strategy or subroutine. If you are using legacy hardware, you can choose the options that
apply to each strategy you're working with, without affecting other strategies.

IMPORTANT: Once you have enabled a legacy option for a specific strateqy or subroutine, you cannot
disable it later for the same strategy or subroutine.

Enabling Legacy Options
Here's how to set legacy options:
1. In PAC Control, open the strategy or subroutine for which you want to change options.
2. Choose File > Strategy Options. Click the Legacy tab.
Depending on the hardware you're using, you can set one or more of the following options:
- Enable Ethernet, Ultimate, and Simple I/0 units and commands (see page 209).
— Enable high-density digital commands (see page 209).
- (PAC Control Pro only) Enable mistic I/0 units and commands (see page 210).

3. (lickthe option you want to enable. At the confirmation dialog box, make sure it is correct, and
then click Yes. Repeat to enable other options.

The options are changed for the strategy or subroutine.

Enable Ethernet, Ultimate, and Simple 1/0 Units and Commands

If you're using any of the I/0 unit types shown in the following table, you should enable Ethernet,
Ultimate, and Simple I/0 units and commands. When you do, both the I/O unit types and the
commands shown in the table will become available in the strategy.

1/0 Unit Types Commands

IVAL Set Digital-64 1/0 Unit from MOMO Masks [DEPRECATED)]
IVAL Set Mixed 64 1/0 Unit from MOMO Masks [DEPRECATED]
IVAL Set Mixed I/0 Unit from MOMO Masks [DEPRECATED]
IVAL Set Simple 64 1/0 Unit from MOMO Masks [DEPRECATED)]
Set Digital-64 /0O Unit from MOMO Masks [DEPRECATED]

Set Mixed 64 1/0 Unit from MOMO Masks [DEPRECATED]

Set Mixed I/0O Unit from MOMO Masks [DEPRECATED)]

Set Simple 64 /O Unit from MOMO Masks [DEPRECATED]

SNAP-ENET-D64
SNAP-B3000-ENET
SNAP-ENET-RTC
SNAP-UP1-D64
SNAP-UP1-ADS
SNAP-UP1-M64
SNAP-ENET-S64

Enable High-Density Digital Module Commands

All SNAP high-density digital modules are fully supported by the SNAP PAC System using regular
digital point commands. However, three of our older HDD modules can also be used with
analog-capable SNAP Ultimate, SNAP Ethernet, and SNAP Simple I/0 units, if you use the older
“legacy”HDD commands.
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If you are using SNAP-ODC-32-SNK, SNAP-ODC-32-SRC, or SNAP-IDC-32 HDD modules with these
older I/0O units, you should enable High-Density Digital module commands. When you do, the
following commands become available in the strategy:

Commands
Clear HDD Module Off-Latches Get All HDD Module On-Latches
Clear HDD Module On-Latches Get All HDD Module States
Get & Clear All HDD Module Off-Latches Get HDD Module Counters
Get & Clear All HDD Module On-Latches Get HDD Module Off-Latches
Get & Clear HDD Module Counter Get HDD Module On-Latches
Get & Clear HDD Module Counters Get HDD Module States
Get & Clear HDD Module Off-Latches Set HDD Module from MOMO Masks
Get & Clear HDD Module On-Latches Turn Off HDD Module Point
Get All HDD Module Off-Latches Turn On HDD Module Point

Enable mistic 1/0 Units and Commands

If you're using legacy mistic hardware with a SNAP PAC S-series controller and PAC Control
Professional, you should enable mistic I/0 units and commands. When you do, the following I/0 unit
types and commands will become available in the strategy.

I/0 Units Types.
1/0 Unit Types Other Types
G4D16R B3000 or B3000-B (Digital) Mistic PID Loop
G4D32RS B3000 or B3000-B (Analog) Digital Event/Reaction
G4A8R, G4RAX B100 Analog Event/Reaction
B200 SNAP-BRS Event/Reaction Group
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Commands.

Commands

Clamp Mistic PID Output

Clamp Mistic PID Setpoint

Clear All Event Latches

Clear Event Latch

Convert Mistic /0O Hex String to Float

Convert Number to Mistic 1/0 Hex String

Disable Communication to Event/Reaction

Disable Communication to Mistic PID Loop

Disable Event/Reaction Group

Disable Mistic PID Output Tracking in Manual Mode
Disable Mistic PID Output

Disable Mistic PID Setpoint Tracking in Manual Mode
Disable Scanning for All Events

Disable Scanning for Event

Disable Scanning of Event/Reaction Group

Enable Communication to Event/Reaction

Enable Communication to Mistic PID Loop

Enable Event/Reaction Group

Enable Mistic PID Output Tracking in Manual Mode
Enable Mistic PID Output

Enable Mistic PID Setpoint Tracking in Manual Mode
Enable Scanning for All Events

Enable Scanning for Event

Enable Scanning of Event/Reaction Group

Event Occurred?

Event Occurring?

Event Scanning Disabled?

Event Scanning Enabled?

Event/Reaction Communication Enabled?
Event/Reaction Group Communication Enabled?
Get Analog Filtered Value

Get Analog Square Root Filtered Value

Get Analog Square Root Value

Get Analog Totalizer Value

Get & Clear Analog Filtered Value

Get & Clear Analog Totalizer Value

Get & Clear Event Latches

Get & Restart Off-Time Totalizer

Get & Restart On-Time Totalizer

Get & Restart Period

Get Event Latches

Get Frequency

Get Mistic PID Control Word

Get Mistic PID D Term

Get Mistic PID | Term

Get Mistic PID Input

Get Mistic PID Mode

Get Mistic PID Output Rate of Change
Get Mistic PID Output

Get Mistic PID P Term

Get Mistic PID Scan Rate

Get Mistic PID Setpoint

Get Off-Time Totalizer

Get On-Time Totalizer

Get Period

Get Period Measurement Complete Status
IVAL Set Analog Filtered Value

IVAL Set Digital Binary [DEPRECATED)]
IVAL Set Frequency

IVAL Set Mistic PID Control Word

IVAL Set Mistic PID Process Term

IVAL Set Off-Totalizer

IVAL Set On-Totalizer

IVAL Set Period

Mistic PID Loop Communication Enabled?
Read Event/Reaction Hold Buffer

Set Analog Totalizer Rate

Set Digital I/O Unit from MOMO Masks [DEPRECATED)]
Set Mistic PID Control Word

Set Mistic PID D Term

Set Mistic PID | Term

Set Mistic PID Input

Set Mistic PID Mode to Auto

Set Mistic PID Mode to Manual

Set Mistic PID Output Rate of Change
Set Mistic PID P Term

Set Mistic PID Scan Rate

Set Mistic PID Setpoint
Transmit/Receive Mistic 1/0 Hex String

Advanced Options

Very few applications require changes to the “Advanced” options, which involve adding and
changing variables and points in the strategy. However, these options can be useful for strategies

with a very large number of charts.

Three options are available. Unless you are certain you need these options, do not select them.

1. To see the options, choose Configure > Options. Click the Advanced tab.
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2.

By default, these options are not selected:

PAC Control Options *

Workspace Debugger Advanced

[]When adding Pairts and Variables, do not check OptoScript blocks
[]When renaming Points and Variables, do not update OptoScript blocks
] Allow Points and Variables with references to be deleted

Cancel Help

If you are sure you require one or more options, choose the one(s) you need.

When adding Points and Variables, do not check OptoScript blocks: If you check this
box, when you add a point or variable, OptoScript blocks will not be searched to see if it is
already being used in the block. That makes it faster to add points and variables in a
strategy that has a large number of charts. However, reference counts are not updated
during this process. When you have finished adding all the points and variables, choose
Tools > Regenerate Reference Counts.

When renaming Points and Variables, do not update OptoScript blocks: If you check
this box, you can rename a variable or point in the Strategy Tree, and it will not be renamed
in any OptoScript block. Renaming points and variables is faster in a strategy with a large
number of charts that have no OptoScript blocks; but if any renamed items exist in
OptoScript blocks, the strategy will not compile. You will have to manually edit those
OptoScript blocks.

Allow Points and Variables with references to be deleted: Use this feature on
variables or points that are used only in OptoScript blocks. If the variable or point is used in
an Action or Condition block, the strategy will not compile.

NOTE: If you want to delete a variable or point that shows a reference count greater than zero,

but itis not being used in the strategy, don't use this advanced option. Instead, choose Tools >

Regenerate Reference Counts to recalculate all reference counts. Then you will be able to delete
the variable or point.

212 PAC Control User's Guide



8: Working with Flowcharts

Introduction

This chapter shows you how to work with flowcharts, the building blocks of your strategy. When you
create a new strategy, one chart is created for you: the Powerup Chart. You must create all the other
charts to do the work of the strategy.

In this Chapter

Creating a New Chart ...
Working with Chart Elements... .
Opening, Saving, and Closing Charts..........

Copying, Renaming, and Deleting Charts
PHNTING CRAIS oo ssmssses s sssssess s sssmssoes oo
Exporting and Importing Charts.......

Creating a New Chart

1. With your strategy open and in Configure mode, select Chart > New, or right-click the Charts
folder on the Strategy Tree and select New from the pop-up menu.

The Add New Chart dialog box appears.

1 Add New Chart 3

Marne:

Description;

QK H Cancel ][ Help
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2.

Enter a name for the new chart.

The name must start with a letter, but may also include numbers and underscores. If you type
spaces, they are converted to underscores. All other characters are ignored.

(Optional) Type a description.
Click OK.

The new chart s listed on the Strategy Tree under the Charts folder, and the new chart window
appears. Block 0, the starting block, is shown automatically. No matter how many other blocks
you add or where you place them, block 0 is always the first block to be executed in the chart.

= Mew_Chart |Z| |E| El
o

(LA T Ghart /

NOTE: Because chart windows show a small portion of a potentially large chart, a small movement
with the scroll bar can mean a big change in what you see. If you lose your flowchart in the window,
select View > Center on Block and choose the block you want to see in the middle of the screen. Or
just right-click inside the flowchart and choose Center on Block from the popup menu.

Working with Chart Elements

Chart Components

Charts can contain five kinds of flowchart blocks, lines connecting the blocks, and text.

Action Blocks are rectangles that contain one or more commands (instructions) that do the work
of the strategy, such as turning things on or off, setting variables, and so on. See “9: Using Variables
and Commands” for more information. Action blocks can have more than one entrance but only
one exit.

Condition Blocks are diamonds containing questions that control the logical flow of a strategy.
Condition blocks can have many entrances, but only two exits: True and False.

OptoScript Blocks are hexagons containing OptoScript code, a procedural language you may want
to use to simplify certain tasks. See “11: Using OptoScript” for more information. OptoScript blocks
can have more than one entrance but only one exit.
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Continue Blocks are ovals that contain no commands, but simply route chart logic to a new
location, such as to the top of a chart. These blocks help keep charts neat by avoiding awkward
connections between two blocks that are far apart.

Sync Blocks are used in charts that control systems with controller redundancy. When a sync block
is encountered, the redundant controllers are synchronized. For more information, see Opto 22
form 1831, the SNAP PAC Redundancy Option User’s Guide.

Connections are lines with arrows that connect one block to the next, directing the flow of strategy
logic.

Text explains the chart’s purpose and elements for anyone who needs to understand them later.

Using the Drawing Toolbar

The drawing toolbar includes tools for each of the elements plus a Select tool, or pointer, for
manipulating elements:

Action block
OptoScript block
Condmon block
éCommue block
Select TEXt

Connect

Changing the Appearance of Elements in a Chart Window

You can change the background appearance of charts or subroutines, the color and size of blocks
and text, and the color of connection lines. Depending on the scope you want to affect, you can
change these window properties at three levels:

«  Across PAC Control—to change the appearance of all new charts in all new strategies, and all
new subroutines.
«  Across a strategy—to change the appearance of all new charts in the open strategy.

«  Forthe open chart or subroutine—to change the appearance of all new elements in the open
chart or subroutine window.

IMPORTANT: Note that most changes affect only new charts and their elements. Existing charts,
subroutines, and elements are not changed. To avoid having to go back and change each item
individually, make sure you set the defaults the way you want them before you create new charts. Once
you have changed the defaults, see “Changing Existing Elements to Match New Defaults” on page 217 to
change existing elements to match the new defaults.

To change the appearance of charts and elements, follow these steps:
1. Choose one of the following, depending on the scope you want to change:

- Tochange all new charts in all new strategies and all new subroutines, choose Configure >
Default Properties to open the Configure PAC Control Default Properties dialog box.

— Tochange all new charts in the open strategy only, choose File > Strategy Properties to
open the Configure Strategy Properties dialog box.
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— Tochange new elements in the open chart or subroutine only, choose Chart > Properties
or Subroutine > Properties to open the Configure Chart Properties or Configure Subroutine
Properties dialog box.

The dialog box that opens looks like this, except that its title may be different.

2. Complete the fields as described in “Configure Chart Properties Dialog Box” below.
3.  When you have made all the changes, click OK.

Configure Chart Properties Dialog Box

Configure Chart Properties

Flowihart Farameters
A —1— Background Colar: Grid Color: [

Display Block ID: [ Smooth Scrolling

Action Block Parameters

e . . C fior:
it Height; Calar; Fort: | Arial - 10 point w
Caondition Block. Parameters
; : q n Troe: | E—
Width: |95 | Height Color: Fort: | Arial - 10 point e
OptaScript Block
A R © fion:
B — width; Height: Color; Font; | Arial - 10 point w

Checkpoint Black

widh (96 | Height: (48 | Color Fort: | Arial - 10 point

Continue Black Parameters Alzo Apply Ta
Ll Wwidth: Height; Color; ’_ Font; | Arial - 10 point ] PAC Control
Tex Dt
C—1 widh Height: Font: | Arial - 10 point
Lok J[ cancel || Hep | [ Besetai— E

A—Flowchart Properties. Specify general chart display in this area. To apply these changes to
existing charts as well as to new ones, click All charts in D.

«  Tochange the chart background color from the default of white, click the Background Color
box. Choose a new color from the Color dialog box.

«  Tochange the chart’s grid color from the default of black, click the Grid Color box.

«  Thegrid and block ID numbers are displayed by default. To remove them, click Display Grid or
Display Block ID’s to remove the check mark.

«  Toenable or disable smooth scrolling in a flowchart, click Smooth Scrolling; this option is
disabled by default.

B—Action Block Parameters. Define the appearance of action blocks, condition blocks,
OptoScript blocks, and continue blocks in this area. These changes affect new blocks only, not
existing blocks. (To change existing blocks, see “Changing Existing Elements to Match New Defaults”
below.)

« Inthe Width and Height fields, type the block size in pixels. For action and continue blocks, the
default width is 96 and the default height is 48; the minimum parameters are 48 (width) and 32
(height). For condition blocks, the default height is 64. (Note that the numbers you enter are
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rounded down to be evenly divisible by 16; for example, if you enter 81, click OK and then
reopen the dialog box, the parameter reads 80.)

«  To change the color of the blocks from the default, click the Color box.

«  Tochange block name text formatting, click the Font box. In the Font dialog box, change the
font, font style, size, effects, and color. The default font is black 10-point Arial bold.

«  Tochange text alignment, right-click the Font box and choose left, center, or right from the
pop-up menu.

«  Tochange the color of connection lines, click a Connection line at the far right. Choose the new
color from the Color dialog box.

C—Text. Define width, height, and font of text blocks that appear as comments in a chart or
subroutine. Default width is 192; default height is 128; the minimum for both is 16. The default font
is black 10-point Arial bold.

D—AIso Apply To. To expand the scope of the changes you've made, click these boxes. Click
PAC Control to apply the changes to all new strategies and subroutines in PAC Control. Click Strategy
to apply the changes to all new charts in the current strategy. Click All Charts to apply the changes
to all new charts and all new graphic objects added to the current strategy.

Depending on which dialog box you are in and what is currently open, one or more of these options
may be grayed out. For example, if you are in the Configure PAC Control Default Properties dialog
box, it is assumed that the changes are to be applied throughout PAC Control, and that option is
therefore grayed out.

E—Reset All. To reset all parameters and options to their factory default settings, click Reset All.

Changing Existing Elements to Match New Defaults

Once you have changed the defaults for the way elements appear in a chart, you can update
existing blocks, connections, and text to match.

CAUTION: When you update existing objects to match, you cannot undo the update.

1. Right-clickon an empty space in the chart whose elements you want to change. Choose Select
from the pop-up menu. From the sub-menu, choose the item type you want.
For example, to select all action blocks, choose Select > Action Blocks.

2. Right-click again in the chart, and choose Properties > Copy from Default from the pop-up
menu.

The color, size, and font of all selected items change to match the flowchart defaults.

Drawing Blocks

Action, condition, OptoScript, and continue blocks are all drawn the same way.

1. With the chart open and the strategy in Configure or Online mode, click the tool you want to
use.

—  foran action block
<»  for a condition block
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> foran OptoScript block
@ foracontinue block.
As you move the mouse into the window, you see an outline representing the block.

2. (lick where you want to place the block.

The new block appears.

= Mew_Chart |Z| |E|[g

E

(LA TE T Ghart /

3. (ickin anotherlocation to place other blocks of the same type. When you have finished using
the tool, click the right mouse button, click another tool in the toolbar, or press Esc.

Naming Blocks

1. With the chart open and the strategy in Configure or Online mode, click the Select tool ; ' and
click the block to select it.

2. Right-click the block and choose Name from the pop-up menu.

#1 Name Block

3. Inthe Name Block dialog box, type the name and click OK.

Renaming Blocks

1. With the chart open and the strategy in Configure or Online mode, click the Select tool i; ' and
click the block to select it.

2. Right-click the block and choose Name from the pop-up menu.

3. Inthe Name Block dialog box, change the name. Click OK.
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Connecting Blocks

To connect blocks, start with the chart open and the strategy in Configure or Online mode.
Remember that action blocks and OptoScript blocks have only one exit, and condition blocks have

two.

Action Blocks and OptoScript Blocks

1.

To connect an action block or an OptoScript block to the next block in a program sequence,
click the Connect tool + .

First click the source block and then click the destination block.

Although you can click anywhere inside the blocks to make a connection, the connection is

attached at the side closest to where you clicked. In the figure below, Block 0 is the source
block and Block 1 is the destination block:

= Mew_Chart

Block 0

(i) Shortcuts | 100 -

(LT Ghart /

To keep your charts neat, try to draw the most direct connections possible. To do so, after
clicking the source block, move your cursor out of the block at a point closest to its destination.

To create a bend or elbow in a connection, click wherever you want the bend while drawing
the connection.
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For example, to draw the connection in the following figure, we selected the Connect tool,
clicked Block 0, moved the cursor out of the block to the right, clicked at point A, clicked again
at point B, and then clicked the right side of Block 1:

—~ New_Chart

(i) Shortcuts | 100 -

(LT Ghart /

While you're still drawing a line, to delete an elbow you don't want, click the right mouse
button once to undo it.

If you created several elbows, you can eliminate them in reverse order with repeated right
mouse clicks. If no more elbows remain and you right-click again, you delete the connection.
Once you have completed a connection, however, you cannot undo it this way.

Condition Blocks

1.

To connect a condition block to the next block in a program sequence, click the Connect tool
5
Click the source block.

Select Connection Type

[ True Connection H False Connection ” Cancel ]

Indicate whether you are drawing the True connection or the False connection, and then click
OK.

Click the destination block you chose (True or False).
The connection is labeled T or F depending on its type.
Draw another connection to the second destination block.

Itis labeled the opposite exit type.
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For example, the following figure shows the True and False connections from the condition
block, Block 1. If the conditions in Block 1 are true, Block 2 is executed next. If the conditions in
Block 1 are false, Block O is executed next:

— New_Chart E| @lg

E

o Block 0

b B
(i) Shortcuts | 100 w
(LA 2 Chart /
Adding Text

One of the best places to put comments about a strategy is directly on its flowcharts. Start with the
chart open and the strategy in Configure or Online mode.

1. Toadd text to a chart, click the Text tool & .
When you move the mouse onto the chart, a rectangle representing the text area appears.

2. (lickthe mouse button and type your comments.
If you type in more text than the text frame holds, it expands in length.

3.  When you have finished typing, click anywhere on the chart outside the text frame.
The frame becomes invisible, and only the text appears. To change the size or shape of the text
block, see “Resizing Blocks or Text Blocks” on page 224.

4. C(lickin another location to create another text frame, or release the tool by right-clicking in the
chart or choosing another tool from the toolbar.

Editing Text

1. With the chart open and the strategy in Configure or Online mode, click the Select tool i .

2. Double-click the text block you want to change.
A blinking cursor appears at the beginning of the text.

3. Change the text as needed.
You can use any standard Windows Ctrl key combinations when editing, including Ctrl+arrow
keys and Ctrl+-Home or End for navigation. You can also use Ctrl+X (cut), Ctrl+C (copy), and
Ctrl+V (paste).

4. When you have finished changing text, click outside the text frame.
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The text block stays the same width but changes length to accommodate additional or deleted
text. To change the size or shape of the text block, see “Resizing Blocks or Text Blocks” on
page 224.

Selecting Elements

Before you can manipulate most elements, you need to select them. Start with the chart open and
the strategy in Configure or Online mode.

1. Clickthe Select tool I .

2. Toselect an action, OptoScript, condition, continue, or text block, click the block.

Handles appear around the block:

T/ \‘>Hand|es

Block 25

h

3. Toselecta connection, click it.

Handles appear at the elbows and end points of the connection:

—im Block 0

1
I—FI Block 1

4. Toselectall connections entering or exiting a block, click the block, click the right mouse
button, and choose Select Connections from the pop-up menu.

Handles

5. Toselect more than one element, do one of the following:
- Select the first element, hold down the Shift key, and select additional elements.

- (lickand drag the mouse to draw a rectangle completely around the elements you want to
select.

- Toselect all items of the same type, right-click anywhere in the window and choose Select
from the pop-up menu. From the sub-menu, choose the item type you want.

Moving Elements

1. With the chart open and the strategy in Configure or Online mode, click the Select tool I

2. Tomove any action, OptoScript, condition, continue, or text block, click it. Then click and hold
the mouse button anywhere on the selected item except on its handles, and drag it to the
position you want.

You can also use the arrow keys on your keyboard to move a block in any direction. Note that
when you move a block, any connections attached to it also move.

3. Tomove a connection, click it. Then click and drag any handle in any direction.
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You can also move an end point from one block to another, as long as the result is a valid
connection. A disallowed move is ignored.

4. Tomove several elements at once, select them, and then click and drag them.

If elements end up stacked on top of each other, you may need to change their z-order before
you can move them. Seethe following section.

Moving Elements in Front of or Behind Other Elements (Changing Z-Order)

If elements are stacked on top of each other, you can select only the one in front. To change their
position (z-order), follow these steps:

1. Click the element to select it.

2. Right-click the element. From the pop-up menu, choose Z-order. From the sub-menu, choose
the action you want to take:

- Bring Forward—moves the element one position closer to the front.
- Bring To Front—moves it all the way to the front.

- Send Backward—moves the element one position closer to the back.
- SendTo Back—moves it all the way to the back.

Cutting, Copying, and Pasting Elements

You can cut, copy, and paste most chart or subroutine elements. Cut or copied elements are placed
on the Windows Clipboard, and they can be pasted in the same chart or subroutine, in a different
chart or subroutine, or in a different strategy.

A connection can be cut or copied, but it cannot be pasted unless its original source and destination
blocks have also been pasted. Block 0 cannot be cut.

1. With the chart open and the strategy in Configure or Online mode, click the Select tool i .
2. Tocutor copy element(s), click them. Press Ctrl+X to cut or Ctrl+C to copy.

You can also select the element(s) and then click Edit > Cut or Edit > Copy, or click the right
mouse button and choose Cut or Copy from the pop-up menu.

3. To paste blocks, press Ctrl+V, click Edit > Paste, or right-click anywhere on a chart and then
select Paste from the pop-up menu.

Text blocks are pasted immediately. For action, condition, or continue blocks, a message
appears asking if you want to keep the original name of the block being pasted.

If you paste to a different strategy or to a subroutine, PAC Control checks the referenced
variables to make sure they match. Variables that do not exist are created. Variables that exist
but are different—for example, a table with the same name but a different table length—are
noted in a log file that appears when the paste is complete.

Deleting Elements

1. Make sure the chart is open and the strategy is in Configure or Online mode.
2. C(Clickthe Selecttool L . Click the element(s) to select them.

CAUTION: Make sure you have selected the element you want. You cannot undo a deletion!
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3. Press Delete.

You can also select the element(s), right-click them, and select Delete from the pop-up menui.
Block 0 cannot be deleted. If you delete a block, you'll be asked to verify the deletion.

Changing Element Color and Size

You can change the colors and sizes of blocks, connections, and text in your chart. To change one
element (for example, the color of one block), use the steps in this section. To change more than
one at a time, see “Changing the Appearance of Elements in a Chart Window" on page 215.

Start with the chart open and the strategy in Configure or Online mode.

Resizing Blocks or Text Blocks

1. Click the Select tool I:  and click the block to select it.

2. (lick one of the handles, then drag it in the direction you want. To resize horizontally and
vertically at the same time, drag a corner handle.

Changing Block Colors

1. Clickthe Select tool I;  and click the block to select it.
2. Right-click the block and choose Color from the pop-up menui.
3. Pick the color you want and click OK.

Changing Text

You can change the size, font, font style, or color of the text in any block.

1. Clickthe Selecttool i; = and click the block to select it.

2. Right-click the block and choose Font from the pop-up menu.

3. Inthe Font dialog box, make the changes you want. Click OK.

4. Tochange whether text appears at the left, the center, or the right of a block, select the block

and click the right mouse button. From the pop-up menu, choose Justify; from the sub-menu,
choose Left, Center, or Right.
Changing an Element Back to the Defaults

1. Select the item and click the right mouse button.
2, From the pop-up menu, choose Properties. From the sub-menu, choose Copy from Default.

To change defaults, see “Changing the Appearance of Elements in a Chart Window”on
page 215.

Opening, Saving, and Closing Charts

Opening a Chart

Make sure the strategy is open. In the Strategy Tree, double-click the chart you want to open.
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You can also open a chart by selecting Chart > Open, and then double-clicking the chart name in
the Open Chart dialog box, which lists all charts that are not currently open.

If a chart is open but not visible on the screen, click the chart’'s name tab at the bottom of the
window to make it visible.

Saving a Chart

1. Make sure the chartis open and is the active window.
2. From the Chart menu, choose Save.

Charts are automatically saved when you choose File > Save All. If you choose File > Save Strategy
or click the Save Strategy icon &l on the toolbar, you can choose which charts to save in the Save
Strategy dialog box.

Closing a Chart

To close a chart, click the close box in the upper-right corner of the chart’s window (not the PAC
Control window). You can also close a chart by pressing Ctrl+F4 when the chart window is active. If
you have made changes to the chart, you are prompted to save them.

Copying, Renaming, and Deleting Charts

Copying a Chart

If an existing chart is similar to one you want to create, it is easier to copy it than to create a new one
from scratch. To copy a chart in the same strategy, follow the steps in this section. To copy a chart to
another strategy, see “Exporting and Importing Charts” on page 227.

1. With the strategy open and in Configure mode, select Chart > Copy.
The Copy Chart dialog box appears.

Copy Chart El
Fram To
Marne: Marne:

| Alarms

Dezcription; Description;

Check the E-Stop button &
the two level alarms.

[ 1] H Caticel ][ Help ]

2. Inthe From field, choose the chart you want to copy from the drop-down list.
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3. IntheTofield, enter a name for the new chart.

The name must start with a letter and include only letters, numbers, or underscores. (Spaces
are converted to underscores).

4. (Optional) Enter a description for the new chart.
5. ClickOK.
The new chart is created and appears as the active window on the screen.

Renaming a Chart

1. Make sure the strategy is in Configure mode and that the chart you want to rename is the
active window.

2. From the Chart menu, choose Rename.

*1 Rename Chart gl

Description:

Controlz sprinklers for the front lavn.

I Ok H Cancel ][ Help ]

3. Enteranew name and description (optional). Click OK.

The chart is renamed.

Deleting a Chart

You can delete any charts except for the Powerup chart. However, you cannot delete a chart if it is
called or used by another chart in your strategy.

1. Make sure the strategy is open and in Configure mode.

2. Inthe Strategy Tree, right-click the name of the chart you want to delete and choose Delete
from the pop-up menu. Or, if the chart is the active window, choose Chart > Delete.

3. Atthe confirmation message, make sure you are deleting the correct chart.

CAUTION: You cannot undo a deletion!

4. C(lick Yes to delete the chart.

The chart window disappears (if it was open), the chart is removed from the Strategy Tree, and
the strategy is saved.
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Printing Charts

You can print any flowchart. To print a chart as it appears on the screen, see “Printing Chart or
Subroutine Graphics”on page 197.To print commands (instructions) for the chart, see “"Viewing and
Printing Strategy or Subroutine Commands”on page 199.

Exporting and Importing Charts

To copy a chart to another strategy, you must export it as a PAC Control chart export file (.cxf file) and
then import it into the strategy where you want it.

Exporting a Chart

1. With the strategy open and in Configure or Online mode, choose Chart > Export.

The Export Chart dialog box appears.

Export Chart fg|
From To
Mame: Mame:
| Spritkler_Contral | | [ﬁelect... ]

Description: Digscription:

Controls sprinklers for the front
lawn.

[ ak. H Caticel ][ Help ]

2. Inthe From section of the dialog box, select the chart to be exported from the Name
drop-down list.

3. IntheTo section of the dialog box, click Select.

Select Destination for, Export File

Save in: | I P&LC Contral vl €] ? e M-
File name: || | I ST ]
Save as lype: | FALC Contral Chart Expart Files (% cxf) v | ’ Cancel ]
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4,

Navigate to where you want the exported chart file to be saved. In the File name field, enter a
name for the exported chart. Click Save.

You return to the Export Chart dialog box, which now shows the path and file name in the To
section.

(Optional) Enter a description for the new chart.
Click OK.

The exported chart is saved. You can import it into any PAC Control strategy. See the next
section for information on importing charts.

Importing a Chart

Use the Automatic Chart Import dialog box to import a chart previously exported. Also see
“Exporting a Chart”on page 227.

1.

N

With the strategy open and in Configure mode, choose Chart > Import.
The Automatic Chart Import dialog box appears.

Automatic Chart Import

() Beplace existing chart
To
MHame:
| [§elect... ] |
Description: D escription:
[ QK ] [ Cancel ] [ Help ]

At the top of the dialog box, click Create new chart or Replace existing chart.

CAUTION: If you choose Replace existing chart, the old chart will be completely overwritten with
the chart you are importing.

Click Select. Navigate to the exported chart. Click OK.
In the To section of the dialog box, enter a name for the new chart.
If you wish, enter a description. If you are replacing an existing chart, select it from the list. To

copy the imported chart description, select the text in the left description field, copy it, and
paste it in the right description field.

Click OK.
The chart is imported. A Chart Import Report window shows you how the tags in the chart

match with those already in the strategy. Any tags from the chart that do not already exist in
the strategy are created and added.
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9: Using Variables and
Commands

Introduction

This chapter discusses the seven types of variables used in PAC Control: numeric, string, pointer,
numeric table, pointer table, string table, and communication handle variables.

This chapter also shows you how to use the commands, or instructions, in PAC Control and discusses
the mechanics of adding commands to your strategy flowcharts. For command information to help
you program your strategy effectively, see Chapter 10.To find out how to use commands in
OptoScript code, see Chapter 11. For a list of all standard PAC Control commands and their
OptoScript equivalents, see Appendix E.

In this Chapter
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Cutting or Copying @ COMMANG ....coooeverreerreeeseess s 251

Configuring a Continue Block... . . . . . . 252

Viewing and Printing Chart Instructions... . . . O 252
About Variables

As Chapter 2 mentions, variables store pieces of information in a strategy. You create a variable for
each piece of information in your control process that must be acted upon. These pieces of
information might include the name of a chart, the on or off state of a switch, communication
parameters for a peer on the network, or a table that holds a series of numbers.

Each variable has a name and a value. You assign the variable’s name in plain English, so you know
what it is. The variable’s value is the current information it represents. As a strategy runs, the
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variable’s name remains the same, but its value may change. For example, the name of the variable
Oven_Temperature stays the same, but its value (the temperature of the oven) may change several
times while the strategy is running.

To illustrate variables, suppose you are regulating the

amount of water in a tank. You must keep the tank filled >

beyond a minimum level, but you cannot let it get too full. Level_ :f

You've already configured the I/O points: Meter _— Pump_1
an

+  Level_Meteris an analog input point that registers the
quantity of water in the tank.

«  Pump_1isadigital output point that turns the pump y

on or off. Drain_1

«  Drain_1 s a digital output point that opens or closes
the drain.

Next, you configure variables as places to hold information that these I/0 points must work with:

«  Toavoid constantly polling Level_Meter to find out the quantity of water in the tank, you create
avariable called Tank_Level_Reading in which to store the level. The input point Level_Meter is
periodically checked and the value of Tank_Level_Reading updated.

«  Toestablish the maximum and minimum levels, you create variables called Tank_Max_Level
and Tank_Min_Level. The value in Tank_Level_Reading can be compared to the values in these
two variables to determine whether the pump should be turned on or off, or the drain opened
or closed, to maintain the proper level. (You could create constant values, called literals, for the
minimum and maximum levels, but creating them as variables lets you change their values in
Debug mode.)

Types of Data in a Variable

A variable stores one of six types of data: floating point, integer, timer, string, pointer, or
communication handle. When you create the variable, you designate the type of data it contains. It
is always best to choose the most appropriate data type for the information you are storing. PAC
Control can store an integer in a floating point variable, but it has to convert the data first.
Unnecessary data conversions take up processor time.

«  Numeric data stores numbers and can be one of the following types:

- Afloating point (or float) is a numeric value that contains a decimal point, such as
3.14159, 1.0, or 1,234.2. A good example of a float variable is one that stores readings from
an analog input such as a thermocouple. PAC Control uses IEEE single-precision floats with
rounding errors of no more than one part per million.

- Aninteger is a whole number with no fractional part. Examples of integer values are -1, 0,
1,999, or -4,568. The state of a switch, for example, could be stored in an integer variable as
1 (on) or 0 (off).
Most integers used in PAC Control are 32-bit signed integers, which can range from
-2,147,483,648 10 2,147,483,647. These 32-bit integers should be used for general integer
use, such as status variables, mathematics, and indexes. . 64-bit integers address the entire
I/0 unit at once but are slower than integer 32 commands.
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- Atimer stores elapsed time in units of seconds with resolution in milliseconds. Up Timers
count up from zero, and Down Timers start from a value you set and count down to zero.
Timers can range from 0.001 to 4.611686 x 10'°.

+  Astring stores text and any combination of ASCII characters, including control codes and
extended characters. For instance, a string variable might be used to send information to a
display for an operator to see. A string variable is also used to set parameters for peer-to-peer
communication. When defining most string variables, you must specify the width of the string.
The width is the maximum number of characters that the variable may hold.

A string variable can contain numeric characters, but they no longer act as numbers. To use
them in calculations, you must convert them into floating point or integer numbers.
Conversely, a numeric value to be displayed on a screen must first be converted into a string.

» A pointer does not store the value of a variable; instead, it stores the memory address of a
variable or some other PAC Control item, such as a chart or an 1/0 point. You can perform any
operation on the pointer that you could perform on the object the pointer points to. Pointers
are an advanced programming feature and are very powerful, but they also complicate
programming and debugging.

« A communication handle stores information used to communicate with other entities, for
example other devices on the network or files that store data. The communication handle’s
value is a string containing the parameters needed to make a connection with a specific entity.
For outgoing Ethernet communication, for example, these parameters usually include the
protocol, the IP address of the device you are communicating with, and the port number used
on the device.

After the initial connection is made, the communication handle is referenced during
communication with the entity, and then used to close communication.

Variables in PAC Control

In PAC Control there are seven types of variables:
e numeric

«  numeric table

e string

« string table

e pointer

«  pointer table

« communication handle

Numeri, string, and pointer variables contain individual pieces of data. Numeric table, string table,
and pointer table variables contain several pieces of related data in the form of a table.
Communication handle variables contain parameters used by PAC Control for communicating with
other devices and files.

Table Variables

In a table variable, the variable name represents a group of values, not just one. Table variables are
one-dimensional arrays, which means that each table is like a numbered list of values. You refer to
each item in the list by its number, or index. Indexes start at 0, not at 1. Here are two table examples:
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In a float table, values are floating point numbers:

Index Value

0 82.0
1 86.1
2 85.0
3 74.8
4 72.3
5 72.7

In a string table, values are strings:

Index Value

0 Maria
1 Tom
2 Siu
3 Andre

When you define a table, you must specify its length, which is how many values the table can store.
The length of a table is NOT the value of the last index. Since indexes start at 0, a table with a length
of 100 contains indexes 0 through 99. Table length is limited only by the amount of memory in the

control engine. (For more information on the available memory, see “If You Have Memory Problems”
on page 381)

Numeric tables store either integer values or floating point numbers (but not both in the same
table). String tables store strings. Because pointers can point to any data type (for example, an 1/0O
point, a chart, or even another table), pointer tables can store an assortment of data types.

Persistent Data

Most variables can be either global or persistent in scope. Global variables are set to an initial value
(which you specify during configuration) either whenever the strategy is run or whenever it is
downloaded.

Persistent variables, however, are initialized only when the strategy is first downloaded. Numeric
variables (and tables) are initially set to 0. String variables (and tables), pointer variables (and tables),
and communication handles are initialized as blank, or empty. The key point about a persistent
variable is that its value is saved in the controller's memory; it does not get initialized when the
strategy is run, stopped, or started, and it does not get initialized if the strategy is modified and
downloaded again. A persistent variable’s value remains the same until one of the following events
occurs:

+  Astrategy with a different name is downloaded.
»  The RAM memory on the controller is cleared.
«  Anew firmware kernel is downloaded to the controller.

«  Astrategy download is canceled during the download process.
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«  The persistent object is changed as follows:
— Apersistent table's length (integer, 64-bit integer, float, and string) was modified.
- Apersistent string variable's length was modified.
— A persistent string table element's string length was modified.

— A persistent variable's type has changed. For example, a persistent float variable is deleted
and a new persistent integer variable is created with the same name.

Persistent data can be very useful in certain situations. For example, suppose you have a PID setpoint
that is fine-tuned as your process runs. If the setpoint is configured as persistent, its value won't be
lost if you must re-download the strategy after making a program change.

Pointer variables, pointer tables, and timers are not allowed to be persistent; but all other variables
and tables can be. Persistent variables cannot be configured on-the-fly.

Literals

A literal is used like a variable, but it is constant data that never changes. A literal has no variable
name, only a fixed value, which may be a floating point number, an integer, or a string.

If you are using subroutines, see the information on literals in “Data Types for Subroutines”on
page 366.

Adding Variables

This section includes steps for adding numeric, string, pointer, and communication handle variables.
(For numeric, string, and pointer tables, see “Adding Tables”on page 236.)

1. With the strategy or subroutine open in Configure mode, choose Configure > Variables.

The Configure Variables dialog box opens.

#co nfigure Variables

LT rneric ' ariables Scope! | Global v
I arne Type Init Type Init W alue Description Ref Count Add...

bStartFlag Integer 32 Diownload 2 -
diCookiebaotionTi... Down Timer Run For animation inio... 1
fDoughPressureS... Float Persiztent 1] Desired dough ve... 2

fRamptalue Float Run a For ramping the c... 4
fSetpointtdinusDe... Float Run 1] Dough weszel pre... 2

nChartStatug Integer 32 Persistent 5}

nCookisMationPre... Integer 32 Fiun Foar aniration i io... 1

nLoopCounter Integer 32 Run 2

< | b

’ Claze ] [ Help ]

This dialog box lists all the variables in the strategy or subroutine that are of the type shown in
the Type field. You can sort the data in this dialog by clicking any one of the column header
buttons.

2. Inthe Type drop-down list, choose the type of variable you want to configure.
3. Ifyou are adding the variable to a subroutine, select Subroutine in the Scope drop-down list.
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4. Toadd anew variable, click Add.
The Add Variable dialog box appears.

5. Complete the fields as described in “Add Variable Dialog Box” below.
6. Click OK.

The Add Variable dialog box closes and the new variable appears in the Configure Variables
dialog box.

Add Variable Dialog Box

This dialog box varies depending on the type of variable.

Add Variable =3
A — Hame: | |
B — Description: | | Field agD varies
depending on
— Type: Sri w | Shing Width: .
C (St | Ij variable type.
Initialization

| ) Initialize an strateqy download

E < (#) Initialize on shrateqy min
>~ () Persistent

F——— Iritial Value: |

[ 0K H Cancel H Help ]

The figure above shows the Add Variable dialog box as it appears for string variables. Fields are
slightly different for other variables.

A—Name. Enter a name for the variable. The name must start with a letter and may contain
letters, numbers, and underscores. (Spaces are converted to underscores.)

B—Description. (Optional) Enter a description of the variable.

C—Type. In the Type drop-down list, select the type of data for the variable. Possible types are
shown in the following table. For more information, see “Types of Data in a Variable” on page 230.

Variable Possible Data Types

Numeric Integer 32, integer 64, floating point, up or down timer

Numeric table Integer 32, integer 64, or floating point

String String
String table String
Pointer Pointer to any data type

Pointer table

Pointer to any data type, and the data type may change

over time

Communication handle

Communication handle
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D—String Width. This field varies depending on the variable type.

(Table variables only) In the Table Length field, enter an integer between 1 and 1,000,000
representing the number of elements in the table. The greater the number, the more memory
required to store the table.

(String variables and string tables only) In the String Width field, enter the maximum number of
characters permitted in the string. The number must be an integer between one and 1024. The
greater the number, the more memory required to store the string.

(Pointer variables only) From the Pointer to Type drop-down list, select the type the pointer points
to. Note that void pointers are not allowed; a pointer must point to a specific type. Also note that
you cannot point a pointer to another pointer; PAC Control has only one level of indirection for
pointers. If you try to point to a pointer, PAC Control assigns to the new pointer the address of the
object being pointed to.

E—Initialization. (For all variables except up timers and down timers)
Select one of the following:

Initialize on Strategy Run: Sets the variable to the initial value (F) each time the strategy is run (either
manually from the debugger or automatically via the autorun flag).

Initialize on Strategy Download: Sets the variable to the initial value (F) only when a strategy is
downloaded. The variable retains its current value when the strategy is stopped and then run again,
either through the debugger or autorun. It also retains its value if power is cycled. Note that this
choice means the variable is stored in battery-backed RAM, which is limited in size. To keep a
variable’s current value through both power cycles and strategy download, make the variable a
persistent variable (see the Persistent option below and “Persistent Data” on page 232). See “If You
Have Memaory Problems”on page 381.

Persistent: Data in the variable will be persistent. Pointer variables and timers cannot be persistent.
For more information, see “Persistent Data” on page 232.

The following table shows how your choices about variable initialization and persistence affect what
happens to variables (applies to all variables and tables except up timers and down timers).

Variable What happens to the variable’s value when...?

Same strategy is
downloaded

Strategy stops, then starts

(through debugger or autorun) LT L

Variable initialized on

Set to initial value Set to initial value Set to initial value
strategy run (default)
Variable initialized on Retains current value Retains current value | Set to initial value
strategy download
Persistent variable Retains current value Retains current value | Retains current value

F—Initial Value. (For all variables except pointers, up timers, and down timers) Enter the value
to which the variable is to be set initially. You can use either decimal or hexadecimal form. If you
leave this field blank, the initial value is set to zero.

(For pointer variables only) When you have selected the Pointer to Type, the drop-down list in this
field shows all the valid objects for that type that are currently defined in your strategy. Choose one
or leave the initial value as NULL. A NULL value means that the pointer is created but does not
initially point to anything.
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(For communication handles only) Enter a string containing communication parameters in the
correct format for the type of communication handle you are using. The type (for example, tcp,
Ttp, File) must be in lowercase letters, and parameters are separated by colons and commas
according to the format required. See “Communication Commands”on page 256 for information
and examples.

To communicate with a serial module, use the IP address of the brain the module is attached to,
and use the serial module’s port number according to its position on the rack, for example:
tcp:10.192.55.185:22502. For port numbers, see “Establishing an Ethernet Connection”in form
1191, the SNAP Serial Communication Module User’s Guide. See also, form 1940, TCP and UDP Port
Assignments.

To communicate with another SNAP PAC brain, be aware of port numbers that are reserved for
a specific protocol. For more information, see form 1940, TCP and UDP Port Assignments.

For other peers on the Ethernet network, be aware of port numbers they may use for specific
purposes. Ports 22000 and 22001 are reserved for the control engine. For a list of standard
Ethernet port numbers, refer to http://www.iana.org/assignments/port-numbers. See also,
Opto 22 form 1940, TCP and UDP Port Assignments.

If you are using the Accept Incoming Communication command to listen for communication
requests, leave out the IP address and use the following format: tcp:port

For tables, each value in the table is set to the initial value. If you need to set individual table
elements to differing values initially, you can do so in the Powerup chart. If you need to use an
initialization file to set values on strategy download, contact Opto 22 Product Support.

Adding Tables

See the following topics to add numeric, string, and pointer tables:

“Adding Table Variables” (below)
“Setting Initial Values in Variables and Tables During Strategy Download” on page 237

Adding Table Variables
1.

With the strategy or subroutine open in Configure mode, choose Configure > Variables.

The Configure Variables dialog box opens, listing all variables of one type in the strategy.

#1Co nfigure Variables E|
QRSN umeric Yarniables Scope: | Global "

Mame Tvpe Init Type it % alue Dezcription Ref Count Add...
bStartFlag Integer 32 Download 2 -
diCookietdotionTi... Dovan Timer Run For animation inio... 1
fDoughPressureS ... Float Persistent i} Desired dough ve... 2
fRamp alue Float Rurn 1] For ramping the c... 4
fSetpointtinuzDe... Float Run 0 Dough vesszel pre... 2
nChartStatugs Integer 32 Persiztent 5
nCookiek otionPre... Integer 32 Run For animation inio... 1
nLoopCounter Integer 32 Fiun 2
4 | 3

Cloze ] [ Help
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2. IntheType drop-down list, choose the type of table variable you want to add.

3. Ifyou are adding the table variable to a subroutine, select Subroutine in the Scope drop-down
list.

4. Toadd anew table variable, click Add.
The Add Variable dialog box appears.

Add Variable X]

Marme: |

E

Description: |

Tupe: | Stiing v | String widih

Initialization

() Initislize on strateqy download
(%) Initislize on strateqy wn
() Persistent

Initial Yalue: |1

I Ok l[ Cancel ][ Help ]

The figure above shows the dialog box as it appears for string tables. Fields are slightly different
for other table variables.

5. Complete the fields as described in “Add Variable Dialog Box”on page 234.

NOTE: If you need to set individual table elements to differing values initially, you can do so in the
Powerup chart. If you need to use an initialization file to initialize the values on strategy download,
see the next section, “Setting Initial Values in Variables and Tables During Strategy Download.”

6. To have data in the table be persistent, select Persistent.
Pointer tables cannot be persistent. For more information, see “Persistent Data” on page 232.

7. C(lick OK.

The Add Variable dialog box closes and the new table variable appears in the Configure
Variables dialog box.

Setting Initial Values in Variables and Tables During Strategy

Download

When you are adding table variables in PAC Control, you can set all table elements to one initial
value in the Add Variables dialog box. If you want to set each individual table element to its own
value, however, you need to create an initialization file and download it with your PAC Control
strategy.

In addition to setting initial values for table elements, sometimes it is easier to initialize all variables
during strategy download using an initialization file.

This section shows you how to create an initialization file and download it with your strategy.
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Creating the Initialization File

A sample initialization file, Init.txt, is copied to the local hard drive when you install PAC Control. The
file’s location is C:\Users\Public\Documents\Opto 22\PAC Project <version number>\Control Basic
Examples <or Control Pro Examples, if you have PAC Control Professional>\InitVariables.

You can open this file with a text editor to see the proper syntax for each initialization entry, and
then modify it as necessary for your strategy.

IMPORTANT: Every initialization file should include the following line near the top:
\ """"DOWNLOAD_COMPRESSION_OFF

Make sure to enter a backslash and a space at the beginning of the line. Download compression removes
the newlines necessary for string initialization. This line tells PAC Control to turn off download compression
so strings can be initialized.

IMPORTANT: Each file must end with a carriage return so that the last line in the file is blank, and each
line within the file must end with a carriage return. If you add comments to the file, they must be preceded
by a backslash (\) and a space.

Text Examples

NOTE: Variable names are case-sensitive and can include both upper- and lower-case letters.

Integer Example. To set an initial value of 123 for the variable INTEGER_VARIABLE, you would
include the following text in the initialization file:
123 ~INTEGER_VARIABLE @!

Float Example. Floating point values must contain a decimal point. To set an initial value of 456
for the variable FLOAT_VARIABLE, you would include the following text (with the decimal point and
zero) in the initialization file:

456.0 "FLOAT_VARIABLE @!

String Example. To set an initial value of “String Variable Test String” for STRING_VARIABLE, you
would include the following text in the initialization file. The spaces and newline are very important:

*STRING_VARIABLE $INN
String Variable Test String

Communication Handle Example. To add the parameters of a communication handle
named COMM_Handle, you would include the following text in the initialization file. The spaces and
newline are very important.

*COMM_Handle $INN
tcp:10.0.0.1:1000

Pointer Example. To have the pointer PTR_POINTER_VARIABLE point initially to

INTEGER_VARIABLE, you would include the following text in the initialization file:
~NINTEGER_VARIABLE MoveToPointer PTR_POINTER_VARIABLE

Integer 32 Table Example. To set initial values of 10, 20, 30, 40, and 50 for elements zero

through four of an integer table named My_Int_32_Table, include the following text:
10 O IMy_Int_32_Table TABLE!
20 1 MMy Int_32_Table TABLE!
30 2 My _Int_32_Table TABLE!
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40 3 IMy_Int_32_Table TABLE!
50 4 MMy _Int_32_Table TABLE!

Integer 64 Table Example. To set initial values of 10, 20, 30, 40, and 50 for elements zero

through four of an integer table named My_Int_64_Table, include the following text:
10.. O }My_Int_64_Table 2TABLE!
20.. 1 }My Int_64 Table 2TABLE!
30.. 2 }My_Int_64 Table 2TABLE!
40.. 3 IMy Int_64 Table 2TABLE!
50.. 4 }y_Int_64 Table 2TABLE!

Float Table Example. For a float table, the initial values must include a decimal point. To set
initial values of 1.1, 2.2, 3.3, 4.4, and 5.5 for elements zero through four of a float table named
My_Float_Table, include the following text:

1.1 0 }My Float_Table TABLE!

2.2 1 My _Float_Table TABLE!

3.3 2 }My_Float_Table TABLE!

4.4 3 IMy_Float_Table TABLE!

5.5 4 }My_Float_Table TABLE!

String Table Example. To set initial values of “zero”,"one’, “two”, “three’, and “four” for elements
0-4 of a string table named My_String_Table, include the following text. Make sure you turn off
download compression and use new lines as shown:

0 {My_String_Table $TABLE@ $INN

zero

1 {My_String_Table $TABLE@ $INN

one

2 {My_String_Table $TABLE@ $INN

two

3 {My_String_Table $TABLE@ $INN

three

4 {My_String_Table $TABLE@ $INN

four

Pointer Table Example. Each index in a pointer table points to another item within the
strategy, for example an 1/0 point, a variable, or a chart. Setting initial values for pointer tables
means designating the items the pointer table initially points to. For example, you would include
the following text to have a pointer table named My_Ptr_Table initially point to Oven_Temperature
(a variable), Alarm_Handler (a chart), Thermocouple (an analog input), Fuel_Pump (an analog
output), and Fan_1 (a digital output):

~Oven_Temperature O PTBL_My_Ptr_Table TABLE!

&Alarm_Handler 1 PTBL_My_Ptr_Table TABLE!

~Thermocouple 2 PTBL_My Ptr_Table TABLE!

~Fuel_Pump 3 PTBL_My_ Ptr_Table TABLE!

~Fan_1 4 PTBL_My Ptr_Table TABLE!

Special Characters in the Initialization File. Note that the initial character on each line of
the initialization file is a special character that identifies the object type. Possible characters include
the following:

Character Object Type

A float, integer, or timer
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Character Object Type

* string

PTR_ pointer variable
~ 1/0 point
& chart
} float table or integer table
{ string table

PTBL_ pointer table
% 1/0 unit

Saving the Initialization File. When you have finished modifying the file, save it as a text file
(.txt file extension) to your strategy directory. You can name the file anything you like. (You can also
save it to any directory you like, but it is good practice to save each initialization file to the directory
of the strategy that references it.)

Downloading the Initialization File

To use the file, you need to download it with your strategy.

1. With the strategy open in Configure or Online mode, choose Configure > Control Engines, or
double-click the control engine’s name.

2. Highlight the control engine and click the Download Options button.

The Download Options dialog box appears. The initialization file must be downloaded
immediately after your strategy is downloaded.

#1 Download Options E]

Filez To Download After The Strategy:

[ add. |

[ QK l[ Cancel ]l Help

3. (lick Add.

4. Navigate to the initialization file you created. Double-click the file name.
The file appears in the Download Options dialog box.

5. Cdlick OK.

The initialization file sets values for the variables and table elements immediately after your
next full strategy download.
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IMPORTANT: When you create each variable in the strategy, you must check “Initialize on Strategy
Download” in the Add Variable dialog box.

Since download options are specific to each control engine, make sure you set the initialization file as
a download option for every control engine on which the strategy will run. Because control engines
have separate initialization files, you can use the same master strategy for two or more control
engines and configure differences in variables by customizing the initialization files.

Starting the Strategy Automatically
If you want your strategy to start automatically as soon as the strategy finishes downloading to the
controller using PAC Control Debug mode, modify the Init.txt file as follows:
1. Add the following to the end of the Init.txt file:
_RUN
2. Add 1 or more blank lines after the _RUN line
This is required; it won't work without at least 1 blank line at the end of the file.

If you are not using the other features of the Init.txt file to initialize variables after strategy download,
you can delete the rest of the content of the file.

Changing a Configured Variable

You can change a variable, but you cannot change a variable’s type.

1. Tochange a configured variable, make sure the strategy or subroutine is open and in Configure
or Online mode.

2. Ifyou are working in a strategy, on the Strategy Tree, expand the Variables folder until you see
the name of the variable you want to change. Double-click its name to open the Edit Variable
dialog box.

3. Ifyou are working in a subroutine, choose Configure > Variables. In the Configure Variables
dialog box, double-click the name of the variable you want to change.

4. Inthe Edit Variable dialog box, make the necessary changes and click OK.
If you need help, see “Adding Variables”on page 233 or “Adding Tables” on page 236.

You can also change a variable from the Configure Variables dialog box by double-clicking the
variable’s name or by highlighting it and clicking Modify.

Deleting a Variable
You cannot delete a variable that is referenced within the strategy or subroutine. Be careful when
deleting variables, since you cannot undo a deletion.
1. Make sure the strategy is open and in Configure mode.

2. On the Strategy Tree, expand the Variables folder until you see the name of the variable you
want to change. Right-click the name and choose Delete from the pop-up menu.

The variable is deleted.
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You can also delete a variable from the Configure Variables dialog box by highlighting the variable’s
name and clicking Delete.

Viewing Variables in Debug Mode

242

While the strategy is running in Debug mode, you can view its variables and modify the value of a
variable or of entries in a table. You can also view several variables at once—as well as other strategy
elements—~by putting them into a watch window.

Viewing Numeric, String, and Communication Handle
Variables

1. Make sure the strategy is running in Debug mode. On the Strategy Tree, double-click the
variable you want to view.

The Inspect Variables dialog box opens. The animated icon at the upper left assures you that
the data is fresh. The title bar includes the name of the variable and indicates whether scanning
is occurring.

Sar

“nCookie_Counter” (scanning)

Value: 42836 | GE—— Maximize button

2. Toview more options, click the Maximize button.

3.¢ "nCookie_Counter" (scanning) LIl Communication handlevariables
Name: nCookie_Counter show S|Ight|y different fields.

Value: 42908 |

DMoerls 5

— Minimize button

Scanning stops whenever you click a changeable field. It resumes once you click Apply, another
button, or an unchangeable field. If scanning resumes before you click Apply, any changes you
made are lost.

If you do not want to change the value of the variable, you can click the Minimize button to
shrink the dialog box back to its original size.

3. Toview the configuration information about the variable, click More Info.

»i) bStartFlag

HNAME: bitartFlag
DESCRIPTION:

TYPE: Integer 32 Variable
SCOPE: Flobal

INITIALIZED: Dotmload
INITIAL ¥ALUE: i

AN |

v
[ watch | [DEC » | §(§)Mmqh|1?_r_9§

s
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4. To select the display format, click the button to the right of the Watch button.

%% bStartFlag™ (scanning)
Marne:  bStartFlag

Walue: | u} |

|

® Decimal

Binary !

A numeric variable can appear as decimal, hexadecimal, or binary. A string variable can appear
as ASCll or hexadecimal.

5. Tochange the value of the variable, type the new value in the Value field and click Apply.
The field turns magenta until you click Apply.

For a string variable, if your change lengthens the string beyond its maximum width, the string
is truncated to fit.

For a communication handle variable, changing the value of the variable here has the same
effect as using a Set Communication Handle Variable command. If the communication handle
is currently open, the value will be changed but will not affect the connection.

6. To monitor the variable in a watch window, click Watch.

If you have only one watch window and it is already open, the variable appears immediately in
the window for monitoring.

Otherwise, the Add Watch Entry dialog box appears.

#1 Add Watch Entry

Mame: | Time_of_Dayp

Select Portions To WwWatch:

Walue

Select Watch Window

D | [ tew. | [ Open.

I QK H Cancel l[ Help ]

7. Check the items you want to watch.
ltems to watch vary depending on the variable type.
8. Inthe Add Watch Entry dialog box, do one of the following:

- If the watch window you want to use to monitor the variable is open, choose it from the
Select Watch Window drop-down list.
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- Ifthe watch window you want is not open, click Open. Navigate to it and double-click it to
open it.

- If you want to monitor the variable in a new watch window, click New. (For help, see
“Creating a Watch Window” on page 168.)

When the Add Watch Entry dialog box shows the correct items to watch and the watch

window you want, click OK.

The variable appears in the watch window.

Viewing Pointer Variables

1.

Make sure the strategy is running in Debug mode. On the Strategy Tree, double-click the
pointer variable you want to view.

The View Pointer dialog box appears, showing the pointer's name, type, and item pointed to.

3" "Pointer_A" (scanning)

Mame: Fointer_A
Type:  Puointer Yanable

Item Pointed To:  nLoopCounter

To view the status or value of the item pointed to, click the Inspect icon.

If you need help, follow the steps in “Viewing Numeric, String, and Communication Handle
Variables”on page 242.

Viewing Numeric and String Tables

1.

Make sure the strategy is running in Debug mode. On the Strategy Tree, double-click the table
variable you want to view.

The View Table dialog box appears, showing the table’s name, length (maximum number of
entries), width for a string table, initialization method, and security level. It also lists the index
and value of each table entry. The title bar includes the name of the variable and indicates
whether scanning is occurring.

Here's an example for a string table.

_:'J “Days_Table™ (scanning)

MName: Days_Table

Index  alue
0 Sunday
1 [Monday
2 Tuezaday
3 Wednesday
4 Thursday
b Friday
E Saturday

[ Apply | [ wiatch | [A5CH | Mo Info
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Scanning for an individual table element stops whenever you select an element in the table. It
resumes for that element if no changes are made and another table element is selected, or
when you click Apply. A magenta background indicates that scanning is stopped.

2. Tochange the format of the elements, click the button to the right of the Watch button.
I

[ apply | [(watch | [EECTY JW
Hexadecimgl

For string tables, you can select either ASCIl or Hexadecimal. For numeric tables, you can select
Decimal, Hexadecimal, or Binary.

3. To view the configuration information, click More Info.

o Yy
1 ) Day=s Tahle
=2 “Days_Table* (scar ‘\) =
Mame: Days_Table HAME: Days_Table
DESCRIPTION:
Index  “alue TYPE: string Table
0 [Sundav Mix LEMGTH: 7
1 Monday MaX WIDTH: 10
2 Tuesday SCOFE: Global
3 Wednesday | INITIALIZED: Run
4 Thursday | INITIAL VALUE: sunday
5 Friday
B Saturday \—‘
l,./'
(L &pely ] [ Watch ] [ASCIlp ] {More Info:

4. Tochange a table entry, click its index number, highlight the value, and type in a new value.
Click Apply.

5. To monitor the table in a watch window, click Watch.
The Add Watch Entry dialog box appears.

#1 Add Watch Entry

Marme: |Days_TabIe Length: |? |

Select Indexes To'watch:

@ik

() Single Index I:I

(") RBange fram | | ta | |

Select Watch Window
| v| ’ Hew. .. l [ Open... l

I Ok H Cancel ][ Help ]
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In the Add Watch Entry dialog box, do one of the following:

- If the watch window you want to use to monitor the table variable is open, choose it from
the Select Watch window drop-down list.

- Ifthe watch window you want is not open, click Open. Navigate to it and double-click it to
open it.

- If you want to monitor the variable in a new watch window, click New. (For help, see
“Creating a Watch Window" on page 168.)

Select the indexes you want to watch.

When the Add Watch Entry dialog box shows the correct items to watch and the watch

window you want, click OK.

The table variable appears in the watch window.

Viewing Pointer Tables

1.

Make sure the strategy is running in Debug mode. On the Strategy Tree, double-click the
pointer table you want to view.

The View Table dialog box appears, showing the pointer table’s name, length, and the items
pointed to. You cannot change a pointer table entry in this dialog box.

\£ "Pointer_Table” (scanning)

Marme: Painter_Table

Index Yalue
0[Tocal _Count
1 Previous_Count
2 Status
3 Alarm>

To view the status or value of the item pointed to, highlight it in the table and click More Info.

If you need help, follow the steps in “Viewing Numeric and String Tables” on page 244.

Adding Commands

To make a block in a strategy flowchart do the work it's intended to do, you add one or more
commands. Commands use the I/0 points and variables you've already configured, as well as other
elements in your strategy. A command, for example, might turn on a digital point, move a value to a
variable, or check to see whether a chart is running. PAC Control contains more than 500 commands
you can use. A command in PAC Control is often called an instruction.

You can add commands to action blocks, condition blocks, and OptoScript blocks. Continue blocks
just move flowchart logic to another block. (See “Configuring a Continue Block” on page 252.)
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To add commands to an action or condition block, follow the steps below. (To

add commands to an

OptoScript block, see “OptoScript Functions and Commands”on page 344 and “Using the

OptoScript Editor”on page 358)

1. With the strategy open in Configure or Online mode and the flowchart open, double-click the

block to which you want to add a command.

The Instructions dialog box appears. The highlighted area shows where the new command will

be added.

& Instructions - New_Chart - Block 4 Ed

Highighted area — G
Modify. ..

Delete

Next Blod:

| Previous Block I

_ The Operator grou
Operataor — P . g. P
appears in the dialog
i box only f
. ox only for
- : condition blocks, not
Cose || Hep | [CommandHelp for action blocks.
2. (lick Add to open the Add Instruction dialog box.
& Add Instruction H
Instruction:
| Absolute Value v | Select... |
Comment:
Type MName
of | All Valid Types e | | ailioughVesselPressure s |
Put Resuiltin | All Valid Types e | | aoConveyorSpeedControl w |
oK I | Cancel 1 Help [ Command Help ]
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3. Ifyou know the command you want, enter its name in the Instruction field by typing it in or by
choosing it from the drop-down list. Skip to step 7.

If you don't know the command name, click Select.

& Select Instruction x
Groups: Instructions:
Analog Point " -
Chart Add
Communication Arccosine
Control Engine Arcsine
Deprecated Arctangent
Digital Paint Clamp Float Table Element
Error Handling Clamp Float variable
10 Unit Clamp Integer 32 Table Element
1/O Unit - Event Message Clamp Integer 32 Variable
1/O Unit - Memory Map Complement
1/O Unit - Seratch Pad Cosine
Logical Decrement Variable
Divide
Miscellaneous Generate Random Number
PID - Ethernet Hyperbolic Cosine
Pointers o Hyperbalic Sine -
Sirnnil=tinn Hunerhnlic Tannant
| Cancel | Help | Command Help |

4, (lickthe name of a command group in the left column to display all the commands in that
group. In the right column, click the command you want.

For more information on any command, click the command name and click Command Help to
open help. You can also look up the command in the PAC Control Command Reference.

5.  When the command you want is highlighted, click OK to return to the Add Instruction dialog
boX.

6. (Optional) Enter a comment about the purpose of the instruction.

Comments help explain the command'’s purpose in this block and are helpful to anyone who
debugs or updates the strategy later.

7. Complete each argument for the command by typing in the Type and Name fields or by
choosing from the drop-down lists.

i Add Instruction X

Instruction:
| Subtract v Select...

Comment:

| Open pressure valve when vessel pressure is less than setpoint of 0.5 psig

~
Type Mame
| Float Variable b | | fDoughPressureSetpoint vl
Arguments — _
Minus | Float Literal ~| 0.5 V]
Put Resultin | Float Variable w | | fetpointMinusDeadband vl 3

Cancel Help Command Help
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If the argument type is a literal (or constant), you must type it in. You can use either decimal or
hexadecimal form.

If you type in the name of an item that doesn't exist, for example a variable or I/0 point, you are
prompted to add it to the strategy.

Each command requires a certain number of arguments, from zero to eight. For help in
completing arguments, see the PAC Control Command Reference or the online help for the
specific command you're using.

8. When the arguments are complete, click OK.
You return to the Instructions dialog box, which now shows the command you just added.
Notice that the comment you entered appears just above the command. The arguments you
entered appear as part of the instruction. The highlight shows where the next command will
be placed if you add another command to this block.
Here is an example of an Instructions dialog box for an action block:
ﬁ Instructions - New_Chart - Adjust Pressure Valve - Block 1 *
Comment T Open pressure valve when vessel pressure is less than setpoint of 0.5 psig Add...
Command Subtract
fDoughPressureSetpoint Modify...
Arguments —==_— Minus =
—— Put Result in f5etpointMinusDeadband Delete

Highlight ——

9.

10.

b v e Next Block

| Previous Block

Close Help Command Help

To add another command, click to place the highlight where you want the command to
appear. Click Add and repeat the steps in this section.

If you highlight a command that’s already in the dialog box, the new command will appear just
before it.

TIP: If you are adding commands to several blocks at once, you can quickly move from block to block
in the chart by clicking the Next Block or Previous Block buttons in the Instructions dialog box.

If you're working with a condition block, clicking Next Block opens a dialog box so you can select
which block to choose, since condition blocks have two exits. The same dialog box appears if you click
Previous Block and the block you're working with has connections coming from more than one block.

If you put more than one command in a condition block, complete the Operator group as
follows:

- If both commands must be true to exit the block true, click AND.
- If only one of the commands must be true to exit the block true, click OR.
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Here is an example of an Instructions dialog box for a condition block with two commands. In
this case, the block will exit true if either of the commands is true.

ﬁ Instructions - New_Chart - Sunday or Wednesday? - Block 4 *
Is dayoftheweek Add...
Equal?
To 3 Modify...
Is dayoftheweek Delete
Equal?
To 0 Next Block Either the first

command OR the
second command

| revou tock

Operator can be true for this
8”‘”0 condition block to
5 exit true.

Close Help Command Help

Changing a Command

1. With the strategy open in Configure or Online mode and the flowchart open, double-click the
block containing the command you want to change.

NOTE: To change commands in OptoScript blocks, see “Using the OptoScript Editor” on page 358.
2. IntheInstructions dialog box, double-click any line of the command you want to change.
You can also click the command to highlight it and click Modify.
3. Inthe EditInstruction dialog box, make the necessary changes.

For help, see “Adding Commands” on page 246.
4. C(lick OK to return to the Instructions dialog box, where you can see the changed command.

Deleting a Command

You can delete a command permanently, or you can comment out a command so it is temporarily
skipped, usually for debugging purposes.

Permanently Deleting a Command

1. With the strategy in Configure or Online mode and the flowchart open, double-click the block
containing the command you want to delete.

NOTE: To delete commands in OptoScript blocks, see “Using the OptoScript Editor” on page 358.

2. InthelInstructions dialog box, click any line of the command you want to delete.

CAUTION: Make sure you select the correct command. You cannot undo a deletion!

3. (lick Delete or press Delete on the keyboard.
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Commenting Out a Command

You can mark certain commands so that the strategy temporarily ignores them. Commenting out

one or more commands can help you pinpoint problems in a strategy.

1. With the strategy in Configure or Online mode and the flowchart open, double-click the block
containing the command(s) you want to comment out.

NOTE: To comment out commands in OptoScript blocks, see “Using the OptoScript Editor” on
page 358.

2. IntheInstructions dialog box, click the first command you want to comment out. Click Add.
3. Inthe Add Instructions dialog box, choose the instruction Comment (Block). Click OK.
You return to the Instructions dialog box, and all the instructions in the block from that point
on are grayed out, indicating that they will be ignored when the strategy runs.
4. (lick just beyond the last command you want to comment out. Add another Comment (Block)
instruction.
When you return to the Instructions dialog box, all commands between the two Comment
(Block) instructions are grayed out.

5.  When you no longer want the strategy to ignore the command(s), delete the two Comment
(Block) instructions.

NOTE: The Comment (Block) command is used for this purpose. The Comment (Instruction)
command just places an explanatory comment in the Instructions dialog box. It does not affect any
commands.

Cutting or Copying a Command

For commands in action, condition, and continue blocks you can cut or copy commands to the
Windows clipboard and then paste them in the same block or in another block, or even in a block of
another chart within the same strategy. For OptoScript blocks, see “Using the OptoScript Editor”on
page 358.
1. With the strategy in Configure or Online mode and the flowchart open, double-click the block
containing the command you want to cut or copy.
2. IntheInstructions dialog box, click any line of the command you want to cut or copy.
To cut or copy more than one command, hold down the Shift key while you click all the
commands to be cut or copied at once.

NOTE: To cut and paste all commands in a block, copy and paste the entire block, and then change
its name if necessary.

3. Press Ctrl+X to cut the command(s) or Ctrl+C to copy them.
You can also click the right mouse button and choose Cut or Copy from the pop-up menu.

The command is cut or copied to the Windows clipboard.
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Pasting a Command

Once you have cut or copied a command, you can paste it into any block in the same strategy.

Choose one of the following, and then press Ctrl+V:

To paste the command in the same block, click where you want to insert the command.

To paste the command at the end of the instruction block, move the cursor just below the last
instruction and click to highlight the empty space.

To paste the command to another block, click Close to exit the current Instructions dialog box
and double-click the block where you want to place the command. Click where you want to
insert the command.

Configuring a Continue Block

Continue blocks do only one thing: jump to another block. Thus, the only information you need to
provide in a continue block is the name of the block to jump to.

1.

With the strategy in Configure or Online mode and the flowchart open, double-click the
continue block you want to configure.

You can also click the block, click the right mouse button, and choose Detail from the pop-up
menu.

The Select Continue Block Destination dialog box appears, listing all blocks in the chart.

ﬁ Select Continue Block Destination *
A

Block Id: Marme Type (2

21 Restart Condition

2 Set Devices Action

[i] Start Action

36 Stop Conveyar OptoScript

3 Stop Charts Action

W

< >

Cancel Help

2. C(lick the destination block and click OK.

Viewing and Printing Chart Instructions

To view or print commands in a chart, see “Viewing and Printing Strategy or Subroutine Commands”
on page 199.
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10: Programming with
Commands

Introduction

Commands (or instructions) in PAC Control are roughly grouped by function. This chapter tells you
what you need to know about each group in order to program your PAC Control strategy effectively.
For detailed information on using a command, see Opto 22 form 17071, the PAC Control Command
Reference or form 1711, the PAC Control Command Reference, Legacy Edition.

In this Chapter

Analog Point Commands........
Chart Commands .
Communication Commands
Control Engine Commands......
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Error HaNAliNG COMM@NGS.....oooiooeeveeeeeeeeecceeeeeeeseesseeeesssesssssseeesssssssseeess s
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/0 Unit—Memory Map COMMANGS ......coveerrmerrreerrseeesseessssssesessss e 310
/0 Unit—Scratch Pad ComMmMaNdS ....ooeceeeeeerseeesseenseeesseesss e 310
LOGICAl COMMANGS ....ooce s sssssessssssssesssssssees oo 313

15

18

Mathematical Commands
Miscellaneous COMMANTS ........v.eeeeeeeeeeceerreseeseseeeseseeeeeeeeeeeeeseesesessesesesesssssssessessssssssesseen 3
PID—Ethernet COMMANGS ... eeeeeeeseeseesesseeseeseeeeeessee 318
Pointer Commands........c.......

Simulation Commands
String Commands.................
Time/Date Commands
TIMING COMMANAS oo
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Analog Point Commands

The following commands are used with analog points:

Offset and Gain Totalizers
Calculate & Set Analog Gain Get Analog Totalizer Value
Calculate & Set Analog Offset Get & Clear Analog Totalizer Value
Set Analog Gain Set Analog Totalizer Rate
Set Analog Offset

Others
Minimum/Maximum Values Get HART Unique Address
Get Analog Maximum Value Receive HART Response
Get Analog Minimum Value Receive HART Burst Response
Get & Clear Analog Maximum Value Send/Receive HART Command
Get & Clear Analog Minimum Value Set Analog Filter Weight

Set Analog Load Cell Fast Settle Level
Set Analog Load Cell Filter Weight
Set Analog TPO Period

Offset and Gain Commands

Although you normally calibrate analog points in PAC Manager, PAC Control provides commands to
set the values for a point’s offset and gain. (For more information about calibrating offset and gain, see
“Reading and Writing to Analog Points”in Opto 22 form 1704, the PAC Manager User’s Guide.)

If you already know a point’s offset and gain, you can set the values in PAC Control by using the Set
Analog Offset and Set Analog Gain commands. If you don't know the offset and gain, you can use
the Calculate & Set Analog Offset command, and then use Calculate & Set Analog Gain to have the
brain calculate the offset and the gain for you—»but again, calibration is typically performed in

PAC Manager, and not within a strategy’s logic.

Analog Totalizers

Analog totalizers are used to track total volume or quantity. For example, if an analog point
measures gallons per minute, you could use an analog totalizer to determine the total number of
gallons moved over a period of time.

To read the value and leave the totalizer running, use the command Get Analog Totalizer Value. To
read the value and set the totalizer back to zero, use the command Get & Clear Analog Totalizer Value.

Minimum/Maximum Values

The Opto 22 brain automatically keeps track of minimum and maximum values for analog input
points. Min/max values are often used to monitor pressure or temperature.

To read the minimum or maximum value and leave it as is, use Get Analog Minimum Value or Get
Analog Maximum Value. To read the minimum or maximum value and clear it—for example, to
record the minimum pressure in each 24-hour period—use Get & Clear Analog Minimum Value or
Get & Clear Analog Maximum Value.
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Analog Points and OptoScript Code

In OptoScript code, an analog I/0 point can be used directly, wherever a float variable can be used.
For example, you can assign an analog point a value, or use points directly in mathematical
expressions and control structures. For more information, see “Using I/0 in OptoScript” on page 344.

Reading or Writing Analog Points

The Move command is the main command used to read or write analog points.

Chart Commands

The following commands control charts in the strategy:

Call Chart Continue Calling Chart
Calling Chart Running? Continue Chart
Calling Chart Stopped? Get Chart Status
Calling Chart Suspended? Start Chart

Chart Running? Stop Chart

Chart Stopped? Suspend Chart

Chart Suspended?

For information about charts in a PAC Control strategy, see "PAC Control Terminology” on page 49.

About the Task Queue

How do subroutines fit into the task queue?

Whenever a chart calls a subroutine, the subroutine temporarily inherits the task in use by the
calling chart along with its priority.

Does a task always use all of its allocated time?

Not always. If a chart or subroutine runs in a loop, all allocated time is used. If a chart or subroutine
does not need all of its allocated time to complete its job, all remaining time (including any portion
of a time slice) is given up.

The following conditions cause a chart to use less than a full time slice:
«  Thechart or subroutine stops.

«  The chart or subroutine is suspended.

«  ADelay command is used.

Using the command Delay (mSec) with a value of 1 millisecond is a handy way to give up the time
slice while waiting in a loop for a condition to become True. For more information, see form 1776,
Optimizing PAC Project System Performance.

When does the requested change to a chart or task status take effect?

Not immediately. In any multitasking system, timing and synchronization issues are always a
concern. The time required for a particular request to be implemented depends on the number of
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tasks currently running and the specified chart's location in the task queue. We recommend using
commands such as Calling Chart Suspended? and Chart Running? to determine the status of a

chart.

Communication Commands

The following commands refer to moving data among entities that store and transfer data:

Accept Incoming Communication
Clear Communication Receive Buffer
Close Communication
Communication Open?

Get Communication Handle Value
Get End-Of-Message Terminator
Get Number of Characters Waiting
HTTP Get

HTTP Post Calculate Content Length
HTTP Post From String Table

Listen for Incoming Communication
Open Outgoing Communication
Receive Character

Receive N Characters

Receive Numeric Table

Receive Numeric Table Ex

Receive Numeric Variable

Receive Pointer Table

Receive String

Receive String Table

Send Communication Handle Command
Set Communication Handle Value
Send Email

Send Email with Attachments

Set End-Of-Message Terminator
Transfer N Characters

Transmit Character

Transmit NewLine

Transmit Numeric Table

Transmit Pointer Table

Transmit String

Transmit String Table

Transmit/Receive String

Communication Handles

A communication handle (also known as comm handle or COM handle) is a variable in PAC Control
that stores the parameters needed to connect to a specific entity for the purpose of exchanging
data. The entity may be another device on the network, a file located on the control engine, or some
other thing that stores or transfers data. The value of a communication handle variable is a string
consisting of communication parameters, separated by colons.

Communication handles are used to open and close communication channels, and to transmit and
receive data. You can use communication handles to:

« Communicate with devices (including serial communication modules) via an Ethernet connection
» Communicate with devices via a physical serial port on a SNAP PAC controller
« Create, read, and write data to local and remote files and tables

For example, you might use a UDP communication handle to communicate with another device on
the network via a UDP/IP connection, and use an FTP communication handle to send data from a
controller to a file on a PC.

NOTE: A communication handle is not required to use the SNAP PAC REST API. To configure HTTPS access
to your PAC’s RESTful server and learn how to call the API, visit developer.opto22.com.
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In many cases you'll define a communication handle variable and never change it, because the
parameters rarely change. However, in some cases it might be useful to change it. (Just remember
that if you change parameters while a communication handle is open, you must close the comm
handle and reopen it for the new parameters to take effect.)

PAC Control provides these types of communication handles:

For Ethernet communication via TCP/IP, or with SNAP PAC serial
modules.

TCP Note that outgoing (client) TCP communication handles in PAC
firmware R9.5a (or higher) support secure data exchange via
SSL/TLS. Currently, SSL is not supported in incoming (server) TCP
communication handles.

See page 258.

UDP For lightweight Ethernet communication via UDP/IP. See page 258.

For creating files to be stored on a control engine, and for reading or

File writing to files on a control engine.

See page 276.

For accessing files on a local file system (like a network drive), or on

FTP an FTP server. Also used to transfer files between two servers.

See page 282.

For communication with serial devices that are physically connected
via an RS-232 or RS-485 connector on a SNAP PAC R-series or
S-series controller. (Not used for serial communication modules or
serial-based I/O units.)

Serial

See page 286.

Communication Timeout Values

Each type of communication handle has a predefined default timeout value (the amount of time
the system waits for a command to complete). Timeouts prevent systems from wasting resources
when something is wrong.

Communication Handle Type Default Timeout Value
TCP 10 seconds
UbDP 10 seconds
File 1 second
FTP 30 seconds
Serial 1 second

For the TCP, UDP, and Serial communication handles, you can set a different timeout value and read
the current timeout value for an already open communication handle. For TCP and UDP only, you
can also set the timeout values for receiving data, and for opening both incoming and outgoing
communications. For details, see the “Communication Commands” section in Opto 22 form 1701,
PAC Control Command Reference.

Adding Communication Handles

Using the Add Variable dialog box, you can create variables for each type of communication handle.
For more information about variables, see “Adding Variables”on page 233.
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To add a communication handle:

1. Inthe Strategy Tree, under Variables, right-click Communication Handles, and then choose Add
to open the Add Variable dialog box.

=I5 Variables

+ |25 Mumeric Yariables
I3 String Variables

[C5) Painter Yariables

& - crimunication Handles

|5 Murneric Tables

IC5) String Tables CDI‘Iﬁg; B
|5 Painter Tables

2. Atthe minimum, complete the following fields:

— Name: Create an appropriate name, such as TCP_Handle.
- Type: Select Communication Handle.
- Initial Value: Varies with type.

—  ForTCP and UDP, see page 258.

- For File, see page 276.

—  For FTP see page 282.

- For Serial, see page 286.

Name —1 Mame: | |
Description: | |
Type—— Tvpe: | Communication Handle

Initialization
() |nitialize on strateqy download
(%) Initialize oh strategy wn
() Persistent

Initial Value —f— Initial ¥alue: |

[ u] 4 ” Caticel ][ Help ]

Using TCP and UDP Communication Handles

TCP and UDP communication handles exchange data with accessible devices anywhere on a
network and even over the Internet.

»  Use TCP when you need reliable data transmission with error handling and message retries.

«  Use UDP when bandwidth is a concern and possible data loss is not an issue.

NOTE: If the two devices that are sharing data are both control engines, it may be easier to use the Scratch

Pad areas on each to transfer data, rather than using communication commands. See “1/0 Unit—Scratch
Pad Commands”on page 310 for more information.

Because SNAP serial communication modules are IP-addressable, you communicate with them by
using a TCP or UDP communication handle (not a Serial communication handle). This way, a
strategy running on a PC or SNAP PAC device can access serial devices connected to modules on a
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remote SNAP PAC R-series or EB-series device (which in this case, acts as an Ethernet-to-Serial
converter).

NOTE: Be sure to use a separate TCP (or UDP) communication handle for each chart in a strategy. If two
charts were to run simultaneously while sharing an open communication handle, each chart would be
able to read and write data from the communication handle as if the other running chart didn't exist.
Because these reads and writes are not synchronized between the charts, it is possible for one chart to read
the other chart's data.

TCP Connections

TCPis a connection-oriented protocol, which means a connection must be established between the
client (the device requesting the data) and the server (the device providing the data) before the
devices exchange data. This connection is typically called a handshake. TCP ensures reliable data
transmission, but the handshake and reliable data transmission require more bandwidth than UDP.

Outgoing (client) TCP communication handles in PAC firmware R9.5a (or higher) support secure
data exchange via SSL/TLS—two similar types of Internet protocols that provide authentication
(that is, established proof of identification) over an encrypted network channel. Lower versions of
PAC Control and PAC firmware support SSL over TCP only with the HTTP Get, HTTP Post, Send Email,
and Send Email With Attachment commands. (UDP protocol does not support SSL/TLS.) For more
information about SSL/TLS, see “Installing CA Root Certificates”on page 290.

Incoming and Outgoing Communication
TCP and UDP communication is normally requested by the device that needs the data.

For example, when a PAC Control strategy running on a SNAP PAC I/O unit needs the value of a set
of variables from another strategy running on a different SNAP PAC controller:

«  The controller (the client) requests communication using the command, Open Outgoing
Communication.

«  Thesecond controller (the server) uses the Listen for Incoming Communication command, and
then the Accept Incoming Communication command to establish the connection.

Once connected, data is transmitted and received in both directions.

Depending on the situation, you may want to have both devices request communication and
establish two connections between them. That way if one device goes offline and then comes
online, you can have the flowchart logic set up to immediately open communication again.

In some cases, however, one of the devices may be incapable of requesting communication; for
example, a serial device such as a barcode reader attached to a serial communication module on a
controller. The serial device is incapable of requesting Ethernet communication; essentially it can
only listen and provide data when asked. In cases like this, the controller must use Open Outgoing
Communication to initiate communication. (For serial devices attached directly to a serial port on a
SNAP PAC controller or brain, see “Using Serial Communication Handles to Communicate with Serial
Devices”on page 286.)

Outgoing Communication. For outgoing communication (that is, communication initiated by
the client), the communication handle’s value is in the format:

UDP udp:<Server's IP address or hostname> - <port that is listening for requests>
Basic TCP tcp:<Server's IP address or hostname>: <port that is listening for requests>
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SSL/TLS over TCP tcp=<Secure server's [P address or hostname> - <port that is listening for
requests>,ssi[]

Note the comma after the port number and the empty square brackets
after “ssl”

NOTES:
«  "tcp”and “udp”are lowercase.

»  Ahostname is user-friendly name for the IP address. Hostnames are usually created by a
company’s IT department. (Before you substitute a hostname for a controller's IP address, use
PAC Manager to configure the DSN parameter for the controller. For details, see Opto 22
form 1704, the PAC Manager User’s Guide.)

«  Forinformation about ports, see page 261.

+  OnlyTCP supports outgoing (client) communication with SSL/TLS authentication and
encryption. To use SSL/TLS, your controller must have an installed security certificate. (For
information about security certificates, see “Installing CA Root Certificates”on page 290.)

The following table shows examples of TCP and UDP communication handles for outgoing
communication.

Communication Handle Value

Outgoing Communication
Protocol:Server’s IP Address or Hostname:Port,

Ethernet TCP - to a serial communication module on

another rack tcp:10.192.54.10:22506

Ethernet TCP - to a remote server (using the

server's hastname) tcp:mmy_server:255

Ethernet TCP (with secure SSL/TLS) - to a remote

tcp:10.192.56.185:443,ss1[]
server

Ethernet TCP - to a serial communication moduleon | tcp:10.192.55.90:22511
the same rack (uses SNAP PAC R-series IP address | or
or loopback IP address) tcp:127.0.0.1:22511

Ethernet UDP - to a serial communication module on

another rack udp:10.192.54.10:22506
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To add a communication handle to a PAC Control strategy, see the steps starting on page 257. In the
Add Variable dialog box, enter the communication handle value in the Initial Value field.

Add Variable X

Mame: TCP_Comm_Handle_Outgoing
Description:

Tupe: Communication Handle
Initialization
() Initialize on strategqy download
(%) Initialize on strategy wn
() Persistent
Communication
handle value

Imitial ¥alue: |top:10.152.56.185:22004

[ Ok, H Cancel ][ Help ]

Port Numbers. To communicate with other control engines or other devices on a network, you
can use any port number that is not already in use by that device. For example, you can safely use
ports 22004 and 22005, which have been assigned to Opto 22 by the Internet Assigned Numbers
Authority (IANA). Opto 22 has allocated these Ethernet port numbers for customer use. In general,
anything below 1024 is already predefined and shouldn’t be used unless you are implementing a
predefined protocol that already has a reserved port.

If you do not know what port number to use, ask your network administrator or check the list of
standard reserved Ethernet port numbers at www.iana.org/assignments/port-numbers to see ports
that may apply to your devices on your network.

The following port numbers are the defaults, reserved by Opto 22 devices for the purposes shown.

Port# | Purpose

20 FTP (file transfer protocol) for get, send, and dir

functions
21 FTP (file transfer protocol)
25 SMTP (simple mail transfer protocol)
161 SNMP-based enterprise management systems
502 Modbus/TCP
2001 Main command processor, OptoMMP-based (also
used by SNAP PAC controllers and brains)
iigfs Ethernet/IP

22000 Opto 22 controllers and brains

Host port (for information on configuring the host
22001 port, see Opto 22 form 1704, the PAC Manager User’s
Guide)

22002 | Opto 22 controllers and brains

22003 | Opto 22 controllers and brains
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262

Port# | Purpose

22500~ Serial communication modules
22531

50000~ Internal messagin

50999 g

Note that port numbers on the SNAP PAC controllers and brains are the default ports; some may
have been changed for security reasons. (For more information, see the section on Security in
Opto 22 form 1704, the PAC Manager User's Guide.)

Incoming Communication. For incoming communication (that is, communication requested
by another device), the communication handle value includes just the protocol and the port
number: Protocol -Port. TCP automatically tracks senders so there is no mix-up in the data sent
and received. Here are a couple of examples of communication handles for incoming
communication:

Communication Handle Value

Incoming Communication
Protocol:Port

Ethernet TCP (for example, to use a controller as an HTTP server) | tcp:80

Ethernet UDP (for example, to listen for packets being streamed

from a remote 1/0 unit) udp:5001

To add a communication handle, see the steps starting on page 257. In the Add Variable dialog box,
enter the communication handle value in the Initial Value field.

Mame: | TCP_Comm_Handle_| ncoming |
Description: | |
Type: | Communication Hande v |

Initialization

() Initislize on strateqy download

(%) Initialize on strategy wn

() Persistertt
Communication
handle value

Initial Yalue: [tcp:22004 }

[ Ok H Cancel ][ Help ]

Opening and Closing TCP Communication Handles

When using TCP communication handles, keep in mind that the controller has a limited amount of
TCP/IP resources, so you need to be careful about how frequently these communication handles are
opened and closed. TCP communication handles are meant to be left open as long as possible.

Per the TCP/IP specification, each time one of these resources is closed, the closed resource
unavailable for 120 seconds. Rapidly attempting to open and close TCP communication handles
quickly places all available resources in the unavailable condition.
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Once this unavailable state occurs, a communication handle will be unable to gain a resource upon
the next Open Outgoing Communication command. This effectively causes a lock out of any new
TCP/IP connections to be made with the controller (whether from the strategy or externally).

The lock out affects applications such as PAC Control, PAC Display, PAC Manager, OptoOPCServer,
and PAC Terminal. These applications will either have intermittent or no connectivity with the
controller.,

The solution to this dilemma is to control the rate at which TCP communication handles are opened
and closed. When a TCP communication handle is closed (whether a result of a prior successful or
unsuccessful opening), it should be reopened no sooner than 3 seconds. If this reopening fails to
succeed, double the delay to 6 seconds. If this subsequent reopening fails, double the delay to 12
seconds. And thereafter, subsequent reconnections should be performed no shorter than every 24
seconds. This throttling of the opening allows several TCP/IP resources to expire their closing timer.

TCP and UDP Communication Handle Examples

The following diagram shows an example of a communication handle value for outgoing
communication:

Outgoing Communication

SNAP R-series 1/0 Device A
IP address: 10.192.59.45 [P address: 10.192.59.31

B Request communication

Receives communication
on port 22004

: H ¢ Communicate >

Communication Handle value:
tcp:10.192.59.31:22004 or udp:10.192.59.31:22004
L

\

/
IP address Port number

For incoming communication, the communication handle value could be:

Incoming
Communication

SNAP R-series I/0 Device A
IP address: 10.192.59.45 IP address: 10.192.59.31
B L
" Request communication o
o H Sends communication to

10.192.59.45 on port 22004

.
Communication Handle value:
tcp:22004 or udp:22004

i Communicate
4 > T

Communication Handles for Serial Communication Modules. For communication
with serial devices through a serial communication module, the communication handle value
consists of the IP address of the brain the module is attached to, plus the serial module’s port
number according to its position on the rack.
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NOTE: For port number information, see “Establish an Ethernet Connection” in Opto 22 form 1191, the
SNAP Serial Communication Module User’s Guide.

Here are two examples of communication handles for communicating with serial modules, the first
showing communication through a module on the same rack as a SNAP PAC R-series controller, and

the second showing communication through a module on a different rack.
For a serial module on the same

To a Serial Module on the Same Rack rack, use the loopback IP address
127.0.0.1, which tells the brain to
SNAP R-series /0 talk to its own rack. You can also use

Serial Device the brain’s own IP address (in this
example, 10.192.59.45), but the
loopback address allows you to
change the IP address of the brain

%f" e without having to change the
communication handle.

Communication Handle value:
tcp:127.0.0.1:22507 or udp:127.0.0.1:22507
ortecp: 10 192.59.45: 22507 or udp:10.192.59.45:22507

IP-address: 10.192.59.4

SNAP-SCM
port 22507
il

IP address Port number  NOTE: For port number information, see “Establish an
Ethernet Connection”in form 1191, the SNAP Serial
Communication Module User's Guide.

To a Serial Module on a Different Rack

SNAP R-series I/0 SNAP EB-series I/0
IP address: 10.192.59.45 IP address: 10.1 92 5962
Serlal Dewce
Ethernet network
| Ay I o SNAP-SCM
e S o> o PO 22507
.

Communication Handle value:

tcp:10.192.59.62:22507 or udp:10.192.59.62:22507
| ! |

P address{ po>t number  NOTE: For port number information, see “Establish an
Ethernet Connection” in form 1191, the SNAP Serial
Communication Module User's Guide.

Using Flowcharts to Control TCP or UDP Communication

When a control engine is communicating with another device using TCP or UDP, it runs a
PAC Control flowchart or charts to control communication.

«  For outgoing communication on controller COM ports and serial modules, the
flowchart uses the command Open Outgoing Communication to request a connection.

»  Forincoming communication on controller COM ports, which is requested by another
device, the flowchart must first use Listen for Incoming Communication and then use Accept
Incoming Communication to establish a connection.
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+  Forincoming communication on serial modules, which is requested by another device,
the flowchart uses the Open Outgoing Communication and Communication Open?
commands to establish a connection.

The control engine’s TCP/IP flowcharts should open communication once and then continue to
transmit or receive using the communication handle. Constantly opening and closing
communication for each transaction wastes time and is inefficient.

As a simple example, the flowchart at right is

designed to receive data from a serial device, such
as a barcode reader, through a serial :
communication module on the same rack as a oo - - - | Block0
SNAP PAC R-series /O unit. L

Communication with serial modules in this
example is done via TCP. It can be done from the
SNAP PAC R-series system itself, as in this example,

~ Serial_Comm™

-
1
Open outgoing
communication

or from another TCP/IP device on the network. . 5
In this example, the R-series |/0 unit establishes " eetwofchar
communication through the serial module using o

the communication handle: e m

tcp:127.0.0.1:22507 : _I‘ e

The loopback IP address is used, since the serial : .I 2

module is on the same rack. _ .

When characters are detected in the receive buffer, ff [

the I/0 unit receives the string and processes it, . | Recenve String

and then after a short delay checks for another o e

message. Communication remains open for L -

additional messages. (jshoieuts 1o
fLLe T2 Chart /

This simple flowchart illustrates the basics of
handling communication, without any error checking. However, while receiving and transmitting,
TCP/IP control charts should also monitor the status value returned by commands such as Transmit
Numeric Table and Receive Numeric Table, and close communication if there are errors. If your

PAC Control application opens sessions but does not close unused or bad sessions, the maximum
number of sessions could be used up. Note that communication should not be closed for timeout
errors from Receive commands (error numbers —37 and —39), however, because these errors simply
mean that there was no data waiting in the receive buffer for the specified session.

To save time, before using a Receive command (such as Receive String or Receive Numeric Table),
TCP/IP charts should use the command Get Number of Characters Waiting. If there are zero
characters waiting, then there is no reason to use the Receive command. It is also a good idea to
start a down timer, and then loop on the Get Number of Characters Waiting command until either
there are more than zero characters waiting, or the timer expires.

The following chart is also an example of TCP/IP communication on controller COM ports, but with
three differences: in this case another device is requesting communication, the peer will both
transmit and receive, and error checking is shown for the commands Get Number of Characters
Waiting and Receive Numeric Table.
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Similar error checking should be used for transmit commands, which in this strategy are in another
chart.

*= Incoming_Comm_Control

.......... K Block 0 e A¥e A¥e A¥e AUe AU A¥e AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV AV 4

communication

2 Accept inc

s nicati‘on ........................
N T R R R
- | Delay 10 msec

Close
- Lcommunication

_[# Clear receive
buffer

?Call Transmit chart

(1) Shortouts :‘ID_D°/° v

[1> T2 Chart /

If the devices communicating with each other are all SNAP R-series, be careful not to have one of
them send information to another faster than the receiving system can pull it out of its receive
buffer. When a control engine receives data from the Ethernet network, it holds the data in memory
(the buffer) until the PAC Control flowchart removes it with a Receive command. If the data is not
removed fast enough, the receive buffer will fill up. You can prevent this problem by transmitting
the information less frequently. If the same chart is transmitting and receiving, you can alter the
chart so that it receives more often than it transmits.

Ethernet Connections and Ports

The number of Ethernet connections available varies by hardware, type, and in some cases firmware
version, such as 80 on current SNAP PAC R-series I/0 systems.

The host connection is on port 22000 or 22001 and is used to communicate with the PC that runs
PAC Control. These port numbers are reserved for this purpose, but they can be configured. For
information see Opto 22 form 1704, the PAC Manager User's Guide.

Peer-to-peer connections can be on any other port number that is not already used on the network;
these connections are used to communicate with other control engines or other devices on the
network. When you assign port numbers for peer-to-peer connections, make sure you do not assign
port numbers that devices on your network may use for specific purposes. For a list of standard
Ethernet port numbers, refer to: www.iana.org/assignments/port-numbers

IMPORTANT: If you are using TCP/IP or UDP connections, consult commercially available texts on
TCP/IP or UDP that discuss client/server architectures, so you'll understand how the protocol works and
what to expect during communication.
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UDP Communication Handles

The User Datagram Protocol (UDP) is a fast, lightweight communications protocol that is sometimes
used as an alternative to TCP (see page 258). UDP is used to transmit messages—called
datagrams—across an IP network from a source IP address and source UDP port to a destination IP
address and destination UDP port. UDP communication handles most often used when bandwidth
is a concern and reliable data transmission is not required.

Important Characteristics of UDP
«  Uses port numbers to help distinguish different types of requests.
«  Hasan optional checksum function to ensure the datagram is delivered intact

«  Uses a connectionless transmission model, which means it doesn’t do a “handshake” or
otherwise ensure that the receiving IP address is available and ready to receive.

+  Does not guarantee datagram delivery. If a delivery fails, it does not perform retries.

+  Does not preserve datagram sequencing. Datagrams may arrive at the destination in a different
order than they were sent.

« Isunaware of congestion at the receiving IP address. If the receiver's queue becomes full,
subsequent datagrams are dropped.

The following table describes the available categories of PAC Control UDP communication handles:

chelD Local Characteristics Remote Characteristics e
Category Handle Value

May be used to communicate with
multiple remote IP addresses and
ports by using the command “Send
Communication Handle Com-
mand, “set.dst:<ip

The local UDP port is speci-

Local Bound | fied by the communication udp:<local port>

handle. address>:<port>" or “set.dst:<host-
name with fully qualified domain
name>:<port>.
Remote Local UDP port is chosen by Co.mmumcate‘s with ?he communi- udp:<remote IP
. cation handle’s specified remote IP )
Bound the operating system. address>:<remote port>

address and port.

Can be used to communicate with
multiple remote IP addresses and
ports by using the command “Send
Local UDP port is chosen by | Communication Handle Com-

the operating system. mand” with a destination string like
“set.dst:<ip address>:<port>" or
“set.dst:<hostname with fully quali-
fied domain name>:<port>.

Unbound udp:

NOTE: Be sure to use a separate UDP (or TCP) communication handle for each chart in a strategy. If two
charts were to run simultaneously while sharing an open communication handle, each chart would be
able to read and write data from the communication handle as if the other running chart didn't exist.
Because these reads and writes are not synchronized between the charts, it is possible for one chart to read
the other chart's data.
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Configuring a Local Bound UDP Communication Handle

Alocal bound communication handle is used to receive UDP datagrams through a known UDP port.
You can also configure the communication handle to transmit data to a specific destination. For
details, see the “Set Communication Handle Value” command.

To add a communication handle to a PAC Control strategy, see the steps starting on page 257. In the
Add Variable dialog box, enter the communication handle value in the Initial Value field.

The local bound communication handle value has the following format:
udp:<local bound port number>

Example:

udp:23456

OptoScript example:

SetCommunicationHandleValue(“udp:23456”, cmhMyLocalBoundCommHandle);
Action block example:

configure the local bound communication handle value add...

Set Communication Handle Value
From "udp:23456" Madify. ..

To cmhMyLocalBoundCommHandle
Delete

Mext Blodk

Previous Block

Command Help

In this example, any data sent via UDP to UDP port 23456 will be received by the PAC Control
strategy. UDP datagrams sent to the bound port will be received on all active Ethernet or Wireless
Ethernet interfaces.
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The communication handle value may be configured when defining the communication handle in
the strategy tree. Set the “Initial Value”field when the communication handle is set to be “Initialize
on strategy download” or “Initialize on strategy run.”

Edit Variable “

Mame: cmhMyLocalBoundCommHandle

Description: | Bound UDP comm handle.

Type: Communication Handle
Initialization
() Initialize on strategy download
i Initialize on strategy run

() Pergistent

Initial Value: | udp: 23456

For more information about defining variables in the strategy, see “Adding Variables” on page 233.

Configuring a Remote Bound UDP Communication Handle

A remote bound UDP communication handle is typically used to communicate to another device
that receives UDP datagrams on a bound (preset) port number. The remote port number allows
transmitters to direct the datagram’s destination.

To add a communication handle to a PAC Control strategy, see the steps starting on page 257. In the
Add Variable dialog box, enter the communication handle value in the Initial Value field

The remote bound communication handle value has the following format:
udp:<remote IP Address>:<remote port number>

Example:

udp:192.168.1.100:23456

OptoScript example:

SetCommunicationHandlevValue(*“udp:192.168.1.100:23456",
cmhMyRemoteBoundCommHandle) ;
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Action block example:

configure the remote bound communication handle value Add. ..

Set Communication Handle Value
From "udp:192.168.1.100:23456" Modify...

To cmhMyRemoteBoundCommHandle
Delete

Mext Block

Previous Block

Command Help

The example configures a communication handle that transmits data to the destination host IP
address 192.168.1.100, UDP port 23456.

Configuring an Unbound UDP Communication Handle

The unbound communication handle is very similar to the remote bound category. The only
difference is the communication handle value does not specify the local port.

To add a communication handle to a PAC Control strategy, see the steps starting on page 257. In the
Add Variable dialog box, enter the communication handle value in the Initial Value field.

The unbound UDP communication handle value has this format:
udp:
OptoScript example:

SetCommunicationHandleValue(“udp:”, cmhMyUnboundCommHandle);
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Action block example:

configure the unbound communication handle value Add. ..

Set Communication Handle Value
From "udp" Modify...

To cmhMyUnocundCommHandle
Delete

Mext Block

Previous Block

| Command Help

Opening the UDP Communication Handle

To open either an unbound or bound communication handle, use the OpenOutgoingCommunication
command.
OptoScript example:

i320penUnboundResult =
OpenOutgoingCommunication(cmhMyRemoteBoundCommHandle) ;

1320penBoundResult =
OpenOutgoingCommunication(cmhMyLocalBoundCommHandle) ;

Action block example:

open the remote bound communication handle Add. ..

Open Qutgoing Communication
Communication Handle cmhMyRemoteBoundCommHandle Modify...
Put Result in i220penUnboundResult
Delete
open the local bound communication handle
Open Outgoing Communication Mext Block
Communication Handle cmhMyLocalBoundCommHandle
Put Result in i320penLocalBoundResult Previous Block

M

Help | Command Help
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To find out if the handle opened successfully, inspect the result from the
OpenOutgoingCommunication command. A zero result means the opening succeeded. A negative
value indicates the communication handle was not opened.

Closing the UDP Communication Handle
To close any communication handle, use the command “CloseCommunication.”

OptoScript example:
CloseCommunication(cmhMyRemoteBoundCommHandle) ;

Action block example:

Close Communication
Communication Handle cmhMyLocalBoundCommHandle
Put Status in i32CloseResult Modify...

I, O

Mext Blodk

Previous Block

Command Help

Many applications never close a communication handle once they are opened. If a communication
fault were to occur on an unbound communication handle, the handle continues to remain open
and may still be used to resume communications. If the communication handle was bound, it too
remains open and datagrams will be received once the network problem is corrected.

Transmitting Datagrams with a Remote Bound Communication Handle

The following commands may be used to transmit data with an open UDP communication handle.
»  Transmit Character®

+  Transmit Numeric Table

«  Transmit Pointer Table

«  Transmit String

«  Transmit String Table

«  Transmit/Receive String

*|f transmitting several sequential characters of a string, use Transmit String instead.

When using these commands, the data may be transmitted to the IP address and UDP port specified
when the UDP communication handle was opened.
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To add a communication handle to a PAC Control strategy, see the steps starting on page 257. In the
Add Variable dialog box, enter the communication handle value in the Initial Value field.
OptoScript example:

i32TransmitResult = TransmitNumTable(4, 2, i32tMyDataTable,
cmhMyRemoteBoundCommHandle) ;

Action block example:

transmit data from remote bound to local bound communication handle Add. ..
Transmit Numeric Table
Length 4 Modify. ..
Start at Index 2
Of Table i32tRemoteBoundReceivedData Delete
Communication Handle cmhMyRemoteBoundCommHandle
Put 5tatus in iJZRemoteBoundTransmitResult Mext Block

I, < io-s Sock

|| Help | Command Help

This example transmits elements 2, 3, 4, and 5 of table i32tMyDataTable to the IP address
192.168.1.100, UDP port 23456. All four elements are transmitted in a single datagram over the
network.

Transmitting Datagrams with a Local Bound Communication Handle

Transmitting with a bound communication handle requires the communication handle’s
destination (the IP address and port) to be set. Use the command “Send Communication Handle
Command”to configure these destination parameters. Once the destination is set, the same data
transmit commands may be used.

To add a communication handle to a PAC Control strategy, see the steps starting on page 257.In the
Add Variable dialog box, enter the communication handle value in the Initial Value field.

OptoScript example:

i32SendResult = SendCommunicationHandleValue(cmhMyLocalBoundCommHandle,
“set.dst:192.168.1.101:123457);

i32TransmitResult = TransmitNumTable(4, 2, i132tMyDataTable,
cmhMyLocalBoundCommHandle) ;
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Action block example:

i Instructions - Powerup - Example “
Send Communication Handle Command ~ Add. ..
Communication Handle cmhMyLocalBoundCommHandle
Command "set.dst:192.168.1.101:12345" Modify...
Put Status in ijJ25etResult
Delete
Transmit Humeric Table
Length 4 Mext Block
Start at Index 0
Of Table i2tLocalBoundModifiedData Previous Block
Communication Handle cmhMyLocalBoundCommHandle
Put Status in idJ2LocalBoundTransmitResult

e

Close Help Command Help

This example first configures the local bound UDP communication handle to transmit the data to
the IP address 192.168.1.101, UDP port 12345. Subsequent data transmissions will be sent to the
same IP address and UDP port until a SendCommunicationHandle with a new destination IP address
or UDP port is commanded.

Determining when a Datagram Has Arrived

Use the command “Get Number of Characters Waiting”to determine if datagrams have arrived on
the UDP communication handle.

OptoScript example:
i32BytesWaiting = GetNumberOfCharsWaiting(cmhMyLocalBoundCommHandle) ;
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Action block example:

& Instructions - Powerup - Example “
Get Number of Characters Waiting Add. ..
Communication Handle cmhMyLocalBoundCommHandle
Put in i3Z2LocalBoundDataWaiting Modify...
I | -
Mext Blodk
Previous Block

Close Help Command Help

The strategy should inspect the result value from the command. When positive, this indicates the
amount of data pending. When receiving a positive result, the value indicates the amount of data
contained in the current datagram.

In some cases, a timer is used to limit how long the chart will wait for data to arrive. This is usually
configured as a loop and includes either an up- or down-timer to monitor the elapsed time. Within
the loop, checking for the number of characters waiting, include a “Delay Millisecond”command
with a reasonable delay time to allow the chart to release its timeslice.

Receiving Datagrams

Use the following commands to receive datagrams from a bound or unbound UDP communication
handle.

«  Receive Character

+  Receive N Characters

+  Receive Numeric Table

«  Receive Numeric Table Ex
»  Receive Numeric Variable
«  Receive Pointer Table

+  Receive String

+  Receive String Table

When the chart logic has determined that a datagram is pending on the communication handle,
the data may be received.

When receiving the datagram, ensure that all of the bytes contained within the current datagram
reported by the command “Get Number Of Characters Waiting”are received. Once all the data of the
current UDP datagram is received, the next datagram may be received. The reading of the entire
datagram within PAC Control's implementation of UDP messaging differs from typical programming
environment “socket”implementations.
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Retrieving The Received Datagram’s Source IP address And Source UDP port

When a datagram is received, the identity of the transmitter can be retrieved using the “Send
Communication Handle Command”command. The command returns the values in a numeric
format. To set a destination address and port so that a reply can be sent on the same
communication handle, these values must be converted to strings and formatted into a command
string understandable by Send Communication Handle Command.

OptoScript example:
// retrieve the datagram’s source IP address and source port

i32SourcelpAddress = SendCommunicationHandleCommand(cmhMyBoundCommHandle,
'get.src');

i32SourcePort = SendCommunicationHandleCommand(cmhMyBoundCommHandle,
"'get.srcport');

// convert numeric source values to strings
Int32TolpAddressString(i32SourcelpAddress, sSourcelpAddress);
NumberToString(i32SourcePort, sSourcePort);

// create a command string for the “Send Communication Handle Command”
sReplyAddress = “set.dst:” + sSourcelpAddress + ":" + sSourcePort;

The result stored in sReplyAddress (for example “set.dst:192.168.1.100:54321") is used as the
command string to set the next transmission destination to send a datagram to IP address
“192.168.1.100," port 54321.

Using the Control Engine’s File System

The memory available for file storage is about 4 MB on a PAC S-series controller, or 2 MB on a PAC
R-series controller. File storage on a SoftPAC controller is limited only by the size of your hard drive
and the volumes available on your network. Any types of files can be stored there, and files can be
sorted into directories or folders just as they can on a PC. These stored files are then available for use;
for example, the control engine can read them, add data to them, and even send data from them via
FTP to another device on the network. SNAP PAC controllers also allow you to store data or files
using a microSD card. For more information about using a microSD card, see the user’s guide for the
controller.

NOTE: Certain FTP commands may also be useful when dealing with files, even if the files are all local. For
example, the dir command is available with comm handles.

The file communication handle is used to create, write to, and read from stored files on the control
engine. The format for the handle’s value is: file:<open mode>,<filename>

Note that File isall lowercase. Open modes are:

Open mode Description

r Opens a file for reading. If the file does not