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Introduction
The Opto 22 software utility PAC Manager™ must be used to configure E1 and E2 
brain boards with compatible racks and modules. (This combination of brain board 
with I/O rack and modules is called an I/O unit.) This technical note describes how to 
configure E1 and E2 I/O units for an I/O system that uses one—or more—of the 
following applications:

• PAC Control™, OptoOPCServer™, or OptoDataLink™—PAC Control is 
Opto 22’s flowchart-based programming application for creating control 
programs that run on Opto 22’s SNAP PAC programmable automation 
controllers. OptoOPCServer is an OPC 2.0-compliant data server for data 
connectivity with OPC clients. OptoDataLink provides bi-directional data 
exchange with common SQL databases.

PAC Control is part of Opto 22’s PAC Project Basic™ software suite, which also 
includes PAC Display™ human-machine interface (HMI) software. Since PAC 
Display uses the control program you create in PAC Control, no additional 
changes are needed to use E1 or E2 brain boards with PAC Display. 
OptoOPCServer and OptoDataLink can be purchased separately or as part of 
PAC Project Professional; they also use the I/O configuration you set up here.

• A Modbus/TCP application such as a SCADA package.

• A custom application written using Opto 22’s memory-mapped OptoMMP™ 
protocol.

Configuring an E1 or E2 I/O unit is usually a one-time task that is done as part 
of commissioning a new E1 or E2 brain board for use in an I/O system. After an E1 or 
E2 I/O unit is configured and its configuration information stored to flash memory, 
the I/O unit is ready for use with the kinds of applications listed above.

For Optomux Users
This technical note does not apply to E1 or E2 brain boards used in an Optomux I/O 
system (on either a serial or Ethernet network). Configuration for Optomux 
operation is done using jumpers on the brain board and in the Optomux application 
itself. See the E1 and E2 User’s Guide (Opto 22 form 1563) and the Optomux Protocol 
Guide (Opto 22 form 1572) for instructions and more information.

Requirements
This technical note assumes the following:

• E1 and/or E2 I/O units are already attached to your Ethernet network and have 
been assigned network IP addresses. If an I/O unit does not yet have an IP 
address and other network information assigned to it, configure these settings 
now, following the instructions in the PAC Manager User’s Guide (Opto 22 form 
1714).
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• PAC Manager software is already installed on your computer. PAC Manager is included 
on the CD shipped with E1 and E2 brain boards, and is also available as a free 
download from the Opto 22 website.

Documentation
See the following guides for additional information on using E1 and E2 I/O units and 
related software applications:

For Help
If you are having trouble and cannot find the help you need in this technical note or in the 
documentation listed above, contact Opto 22 Product Support.

Phone: 800-TEK-OPTO (800-835-6786)
951-695-3080
(Hours are Monday through 
Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

Preparing for Configuration
When you use E1 and E2 I/O units with any protocol except Optomux, you are 
communicating with the E1’s or E2’s memory map. Because the memory map was 
originally developed for SNAP Ethernet brains, it is based on SNAP modules, which differ 
from the modules used with the brain boards. Currently, E1 and E2 I/O units must be 
configured as if they were SNAP Ethernet I/O units.

For using See these guides Opto 22 form

E1 and E2 E1 and E2 User’s Guide 1563

PAC Manager PAC Manager User’s Guide, Legacy Edition 1714

PAC Control
PAC Control User’s Guide
PAC Control Command Reference
PAC Control Commands Quick Reference Card

1700
1701
1703

OptoOPCServer OptoOPCServer User’s Guide 1439

PAC Display PAC Display User’s Guide 1702

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.
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I/O System Inventory
Before starting to configure E1 and E2 I/O units, collect information on the I/O units in your 
I/O system, including network settings and installed I/O modules. You can use the “E1 and 
E2 I/O Unit Inventory Form” on page 25 for this purpose. Copy the form for each I/O unit 
and fill it in so all the information you need is in one place.

For each analog module on the inventory form, determine the corresponding SNAP 
module and initial scaling from the following tables and write it on the form.

Analog Input Modules and Initial Scaling

For this G1 analog input module... ...select this SNAP analog input module and
initial scaling.

AD2T: 0 - 20 mA SNAP-AIMA: -20 - +20 mA

AD3 or AD3T: 4 - 20 mA SNAP-CUSTOM-AI: Mode 1

AD4: ICTD Temp. Probe SNAP-AICTD: ICTD Temp. Probe, Degrees C

AD5 or AD5T: Type J TC SNAP-AITM: Type J Thermocouple, Degrees C

AD6, AD6T, or AD6HS: 0 - 5 VDC SNAP-AIV2-i: -50 - +50 VDC

AD7: 0 - 10 VDC SNAP-AIV2-i: -100 - +100 VDC

AD8 or AD8T: Type K TC SNAP-AITM: Type K Thermocouple

AD9T: 0 - 50 mV SNAP-AITM2-i: -50 - +50 mV

AD10T2: 100 Ohm RTD SNAP-AIRTD: 100 Ohm Pt 3-wire

AD11: -5 - +5 VDC SNAP-AIV: -5 - +5 VDC

AD12: -10 - +10 VDC SNAP-AIV: -10 - +10 VDC

AD13T: 0 - 100 mV SNAP-AITM: -150 - +150 mV

AD14T: 10 Ohm RTD SNAP-AIRTD: 120 Ohm Ni 3-wire

AD15T: 28 - 140 VAC SNAP-AIVRMS: 0 - 250 VAC/VDC

AD16T: 0 - 5 A AC/DC SNAP-AIARMS: 0 - 10 A AC/DC

AD17T: Type R TC SNAP-AITM2: Type R Thermocouple

AD17T: Type S TC SNAP-AITM2: Type S Thermocouple

AD18T: Type T TC SNAP-AITM2: Type T Thermocouple

AD19T: Type E TC SNAP-AITM: Type E Thermocouple

AD20: Rate (Freq) SNAP-AIRATE: Rate (Frequency)
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Analog Output Modules

Important Notes
E1 I/O units—Because the E1 is not exactly like any SNAP brain, there is one limitation: to 
use counters, you can use no more than eight points on the unit (similar to a 
SNAP-B3000-ENET, which supports a maximum of eight digital modules on the rack). If you 
are not using counters, up to 16 points can be used (similar to a digital-only 
SNAP-ENET-D64, which does not support counters).

Configuring I/O Units
Follow the steps in each section to configure each E1 and E2 I/O unit on your network. 
Note that you can include multiple E1 and E2 I/O units in a single configuration file.

IMPORTANT: Even if you plan on using E1 and E2 I/O units with PAC Control, you must use PAC 
Manager to create a new configuration file, configure points, and save the configuration to flash 
memory on the brain. For an E2, custom scaling (and calibrating offset and gain, if necessary) are 
separate steps that require a second save to flash. Follow the steps below.

Creating a New Configuration File
1. If PAC Manager is not already open, choose Start > Programs > Opto 22 > PAC Project 

Software > PAC Manager.

2. In the PAC Manager main window, click the New button  or choose File > New. 

3. In the Create New Tag Database dialog box, navigate to the location where you want 
the file to be. Type a filename. Click Open.

A new configuration tree appears. (If you are familiar with PAC Control, ioControl, or 
OptoControl, you’ll notice that this window looks like part of a Strategy Tree.) 

For this G1 analog output module... ...select this SNAP analog output module.

DA3:  4 - 20 mA
DA3T: 4 - 20 mA

SNAP-AOA-3: 4 - 20 mA

DA5:  0 - 10 VDC SNAP-AOV-5: 0 - 10 VDC

DA7:  -10 - +10 VDC SNAP-AOV-7: -10 - +10 VDC

DA4:  0 - 5 VDC
DA4T: 0 - 5 VDC

SNAP-AOV-25: 0 - 10 VDC

DA6:  -5 - +5 VDC SNAP-AOV-27: -10 - +10 VDC

DA8:  0 - 20 mA SNAP-AOA-28: 0 - 20 mA
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You can expand and collapse the folders to see or hide the I/O units and points in 
them. Closing the configuration tree is the same as closing the configuration file.

4. To save the configuration file, click the Save button  or choose File > Save.

5. Once the file is saved, continue with the next section, “Adding an E1 or E2 I/O Unit.”

Adding an E1 or E2 I/O Unit
An E1 or E2 I/O unit consists of a mounting rack, plus the E1 or E2 brain board and I/O 
modules mounted on it. In PAC Manager you must add an I/O unit before you can 
configure its modules and I/O points.

1. Make sure the configuration file is open. On the configuration tree, double-click the 
I/O Units folder to open the Configure I/O Units dialog box:

Configuration tree
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2. To add a new I/O unit, click Add or double-click anywhere in the box below any listed 
units. 

The Add I/O Unit dialog box appears:

3. Complete the fields as follows:

A
B

C
D

E
F

Address List area

G
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A Enter a name for the I/O unit. The name must start with a letter and may contain 
letters, numbers, and underscores. Spaces are converted to underscores.

B (Optional) Enter a description of the unit. 
C Select the type of I/O unit from the drop-down list.

D Choose whether temperatures will be handled in Fahrenheit or Celsius. 
E Specify the communication port to use (2001, unless you have changed it for 

security purposes according to the instructions in the PAC Manager User’s Guide).
F Enter the I/O unit’s IP address. Leave the Secondary field blank.

The Address List area shows IP addresses of the I/O units that should receive this 
configuration. If you have I/O units that are exactly alike (having exactly the same 
modules and features), list all of them here. That way you can download the 
configuration file to all the I/O units at once.
– To add an IP address, click Add. (In the dialog box, you can add a single IP 

address or a range of addresses.)

– Enter the IP address(es) and click OK.
The addresses appear in the Address List area.

G Select whether you want a Watchdog on the unit. The default is No (disabled). If 
you select Yes, a new field appears; enter the Watchdog timeout value in seconds. 
The default timeout is 0.5 seconds.

4. When information in the Add I/O Unit dialog box is complete, click OK.

For this E1- or E2-based I/O unit... ...select this SNAP I/O unit.

E1 brain board with:

• up to 8 digital I/O points

• any digital point configured as a counter

SNAP-B3000-ENET

E1 brain board with:

• up to 16 digital I/O points

• no digital point configured as a counter

SNAP-ENET-D64

E2 brain board SNAP-B3000-ENET
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The new I/O unit appears in the Configure I/O Units dialog box:

5. Add other I/O units or continue with the next section on configuring I/O points.

Configuring I/O Points
Modules used with E1s and E2s have only one point per module. However, PAC Manager 
was originally developed for SNAP modules, which accommodate up to four points each. 
When you use PAC Manager with E1s and E2s, each module on the E1 or E2 corresponds to 
the first point (point 0) on a similar SNAP module. 

EXCEPTION: Point numbering for Modbus/TCP operation starts with 1, not 0. See the E1 and E2 
Brain Board User’s Guide (Opto 22 form 1563) for more information on using Modbus/TCP.

When you use PAC Manager or the memory map with E1s and E2s, each module on the E1 
or E2 corresponds to the first point on a similar SNAP module.

E1 brain boards can be used with a variety of modules. The maximum number of points is 
16 on the largest rack, as shown below. 
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E2 brain boards are used with analog G1 modules only. The largest rack (shown below) 
holds 16 single-point modules.

E1 shown with G4 modules. 
Since each module has just one point, use only the first 
point for each module in the memory map. 

E1 with Quad Pak modules. 
Quad Pak modules have four input or four output points, but each 
point is treated as if it were a separate one-point module.

Module position on 
Quad Pak rack

Module 
number

Point 
number

0

00
01
02
03

0
0
0
0

1

04
05
06
07

0
0
0
0

2

08
09
10
11

0
0
0
0

3

12
13
14
15

0
0
0
0

Module position 0

0

1

2

3

Module # Point #

00

15

0

0
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Adding and Configuring E1 Modules and Points
For E2, see “Adding and Configuring E2 Modules and Points” on page 13.
1. In the Configure I/O Units dialog box, make sure the I/O unit for the point you are 

adding is highlighted. Click the I/O Points button.

The Configure I/O Points dialog box appears:

2. Double-click the number that represents the digital module’s position on the rack.

E2 with G1 modules. 
Since each module has just one point, use only the 
first point for each module in the memory map. 

Module position 0

Module # Point #

00

15

0

0
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3. In the Add Module dialog box, choose the type and then choose the module:

• Select any SNAP-IDC5 module for a digital input.

• Select any SNAP-ODC5 module for a digital output.
4. Back in the Configure I/O Points dialog box, click the plus sign next to the new 

module to expand it.
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5. Double-click the first point (point 0) of the module you want to configure. (Remember 
that points 1–3 don’t apply. See “Configuring I/O Points” on page 8.)

The Add Digital Point dialog box opens.

6. Complete the fields as follows:
A Enter a name for the point. The name must start with a letter and may contain 

letters, numbers, and underscores. Spaces are converted to underscores.
B (Optional) Enter a description of the point. 
C Type and module are already filled in for you.
D (Input points only) To use the point as a counter, choose Counter from the Features 

list. Note that Quadrature Counter may appear in the Features list, but this feature 

Module icon 

Expand or collapse points 
on the module by clicking 
the + or - sign in the box.

Points 

A

C

D

E

B
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cannot be used here. 
For output points, leave the Features field as None.

E (Output points only) To set a Watchdog, click Yes and choose On or Off from the 
drop-down list. 

7. When you have completed the fields, click OK.

The new point appears in the list:

8. To configure more digital points, repeat the steps. Remember for each module, 
configure only the first point (point 0).

9. When you have finished adding digital points to the I/O unit, click Close and then 
Close again. 

10. Click the Save button  or choose File > Save to save the configuration file.

11. Follow steps in “Saving I/O Unit Configuration to Flash on the Brain” on page 16 to 
save the configuration to the E1 brain board’s flash memory.

Adding and Configuring E2 Modules and Points
If you don’t already have an E2 I/O unit in the configuration file, follow the instructions in 
“Adding an E1 or E2 I/O Unit” on page 5. 

IMPORTANT: f you plan to use custom scaling with any analog module, follow the steps below 
to first add the modules and points and save the configuration to flash memory on the brain. 
Then you’ll apply custom scaling, calibrate the modules if necessary, and save the configuration 
to flash again. 

1. Make sure the unit is highlighted, and then click the I/O Points button to open the 
Configure I/O Points dialog box.
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2. In the Configure I/O Points dialog box, double-click the number that represents the 
analog module’s position on the rack.

The Add Module dialog box opens.

3. Choose the type (Analog Input or Analog Output) and then the corresponding SNAP 
module from the list.

If you completed the inventory form earlier, the SNAP module you need to select 
should be listed there. Otherwise, see “Analog Input Modules and Initial Scaling” on 
page 3 or “Analog Output Modules” on page 4.

4. Click OK.
5. In the Configure I/O Points dialog box, click the plus sign next to the new module to 

expand it.
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6. Double-click the first point (point 0) for the SNAP module you just added. Remember 
that other points on the module don’t apply (see “Configuring I/O Points” on page 8).

The Add Analog Point dialog box opens.

7. Complete the fields as follows:
A Enter a name for the point. The name must start with a letter and may contain 

letters, numbers, and underscores. (Spaces are converted to underscores.)
B (Optional) Enter a description of the point. 
C Type and Module are inserted for you.

Module icon 

Expand or collapse points 
on the module by clicking 
the + or - sign in the box.

Points 

B

E

C

A

D
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D Scaling will be configured in a later step. Don’t do it now. Scaling is a 
two-step process. The default point scaling must be saved to the I/O unit first; later you 
can scale the points and save the configuration again. 

E (Outputs only.) To set a Watchdog on this point, click Yes, and define the value to 
be assigned to the output if the Watchdog is triggered. A Watchdog is triggered if 
no communication activity is detected for the amount of time specified in the 
Watchdog field of this point’s I/O unit. 

8. When you have completed the fields, click OK.

The new point is added:

Point types and features are shown in the Features/Subtype column.

9. To add more analog points, repeat the steps.
10. When done, click Close and then Close again. 

11. Click the Save button  or choose File > Save to save the configuration file.

Note the location where you saved the file so you can open it in PAC Manager to 
complete scaling (and calibrating, if necessary) later. 

Saving I/O Unit Configuration to Flash on the Brain
IMPORTANT: You must now download the current I/O unit configuration to the brain board 
and save it to flash memory. If you’re configuring an E2 analog I/O unit, this is an intermediate 
step; after you’ve finished scaling analog I/O points (and calibrating them, if necessary), you will 
again need to download the I/O unit configuration to the brain board and save it to flash. 

1. Choose Tools > Send Configuration to I/O Unit to save the I/O unit configuration to 
the E1 or 2 brain board’s flash memory.
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2. In the Send Configuration to I/O Unit dialog box, do the following:
a. Select the configuration name from the list on the left.
b. Make sure the Save to Flash checkbox is selected. 
c. Select the IP address of the I/O unit that will receive the configuration.
d. Click Send to send the configuration to the I/O unit.

3. Click Close.

To configure analog point scaling and offset and gain, if necessary, continue with the next 
sections.

Using Custom Scaling
Scalable analog modules can be set to show something other than the actual inputs or 
outputs. For example, you could scale the readings of a voltage input point to measure its 
input as a percentage between 0% and 100% rather than volts.

NOTE: Custom scaling has no effect on the resolution or accuracy of the module.

IMPORTANT: The range of the G1 module is usually different from the range of the 
corresponding SNAP module, so scaling isn’t intuitive. For example, the AD2T has a range of 0–20 
mA, but the equivalent SNAP-AIMA’s range is -20 to +20 mA. 

Counts may be different as well; for example, all G1 analog modules are 0–4095 counts, but the 
SNAP-CUSTOM-A1: Mode 1 that is equivalent to the AD3 shows -25,000 to +25,000 counts.

Follow the steps and examples in this section to make sure your points are scaled correctly.

1. In PAC Manager, open the configuration file you just saved. If you wish, choose File > 
Save As and add “scaled” to the filename. 

You will then have two configuration files, one with the points before scaling and one 
with the points scaled. That way, if you ever have to download the configuration to 
this brain again, you’ll have both files you need to download: first the non-scaled file 
and then the scaled file.
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2. In the configuration tree, double-click the Points folder for the I/O unit you will 
configure.

3. Now double-click the analog I/O point you want to scale.
4. In the Edit Analog Point dialog box, select the Module that has “(Scalable)” at the end 

of the description, and then click Custom.



I/O Configuration for E1 and E2 Brain Boards

PAGE
19TECHNICAL NOTE • Form 1576-131004

5. Complete the fields in the Scale Analog Readings dialog box.

A Enter new engineering units for the module. 
B In most cases, enter the actual lower value of the G1 module’s range (NOT the 

equivalent SNAP module’s range). Exceptions: See the example tables on page 20.
C Enter the new scaled lower value. This value can be any floating point value.
D Enter the actual upper value of the G1 module’s range. 
E Enter the new scaled upper value. This value can be any floating point value 

greater than the scaled lower value. 

In the example at right, the point 
is on an AD7 module, which has a 
range of 0–10 VDC. It is scaled to 
percent with a lower value of 0 
and an upper value of 100. 

When the actual reading is 10 
VDC, the scaled reading is 100%.

6. Click OK.

The new custom-scaled units 
appear in the Edit Analog Point 
dialog box. 

A

C

D

B

E
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7. To calibrate offset and gain, continue with “Calibrating Offset and Gain” on page 21. 
Otherwise, skip to “Saving the I/O Unit Configuration” on page 23.

Custom scaling examples: 0–100% Engineering Units 

G1 
Module

Lower 
Value 
Actual

Upper 
Value 
Actual

Lower   
Value 

Scaled

Upper 
Value 

Scaled

Notes

Percent Percent

AD2T 0 20 0 100

AD3
AD3T

5000 25000 0 100
Use 5000 and 25000 (instead of 4 and 20) 
for the "Actual" values.

AD6
AD6T
AD6HS

0 10 0 100
Use 0 and +10 (instead of 0 and +5) for 
the "Actual" values.

AD7 0 10 0 100

AD9T 0 50 0 100

AD11 -10 10 0 100
Use -10 and +10 (instead of -5 and +5) for 
the "Actual" values.

AD12 -10 10 0 100

AD13T 0 100 0 100

AD15T 28 140 0 100

AD16T 0 5 0 100

Notice the new units of percent. 
Don’t be concerned about the new 
zero-scale and full-scale values (in 
this example, -1000 and +1000). 
These values are extrapolated from 
the values you entered. As long as 
you entered the correct values, the 
point will give accurate readings.
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Custom scaling examples: 300–4500 PSI Engineering Units 

Calibrating Offset and Gain
The E2 brain board can calibrate analog input points. If a -50 mV to +50 mV input receives 
signals that are slightly off (not exactly -50 mV at the lowest point, for example), the offset 
and gain can be calculated so that values will appear accurately when read.

Offset and gain values affect engineering units. For a temperature input, engineering units 
are in degrees C or F, depending on how the brain is configured. You can manually set 
offset and gain or have the brain automatically calculate and set them for you.

IMPORTANT: To calibrate the point, the I/O unit must be turned on and attached to the 
network, and you must have access to it to use the calibrator. After calibrating, save the 
configuration to flash so that it will not be lost when power is turned off. Since each calibration 
is for a specific point on a specific E2 brain board, the result cannot be saved to the configuration 
file and cannot be sent to any other brain board. 

Calculate offset first, and then calculate gain. The offset must be calculated at the point’s 
low scale, and the gain must be calculated at the point’s high scale.

G1 
Module

Lower 
Value 
Actual

Upper 
Value 
Actual

Lower   
Value 

Scaled

Upper 
Value 

Scaled

Notes

PSI PSI

AD2T 0 20 300 4500

AD3
AD3T

5000 25000 300 4500
Use 5000 and 25000 (instead of 4 and 20) 
for the "Actual" values.

AD6
AD6T
AD6HS

0 10 300 4500
Use 0 and +10 (instead of 0 and +5) for 
the "Actual" values.

AD7 0 10 300 4500

AD9T 0 50 300 4500

AD11 -10 10 300 4500
Use -10 and +10 (instead of -5 and +5) for 
the "Actual" values.

AD12 -10 10 300 4500

AD13T 0 100 300 4500

AD15T 28 140 300 4500

AD16T 0 5 300 4500
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1. In the Configure I/O Points dialog box, highlight the analog input point you want to 
calibrate.

2. Click the Calibrate button in the lower-right corner of the dialog box.

3. To have the Ethernet-based brain calculate offset and gain, do the following:
a. Use a calibrator to input minimum scale on the analog input point (for example, 0 

degrees F or C for a temperature input). Click Offset, then click the Set Offset 
button. 

b. Use the calibrator to input maximum scale on the analog input. Click Gain, then 
click the Set Gain button.

4. To manually set offset and gain, do the following:
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a. Click the More button.

b. Enter the Offset value. Click the Set Offset button.
c. Enter the Gain value. Click the Set Gain button.

5. When you have finished calibrating the point, close the dialog box to return to 
configuring I/O points. 

NOTE: To store offset and gain values permanently, you must save the change to flash when you 
send the configuration data to the I/O unit (next section)

Saving the I/O Unit Configuration
The final step in setting up an E1 or E2 I/O unit is to save the configuration information, 
both as a file and in the E1 or E2 brain board’s flash (non-volatile) memory.

1. To save the configuration file, click the Save button  or choose File > Save. 

Note the location where you saved the file. You can open this file in PAC Manager to 
restore the configuration to an I/O unit, and you can also import the file into PAC 
Control, OptoOPCServer, and OptoDataLink software.

2. To save the I/O unit configuration to the E1 or E2 brain board’s flash memory, choose 
Tools > Send Configuration to I/O Unit.
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3. In the Send Configuration to I/O Unit dialog box, do the following:
a. Select the configuration name from the list on the left.
b. Make sure the Save to Flash checkbox IS selected.
c. Select the IP address of the I/O unit that will receive the configuration.

4. Click Send to send the configuration and have it saved to flash memory.

Note on Point Numbers
In most cases points appear in the format module xx, point 0 (see page 8). But in some 
cases, like a Digital Bank or Analog Bank read or in certain tables in PAC Control, you’ll see 
points numbered differently, like this: 

What’s Next
Configuration of the E1 or E2 I/O unit is complete. Depending on your I/O system and 
application(s) you plan to use the I/O unit with, do the following:

• For using a Modbus/TCP application, see the Modbus/TCP chapter in the E1 and E2 
User’s Guide (Opto 22 form 1563). 

• For using a custom application based on OptoMMP, see the OptoMMP Protocol Guide 
(Opto 22 form 1465). 

• For using PAC Control or OptoOPCServer, see the PAC Control User’s Guide (Opto 22 
form 1700) and the OptoOPCServer User’s Guide (Opto 22 form 1439). In both guides, 
refer to the information on importing .OTG files from PAC Manager. 

Module position on E1 or
E2 I/O rack:

0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

Corresponding SNAP
point number:

0 4 8 12 16 20 24 28 32 36 40 44 48 52 56 60
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E1 and E2 I/O Unit Inventory Form

Brain Board and Network Settings

I/O Rack with G1 Analog, G1 Digital, or G4 Digital I/O Modules

Brain board model E1 E2 IP address

Physical Location Subnet mask

MAC address 00-A0-3D-00-____ - ____ Gateway address

Module
Position

Part
Number

Input
or Output

Corresponding
SNAP module

Point
Number

Digital
Counter?

Analog
Scaling?

Scaling Information

0 0  Yes
 No

 Yes
 No

1 0  Yes
 No

 Yes
 No

2 0 Yes
No

Yes
No

3 0 Yes
No

Yes
No

4 0 Yes
No

Yes
No

5 0 Yes
No

Yes
No

6 0 Yes
No

Yes
No

7 0 Yes
No

Yes
No

8 0 Yes
No

Yes
No

9 0 Yes
No

Yes
No

10 0 Yes
No

Yes
No

11 0 Yes
No

Yes
No

12 0 Yes
No

Yes
No

13 0 Yes
No

Yes
No

14 0 Yes
No

Yes
No

15 0 Yes
No

Yes
No
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I/O Rack with Quad Pak Digital I/O Modules

Module
Position

Part
Number

Input
or Output

Corresponding
SNAP Module

Point
Number

Digital
Counter?

0

0 Yes
No

0 Yes
No

0 Yes
No

0 Yes
No

1

0 Yes
No

0 Yes
No

0 Yes
No

0 Yes
No

2

0 Yes
No

0 Yes
No

0 Yes
No

0 Yes
No

3

0 Yes
No

0 Yes
No

0 Yes
No

0 Yes
No
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